(Topic ID: 53823)

Police Force Pinball - car error 31? Help? Car won't back up on goes forward..


By Choggard

6 years ago



Topic Stats

  • 35 posts
  • 10 Pinsiders participating
  • Latest reply 2 years ago by atariaction
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

image.jpg
IMG_0325.JPG
IMG_0324.JPG
image.jpg
image.jpg

#1 6 years ago

On my police force in switch test mode I am get a car error 31. So I ordered a new switch. The car isn't in the correct position. Does that mean the switch isn't working to stop the car?

Thanks in advance

#2 6 years ago

Or car isn't working and hitting the switches.

LTG : )

#3 6 years ago

The belt that moves the car may be stretched and slipping.

#4 6 years ago

It can be the relay for the car under playfiled.I had this problem before

#5 6 years ago
Quoted from KenLayton:

The belt that moves the car may be stretched and slipping.

Car is working, it's moving but the switches aren't stopping it..

#6 6 years ago
Quoted from arakissun:

It can be the relay for the car under playfiled.I had this problem before

I think it is the relay switches, but I've tried bending them and it doesn't seem to work.. I'll do more tomorrow..

#7 6 years ago

I manually put the car in the correct position, and you can see the front relay switch isn't closed.. When I bend it it still doesn't bend right. I need to see someone else's relay switch and how it's bent. I did tighten the belt too..

image.jpg

#8 6 years ago

I have a police car error on my machine and my motor works but when it moves it doesn't stop in the right position. It goes passed the point to hold the ball for multi-ball. When I look underneath the playfield I noticed a switch that the car hits but doesn't stop. I don't know if it's a bad switch or not? Also could someone post a picture of the belt underneath the playfield. Mine just doesn't look right...

Thanks in advance..

#9 6 years ago

You get a photo yet choggard? If not, lmk. Replacing some ramps tomorrow, so I'll be under the ' cop cars' hood. Have fun~SpOoKy

#10 6 years ago
Quoted from SpOoKyRiDeS:

You get a photo yet choggard? If not, lmk. Replacing some ramps tomorrow, so I'll be under the ' cop cars' hood. Have fun~Spooky

No photo yet, thanks I need a photo of the pulley areas where the car runs. I think my switch are bad or something is not hooked up right.. Thanks in advance-Cory

#11 6 years ago

Just replaced both switches and the damn car still tries to drive down off the ramp.. Could it be a connector problem? If so I am not good at reading schematics.. Could someone tell me what connector I should be looking at..

Thanks in advance..

#12 6 years ago
Quoted from Choggard:

Just replaced both switches and the damn car still tries to drive down off the ramp.. Could it be a connector problem?

Have you checked the switches in switch test ? You could have a broken wire elsewhere killing them, carriage not hitting them, etc.

LTG : )

#13 6 years ago

In switch test it's just says car error 31...

#14 6 years ago

Car error up 31 and car error down 32

#15 6 years ago

Do the switches work though in switch test, not what comes up in error when you hit enter on the diagnostics button.

Them coming up in error means they aren't working. Bad switch, car mech not hitting them, broken wires there or at other switches.

LTG : )

#16 6 years ago

Switch 45 is bad too...

#17 6 years ago
Quoted from Choggard:

Switch 45 is bad too...

Fix it.

Can be a bad switch, can be a broken wire at switch, or a broken wire from the switch to the board in the head.

A meter can help you figure out if it's the switch or wiring in short order.

LTG : )

#18 6 years ago

Alright fixed all switches, but the car only goes forward but not backwards.. Why would it not go backwards?

#19 6 years ago
Quoted from Choggard:

Alright fixed all switches, but the car only goes forward but not backwards.. Why would it not go backwards?

If power goes through a relay on a small circuit board, try reflowing the solder on that.

LTG : )

#20 6 years ago
Quoted from LTG:

If power goes through a relay on a small circuit board, try reflowing the solder on that.
LTG : )

Could you tell me which connector would have to be reflowed? Not good at reading schematics..

Here's the manuals link

http://mirror2.ipdb.org/files/1841/Williams_1989_Police_Force_Operations_Manual.pdf

#21 6 years ago
Quoted from Choggard:

Could you tell me which connector would have to be reflowed?

Not connector.

If there is a small circuit board with a relay on it, for the motor. Pull that board and reflow the solder on the parts holding the relay to the board.

LTG : )

#22 6 years ago
Quoted from LTG:

Not connector.
If there is a small circuit board with a relay on it, for the motor. Pull that board and reflow the solder on the parts holding the relay to the board.
LTG : )

Okay where is that? I'll look.. Many thanks!!

#23 6 years ago

Not connector.
If there is a small circuit board with a relay on it, for the motor. Pull that board and reflow the solder on the parts holding the relay to the board.
LTG : )

Alright I see it, but it looks like it held on by solder in the middle of it.. That doesn't look easy to get off

image.jpg

#24 6 years ago
Quoted from Choggard:

Alright I see it, but it looks like it held on by solder in the middle of it.. That doesn't look easy to get off

Not that one. Those are resistors and are fine, your motor does turn.

I mentioned relay, plastic box with leaf blade points inside.

LTG : )

#25 6 years ago

Your game has two. Now this may or may not solve your problem. But these boards over time take a beating on the solder joints from gravity and vibration.

One is on the left side, one on the bottom right.

LTG : )

IMG_0324.JPG IMG_0325.JPG

#26 6 years ago

So take them off and resolder the joints where the connectors are at?

#27 6 years ago
Quoted from Choggard:

So take them off and resolder the joints where the connectors are at?

No, all the spots involving the relay. The relay is soldered to that board to hold it on and for the leaf blade switches inside.

LTG : )

#28 6 years ago

Here's the back of the one on left.. Doesn't look to bad..

image.jpg

#29 6 years ago

I reflowed the points and it works! Thanks a lot!! I am so excited, I wasn't going to bed until I got it working..lol

#30 6 years ago

Here are a couple pics from my working Police Force, I have the machine open and if you want more I will gladly provide them to you.

The pics are the top and bottom switches for the moving car...

// Error: Image 110409 not found // // Error: Image 110410 not found //

#31 6 years ago
Quoted from Matt_Rasmussen:

Here are a couple pics from my working Police Force, I have the machine open and if you want more I will gladly provide them to you.
The pics are the top and bottom switches for the moving car...

Thanks got it!

1 year later
#32 5 years ago

i have a police force car was working fine i shopped it played a couple of games then the divertor went wacky and the car just stays down in test mode the motor turns but it wont go up on its own i adjusted the belt im lost and way upside down on this game any help would really help i took the relay and switched it with the lights relay and it didnt make a diffferecnce

#33 5 years ago
Quoted from oldpinballer:

i have a Police Force car was working fine i shopped it played a couple of games then the divertor went wacky and the car just stays down in test mode the motor turns but it wont go up on its own i adjusted the belt im lost and way upside down on this game any help would really help i took the relay and switched it with the lights relay and it didnt make a diffferecnce

You may fare better posting a new thread instead of this year-old one.

2 years later
#34 2 years ago

I had the same problem with the car going down only and not up. When I took the belt off and did a car test, it showed the motor spinning the same direction for both up and down. I took LTGs advice and took the upper left relay off and reflowed the contact points on the back. Worked like a charm. The motor now spins both directions. Thanks a ton for the advice, I would have never figured this out without your help.

5 months later
#35 2 years ago

How many balls go in this game? Is it always a 2 ball multiball?

Promoted items from the Pinside Marketplace
$ 18.99
Eproms
Matt's Basement Arcade
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 12.00
Electronics
Yorktown Arcade Supply
2,195
Machine - For Sale
New Kensington, PA
$ 25.00
Hardware
Tucson Pinball
$ 36.99
Eproms
Matt's Basement Arcade

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside