(Topic ID: 286959)

Please Help!!! WPC (Judge Dredd) Matrix Rows 1&2 shorted

By mobilexx

1 year ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 1 year ago by mbelofsky
  • No one calls this topic a favorite

You

Linked Games

No games have been linked to this topic.

    #1 1 year ago

    I have a Judge Dredd , Had an issue with 12vu that was repaired and working now, also had an issue with volume down that was repaired along with a vram installed, board was clean, no visible acid damage, he said all switches were fine when in his game.. I put it in and kept saying "slam switch stuck" and would flash something before that really fast, switches are all fine, even disconnected them, turns out after doing some digging, that if you go to switch edge, that any switch on rows 1 and 2 on the Matrix will activate the other as well.. I you activate 12, it will also activate 22, if you activate 14, it will activate 24 as well, etc...
    I removed j212 and same thing still, and them removing j209 and same thing..
    So I guessing problem is in the board ? or can it be something else ?

    #2 1 year ago
    Quoted from mobilexx:

    I have a Judge Dredd , Had an issue with 12vu that was repaired and working now, also had an issue with volume down that was repaired along with a vram installed, board was clean, no visible acid damage, he said all switches were fine when in his game.. I put it in and kept saying "slam switch stuck" and would flash something before that really fast, switches are all fine, even disconnected them, turns out after doing some digging, that if you go to switch edge, that any switch on rows 1 and 2 on the Matrix will activate the other as well.. I you activate 12, it will also activate 22, if you activate 14, it will activate 24 as well, etc...
    I removed j212 and same thing still, and them removing j209 and same thing..
    So I guessing problem is in the board ? or can it be something else ?

    I had similar issue (with Slam tilt) on my WCS. The 12 volts was not stable on the driver board.

    I found this problem when I was trying to figure out if the MPU was the issue and put in a Kahr daughterboard. This caused the game to go crazy since it was relying on the under used 12volt circuit to power the 5 volts. Since the 12 volts was the issue, this brought it out immediately.

    I have several driver boards so I replaced the driver and the WCS worked perfectly. I sent the board to my friend to repair and the upper right area (as well as other things he "improves" for me) were fixed.

    See if LED1 (12 volts to switch matrix) and LED 7 (12volts to opto lights, etc) are on on the driver board.

    --

    For multiple switches firing in test mode, can you check your diodes on the switches in row 1 and 2? could one be shorting against something?

    Reply

    Wanna join the discussion? Please sign in to reply to this topic.

    Hey there! Welcome to Pinside!

    Donate to Pinside

    Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!