(Topic ID: 246653)

Please help! TSPP is not giving me any Mystery awards


By Pinrookie

4 months ago



Topic Stats

  • 12 posts
  • 3 Pinsiders participating
  • Latest reply 81 days ago by Pinrookie
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

EDC31D6E-FE54-443D-99EF-3355EC43FE58 (resized).jpeg

#1 4 months ago

Hi there

I just have an issue here. My TSPP is not giving any Mystery award at all. I checked the switch everything is working fine. I just wonder is it a software setting issue or rom corrupted issue? I am using 5.0 in my TSPP

I can fix this issue by re-setting the machine but is it normal? Because I will lost all my scores and setting.

Please help.

#2 4 months ago

So the mystery target is hit, then you shoot the ball in the tv hole and what happens? The ball just gets released?

#3 4 months ago
Quoted from Lermods:

So the mystery target is hit, then you shoot the ball in the tv hole and what happens? The ball just gets released?

Thank you for a reply.

In normal situation I believe It should act like this:

Mystery target hit > Ball dropped back to lower playfield > ball go though the garage door > mystery award is given > then the ball go to the upper playfield

However my machine will act like this:

Mystery target hit > Ball dropped back to lower playfield > ball go though the garage door > It spelled Simpson > then the ball go to the upper playfield

In general, no matter how many time the mystery target were hit. My machine will not give you any mystery award. Even I set Mystery award to easy it still won’t give me any award.

Best regards

#4 4 months ago

Bump

#5 4 months ago

so i think this is the garage ramp switch being bad. go into a switch test and trigger with hang then ball to see if it activates. i think this is the bad switch. also does “clean the garage” insert light go out when you go through garage door?

MJR

2 weeks later
#6 3 months ago
Quoted from MJR8peanut:

so i think this is the garage ramp switch being bad. go into a switch test and trigger with hang then ball to see if it activates. i think this is the bad switch. also does “clean the garage” insert light go out when you go through garage door?

Yes, it is a bad switch. Now my game is acting normal now after I replaced the switch. Thank you for all the advices

1 week later
#7 3 months ago

My game is not giving me any Mystery awards again. Plus Clean the garage lights is on when the ball go though the garage door.

In Switch test mode there are two switches at the garage door. I pressed the garage door it is activated #48 garage door. I press the other switch is say couch entry #36. I believe both switches are working fine.

I just noticed something. When I pressed the flipper buttons. It doesn’t activate any switch in test mode. Just wondering it is normal?

#8 3 months ago

Bump

1 week later
#9 83 days ago

woulda like a switch matrix issue. shouldn’t be couch entry for the second switch

#10 82 days ago

Thank you. Yes, you are correct. I believe it should tested as “garage entry” based on the switch matrix. Sorry, i am not a tech here. Can you let me know how to solve this problem? Like which switches or diodes should I check 1st?
EDC31D6E-FE54-443D-99EF-3355EC43FE58 (resized).jpeg

#11 82 days ago

replace all switches affected is how i would go about it

MJR

#12 81 days ago

Thank you for the advice. I pulled the whole upper playfied out and I found the issue. The issue was the wire was wrongly connected. Now i plug it correctly. At least it solved the issue from now.

Promoted items from the Pinside Marketplace
5,500
Machine - For Sale
Cedar Rapids, IA
£ 12.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside