(Topic ID: 87863)

Please Help; Data East WWF Royal Rumble Flippers


By ShootAgainDave

5 years ago



Topic Stats

  • 15 posts
  • 4 Pinsiders participating
  • Latest reply 5 months ago by svendmute
  • No one calls this topic a favorite

You

Linked Games

#1 5 years ago

Hi!

Longtime pinball player and longtime Pinside message boards reader/follower. But I'm a new Pinside member and I may have a "noob" question. I have a WWF Royal Rumble pinball. Everything works fine except for the flippers. They are activated even on "attract mode". Yes, I have the Operator's Manual but the small parts of the pages I need to check for this problem are blurry. Any help would be VERY appreciated.

Thanks!

Dave

#2 5 years ago

Power probably runs through a relay. Check if it's magnetized, transistor driving it failed and locked on. Things like that.

The relay would have a plastic cover and be mounted on a circuit board.

Someone with a WWF may be able to help more, pictures or something.

LTG : )™

#3 5 years ago

Sounds like you have a bad transistor or two on the flipper boards. I'd start by testing those.

#4 5 years ago
Quoted from hawkeye11:

Sounds like you have a bad transistor or two on the flipper boards. I'd start by testing those.

By activated, do you mean still flip when the game is off, or they are locked in the up position ?

If locked in the up position, please follow hawkeye11's advice.

LTG : )

#5 5 years ago

If i'm reading this right they are activated on power-on and in attract mode. Which I think is almost always those transistors. I probably learned that from LTG back on RGP.

#6 5 years ago

Thank you guys, I appreciate!

To *LTG* - I mean they still flip when the game is off/attract mode.

Dave

#7 5 years ago

Lets make sure were clear here. The flippers are up when the game is off? Or they go up when you turn the game on?

#8 5 years ago

I mean; When I turn the power on, if I press the flipper buttons, they activate like in a normal game.

#9 5 years ago

But the game is still on "Attract Mode"

#10 5 years ago

Ok. So they work fine in gameplay, but they are still activating in attract mode. Not sure what would cause that. I thought you meant they would energize, without hitting the buttons, when you turn the game on.

#11 5 years ago
Quoted from hawkeye11:

Ok. So they work fine in gameplay, but they are still activating in attract mode.

Yes - That's what I mean.

#12 5 years ago
Quoted from ShootAgainDave:

I mean; When I turn the power on, if I press the flipper buttons, they activate like in a normal game

Then find the relay they run through.

LTG : )™

#13 5 years ago

Where should I start?

#14 5 years ago

That relay is on the CPU board.

5 years later
#15 5 months ago

So did you fix the issue?
My Baywatch is having a similar issue so would like to hear what your issue was…

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 40.00
Lighting - Interactive
Professor Pinball
Wanted
Machine - Wanted
Plainfield, IL
$ 26.50
$ 35.00
Hardware
Filament Printing
From: $ 40.00
Cabinet - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside