(Topic ID: 258326)

Playfield lights stuck on


By robey99

62 days ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 55 days ago by robey99
  • No one calls this topic a favorite

You

Linked Games

#1 62 days ago

I finally tore down and shopped my Indy500. I put back together and the play field lights are stuck on. I checked all the connections and replaced the display, driver and cpu boards with new ones. All fuses good. Still nothing is working. I am at a loss and did lots of research and cannot find anything. Appreciate any thoughts on next steps to check. Thanks.

#2 62 days ago

All connectors in the correct spots ? Facing the right direction ? Ribbon cables red stripe pin one each end ? Not off by a row ?

If it was okay before. Then something changed when you reassembled it.

LTG : )

1 week later
#3 55 days ago

Thanks but I have triple checked all the connections and no luck. I have tried researching this issue extensively and I cannot find any topics on pkayfiels lights being stuck on. I can’t believe this is not a common issue.

Promoted items from the Pinside Marketplace
From: $ 9.99
Eproms
Matt's Basement Arcade
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer
From: $ 22.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside