(Topic ID: 182596)

Playboy 35th Ann. P in pinball light always on. Please help

By StotzBotz

4 years ago



Topic Stats

  • 3 posts
  • 3 Pinsiders participating
  • Latest reply 4 years ago by wayout440
  • No one calls this topic a favorite

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    View topic image gallery

    002 (resized).jpg

    #1 4 years ago

    Hello and thanks for trying to help me with my problem. I own a Playboy 35th Anniversary pinball machine by Data East and got a lot of good info here recently. This problem just started. The P in the word pinball that's between the speakers is always lit from the time you put a quarter in or have the machine in the Free play mode and just turn it on. "P I N B A L L" lights up letter by letter when you supposedly shoot your ball up the ramp when multi ball function is activated. My machine has a new cpu by rottendog and all of the other boards have been rebuilt. UI set the machine back to factory thinking that maybe it was something I did. The initial test shows no bad switches or coils. Any help would sure be appreciated.

    After posting this I found a setting in the machine that is a PINBALL MEMORY. It was set to ON so after turning it off the light went off. So many settings this machine has

    002 (resized).jpg

    #2 4 years ago

    Does the lamp socket have a diode on it. This could be bad. 1n4007

    #3 4 years ago
    Quoted from chad:

    Does the lamp socket have a diode on it. This could be bad. 1n4007

    That's not it because when he set the "pinball memory" setting to off, it went off.

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside