(Topic ID: 145839)

Pistol Poker - Members Only - "Howdy Partner"


By pinball_faz

3 years ago



Topic Stats

  • 75 posts
  • 28 Pinsiders participating
  • Latest reply 1 day ago by pinballjah
  • Topic is favorited by 9 Pinsiders

You

Linked Games

Topic Gallery

There have been 19 images uploaded to this topic. (View topic image gallery).

20191005_145215 (resized).jpg
20191005_145242 (resized).jpg
20191005_145148 (resized).jpg
20190922_141939 (resized).jpg
20190911_112122 (resized).jpg
20190911_112132 (resized).jpg
Pistol Poker cards (resized).jpg
03ECBFF1-04B5-4CAD-9415-B41FB6FAFD0A (resized).jpeg
20170705_204510 (resized).jpg
20170705_204516 (resized).jpg
20170705_204505 (resized).jpg
20170705_204033 (resized).jpg
20170705_202007 (resized).jpg
DSC_0175 (resized).JPG
DSC_0173 (resized).JPG
2016-10-10 23.33.17 (resized).jpg

You're currently viewing posts by Pinsider pmuis.
Click here to go back to viewing the entire thread.

#41 2 years ago

Just got my licence to this club yesterday. Played a little on it but needs a lot of tuning and I get annoyed really fast when it's not just right. Also fixed the first few things. Really hard to get used to not being able to find parts and not a lot of information. My machine gave an Flasher problem error at startup and flashers weren't working. They did work in test-mode. I noticed the ramp flashers went on with every other flasher and stayed on a lot longer. Found out it was just a shorted mosfet and the flashers go through a relay that shuts of the power so that's why it behaved like that. Also had some lose flippers. I found out that the cranks had worn out threads in them. Since no new parts are available I decided to tap new treads on there. I went 1.5 mm bigger and it worked out great. A lot of work for relatively small problems but nothing major left on the machine, just some cleaning, rubbering and adjusting. Here are some pictures of my machine. 20170705_204033 (resized).jpg20170705_204516 (resized).jpg20170705_204510 (resized).jpg20170705_204505 (resized).jpg20170705_202007 (resized).jpg

1 week later
#43 2 years ago

I have a question regarding the multiball. I only have the bug one in a while and I just shoot the extra ball into play and it doesn't bother me too much. But an other thing I noticed when going into multiball, if you haven't collected the chips of the last hand you were playing as megamode starts, it goes back to first having to collect cards. Even if you already collected the hand. Do all PP's have this? I find this more annoying than 1 out of 20 megamodes feeding an extra ball in the shooterlane. I don't have the problem that the ball is shot too hard so it flies into the shooterlane.

2 months later
#45 2 years ago
Quoted from horriblehager:

I bought this machine back in 2012 for a good price but the machine did not work. It was missing a DMD. The machine would not light up or play. Someone even stole the Plunger launch gauge cover(seller didn't tell me until I picked it up) (I actually think i bought the cover from the guy who stole it because he lived 25 miles from seller of machine. Long story short.. A gentleman came out to help fix machine but ended up taking parts from it.)
I got the machine up and running after checking fuses and replacing missing cr2325 battery on main board. I bought a DMD, replaced plunger launch cover(I still need to paint to specs).
Machine plays fully except I have two problems:
1.The plunger doesn't have enough power to get the pinball on the playfield every time plunged.
2.The DMD doesn't work correctly. I checked the voltage to the pins on the connector and there are missing voltages where there should be voltage. I replaced board with one from PSPA Australia (I bought extra boards just in case I would need them in the future) and the DMD and voltage still didn't register correctly. I think i have a faulty transformer?
Any thoughts or ideas on how to fix the machine or what I should look at?

Transformer would be one of the last placed I would look. It a bit hard to find good informatie about these games. I would first check any connectors for cold solder joints. What voltages are you missing?

Promoted items from the Pinside Marketplace
2,500 (Firm)
Machine - For Sale
Plainfield, IL
2,500 (OBO)
Machine - For Sale
Harrisburg, PA
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 18.00
Apparel - Men
Pinside Shop
$ 0.35
From: $ 19.95
Playfield - Toys/Add-ons
PinBoss Mods
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
From: $ 11.95
Playfield - Toys/Add-ons
ULEKstore
$ 89.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 35.00
Cabinet - Decals
Pinball Haus
$ 125.00
Cabinet - Toppers
Sparky Pinball
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 6.95
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 30.00
$ 5,799.00
Pinball Machine
Operation Pinball
From: $ 220.00
$ 125.00
Cabinet - Toppers
Sparky Pinball
$ 229.99
Lighting - Led
PinballBulbs

You're currently viewing posts by Pinsider pmuis.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside