(Topic ID: 145839)

Pistol Poker - Members Only - "Howdy Partner"


By pinball_faz

3 years ago



Topic Stats

  • 74 posts
  • 28 Pinsiders participating
  • Latest reply 14 days ago by ltd73
  • Topic is favorited by 9 Pinsiders

You

Linked Games

Topic Gallery

There have been 19 images uploaded to this topic. (View topic image gallery).

20191005_145215 (resized).jpg
20191005_145242 (resized).jpg
20191005_145148 (resized).jpg
20190922_141939 (resized).jpg
20190911_112122 (resized).jpg
20190911_112132 (resized).jpg
Pistol Poker cards (resized).jpg
03ECBFF1-04B5-4CAD-9415-B41FB6FAFD0A (resized).jpeg
20170705_204510 (resized).jpg
20170705_204516 (resized).jpg
20170705_204505 (resized).jpg
20170705_204033 (resized).jpg
20170705_202007 (resized).jpg
DSC_0175 (resized).JPG
DSC_0173 (resized).JPG
2016-10-10 23.33.17 (resized).jpg

You're currently viewing posts by Pinsider fastfred.
Click here to go back to viewing the entire thread.

#49 1 year ago

I was in the game business from 73 to the 90's. I presently live in the Philippines where the city I live in does not have any pinball machines but I came across one from a friend of mine. Went over there today to see this Alvin G Pistol Poker. Not in bad condition. I fixed most of the issues that was wrong with the game. Not starting, Ball kicker plunger was not working, etc etc. My problem is all three flippers are dead. The game is from the Netherlands and was transported over here to the Philippines Never worked on a Alvin G machine. Cleaned the contacts, checked wiring and checked every fuse in the head of the game on the side as well as the fuses on the board and with Williams and Bally the games have a fuse under the play field but this game I did not see a fuse. Is this possible a board issue? I went thru the tests for coils and only ones that did not work is the flipper relay. Need help to resolve this issue. Thank you, Fred

10 months later
#57 7 months ago

Pistol Poker issue. Game stopped advancing when you get the shot in the hole in the middle and now does not even say "Ready-Aim-Fire" or even use the flippers to advance what you want to put it at on the back box by selecting a suit. Ball does shoot out to the top of the playfield. Also when making a suit like a pair of Jacks, or Queens or Ace and Jack, etc it will not advance to another suit as stays in that position. One more issue is the left Slingshot does not work. Contacts are fine and in test mode the coil works. All these issues stopped working at the same time. Help please as I am stumped. I did change the CPU, Matrix board as well as the power supply with extra boards but had to change some Roms to the other boards. Any suggestions? Thank you.

Promoted items from the Pinside Marketplace
2,500 (OBO)
Machine - For Sale
Harrisburg, PA
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 18.00
Apparel - Men
Pinside Shop
$ 65.00
Cabinet - Armor And Blades
Texas Pinball
$ 7.00
Electronics
APB Enterprises
$ 6,995.00
Pinball Machine
Classic Game Rooms
$ 25.00
Playfield - Protection
Pinball Mod Co.
From: $ 11.95
Playfield - Toys/Add-ons
ULEKstore
$ 26.95
$ 12.95
$ 5,799.00
Pinball Machine
Pinball Pro
€ 4.20
Flipper Parts
Buthamburg
$ 25.00
Cabinet - Other
Filament Printing
From: $ 218.00
$ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
$ 229.99
$ 78.99
Playfield - Toys/Add-ons
Lermods
$ 96.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 7,399.00
Pinball Machine
Nitro Pinball Shop
$ 96.95
Cabinet - Shooter Rods
Super Skill Shot Shop

You're currently viewing posts by Pinsider fastfred.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside