New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 227217)

Pinbot restoration


By Tomass

2 years ago



Topic Stats

  • 58 posts
  • 9 Pinsiders participating
  • Latest reply 1 year ago by Tomass
  • Topic is favorited by 9 Pinsiders

You

Linked Games

Topic Gallery

There have been 30 images uploaded to this topic. (View topic image gallery).

15624646843017380117303683303856 (resized).jpg
20190706_081314 (resized).jpg
20190103_173356 (resized).jpg
20181105_180347 (resized).jpg
20181103_172125 (resized).jpg
20181028_125019 (resized).jpg
1540686414107413352319 (resized).jpg
20181018_170346 (resized).jpg
20181016_204428 (resized).jpg
1539745532174-2082610775 (resized).jpg
20181016_185711 (resized).jpg
20181016_185424 (resized).jpg
20181014_082350 (resized).jpg
20181014_081056 (resized).jpg
153949145987861693507 (resized).jpg
20181009_062814 (resized).jpg

There are 58 posts in this topic. You are on page 1 of 2.
#1 2 years ago

Starting this along side my Cyclone and Comet. I will need to find a coin door, as this one did not have one when I got it. It came from Fairbanks AK and an operator sold it to the person I got it from without a door to prevent competition years ago. The board had been damaged from a leaky battery. The spiral ramp is also damaged, but that will be very hard to replace. The playfield is in very good shape and the cabinet is decent.

20180901_192635 (resized).jpg20180901_193416 (resized).jpg20180901_193425 (resized).jpg20180901_193430 (resized).jpg20180901_193436 (resized).jpg20180901_193745 (resized).jpg20180901_194308 (resized).jpg20180901_194527 (resized).jpg
#2 2 years ago

I am currently working on the board damage and waiting on a few components. I want to get it working before the teardown.

20181001_160212 (resized).jpg20181002_063732 (resized).jpg20181002_150510 (resized).jpg20181003_054711 (resized).jpg
#3 2 years ago

Sanding away the solder mask revealed mostly in-tact traces. Lost 1 that will need a jumper and repaired a couple, but not too bad. I resealed the traces with clear epoxy to prevent future issues.

20181003_185734 (resized).jpg20181004_183421 (resized).jpg20181009_062814 (resized).jpg
#4 2 years ago

I just got some transistors and resistor networks, so I will just be waiting on 2 ic's to test it. I am also not sure about a capacitor. It calls for a tantalum and I only have a ceramic one. Not sure if it will work.

153949145987861693507 (resized).jpg
#5 2 years ago

Looks like a descent cabinet. Marco sells a black Jackbot siiral ramp https://www.marcospecialties.com/pinball-parts/A-20080

Here’s a thread describing repair of the original spiral https://www.stevechannel.com/pinbot.htm

#6 2 years ago

Thanks. I will probably go the repair route at this point.

#7 2 years ago

Seems there was a mispick on my order of resistor netwoks. Was able to put the transistors in, but I am short a couple resistors still. The ic's are coming from China, so no hurry I guess.

20181014_081056 (resized).jpg
#8 2 years ago

Hoping this trace doesn't cause issues when I put the resistor in there. Tests good on the meter for now.

20181014_082350 (resized).jpg
#9 2 years ago

Well it may not be pretty but it all tests good on the meter. I use the lead from a diode to repair the trace. Once the epoxy hardens I will cut it off. Replaced the other src sub too. Will be just waiting now.

1539745532174-2082610775 (resized).jpg20181016_185424 (resized).jpg20181016_185711 (resized).jpg
#10 2 years ago

Well I wanted ti be careful with that trace underneath but when I cut the diode, the epoxy lifted. I will need to scrub that area carfully so I can cover and protect that trace.

20181016_204428 (resized).jpg
#11 2 years ago

Timer ic and a couple components came in today. Now just waiting on 1 ic and 1 resistor network to test this board out. Feels like it will take a small miracle for this thing to actually work, even though things seem to meter out.

20181018_170346 (resized).jpg
1 week later
#12 1 year ago

It has been 25 days since I ordered the ic that I am waiting on to move forward. Moved some machines around today and brought Pinbot inside. The playfield is in really good shape. Has a full mylar and plastics all look good and straight. Rubbers are dry rotted. I think I found a coin door that will need restored.

1540686414107413352319 (resized).jpg
#13 1 year ago

I've got this rats nest almost sorted out. I want to be able to test when I finally get my last piece.

20181028_125019 (resized).jpg
#14 1 year ago

Wow, great work on that PCB. I would've just thrown in the towel and replaced it, but I am also lazy. Nice job!

#15 1 year ago
Quoted from TheDrewster:

Wow, great work on that PCB. I would've just thrown in the towel and replaced it, but I am also lazy. Nice job!

Thank you, sir!

#16 1 year ago

I just hope it works! It's a mess after all that Alkaline.

#17 1 year ago

I have a good D-10877 display board . Tested with no hacks if your needing one .

#18 1 year ago
Quoted from Pbgixxer:

I have a good D-10877 display board . Tested with no hacks if your needing one .

I won't know until I get this last ic and actually get to test it. Been almost a month since ordering.

#19 1 year ago

Are these hard to find replacements for? Just wondering. Sometimes I will pick up extra boards if I find them cheap or if they are better than the boards I have.

#20 1 year ago

I may post a vid of the first boot of the mpu; good, bad or ugly. Always such a tense moment. My hands will be sweating when I flip that switch. If anyone is following along and wants to see that, drop a comment. I will, if any interest.

#21 1 year ago
Quoted from Tomass:

I may post a vid of the first boot of the mpu; good, bad or ugly. Always such a tense moment. My hands will be sweating when I flip that switch. If anyone is following along and wants to see that, drop a comment. I will, if any interest.

I do great work so far. I just finished shopping mine. What an awesome game

#22 1 year ago
Quoted from darcangeloel:

I do great work so far. I just finished shopping mine. What an awesome game

Ok, will do. As soon as I get that last ic. Was in Kent WA 3 days ago.

#23 1 year ago

Got a huge piece to my resto in the mail today! This thing is nice! Anyone on the fence about buying the repro, I will say it is very nice.

20181103_172125 (resized).jpg
#25 1 year ago

Whelp, as promised.

U38 is right in the line of damage. It looked fine, and I did not replace it. Hope that is all.

#26 1 year ago

At least I have this to be happy about.

20181105_180347 (resized).jpg
#27 1 year ago

Looks like she booted up? Just got the factory reset warning. No biggie on that. Change the batteries and she should be good right?

#28 1 year ago

It is giving u38 pia failure. I think this is good though, since it is right in the area bit was not replaced. Looked fine but must have an issue.

#29 1 year ago
Quoted from Tomass:

It is giving u38 pia failure. I think this is good though, since it is right in the area bit was not replaced. Looked fine but must have an issue.

Ffffff is u38 bad or are the traces to u38 messed up? I wonder if its an issue of continuity?

#30 1 year ago

Only reason I say that is last night I thought u51 was bad turns out yours truly may or may not have lifted two traces when replacing SRC9... I got some interesting garbage on the bottom two displays I took the board back out and fixed the two traces and no issues after that.

#31 1 year ago

I will be checking over the next couple days. Have a 4 day conference for work so who knows how long they will go each day.

#32 1 year ago

Replaced u38 but still had problems. Found broken trace and now it boots! I need to fix a locked on knocker and I also have no speech. Also my controlled lights are rapid pulsing when they light up.

#33 1 year ago
Quoted from Tomass:

Replaced u38 but still had problems. Found broken trace and now it boots! I need to fix a locked on knocker and I also have no speech. Also my controlled lights are rapid pulsing when they light up.

IT'S ALIVE ALIVEEEEEEE awesome work man.

#34 1 year ago
Quoted from Tomass:

Replaced u38 but still had problems. Found broken trace and now it boots! I need to fix a locked on knocker and I also have no speech. Also my controlled lights are rapid pulsing when they light up.

The rapid plusing can you describe that a bit more? If you are in light test and you cycle through them does more than one come on at a time (I wonder if a row or column is shorted).

#35 1 year ago
Quoted from darcangeloel:

The rapid plusing can you describe that a bit more? If you are in light test and you cycle through them does more than one come on at a time (I wonder if a row or column is shorted).

I will put it on a video if it shows up on camera. I have the board out right now. U19 and u20 seem to be shorted or something. Pins 1 and 2 are both solid high and pin 3 reads nothing with a logic probe. The other gates on these chips are reading similar. The trasistors seem to test good. Is swapping u19 and u20 out the best option?

#36 1 year ago

I swapped out u20 and it still reads the same.
Pin 1 H
Pin 2 H
Pin 3 nothing.
Other 3 gates give same reading.

#37 1 year ago

Also even single lamps in test mode will rapid pulse rather than steady on.

#38 1 year ago
Quoted from Tomass:

I will put it on a video if it shows up on camera. I have the board out right now. U19 and u20 seem to be shorted or something. Pins 1 and 2 are both solid high and pin 3 reads nothing with a logic probe. The other gates on these chips are reading similar. The trasistors seem to test good. Is swapping u19 and u20 out the best option?

Sadly I'm not super familiar with those two. I wonder if @grumpy might have an idea

#39 1 year ago

I thought I made progress. I had it seemingly working without anything locking. Went into the other room to grab my mulitimeter and heard it reset. Then it reset a few times. Now it has pia failures and coils locking. Back to the drawing board!

2 weeks later
#40 1 year ago
Quoted from Tomass:

Got a huge piece to my resto in the mail today! This thing is nice! Anyone on the fence about buying the repro, I will say it is very nice.
[quoted image]

Glad to help Friend! It is coming along nicely. You can get repro Mini playfields (the clear one with the posts) as well if yours is too dingy or splintered (they have them every year at Expo).

#41 1 year ago

For the speech issue, check the U24 6802 CPU chip.

#42 1 year ago

With a board with that much damage, the corrosion will continue to spread under the green coating over time. My High Speed was repaired and worked fine for a few months, but now its going crazy again and resetting constantly. It will be almost impossible for me to get all the corrosion off the board with those fine traces. I hope you have better luck but these boards are tough once they are damaged.

#43 1 year ago

It seems to be working. I swapped the PIAs out to see if I got a new defective one and it seems to work. I have been focussed on getting my Cyclone and Comet ready for clear coat.

#44 1 year ago

Not saying ot won't spread and come back, but lets hope it doesn't. I sanded the mask back past the corrosion, but who knows for sure.

#45 1 year ago

Arranged for a big piece of this project! A pinsider who is on a podcast answered my ad for a coin door. I have 2 sys 11 doors on the way. I will use the best parts to restore a nice door for this Pin Bot! This project is going to be moving along as soon my other 2 are just a little further. Also going to order some nvram chips. I noticed I get errors when I reset factory and switch off and on with battery.

3 weeks later
#46 1 year ago

Just got a big piece of this project in the mail today. I will make 1 from the best parts of the 2 and replace parts as needed.

20190103_173356 (resized).jpg
#47 1 year ago
Quoted from Tomass:

Just got a big piece of this project in the mail today. I will make 1 from the best parts of the 2 and replace parts as needed.

Will you replicate the original look of the paint on the coin door?
Looks like the one on the right was spray painted with some mat black...
and it wasn't even disassembled when it was repainted things like that makes me sick.
I hope it won't be going on the pin like that!

#48 1 year ago
Quoted from Houkaka:

Will you replicate the original look of the paint on the coin door?
Looks like the one on the right was spray painted with some mat black...
and it wasn't even disassembled when it was repainted things like that makes me sick.
I hope it won't be going on the pin like that!

It will be restored to the best of my ability and I will be replicating the splatter spray as close to the original as I can. The one has definitely been repainted and the splatter effect is gone.

#49 1 year ago

Great progress. My PinBot was occasionally resetting during play. Re-capped the power supply and all is good now. Will be following this... keep on trucking!

1 month later
#50 1 year ago

Nice work!

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
2,000 (Firm)
Sale Pending!
West Deptford, NJ
$ 17.00
$ 18.99
Eproms
Matt's Basement Arcade
From: $ 18.00
Apparel - Men
Pinside Shop
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 50.00
$ 175.00
Lighting - Interactive
Professor Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 0.95
Playfield - Other
Rocket City Pinball
There are 58 posts in this topic. You are on page 1 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside