(Topic ID: 245057)

Pinbot both flippers causing errors


By thebman80

4 months ago



Topic Stats

  • 14 posts
  • 2 Pinsiders participating
  • Latest reply 4 months ago by thebman80
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 4 images uploaded to this topic. (View topic image gallery).

20190613_194358 (resized).jpg
20190613_191546 (resized).jpg
20190613_181522 (resized).jpg
20190613_181554 (resized).jpg

#1 4 months ago

My pinbot was working great and I turn it on today and the left flipper tilts and ends the game. The game says "all data lost" when the left flipper is hit and everything ends until the ball is sunk. The right flipper works fine but some sort of bonus triggers each time the flipper is hit. I have no Idea whats going on the switch test says no switches are bad.

Is this a CPU issue or a Diode issue?

I was was in the middle of having this game up for sale and was getting emails about the game when this BS started happening so any help with this would be greatly appreachieated since I'm basically in panic mode with this thing.

#2 4 months ago

I would check the diodes on your flipper coils. They could have failed and you are sending a voltage spike back to the mpu when the emf collapses.

Also - in switch edge test i am curious if you hit the left flipper do you get more switches showing up than just the EOS switch. You mention the game tilts but is it showing tilted or just resetting?

#3 4 months ago

I replaced the diodes on the left flipper already and when in switch test mode I hold down the flipper button and one switch randomly triggers each time I press and hold down the flipper button. The switches that trigger are 02, 10, 18, 26, 34, 50, 58, but just one of these switches each time the button is pressed. I also replaced the diode on the roller tilt switch with the ball.

The right side I didn't do the diodes yet on the flipper if you hold down the flipper button in switch mode it continually cycles through all these switches never stopping. unlike the other left flipper where its one at a time then stops. It cycles through 3, 11, 19, 27, 35, 43, 51, 59 endlessly.

Also the left flipper I just wanted to double check the banded side of the diode that points towards the grey wire on the coil?

#4 4 months ago

if the grey wire is your “hot” wire then yes. The incoming voltage should be attached to the banded side of the diode.

You have two entire rows out. Row 2 (white/red wire) and row 3 (white/orange wire). I would start by looking for a short. Or a bad diode, but it wont necessarily be on the switch you are triggering. When testing for a bad diode make sure to remove one leg from the circuit first.

So this just happened from one day working great to the next this problem? Or was anything being done where a switch terminal could of been bent over to cause a short.

This can look like a big issue but it could be one small issue causing a big mess in your switch matrix.

#5 4 months ago

This just occurred out of nowhere game was 100% working. The game was sitting in the center of my workshop for a few weeks not plugged in or touching anything so it was noting I did to it.

#6 4 months ago

Ok here's where I'm at as of right now.

Switch 02 (ball roll tilt), 18 (Ball trough #2 (center)), 26 ((Right eject) right eye), 34 (right 5-bank), 50 (left drop target (mid))

All tested fine but replaced diode anyways since I had it half removed already.

Switch 10 (left lane change) where is this? Is it the switch that's on the flipper assembly? If it Is I replaced all the diodes on both flippers coil and switch.

Switch 42 and 58 not used so irrelevant.

Next row

Switch 10 (advance planet), 35 (right 5-bank center), 51 (left drop target (lower)), 59 (10 point)

All diodes tested fine but replaced anyways

Switch 3 (credit button) Is that the start button on the front of the game? If so diode tested fine but replaced anyways.

Switch 11 (Right lane change) again where the hell is this one? If it was the leaf switch with the flipper coil assembly then it was replaced.

Switch 27 and 43 not used so irrelevant.

Tested and replaced all these switch diodes and all the diodes on the flipper assemblies. All were testing good and after replacing all of them the game still has the issues nothing has changed.

#7 4 months ago

I’ve never had to troubleshoot an entire row out let alone two. But i’m not sure a bad diode would cause this behavior.

I would start going through the wiring looking for a broken wire. Especially in areas where wires flex or mechs create vibration.

Also - if you remove the row and column connectors from MPU, and determine if this is a board issue or a pf issue. This is done in switch test by attaching an alligator clip (or similar) to pin one of The column header, then Touching the other end to pin one of the row header. You should see only one switch. Then work your way down the row pins observing the correct switch is registered. Move to column pin 2 and repeat.

#8 4 months ago

Ok so take a jumper to either pin 7 or 8 of well both one at a time of 1J10 and touch to 1-8 of 1J8. And see if the correct switch comes up matching the Switch matrix chart. So I'm guessing if it's all coming up correct then its a board issue then.

20190613_181522 (resized).jpg20190613_181554 (resized).jpg
#9 4 months ago

Ok I couldn't get anything to happen when I removed the row and column connectors from the cpu and tried to jumper. When I left them connected to the CPU and jumped either switch row 3 pin 7 or switch row 2 pin 8 to 1-8 on the Column connector all tested fine to the correct switch but both did not test fine when jumpered to pin 2 on 1J8. When either row 2 or 3 were jumpered to column pin 2 on 1J8 they would cycle through all the switches on their corresponding row.

So row 2 column 2 is switch 10 (Left lane change) and row 3 column 2 is switch (Right lane change)

So I not sure If I did that right or not it wouldn't work when one or both connectors were off the CPU only when both connected.

The thing that has me is where are 10 and 11? the diagram shows them under the playfield.
20190613_191546 (resized).jpg

#10 4 months ago

So I'm going to guess this was something on the CPU that failed and the parts I have circled in red are what pin 2 passes through.

20190613_194358 (resized).jpg
#11 4 months ago
Quoted from thebman80:

Ok I couldn't get anything to happen when I removed the row and column connectors from the cpu and tried to jumper.
[quoted image]

So with IJ8 and IJ10 removed, with game on and in switch edge test you dont get any switch numbers showing up when you jumper the pins? If you get the proper switch (and only one) according to the switch matrix chart, you know your MPU is good and it is a pf issue. If you get weird results and the rows showing up again you will know it is on the MPU.

I’m not clear on what you mean by nothing happens.

Cant remember if the lane change switches are stacked on the EOS switch on the flipper assembly. But its for sure connected to either the EOS switch or the flipper switch somehow.

#12 4 months ago

The switches wont work when the connectors are removed. They only register when connected to the CPU. Since they both went wonky when connected to pin 2 of 1J8 that basically confirmed that the CPU had an issue. I pulled the CPU and my first thought was to pull the 3904 transistor Q49. Transistors always seem to be the things I find bad on pins so I figured it was the best place to start. I tested the part when I pulled it off the board and it was bad. I reinstalled a new 3904 and now the game works again. I did have another issue when I turned it on the left flipper didn't work after I jiggled the small 1J19 two pin connector it started working again so I'm going to repin the 1J19 connector and that should fix that.

#13 4 months ago

Sweet! Good job.

#14 4 months ago

Thanks that really was a pain and I'm so happy that it's working again. Also repined that 1J19 connector on the CPU made it all one connector instead of a separate 2 pin plus a 7 pin. Game has been working good now and better stay that way lol.

Promoted items from the Pinside Marketplace
2,600 (OBO)
Machine - For Sale
Elburn, IL
$ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
Wanted
Machine - Wanted
Canfield, OH
1,900 (OBO)
Machine - For Sale
Annapolis, MD
$ 14.00
Electronics
Yorktown Parts and Equip
3,100 (OBO)
Machine - For Sale
Mechanicsville, VA
$ 40.00
Lighting - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside