(Topic ID: 257273)

Pinball pool Gottlieb system 1 display problem

By Croppie1Kenobi

2 years ago



Topic Stats

  • 5 posts
  • 3 Pinsiders participating
  • Latest reply 2 years ago by Croppie1Kenobi
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

0E0CB200-86F5-4DD8-B1C8-C9EFD5178813 (resized).jpeg
900px-Gtb_sys1_displays (resized).png

#1 2 years ago

Hello all. I have this game all working except last 2 digits on the displays don’t work. CPU has been gone through with ics replaces where needed. Ground mods and really everything that I can find on the repair guide. Any ideas? I have 2 sets of displays that test ok. Thanks for any help.

#2 2 years ago

Have you tested the voltages to see if your getting the following? And is there any change in test mode?

6 Digit Display

+60vdc
+8vdc
5vac

4 Digit Display

+42vdc
+4vdc
3vac

Thanks
Blake

#3 2 years ago
Quoted from Blake:

Have you tested the voltages to see if your getting the following? And is there any change in test mode?
6 Digit Display
+60vdc
+8vdc
5vac
4 Digit Display
+42vdc
+4vdc
3vac
Thanks
Blake

Yes when the power board was rebuilt. I'll double check tonight. Thank you for the response.

#4 2 years ago
Quoted from Croppie1Kenobi:

Hello all. I have this game all working except last 2 digits on the displays don’t work. CPU has been gone through with ics replaces where needed. Ground mods and really everything that I can find on the repair guide. Any ideas? I have 2 sets of displays that test ok. Thanks for any help.

If all the other digits are working I suspect that it isn't a power issue. The fact the majority of them are lit indicates the power is ok.

https://www.pinwiki.com/wiki/index.php?title=Gottlieb_System_1#Display_Problems

Issue with more than one display

If the problem shows up on two or more displays, suspect one of the two connectors on the CPU board (A1J2 or A1J3), or the chips which control the display data on the CPU board. If there is a digit issue, the issue will be present on player 1 and 3 or player 2 and 4 displays. If there is a segment issue, the issue will be present on player 1, 2, and the status displays or player 3 and 4 displays. Although the picture shown to the left is from a System 80A game with 7-digit displays, the problems illustrated apply to System 1 games as well.

900px-Gtb_sys1_displays (resized).png
#5 2 years ago

Solved. Replaced a chip on the board in this section. (See picture) After that worked, socketed and replaced them all for good measure.

0E0CB200-86F5-4DD8-B1C8-C9EFD5178813 (resized).jpeg
Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
1,300 (OBO)
Sale Pending! Machine - For Sale
Ames, IA
From: $ 15.00
Lighting - Led
Professor Pinball
$ 109.95
Cabinet - Sound/Speakers
Pinball Pro

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!