(Topic ID: 284032)

"Morning MU/TH/UR" Pinball Brothers Alien Remake Owners Club

By Red_Devils

1 year ago


Topic Heartbeat

Topic Stats

  • 5,269 posts
  • 299 Pinsiders participating
  • Latest reply 37 minutes ago by Zablon
  • Topic is favorited by 150 Pinsiders

You

Linked Games

Topic poll

“What are you in on an SE or LV?”

  • LV 62 votes
    33%
  • SE 59 votes
    32%
  • Not interested in this game 65 votes
    35%

(186 votes)

This poll has been closed.

Topic Gallery

View topic image gallery

072C0527-3805-4B82-A404-B49C2987BCC6 (resized).jpeg
127B950A-F686-4A09-9C9E-E7BDD1DA4911 (resized).jpeg
0123221405a (resized).jpg
0123221405 (resized).jpg
PXL_20220123_172517836 (resized).jpg
PXL_20220123_172447980 (resized).jpg
PXL_20220123_172420338 (resized).jpg
PXL_20220123_172400269 (resized).jpg
PXL_20220123_172350553 (resized).jpg
PXL_20220123_172337814 (resized).jpg
PXL_20220123_172327678 (resized).jpg
PXL_20220123_172321044 (resized).jpg
PXL_20220123_172517836 (resized).jpg
PXL_20220123_172447980 (resized).jpg
PXL_20220123_172420338 (resized).jpg
PXL_20220123_172400269 (resized).jpg

Topic index (key posts)

4 key posts have been marked in this topic (Show topic index)

There are 5,269 posts in this topic. You are on page 54 of 106.
#2651 4 months ago
Quoted from Asylum:

It really is that different of a game to what I have had and what is out now.

Same here, Iv'e owned a lot of games. Started collecting in the early 90s. This one is different!

#2652 4 months ago
Quoted from RussG:

What was lighting the egg in the BG originally?
Anyone have a picture?

There are about 40 LED lights around the black case in this picture. This is the only lighting for the backglass.

IMG_6547 (resized).JPGIMG_6548 (resized).JPGIMG_6549 (resized).JPG

#2653 4 months ago
Quoted from mrclean:

It would be cool, it wouldn’t surprise me If they add some or most of these features into the LV:
-Lockdown bar as additional screen / viewing area. (Assuming they don’t place the other screen into the playfield)
-Larger backbox LCD monitor
-Black / Shinny Alien Wet look to match the queen powder coated trim
-Upgraded HD / Invisaglass
-Beacon “topper” lights
-Numbered Plaque
-Shaker
-Customs Shooter Rod
-Mirrored upgraded art / Backglass / blades
-Extra game mode

The best thing they could add is an upgraded apron like the one selling aftermarket. The apron is the cheapest looking part of the entire game IMO.

#2654 4 months ago

So tonight was the night the gremlins came out. 4 different lock ups/issues within 10 minutes after an hour of play.

1. putting in initials, suddenly it just 'finished' the initials on its own, then switched to the volume screen and went to 0. While I could leave the screen, the volume would not change from zero until a reboot.

2. ball bounced back into trough and the ball search never tried to push another ball out. I tilted the machine while trying to get it to move one way or the other and after the tilt animation, the game just locked up (screen included) and would do nothing until a reboot.

3a) during ambush multiball the right flippers stopped working and the xeno mouth stayed open.

3b) On reboot x 4 the xeno would not work. Then, toggling in and out of the service menu, it started working again and the flippers started working again

This is on 2.2D

As for the xeno, I didn't have any issues after this, but I wonder if after so many games that badly implemented switch starts to get bent and deformed. I haven't opened up the game to see yet.

Also, the dimples...they are a comin.

#2655 4 months ago
Quoted from Zablon:So tonight was the night the gremlins came out. 4 different lock ups/issues within 10 minutes after an hour of play.
1. putting in initials, suddenly it just 'finished' the initials on its own, then switched to the volume screen and went to 0. While I could leave the screen, the volume would not change from zero until a reboot.
2. ball bounced back into trough and the ball search never tried to push another ball out. I tilted the machine while trying to get it to move one way or the other and after the tilt animation, the game just locked up (screen included) and would do nothing until a reboot.
3a) during ambush multiball the right flippers stopped working and the xeno mouth stayed open.
3b) On reboot x 4 the xeno would not work. Then, toggling in and out of the service menu, it started working again and the flippers started working again
This is on 2.2D
As for the xeno, I didn't have any issues after this, but I wonder if after so many games that badly implemented switch starts to get bent and deformed. I haven't opened up the game to see yet.
Also, the dimples...they are a comin.

Oh wow, I just went from wanting this pin immensely to "undecided" again after reading this. Why so many issues? Is it the coding or something else?

#2656 4 months ago
Quoted from RussG:

What are they recommending then?
Terry cloth for wiping and waxing?

tumblr_3c40e1d9abc3bff8c8df7d3bc6a496fa_cddddd3e_250 (resized).png
#2657 4 months ago

I am going to find some sort of natural, soft fiber cloth used for polishing- 100% cotton polishing pad.

I found these on Amazon: amazon.com link »

#2658 4 months ago

I blew a fuse the other day. Went to replace it and noticed it was the wrong amp that was originally put in there.

#2659 4 months ago

Hd or PDI glass for Alien pin.. Anyone have a vendor or model number so i can pre purchase?

#2660 4 months ago
Quoted from Zablon:

So tonight was the night the gremlins came out. 4 different lock ups/issues within 10 minutes after an hour of play.
1. putting in initials, suddenly it just 'finished' the initials on its own, then switched to the volume screen and went to 0. While I could leave the screen, the volume would not change from zero until a reboot.
2. ball bounced back into trough and the ball search never tried to push another ball out. I tilted the machine while trying to get it to move one way or the other and after the tilt animation, the game just locked up (screen included) and would do nothing until a reboot.
3a) during ambush multiball the right flippers stopped working and the xeno mouth stayed open.
3b) On reboot x 4 the xeno would not work. Then, toggling in and out of the service menu, it started working again and the flippers started working again
This is on 2.2D
As for the xeno, I didn't have any issues after this, but I wonder if after so many games that badly implemented switch starts to get bent and deformed. I haven't opened up the game to see yet.
Also, the dimples...they are a comin.

1. I haven't seen that particular issue, but I have seen controls stop working after being left on for an extended period of time once. I reported this.

2. This one was causing me a lot of grief. Setting power to -50% plus 2.2F seems to have fixed it. There was some issue that caused the power of the trough eject to fluctuate. 2.2F seems to have made it stable.

3a. I think this is related to #1... I did have the flippers stop responding once in the past 4 months. I believe it was after I left the game on for 8 hours or more.

3b. I know there is a timing issue on power-on that can cause some weird issues. One thing I've seen is that the screen would be blank on power-on in certain cases. Not sure if this is fixed in 2.2F, but I do know I haven't seen it recently.

#2661 4 months ago
Quoted from AD72:

I have been getting the ball stuck in the ailien’s jaw sometimes. It will finish the multiball and I will have drained all balls except this one. It is only in ball search that the alien drops the ball through the bottom of mouth. Then it just continues play on that ball. Running 2.2D and everything else is working with the alien picking up the ball.
[quoted image]

I have gotten this a few times since updating as well. I think the gear is slightly slipping sometimes. There is a thread on the support desk showing how to tighten the set screw on the gear I haven't done it yet but I'm going to start there

#2662 4 months ago
Quoted from brado426:

1. I haven't seen that particular issue, but I have seen controls stop working after being left on for an extended period of time once. Took a log and reported this.
2. This one was causing me a lot of grief. Setting power to -50% plus 2.2F seems to have fixed it. There was some issue that caused the power of the trough eject to fluctuate. 2.2F seems to have made it stable.
3a. I think this is related to #1... I did have the flippers stop responding once in the past 4 months. I believe it was after I left the game on for 8 hours or more.
3b. I know there is a timing issue on power-on that can cause some weird issues. One thing I've seen is that the screen would be blank on power-on in certain cases. Not sure if this is fixed in 2.2F, but I do know I haven't seen it recently.

I had the screen blank on 2.2 once, but not 2.2D.

As for what was asked, I think most of these are indeed software issues as they are not persistent. If it was hardware/electrical something would have blown or stayed broken. Just wierd that I played so many games w/o issue and then had them all at once. We'll see how this weekend goes as I have people coming over.

#2663 4 months ago
Quoted from Zablon:

I had the screen blank on 2.2 once, but not 2.2D.
As for what was asked, I think most of these are indeed software issues as they are not persistent. If it was hardware/electrical something would have blown or stayed broken. Just wierd that I played so many games w/o issue and then had them all at once. We'll see how this weekend goes as I have people coming over.

I can get to your place in 15 hours....lol

#2664 4 months ago
Quoted from Zablon:

2. ball bounced back into trough and the ball search never tried to push another ball out.

I don’t think it would be wise for a ball search to activate the trough kicker or you would end up with multiple balls on the playfield whenever a search is performed

#2665 4 months ago
Quoted from Mageek:

I don’t think it would be wise for a ball search to activate the trough kicker or you would end up with multiple balls on the playfield whenever a search is performed

It should recognize right away with the trough switch that the ball isn't there and bounced back in and should eject again..That's pretty standard in pinball machines and this one does not do it.

#2666 4 months ago
Quoted from kciaccio:

It should recognize right away with the trough switch that the ball isn't there and bounced back in and should eject again..That's pretty standard in pinball machines and this one does not do it.

Hate to disagree but mine certainly does . That has nothing to do with a ball search.

#2667 4 months ago
Quoted from Mageek:

Hate to disagree but mine certainly does . That has nothing to do with a ball search.

I understand and agree it should not be part of "Ball Search" But I have had plenty of saved balls not eject out right and the game sits in limbo and just ends up draining the ball.

Your machine might re-kick out a ball when a ball is not activated on the trough switch but mine does not automatically. Maybe because mine does not get registered by the trough because it is stick between eject and trough sensor.

#2668 4 months ago

Are there any cool pin gulps out there for this Alien pin yet?

#2669 4 months ago
Quoted from kciaccio:

It should recognize right away with the trough switch that the ball isn't there and bounced back in and should eject again..That's pretty standard in pinball machines and this one does not do it.

In this case it wasn't in the trough, it had hit the other side and bounced back in and got stuck on the lip, thus why i was shaking the machine. It should have seen a ball missing, but he's right, it would have tried to eject 2 balls I think. The lockup was really more of the concern. I was aware of the ball ejecting hard, and have the power turned down by 15% and for the most part that has been fine.

A few things I've noticed though (and R&M has this same issue) is the variance in the shooter lane power. Most times it works just fine, and other times it doesn't. I will give it some credit though, when I was setting it up i ended up with 2 balls in the shooter lane. It kept increasing the power until both balls were launched.

#2670 4 months ago
Quoted from EightBallTexas:

I can get to your place in 15 hours....lol

LOL, man I used to make that drive a lot. Such a slog...so many hours of just...nothing

#2671 4 months ago
Quoted from EightBallTexas:

I can get to your place in 15 hours....lol

When do you get your pin? I am thinking of inviting some pinsiders to come play mine next month when my Halloween pin arrives.

Thought of doing a pinball Halloween party and Play ACNC, TFTC, Halloween and Alien...

#2672 4 months ago
Quoted from kciaccio:

When do you get your pin? I am thinking of inviting some pinsiders to come play mine next month when my Halloween pin arrives.
Thought of doing a pinball Halloween party and Play ACNC, TFTC, Halloween and Alien...

You need a Haunted House too!

#2673 4 months ago
Quoted from kciaccio:

When do you get your pin? I am thinking of inviting some pinsiders to come play mine next month when my Halloween pin arrives.
Thought of doing a pinball Halloween party and Play ACNC, TFTC, Halloween and Alien...

Who knows man, LV could be next year.

We are coming to H town for the pinball expo, let's have a house party to kick it off.

#2674 4 months ago
Quoted from Zablon:

You need a Haunted House too!

and a gilligans island..

#2675 4 months ago
Quoted from Zablon:

In this case it wasn't in the trough, it had hit the other side and bounced back in and got stuck on the lip, thus why i was shaking the machine. It should have seen a ball missing, but he's right, it would have tried to eject 2 balls I think. The lockup was really more of the concern. I was aware of the ball ejecting hard, and have the power turned down by 15% and for the most part that has been fine.
A few things I've noticed though (and R&M has this same issue) is the variance in the shooter lane power. Most times it works just fine, and other times it doesn't. I will give it some credit though, when I was setting it up i ended up with 2 balls in the shooter lane. It kept increasing the power until both balls were launched.

Yes, I used to have that issue with the ball bouncing off the side and then falling back in... even if I decreased power to -50%, it still did that occasionally.) With 2.2F, it never does that... so I *think* that is going to be fixed soon.

#2676 4 months ago

Are mirror blades available for PB alien?

#2677 4 months ago
Quoted from Jimmyhonda:

Are mirror blades available for PB alien?

I have not seen them, and i have been looking. If you find, please share link with me.

#2678 4 months ago

I'm not sure Mirror blades would fit...it is TIGHT.

#2679 4 months ago

I just put my $1 down with Cointaker. I was told that the list is long but they have confirmed numbers from PB and there's definitely still some available. Stop your grinning and grab you linens boys!

#2680 4 months ago

I'm behind on my updates. I'm on C I think. Can I jump straight to F or whatevers newest now? I do I go back and do D,E and then F? Thx

#2681 4 months ago
Quoted from Llabnip1972:

I just put my $1 down with Cointaker. I was told that the list is long but they have confirmed numbers from PB and there's definitely still some available. Stop your grinning and grab you linens boys!

Well that just got me off the fence! Just put down my dollar!

#2682 4 months ago

Did the Pinball Brothers ever say how many LVs would be made?

#2683 4 months ago
Quoted from pcprogrammer:

Did the Pinball Brothers ever say how many LVs would be made?

I am guessing that might be one of the things answered on the 24th.

#2684 4 months ago
Quoted from kciaccio:

things answered on the 24th.

7 days to go .....

#2685 4 months ago

As I was making space for this, I hadn't realized the backbox was normal sized so even as a wide body it took up less space than the old Time Machine I moved elsewhere.

So far today no issues. Small targets were beginning to move around so I took them out and ground down the inside of the plastics. No sticking issues now. I really hope whatever v3 is, they do away with those switch buttons, those will never last very long as a bash toy, even if they aren't getting the full impact.

Also, I noticed that those boards have leds that are not used in them...hmm...

#2686 4 months ago
Quoted from Zablon:

You need a Haunted House too!

EHOH would be a better choice.. a bit of a price differene, though

#2687 4 months ago
Quoted from Zablon:

As I was making space for this, I hadn't realized the backbox was normal sized so even as a wide body it took up less space than the old Time Machine I moved elsewhere.
So far today no issues. Small targets were beginning to move around so I took them out and ground down the inside of the plastics. No sticking issues now. I really hope whatever v3 is, they do away with those switch buttons, those will never last very long as a bash toy, even if they aren't getting the full impact.
Also, I noticed that those boards have leds that are not used in them...hmm...

Hmmm indeed... i am wondering if the connections from an earlier post with open sockets on boards line up with these? are there sockets on the LED boards in the switches?

#2688 4 months ago
Quoted from Utesichiban:

EHOH would be a better choice.. a bit of a price differene, though

And A Rob Zombie pin...

#2689 4 months ago
Quoted from PunkPin:

My temporary solution was to move the nut further down the screw to the bottom of the bracket[quoted image]

Funny. I did the exact same thing 24 hours ago.

#2690 4 months ago

Just joined the club game was missing the legs had to use some extra's I had unfortunately. Other than that really happy to finally add Alien to the collection.

20210917_205054 (resized).jpg

#2691 4 months ago
Quoted from Coolpinballdino:

Just joined the club game was missing the legs unfortunately. Other than that really happy to finally add Alien to the collection.
[quoted image]

Missing legs!?

1EBC1771-F4EF-465B-B0C5-0D1D96DE4561 (resized).jpeg
#2692 4 months ago
Quoted from ElCid95:

Any suggestions on why I get a "unknown update error" when I try to update my game? It came with 2.2 installed and trying to put 2.2D on it.

Finally got my game to update to 2.2D The fix was to use a program called Rufus to reformat my USB stick as a non-bootable device.

#2693 4 months ago
Quoted from Baggerman:

Hmmm indeed... i am wondering if the connections from an earlier post with open sockets on boards line up with these? are there sockets on the LED boards in the switches?

yes, the boards are the same for the small and large, and the large have the 2nd socket used. It will come down to software I believe.

I forgot to ask...anyone else notice that the glass on this seems...tinted? I think it might have a bit of anti-reflectivity on it. It's not 100% but it seems to be darker than my other games. (when it was out)

#2694 4 months ago

Having an issue with the left side coils not working and left flippers not holding. Worked with Cato and checked the molex connector in the playfield control box, as well as the fuses there. Everything appears to be fine, but I’m still having the issue. Thought I’d post here to see if anyone else has thoughts.

#2695 4 months ago
Quoted from Paddy-o:

Having an issue with the left side coils not working and left flippers not holding. Worked with Cato and checked the molex connector in the playfield control box, as well as the fuses there. Everything appears to be fine, but I’m still having the issue. Thought I’d post here to see if anyone else has thoughts.

I had a similar issue and it was the fuse. Did you test the fuse with a multimeter? Sometimes they look fine but are blown. If you don't have a replacement fuse, maybe swap the fuses around (there are three I believe) and see if the problem goes away or moves to the center or right coils.

#2696 4 months ago

I noticed a collision between the jaw and the targets when they get pushed inwards. I had to tighten the screws holding the support bracket to the switch. I may get some locknuts or use loctite.

2335B893-A3C3-46CA-84BA-3AAC336DD8E5 (resized).jpeg33698810-5B0A-42B4-A316-F86E17F1F467 (resized).jpeg
#2697 4 months ago
Quoted from TinyBlackDog:

I had a similar issue and it was the fuse. Did you test the fuse with a multimeter? Sometimes they look fine but are blown. If you don't have a replacement fuse, maybe swap the fuses around (there are three I believe) and see if the problem goes away or moves to the center or right coils.

I didn't have replacement fuses, so I did exactly what you had suggested, and the problem remained. Have additional fuses on order, and will replace them. Curious about the fuses, as the box says 8amp, but the manual says 10amp.

#2698 4 months ago

One of my customers made it to "All Out War" a week or so ago. It was pretty awesome to witness. I got video, but don't want to be a spoiler for those that like to witness it for the first during their own game. I will have to say, I wish there was more going on with the screen. It pretty much just displays the same wording the whole time.

#2699 4 months ago

Who the hell is looking at the screen during multiball!!

#2700 4 months ago
Quoted from Zablon:

Who the hell is looking at the screen during multiball!!

The person filming. HA.

Yeah dont show us the video...

There are 5,269 posts in this topic. You are on page 54 of 106.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside