(Topic ID: 284032)

"Morning MU/TH/UR" Pinball Brothers Alien Remake Owners Club

By Red_Devils

1 year ago


Topic Heartbeat

Topic Stats

  • 5,253 posts
  • 299 Pinsiders participating
  • Latest reply 8 minutes ago by Lethal_Inc
  • Topic is favorited by 151 Pinsiders

You

Linked Games

Topic poll

“What are you in on an SE or LV?”

  • LV 62 votes
    33%
  • SE 59 votes
    32%
  • Not interested in this game 65 votes
    35%

(186 votes)

This poll has been closed.

Topic Gallery

View topic image gallery

pasted_image (resized).png
index3 (resized).jpg
index2 (resized).jpg
index (resized).jpg
received_1639569626388100 (resized).jpeg
received_358044395832938 (resized).jpeg
received_260732789448455 (resized).jpeg
received_692021131801245 (resized).jpeg
received_651280516070057 (resized).jpeg
Alien LV (resized).jpg
20220119_194053 (resized).jpg
0DA64A13-C4DA-4B13-8635-7BA3EADEE15D (resized).jpeg
A8EE1733-4DF6-43BE-BCB2-19A43E7D39F8 (resized).jpeg
3063B580-2027-4B30-BA95-9CCB1CB505E0 (resized).jpeg
5E7BD537-604E-49C4-BA77-4789B1E6DC34 (resized).jpeg
fJUQEag6h3l3nAQI0nxf5t5se2U=.gif

Topic index (key posts)

4 key posts have been marked in this topic (Show topic index)

There are 5,253 posts in this topic. You are on page 47 of 106.
11
#2301 4 months ago

I dropped in code version 2.2d last night before my stream. No hang ups at all. I also adjusted the trough kickout and muthur kickout down a bit and both work great. I beat Self Destruct again and set a new GC of 307M. 2.2d was a huge improvement over 2.2. Also, the Xeno grabbed the ball every time. Huge improvement on the magnet grab. Here is a link if anyone wants to check it out.

Quoted from ElCid95:

Yep, it was freshly formatted and in the root directory.

#2302 4 months ago

One thing I would recommend is to check the post directly in front of the upper right flipper. I noticed it moved a little after about a week of play so I added some loc-tite and reinstalled it. About a month or so later, I noticed it was coming loose again. There is a t-nut in the bottom of the playfield and it is located under the flipper plate mech. After digging further into it, it appears there is only a few threads that make contact with the t-nut. I grabbed a Bally Williams post, another washer, and a low profile locknut and replaced the stock PB post and t-nut. As you can see from the pic, this could get pretty bad if it is loose as the post takes a lot of direct hits. The wear from the old washer is covered by the new washer I installed but thought I would share this so others could check and adjust as need. The post I used was roughly about a 1/4 of an inch longer (the threads) but not so long as to contact the flipper plate.

275D5142-E858-4A59-B14A-457112E979EB (resized).jpeg449D5DB7-40E0-40E1-8139-62B9C4AFE5E2 (resized).jpegD4EABDBF-A6CB-4288-858E-719AE0B42EE9 (resized).jpeg

#2303 4 months ago
Quoted from HurryUpPinball:

One thing I would recommend is to check the post directly in front of the upper right flipper. I noticed it moved a little after about a week of play so I added some loc-tite and reinstalled it. About a month or so later, I noticed it was coming loose again. There is a t-nut in the bottom of the playfield and it is located under the flipper plate mech. After digging further into it, it appears there is only a few threads that make contact with the t-nut. I grabbed a Bally Williams post, another washer, and a low profile locknut and replaced the stock PB post and t-nut. As you can see from the pic, this could get pretty bad if it is loose as the post takes a lot of direct hits. The wear from the old washer is covered by the new washer I installed but thought I would share this so others could check and adjust as need.
[quoted image][quoted image][quoted image]

Thank you for this. This should probably be done immediately when getting the game.

Thanks for all your inputs!

#2304 4 months ago
Quoted from brado426:

Not only is it solid, but any problem I have encountered so far has been a super easy fix. The thing is designed in a way that replacing parts is super easy. I'm used to working on older pinball machines and the design makes it a joy to work on.

So it was super easy to fix the loud grinding noise that the alien tongue makes? I know someone posted about that, but wasn’t sure how well the fix worked, or how easy it was.

#2305 4 months ago
Quoted from chuckwurt:

So it was super easy to fix the loud grinding noise that the alien tongue makes? I know someone posted about that, but wasn’t sure how well the fix worked, or how easy it was.

I'm curious why it is making the grinding noise in mine as well. What was the fix?

#2306 4 months ago
Quoted from chuckwurt:

So it was super easy to fix the loud grinding noise that the alien tongue makes? I know someone posted about that, but wasn’t sure how well the fix worked, or how easy it was.

I've never had to touch my Alien Xenomorph. As I recall, it was particularly loud when you first powered in on in an earlier software version, but a software update changed the speed of the Xenomorph tongue on power-on, which resolved that.

#2307 4 months ago
Quoted from brado426:

I've never had to touch my Alien Xenomorph. As I recall, it was particularly loud when you first powered in on in an earlier software version, but a software update changed the speed of the Xenomorph tongue on power-on, which resolved that.

Glad to hear. Sounded awful before. Fingers crossed it holds up.

#2308 4 months ago
Quoted from brado426:

I've never had to touch my Alien Xenomorph. As I recall, it was particularly loud when you first powered in on in an earlier software version, but a software update changed the speed of the Xenomorph tongue on power-on, which resolved that.

This - fixed in software as I experienced this too.

#2309 4 months ago

Mine is still loud, but did get quieter after the software update. It's functioned just fine though, minus the sound.

#2310 4 months ago
Quoted from zacaj:

Mine is still loud, but did get quieter after the software update. It's functioned just fine though, minus the sound.

i would consider mine loud too .. only went from 2.2 to 2.2 d and didnt notice a significant improvement , although i wasnt expecting one , so ill have to pay more attention.

Pinnovators is working on a headphone kit. I might be the beta tester for this one.

#2311 4 months ago

New update has been great for me.

The only issue I have now is occasionally when they ball gets ejected into the shooter lane after being saved it will bounce back into the trough and ends the ball. Seems like that there should be an update on how the machine deals with balls bounced back into trough.

My Alice Cooper Nightmare Castle does that occasionally but recognizes the ball did that and ejects again back into the shooter lane. Other than that game is playing superbly.

#2312 4 months ago
Quoted from kciaccio:

The only issue I have now is occasionally when they ball gets ejected into the shooter lane after being saved it will bounce back into the trough and ends the ball. Seems like that there should be an update on how the machine deals with balls bounced back into trough.

Turn down the trough kickout coil power in the adjustment menu. I had to do this on the original Aliens pin I'm working on for a local Pinsider.

#2313 4 months ago
Quoted from PinballManiac40:

Turn down the trough kickout coil power in the adjustment menu. I had to do this on the original Aliens pin I'm working on for a local Pinsider.

I have been playing with all the different power settings and then it occasionally does not have enough power to eject out strong enough and falls back in to trough.

Damned if I do damned if I don't. lol I will keep playing with it. I checked for trough plunger coil alignment and its straight.

#2314 4 months ago
Quoted from kciaccio:

I have been playing with all the different power settings and then it occasionally does not have enough power to eject out strong enough..lol
Damned if I do damned if I don't. lol

I had the same problem so I 3D printed this thing to help keep the ball from bouncing back into the trough. Original is on the right

3D8B54E3-9AB1-4DB1-9537-0B50E7043A66 (resized).jpegF83F922F-0315-4DAB-807A-53037FEB1D44 (resized).jpeg
#2315 4 months ago
Quoted from Mageek:

I had the same problem so I 3D printed this thing to help keep the ball from bouncing back into the trough. Original is on the right
[quoted image][quoted image]

Nicely Done.

#2316 4 months ago
Quoted from Mageek:

I had the same problem so I 3D printed this thing to help keep the ball from bouncing back into the trough. Original is on the right
[quoted image][quoted image]

Sell them. lol...I will buy one!

#2317 4 months ago
Quoted from kciaccio:

Sell them. lol...I will buy one!

I will take 2. Back up as I will be playing the shit out of this PIN.

#2318 4 months ago
Quoted from HurryUpPinball:

One thing I would recommend is to check the post directly in front of the upper right flipper. I noticed it moved a little after about a week of play so I added some loc-tite and reinstalled it. About a month or so later, I noticed it was coming loose again. There is a t-nut in the bottom of the playfield and it is located under the flipper plate mech. After digging further into it, it appears there is only a few threads that make contact with the t-nut. I grabbed a Bally Williams post, another washer, and a low profile locknut and replaced the stock PB post and t-nut. As you can see from the pic, this could get pretty bad if it is loose as the post takes a lot of direct hits. The wear from the old washer is covered by the new washer I installed but thought I would share this so others could check and adjust as need. The post I used was roughly about a 1/4 of an inch longer (the threads) but not so long as to contact the flipper plate.
[quoted image][quoted image][quoted image]

Could you please post the part numbers so i may order from Pin resource in advance of my Alien arriving? Thank you.

#2319 4 months ago
Quoted from Baggerman:

Could you please post the part numbers so i may order from Pin resource in advance of my Alien arriving? Thank you.

Order some pinballs to. The ones that come with it are a little sketch..I also changed out the plastic leg protectors for steel ones and felt protectors.

#2320 4 months ago
Quoted from kciaccio:

Order some pinballs to. The ones that come with it are a little sketch..I also changed out the plastic leg protectors for steel ones and felt protectors.

Please share where and model numbers of those 3 items.

Good call on the balls for sure....I am rolling now with gold ones ...HAHA

Thanks.

#2321 4 months ago
Quoted from EightBallTexas:

Please share where and model numbers of those 3 items.
Good call on the balls for sure....I am rolling now with gold ones ...HAHA
Thanks.

https://www.pinballlife.com/metal-cabinet-protectors-set-of-4.html

https://www.pinballlife.com/felt-cabinet-protectors-set-of-4.html

#2323 4 months ago

I got a surprise drop from PB today: 2.2E. Cato didn't say what they fixed and asked me to figure it out.

Anyhow, if you want to try spot the fix, I'll be streaming the game with the new code within the next hour or so.

- https://twitch.tv/dri374

#2324 4 months ago

I had a set of each of these in my inventory in waiting. Ha!
But thank you.
What balls are you all using? Standards, right? Not super shineys, because of the magnets in the game?

#2325 4 months ago
Quoted from RussG:

I had a set of each of these in my inventory in waiting. Ha!
But thank you.
What balls are you all using? Standards, right? Not super shineys, because of the magnets in the game?

Funny thing all the items I will have in waiting before my LV arrives.....Addicts all of us....HA

#2326 4 months ago
Quoted from dri:

Cato didn't say what they fixed and asked me to figure it out.

My bet is on the coin door lights are now on in "Free Play" I've asked him for that before and he said in a later release To me it looks like he's fixed pretty much everything else that we early adopters have been asking for. I can't test it because my armor is still out being powder coated and he told me last week he's got COVID-19 so it's delayed until he feels better.

I'm getting withdrawal symptoms from not playing

#2327 4 months ago
Quoted from Red_Devils:

My bet is on the coin door lights are now on in "Free Play" I've asked him for that before and he said in a later release To me it looks like he's fixed pretty much everything else that we early adopters have been asking for. I can't test it because my armor is still out being powder coated and he told me last week he's got COVID-19 so it's delayed until he feels better.
I'm getting withdrawal symptoms from not playing

I hope the bounce back into trough recognition is added. First mod has to be the ball that gets stuck problem on top of the upper right flipper. Should be easy to solve.

#2328 4 months ago
Quoted from Red_Devils:

My bet is on the coin door lights are now on in "Free Play" I've asked him for that before and he said in a later release To me it looks like he's fixed pretty much everything else that we early adopters have been asking for. I can't test it because my armor is still out being powder coated and he told me last week he's got COVID-19 so it's delayed until he feels better.
I'm getting withdrawal symptoms from not playing

Coin door lights in FreePlay is not one of the fixes in 2.2E... I know because I asked for it too and have been looking on every release.

Today I fixed a long-standing problem with my drop-targets that I thought I should share with all of you. The problem was that intermittently, the drop targets would not reset. They appeared to try to reset, but the coil seemed to fire way too weak to push the targets up all the way. Really hard to troubleshoot because it was extremely intermittent. I could also replicate this behavior in test mode sometimes, but then it would suddenly start working fine again at full coil strength as it should be. I did check the mechanism with the power off and nothing seemed jammed or stuck.

So immediately after the problem happened, I pulled the playfield up and touched the drop target frame while the power was on to see if it was a mechanical issue that only occurred when the playfield was down. I could feel electricity flowing through my arm to ground. I got my voltmeter out and measured the drop-target frame to ground... 48 VOLTS DC!!! I found that twisting the coil to the right or left would cause the short.

So I pulled the drop-target chassis out and could instantly see the problem:

IMG_20210904_133443152 (resized).jpg

There is supposed to be a peg on the coil that prevents it from twisting. Every time it twisted, it would short 48V to the frame. So you can see in the picture how I temporarily fixed it.... just put a zip-tie around the base of them coil to keep it from twisting.

Now my drop-targets reset 100% with no problems!

Just thought I'd share this because it took me awhile to isolate it. These coils can NOT twist or it will cause problems.... so might be a good idea to look for any missing pegs on any of your coils.

#2329 4 months ago

Hello! Very stoked to have the chance to join this crew thanks to HurryUpPinball trading me for his excellent example of the machine. I love this game! I had a quick question. I play in the dark, and I'd like to maybe add a touch of light to the playfield without ruining the atmosphere. I really think a trough light might do the trick. Has anyone put a trough light in, and if so, do they have recommendations as to color? This machine is so different compared to what I'm used to I'm curious if anyone has some recommendations. Thanks!

#2330 4 months ago
Quoted from brado426:

Coin door lights in FreePlay is not one of the fixes in 2.2E... I know because I asked for it too and have been looking on every release.
Today I fixed a long-standing problem with my drop-targets that I thought I should share with all of you. The problem was that intermittently, the drop targets would not reset. They appeared to try to reset, but the coil seemed to fire way too weak to push the targets up all the way. Really hard to troubleshoot because it was extremely intermittent. I could also replicate this behavior in test mode sometimes, but then it would suddenly start working fine again at full coil strength as it should be. I did check the mechanism with the power off and nothing seemed jammed or stuck.
So immediately after the problem happened, I pulled the playfield up and touched the drop target frame while the power was on to see if it was a mechanical issue that only occurred when the playfield was down. I could feel electricity flowing through my arm to ground. I got my voltmeter out and measured the drop-target frame to ground... 48 VOLTS DC!!! I found that twisting the coil to the right or left would cause the short.
So I pulled the drop-target chassis out and could instantly see the problem:
[quoted image]
There is supposed to be a peg on the coil that prevents it from twisting. Every time it twisted, it would short 48V to the frame. So you can see in the picture how I temporarily fixed it.... just put a zip-tie around the base of them coil to keep it from twisting.
Now my drop-targets reset 100% with no problems!
Just thought I'd share this because it took me awhile to isolate it. These coils can NOT twist or it will cause problems.... so might be a good idea to look for any missing pegs on any of your coils.

Wow is the coil lug really that close to the bracket or is that an optical illusion?

#2331 4 months ago
Quoted from Batedogg:

Hello! Very stoked to have the chance to join this crew thanks to HurryUpPinball trading me for his excellent example of the machine. I love this game! I had a quick question. I play in the dark, and I'd like to maybe add a touch of light to the playfield without ruining the atmosphere. I really think a trough light might do the trick. Has anyone put a trough light in, and if so, do they have recommendations as to color? This machine is so different compared to what I'm used to I'm curious if anyone has some recommendations. Thanks!

So I tried this with my previous OG Alien and it was just too bright. I ended up removing it.

Alien is one of those games you think you need more light but when you add it, you're like something doesn't feel right anymore!

#2332 4 months ago
Quoted from Jarbyjibbo:

Wow is the coil lug really that close to the bracket or is that an optical illusion?

It's pretty close, but as long as the coil is straight and doesn't twist, it is fine.

#2333 4 months ago

I added my polk 10 inch woofer with my pinnovators kit and what a difference. Like playing in the pinball in the movie theater experience.

Totally worth it.

#2334 4 months ago
Quoted from kciaccio:

I added my polk 10 inch woofer with my pinnovators kit and what a difference. Like playing in the pinball in the movie theater experience.
Totally worth it.

Send us a 60sec video.....

#2335 4 months ago
Quoted from EightBallTexas:

Send us a 60sec video.....

You have to watch the YouTube video on a TV to get any kind of depth to the change.

#2336 4 months ago

Think PB needs to be told about some of these mechanical issues (if someone hasn't already let them know) as they should look to address them:
- HurryUpPinball found the upper flipper post is not long enough to be properly held by the T-Nut and causing PF damage
- brado426 found his APC coil shorting due to the coil lacking the lug to stop it twisting

And well done guys on troubleshooting and finding the root cause on these respective issues!

#2337 4 months ago
Quoted from Manny65:

Think PB needs to be told about some of these mechanical issues (if someone hasn't already let them know) as they should look to address them:
- HurryUpPinball found the upper flipper post is not long enough to be properly held by the T-Nut and causing PF damage
- brado426 found his APC coil shorting due to the coil lacking the lug to stop it twisting
And well done guys on troubleshooting and finding the root cause on these respective issues!

All my issues get reported to PB... I provided PB with all the details I posted here tonight.

The remaining issue I have is with the MUTHUR, AIRLOCK, and TROUGH. In rare cases, when a ball goes into any of these three targets, the ball just sits there until A) I press a flipper button or B) about 15 seconds have gone by and a ball-search is triggered. This issue does not prevent a game from finishing, but I'd like to get it solved. Discussing with Cato, it sounds like he is unable to reproduce it on his end. I see it happen at least once or twice in 10 games. Has anyone else seen this problem, so I can tell Cato whether or not it is just me? That would really help.

#2338 4 months ago
Quoted from brado426:

All my issues get reported to PB... I provided PB with all the details I posted here tonight.
The remaining issue I have is with the MUTHUR, AIRLOCK, and TROUGH. In rare cases, when a ball goes into any of these three targets, the ball just sits there until A) I press a flipper button or B) about 15 seconds have gone by and a ball-search is triggered. This issue does not prevent a game from finishing, but I'd like to get it solved. Discussing with Cato, it sounds like he is unable to reproduce it on his end. I see it happen at least once or twice in 10 games. Has anyone else seen this problem, so I can tell Cato whether or not it is just me? That would really help.

I've only had this issue on the airlock. I figured a switch was slightly off but it hasn't happened often enough to look into yet

#2339 4 months ago
Quoted from zacaj:

I've only had this issue on the airlock. I figured a switch was slightly off but it hasn't happened often enough to look into yet

Same. I usually shake the machine a little and it recognizes it’s in airlock. Happens maybe once a game. Never had it happen in mother.

My right in lane I sometimes have to hit with the ramp 3 times to qualify mode. It’s like the sensor does not always see it drop from the drop ramp.

#2340 4 months ago
Quoted from zacaj:

I've only had this issue on the airlock. I figured a switch was slightly off but it hasn't happened often enough to look into yet

In my case, I'm pretty sure it is not a swift. Wiggling or bumping the machine does nothing. Hitting a flipper always releases the ball when it happens. So weird.... sounds like it is just me.

#2341 4 months ago
Quoted from Batedogg:

I play in the dark, and I'd like to maybe add a touch of light to the playfield without ruining the atmosphere.

I do not enjoy playing this game in the dark at all. Most inserts are flashing annoyingly bright and fast which makes the PF incredibly hard to see. I don't know if you can adjust the pulse and brightness of the inserts to get a more smooth dark experience. I only stream this game at the moment, with the overhead lights it looks and feels great IMHO. My comparison is Stranger Things where I have inserts dialed down as low as I can and it gives you a much better moody game in the dark and UV effect gives you true dialed to 11 effect (no pun intended).

#2342 4 months ago
Quoted from HurryUpPinball:

One thing I would recommend is to check the post directly in front of the upper right flipper. I noticed it moved a little after about a week of play so I added some loc-tite and reinstalled it. About a month or so later, I noticed it was coming loose again. There is a t-nut in the bottom of the playfield and it is located under the flipper plate mech. After digging further into it, it appears there is only a few threads that make contact with the t-nut. I grabbed a Bally Williams post, another washer, and a low profile locknut and replaced the stock PB post and t-nut. As you can see from the pic, this could get pretty bad if it is loose as the post takes a lot of direct hits. The wear from the old washer is covered by the new washer I installed but thought I would share this so others could check and adjust as need. The post I used was roughly about a 1/4 of an inch longer (the threads) but not so long as to contact the flipper plate.
[quoted image][quoted image][quoted image]

Now THIS is what a non pooling pf looks like. Should use this pic as a reminder in POTC thread…

#2343 4 months ago

Follow Hurry Ups advice on the post before this happens ..

PXL_20210830_155930609 (resized).jpg
#2344 4 months ago
Quoted from brado426:

In my case, I'm pretty sure it is not a swift. Wiggling or bumping the machine does nothing. Hitting a flipper always releases the ball when it happens. So weird.... sounds like it is just me.

I might be hitting the flipper to when I bump the machine, the flipper buttons are super sensitive plus I get impatient when something sticks and probably hit flippers while I bump so I wouldn’t rule out flipper activation as the key.

I will pay more attention and give you my results.

#2345 4 months ago

Cointaker no longer listing Q3 Preorder for Alien SV? Is this a sign that the SV run is soon to be over, and that focus will shift to LV as stated by PB for Q4? So does this mean that all who have preordered made the cut? Expect delivery in Q4 for SVs ordered? Interesting. Anyone know for sure?

#2346 4 months ago
Quoted from brado426:

The remaining issue I have is with the MUTHUR, AIRLOCK, and TROUGH. In rare cases, when a ball goes into any of these three targets, the ball just sits there until A) I press a flipper button or B) about 15 seconds have gone by and a ball-search is triggered. This issue does not prevent a game from finishing, but I'd like to get it solved. Discussing with Cato, it sounds like he is unable to reproduce it on his end. I see it happen at least once or twice in 10 games. Has anyone else seen this problem, so I can tell Cato whether or not it is just me? That would really help.

This definitely happens on my machine as well, but is quite rare. I reported it to Cato months ago and he is aware that newer software updates have not fixed the issue.

Even with the latest software update I’m having very poor Xeno magnet grabs - less than 10% I’d say. It also seems like 2.2c (and d) have reintroduced a problem I had early on where one of the flippers will randomly lose power and drop while raised - often resulting in a drain. Cato recommended that I go back to 2.2 but I’ve not done that yet. Is anybody else experiencing this? If anybody watched the IE Pinball Alien stream that Karl Deangelo did from Ayce Gogi it happened quite a few times during the stream.

#2347 4 months ago
Quoted from brado426:

All my issues get reported to PB... I provided PB with all the details I posted here tonight.
The remaining issue I have is with the MUTHUR, AIRLOCK, and TROUGH. In rare cases, when a ball goes into any of these three targets, the ball just sits there until A) I press a flipper button or B) about 15 seconds have gone by and a ball-search is triggered. This issue does not prevent a game from finishing, but I'd like to get it solved. Discussing with Cato, it sounds like he is unable to reproduce it on his end. I see it happen at least once or twice in 10 games. Has anyone else seen this problem, so I can tell Cato whether or not it is just me? That would really help.

Running the 2.2D and have the same issue in Airlock and MUTHA .. haven't let it get to a ball search , but yes the ball sits unnoticed (by the switch?) unless a flipper is hit .

I will report today along with constant sticky flipper on my right lower.

#2348 4 months ago
Quoted from ezeltmann:

Running the 2.2D and have the same issue in Airlock and MUTHA .. haven't let it get to a ball search , but yes the ball sits unnoticed (by the switch?) unless a flipper is hit .
I will report today along with constant sticky flipper on my right lower.

Does a ball register on each switch in the switch test? If not, sounds like it needs an adjustment.

#2349 4 months ago
Quoted from TinyBlackDog:

This definitely happens on my machine as well, but is quite rare. I reported it to Cato months ago and he is aware that newer software updates have not fixed the issue.
Even with the latest software update I’m having very poor Xeno magnet grabs - less than 10% I’d say. It also seems like 2.2c (and d) have reintroduced a problem I had early on where one of the flippers will randomly lose power and drop while raised - often resulting in a drain. Cato recommended that I go back to 2.2 but I’ve not done that yet. Is anybody else experiencing this? If anybody watched the IE Pinball Alien stream that Karl Deangelo did from Ayce Gogi it happened quite a few times during the stream.

Do you know that you have the Gen. 2 Xeno targets and not Gen. 1? I have Gen. 1 and Cato is sending me Gen. 2 targets. I highly suspect my Xeno grab problems is because every time the ball hits the Xeno targets, it hops right over the magnet. Curious if the same thing is happening to you. I'm on 2.2E and IF the ball doesn't hop over the magnet, it looks to me like it would be pretty reliable.

#2350 4 months ago
Quoted from ezeltmann:

Running the 2.2D and have the same issue in Airlock and MUTHA .. haven't let it get to a ball search , but yes the ball sits unnoticed (by the switch?) unless a flipper is hit .
I will report today along with constant sticky flipper on my right lower.

Your sticky flipper issue is easily solved by following these instructions:

I had stickiness on 3 of my flippers and all 3 are perfect now.

Thanks, guys, for the info about the "flipper to release ball" issue... Sounds like it isn't just me.

There are 5,253 posts in this topic. You are on page 47 of 106.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside