(Topic ID: 284032)

"Morning MU/TH/UR" Pinball Brothers Alien Remake Owners Club

By Red_Devils

1 year ago


Topic Heartbeat

Topic Stats

  • 11,303 posts
  • 456 Pinsiders participating
  • Latest reply 2 hours ago by Flash71
  • Topic is favorited by 201 Pinsiders

You

Linked Games

Topic poll

“What are you in on an SE or LV?”

  • LV 62 votes
    33%
  • SE 59 votes
    32%
  • Not interested in this game 65 votes
    35%

(186 votes)

This poll has been closed.

Topic Gallery

View topic image gallery

IMG_0901 (resized).jpeg
9306036C-71D1-4027-AC42-B6559FB864D5 (resized).jpeg
pasted_image (resized).png
B282C6FE-0BAE-4124-B512-C6F0F2D1068E (resized).jpeg
05938DC3-30D0-4772-AB8B-DCA8FB39AE29 (resized).jpeg
pasted_image (resized).png
pasted_image (resized).png
95BD68FC-5ED0-4022-98E9-5251122E350F (resized).jpeg
421BAB5E-4EA5-49BE-843D-9308B3C4671C (resized).jpeg
35D8AAD2-6B76-455B-BC51-F06F67CF064F (resized).jpeg
4DE18E9F-266F-4821-9974-D28E0D5E1033 (resized).jpeg
B36C8CF1-61A1-4AFC-A374-6FA48E4B4598 (resized).jpeg
4FF14962-5AE0-4CE1-85AD-5150DC7B329C (resized).jpeg
IMG_2514 (resized).jpg
92DE334D-FD3B-4004-83C2-8EE695B09EF4 (resized).jpeg
82EEEBA9-B43E-48EE-AD2D-D56BD640CE24 (resized).jpeg

Topic index (key posts)

6 key posts have been marked in this topic (Show topic index)

There are 11,303 posts in this topic. You are on page 192 of 227.
#9551 3 months ago

Anyone know, are those the same switches that the HWY version used, or were they an 'update'?

#9552 3 months ago

This is what I used, sling switch, target foam, piece of the original pcb with connector and soldered the switch lugs to the existing connector. Played hundreds of games with no switch issues. They’ll likely never code the light in them anyway.

79BD82E9-99FB-4432-BBB9-9E0099FA22C6 (resized).jpeg
#9553 3 months ago
Quoted from Zablon:

Anyone know, are those the same switches that the HWY version used, or were they an 'update'?

Looks pretty similar but not exact.

https://www.free-play.se/en/electronics/circuit-boards/alien-full-throttle-target-switch-board-w-led.html

D40F5584-7DE5-4FED-8AEE-BDCF588AD3AD (resized).jpeg
#9554 3 months ago

I think these would work better as the top of the is wider than the top section so it can’t get stuck

#9555 3 months ago

I'm trying to adjust my airlock scoop as the ball is consistently fired towards the very end of the left flipper, and often I will drain as a result, as it's just not possible to control the ball. The PB support article mentions bending the scoop a little, but I'm giving it quite a bit of effort - it's not bending, and honestly, I feel like I'm gonna break it. Is this definitely the way to go about it? Are there any other things people have done?

#9556 3 months ago
Quoted from Ceemunkey:

I'm trying to adjust my airlock scoop as the ball is consistently fired towards the very end of the left flipper, and often I will drain as a result, as it's just not possible to control the ball. The PB support article mentions bending the scoop a little, but I'm giving it quite a bit of effort - it's not bending, and honestly, I feel like I'm gonna break it. Is this definitely the way to go about it? Are there any other things people have done?

Check that the inside plunger "nub" is level as well.. sometimes they have a little nipple in the middle.. if so, sand that sucker flat.

#9557 3 months ago
Quoted from Ceemunkey:

I'm trying to adjust my airlock scoop as the ball is consistently fired towards the very end of the left flipper, and often I will drain as a result, as it's just not possible to control the ball. The PB support article mentions bending the scoop a little, but I'm giving it quite a bit of effort - it's not bending, and honestly, I feel like I'm gonna break it. Is this definitely the way to go about it? Are there any other things people have done?

Just be careful it's what works

#9558 3 months ago
Quoted from Ceemunkey:

I'm trying to adjust my airlock scoop as the ball is consistently fired towards the very end of the left flipper, and often I will drain as a result, as it's just not possible to control the ball. The PB support article mentions bending the scoop a little, but I'm giving it quite a bit of effort - it's not bending, and honestly, I feel like I'm gonna break it. Is this definitely the way to go about it? Are there any other things people have done?

Quoted from Mageek:

Just be careful it's what works

It does work. Took a shit ton of force to really rotate the scoop clockwise but 100% necessary to enjoy the game. It took me maybe 4 or 5 tries before I got it bent enough to avoid SDTM returns.

#9559 3 months ago

Before bending the metal on the scoop, loosen all the screws a little, push the entire mech as far as it will go in the desired direction and retighten. Sometimes there's enough slop in the screw holes to be able to make a difference. If it's not enough, then start bending (or fill / make new screw holes).

#9560 3 months ago
Quoted from Chalkey:

Before bending the metal on the scoop, loosen all the screws a little, push the entire mech as far as it will go in the desired direction and retighten. Sometimes there's enough slop in the screw holes to be able to make a difference. If it's not enough, then start bending (or fill / make new screw holes).

I recently found this to be true. I had to take the scoop bracket off so I could get at one of the Xeno bolt. Then when I put it back on again, I had it tilted too far to the left causing it to hit the left side of the left flipper. Once I loosened the bolts, positioned the bracket, and re-tightened, everything was good again.

#9561 3 months ago
Quoted from brado426:

I recently found this to be true. I had to take the scoop bracket off so I could get at one of the Xeno bolt. Then when I put it back on again, I had it tilted too far to the left causing it to hit the left side of the left flipper. Once I loosened the bolts, positioned the bracket, and re-tightened, everything was good again.

Also turn the scoop power down.

#9562 3 months ago
Quoted from Chalkey:

There is without a doubt some sort of issue with the right flippers intermittently not working. I had reports from some players and experienced it myself this evening. I verified the leafs were being contacted properly. I told support that even though I gapped them very nicely to double stage as verified in the switch test, that they were being activated simultaneously in game. Support told me that even though my setting for 2 stage flippers was set to "yes" in the menu, it wasn't programmed into the software yet and perhaps that was the source of my problem. I will change it next time I'm up there but I doubt it will help. This is the kind of thing that should take anyone competent a half day to program.
After receiving a "new tested" xeno it still has the problem of losing track of where the motor exists in space and not dropping the ball. It was suggested that this isn't so bad as it will just drop the ball in search after the multiball ends. I wish this guy could be there to try to give that explanation to my tournament players.
These guys are drowning in software issues. They need to pay Ferret or another consultant who knows code / logic to help them get their OS shit straightened out. It's frustrating to know they've probably got most of their efforts on Queen at this point. 90% of the issues have been going on since February when these things started arriving en masse.

What makes you think it's not the hardware issues? Only ask because they seem to have been shipping lots of replacement parts

#9563 3 months ago

"But why male models?"

Pretty much all of the things I wrote in my post, and the examples others have posted.

#9564 3 months ago
Quoted from Ceemunkey:

I'm trying to adjust my airlock scoop as the ball is consistently fired towards the very end of the left flipper, and often I will drain as a result, as it's just not possible to control the ball. The PB support article mentions bending the scoop a little, but I'm giving it quite a bit of effort - it's not bending, and honestly, I feel like I'm gonna break it. Is this definitely the way to go about it? Are there any other things people have done?

I would also recommend you set the power to the scoop at a reduced level. It will help, there is no need to fire that thing out at 100 miles an hour.

MUTHUR coil especially needs reducing so you can hit the shots.

#9565 3 months ago
Quoted from Mageek:

Happy to say after factory reset and 2.8 installed so far so good, played 30 + games in various numbers of users without a single issue, it’s been in attract mode for almost 12 hours now. So those with v2.8 problems please try a full factory reset and post results.

I have been using incorrect terminology, when I was suggesting a Factory Reset, I didn’t mean using the menu item of that name, I meant a “system rebuild” from the PB website here. This has fixed things for me on more than one occasion including the 2.8 update.

https://pinballbrothers.freshdesk.com/support/solutions/articles/80000843825--how-to-rebuild-machine-alien-2-2

#9566 3 months ago
Quoted from Mageek:

I have been using incorrect terminology, when I was suggesting a Factory Reset, I didn’t mean using the menu item of that name, I meant a “system rebuild” from the PB website here. This has fixed things for me on more than one occasion including the 2.8 update.
https://pinballbrothers.freshdesk.com/support/solutions/articles/80000843825--how-to-rebuild-machine-alien-2-2

Is there anyway to save High Scores when doing this, or is everything lost?

#9567 3 months ago

Fellows with the playfield issues - sorry youre having the same issues I had!

Before you go changing posts, drilling wider holes etc, I would suggest just Loctite and flexible lexan washers underneath all the posts with cracks / pooling.
The cracks start when posts come loose and hit the sides of the holes, you need to keep these posts TIGHT, so use some blue loctite to make sure they dont loosen from repeated hits.
You also want to avoid any hard surfaces touching the PF surface, the lexan washers provide protection to the clear without providing a new hard edge to push into the clear (I tried metal washers and the soft plastic are far superior).
Also I recommend using two rubber rings on the posts, provides a little more bounceback to the ball meaning momentum is not being transferred through the post to the playfield, causing damage

Lastly - anybody with PF issues I recommend contacting PBros and purchasing a spare playfield to store - for a reasonable price shipped you get peace of mind to not worry so much if your game starts to show battle wear.

20220825_135921.jpg
#9568 3 months ago

One thing that would really help this forum - if somebody had a google doc that listed the issues talked about in this forum is a sensible way (has anybody seen the forum for CCr?! It looks so efficient!)

So many issues on this forum have been listed more than once, it would make troubleshooting so much more efficient for everyone if we could look up common issues without relying on the buggy forum search tool.

Has anybody started a spreadhseet or anything like that so far, to get us started? Maybe a user with a post on the first page would be able to edit one of their posts and we can start to add some user 'FAQ' for all of our benefit??

#9569 3 months ago
Quoted from paulbaptise:

Is there anyway to save High Scores when doing this, or is everything lost?

Everything is lost, but I’m sure you remember your high score

#9570 3 months ago

Mine gets here in about two weeks. I wanted to ask all of you, is there anything I should get in advance? Any standard part or upgrade everyone ends up getting?

#9571 3 months ago
Quoted from BriannaWu:

Mine gets here in about two weeks. I wanted to ask all of you, is there anything I should get in advance? Any standard part or upgrade everyone ends up getting?

New balls, mylar rings and plastic washers, flipper fans

I would immediately throw out the balls that come with the game. Mine lasted 3 days before they magnetized.

Hindsight being 20/20, I would definitely preemptively put a mylar ring and plastic washer underneath the post below the upper right flipper. Just do it.

Also watch for any areas that the plastics are cutting into the clear (look for pooling). If you find any I'd put something underneath those areas (mylar ring and plastic washer) to keep it from expanding outward.

I also purchased flipper fans from the pinside shop here and highly recommend them. I felt my flippers getting weaker pretty quickly from day 1 of ownership.

#9572 3 months ago
Quoted from BriannaWu:

Mine gets here in about two weeks. I wanted to ask all of you, is there anything I should get in advance? Any standard part or upgrade everyone ends up getting?

You may not have Metric but drivers.

Second on coil fans.

#9573 3 months ago

Someone should post some really good pics of the later build flipper mechs. I'm curious is something changed.

Also, still using stock balls. Nothing wrong with them.

#9574 3 months ago
Quoted from paulbaptise:

New balls, mylar rings and plastic washers, flipper fans
I would immediately throw out the balls that come with the game. Mine lasted 3 days before they magnetized.
Hindsight being 20/20, I would definitely preemptively put a mylar ring and plastic washer underneath the post below the upper right flipper. Just do it.
Also watch for any areas that the plastics are cutting into the clear (look for pooling). If you find any I'd put something underneath those areas (mylar ring and plastic washer) to keep it from expanding outward.
I also purchased flipper fans from the pinside shop here and highly recommend them. I felt my flippers getting weaker pretty quickly from day 1 of ownership.

Coincidentally, I have a ton of Ninja Pinballs I just bought! Do you have links to the other parts you'd suggest? Thank you for the help!

#9575 3 months ago
Quoted from Zablon:

Someone should post some really good pics of the later build flipper mechs. I'm curious is something changed.
Also, still using stock balls. Nothing wrong with them.

Still using stock balls here from June, 2021... Nothing wrong with them.

13
#9576 3 months ago

Just received LV 123. Have only played a few games on it and so far so good. Only things I had to address out of the box were coin door bolts all rolling around along with some other screws. Just went through and double checked all bolts and screws.

IMG_20220825_101816 (resized).jpgPXL_20220825_213957686 (resized).jpg
#9577 3 months ago
Quoted from brado426:

Still using stock balls here from June, 2021... Nothing wrong with them.

Mine had little scratches all over them but I tossed them in the tumbler for 6 hours with some polish and they turned out fine - also dont forget the balls will scratch alot in the first few weeks (those metal ramps!!) so not a bad idea to change them once or twice in the first month anyways...

#9578 3 months ago

Can you guys show me where exactly you tapped into to supply power to the led strip in the back box for the translite mod.

Thanks

#9579 3 months ago
Quoted from Mageek:

I have been using incorrect terminology, when I was suggesting a Factory Reset, I didn’t mean using the menu item of that name, I meant a “system rebuild” from the PB website here. This has fixed things for me on more than one occasion including the 2.8 update.
https://pinballbrothers.freshdesk.com/support/solutions/articles/80000843825--how-to-rebuild-machine-alien-2-2

What kind of issues did rebuilding it fix in the latest code? Is PB recommending to do this?

#9580 3 months ago
Quoted from McDoom:

Can you guys show me where exactly you tapped into to supply power to the led strip in the back box for the translite mod.
Thanks

Hey McDoom - I tapped in at the AC-in on the main power supply, after the power switch on the bottom, so the power supply is switched on/off with the game. If you unsrew the power supply box on the bottom of the game and flip it over, you will easily see that its a pretty generic power supply, not hard to piggy back onto

#9581 3 months ago
Quoted from Zablon:

Someone should post some really good pics of the later build flipper mechs. I'm curious is something changed.
Also, still using stock balls. Nothing wrong with them.

Nothing has changed to anyone's knowledge. Post photos of yours and other people can look at their games. Coils heat up and lose power, other people have scientifically documented this occurrence.

#9582 3 months ago
Quoted from Waxx:

Nothing has changed to anyone's knowledge. Post photos of yours and other people can look at their games. Coils heat up and lose power, other people have scientifically documented this occurrence.

So, you take that to mean I don't think they do?

But to clarify, lots of hardware changes have happened on this machine over its run. We know this. And to clarify further, no ones flippers should be fading in the first 30 minutes unless you have maybe the power turned way up or your house is hot af. If some people are seeing flipper issues quickly (not talking after hours and hours of play) then there is probably an issue somewhere.

#9583 3 months ago

For anyone who is experiencing some rare resets and hangs in 2.8, there is hope....

I am aware of one hang and one reset issue in 2.8. The hang issue usually happens after the machine has been on for hours. The reset issue could happen at any time... most recently, I saw it happen after 5 minutes of turning on the machine, but it is super rare. I think I've only seen it happen twice.

Sounds like PB has identified the cause of the reset issue from the logs I provided and that should be fixed in System Update 2.9. The hang issue, I think they're still looking into.

#9584 3 months ago
Quoted from BriannaWu:

Coincidentally, I have a ton of Ninja Pinballs I just bought! Do you have links to the other parts you'd suggest? Thank you for the help!

https://pinside.com/pinball/market/shops/1391-ravspec/07046-extended-play-coil-coolers-pinball-brothers-alien

https://pinside.com/pinball/market/shops/1170-pin-monk/02469-star-and-slim-post-clear-mylar-ring-set

**I make my own with a circle punch and a hole punch. I use 3/4” most often

Then get some rubber washers and plastic washers assortments from Amazon or elsewhere.

2BA94BD1-5544-4C7F-97B2-F937090274BA (resized).jpeg
#9585 3 months ago
Quoted from RebelGuitars:

What kind of issues did rebuilding it fix in the latest code? Is PB recommending to do this?

in my case it would lock up , mother scoop would not eject, flippers died, only happened in multi player games. Went back to 2.7 everything was fine. So did the rebuild => v2.8 have not had any issues since including leaving it on for over 24 hours. I’ve Played at least 40 games, in multiplayer and single player. PB recommended it to me in previous updates when problems arose but not specifically for v2.8. Now it sounds like 2.9 is on its way so I’ll definitely do it again before updating to it.

#9586 3 months ago
Quoted from paulbaptise:

https://pinside.com/pinball/market/shops/1391-ravspec/07046-extended-play-coil-coolers-pinball-brothers-alien
https://pinside.com/pinball/market/shops/1170-pin-monk/02469-star-and-slim-post-clear-mylar-ring-set
**I make my own with a circle punch and a hole punch. I use 3/4” most often
Then get some rubber washers and plastic washers assortments from Amazon or elsewhere.
[quoted image]

Ordered! Thank you for the suggestion!

#9587 3 months ago
Quoted from BriannaWu:

Ordered! Thank you for the suggestion!

Thanks again, Your kit is all packed up and ready to ship first thing in the morning.

Mike
-RavSpec:PlayLonger-

I have plenty of kits in stock and ready ship if anyone else is interested.

#9588 3 months ago
Quoted from Zablon:

Someone should post some really good pics of the later build flipper mechs. I'm curious is something changed.
Also, still using stock balls. Nothing wrong with them.

There are some decent pics of the flipper mechs in my shop listing for my cooler kits. If something looks different than what you have post them up and ill take some more detailed pictures as well. Coyohtay on here has a very early game and has mentioned experiencing flipper fade on their game as well.

#9589 3 months ago
Quoted from Waxx:

You may not have Metric but drivers.

I need to get me one of those!!!!

#9590 3 months ago
Quoted from gumnut01:

I need to get me one of those!!!!

Ha, missed that mistype.

#9591 3 months ago
Quoted from Waxx:

You may not have Metric but drivers.
Second on coil fans.

pasted_image (resized).png
Having appropriate tools is important! But don't make the mistake this guy made.

#9592 3 months ago

I'll never understand why some games get flipper fade and others don't when it's the same game. I've only needed a cooling kit on my GnR. Godzilla, Alien, Avengers...I've had 8 hour parties with the games going pretty much non stop and little to no fade on any of them. On the 7th to 8th hour I'll get a little bit on Iron Maiden.

#9593 3 months ago
Quoted from javagrind888:

I'll never understand why some games get flipper fade and others don't when it's the same game. I've only needed a cooling kit on my GnR. Godzilla, Alien, Avengers...I've had 8 hour parties with the games going pretty much non stop and little to no fade on any of them. On the 7th to 8th hour I'll get a little bit on Iron Maiden.

The only one I've needed one on is R&M (of newer games). Some of it is related to flipper mechs, some related to power driving those mechs, some related to code, some related to the type of game play style (or even the play style of a specific player), some related to ambient temps....

What seems to be fairly common from my observations is that the newer style PC driven games seem to have a tougher time keeping heat down for whatever reason.

I don't think most games are going to see much fade in a normal persons play time, which is why I kind of push back against the 'must have' crowd for coolers. Play your game first, see how it acts, then decide. Testing against 1 machine isn't a level set, and with this game I would err on the side of 'there's a hardware issue' with a specific game before I'd say it needs coolers for normal game times. If you are constantly playing an hour or more then it probably does, but most people don't do that beyond the first few weeks of ownership.

#9594 3 months ago

LV-113 arrived yesterday - game is working perfectly out of the box so far.

I did have to contact PB as there is a gouge on the backglass that somehow penetrated the protective sheet that they placed over it - they responded this morning and are going to ship me a new backglass. Great customer service!

I have had a few issues with the ball getting stuck in various places - most notably this gap behind the xenomorph head which can juuuuuust hold a ball, and which was a pain in the ass to actually retrieve it from. Factory settings have been totally fine for me to hit the typical shots so far, but we'll see if I develop a more nuanced opinion after a few weeks.

I don't find the lighting to be an issue at all - seems plenty bright to me. I need to start looking at the mods y'all are doing to see what would be the best fit for me.

IMG_6597 (resized).jpg
#9595 3 months ago
Quoted from brendan:

LV-113 arrived yesterday - game is working perfectly out of the box so far.
I did have to contact PB as there is a gouge on the backglass that somehow penetrated the protective sheet that they placed over it - they responded this morning and are going to ship me a new backglass. Great customer service!
I have had a few issues with the ball getting stuck in various places - most notably this gap behind the xenomorph head which can juuuuuust hold a ball, and which was a pain in the ass to actually retrieve it from. Factory settings have been totally fine for me to hit the typical shots so far, but we'll see if I develop a more nuanced opinion after a few weeks.
I don't find the lighting to be an issue at all - seems plenty bright to me. I need to start looking at the mods y'all are doing to see what would be the best fit for me.
[quoted image]

Expect this to be on the slow boat so it could be some time before you get it. I have found in my experience anything larger then a board, they will ship it with the machines.

#9596 3 months ago
Quoted from precisionk:

Expect this to be on the slow boat so it could be some time before you get it. I have found in my experience anything larger then a board, they will ship it with the machines.

Yeah - they implied it would be late September, so that makes sense. At least it's just cosmetic rather than functional; I can live with it until then...

Pic of the gouge in case anyone is curious.

Image from iOS (14) (resized).jpg
#9597 3 months ago

Intruder alert

#9598 3 months ago

LE 72 arrived about 2 weeks ago. Finally got it set up. Right side flippers don't work, bad pixels on display. Stickers on apron coming off. Cointaker tech support is useless, and there is little documentation. No mention of warranty work or support. I guess it is pretty much buyer beware for PB games.

#9599 3 months ago
Quoted from Pinmeister:

LE 72 arrived about 2 weeks ago. Finally got it set up. Right side flippers don't work, bad pixels on display. Cointaker tech support is useless, and there is little documentation. No mention of warranty work or support. I guess it is pretty much buyer beware for PB games.

Open a ticket here https://pinballbrothers.freshdesk.com/support/login

Check the fuses in the playfield control box if right side coils aren’t working.

#9600 3 months ago

Yes, open a ticket. My game had a board failure and a replacement was in my hands 3 days later. Top notch customer service!

Promoted items from the Pinside Marketplace
$ 160.00
Playfield - Other
RavSpec
Other
$ 649.95
Lighting - Led
Pin Stadium Pinball Mods
Led
From: $ 6.50
Playfield - Other
Rocket City Pinball
Other
$ 119.99
Displays
FlyLand Designs
Displays
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
Sound/Speakers
$ 165.00
Lighting - Interactive
Evolution Mods
Interactive
Wanted
Machine - Wanted
Palm Beach Gardens, FL
From: $ 12.00
Flipper Parts
Precision Pinball prod.
Flipper parts
$ 35.00
Cabinet - Other
Rocket City Pinball
Other
From: $ 12.00
Flipper Parts
Precision Pinball prod.
Flipper parts
$ 19.95
Playfield - Toys/Add-ons
ULEKstore
Toys/Add-ons
There are 11,303 posts in this topic. You are on page 192 of 227.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!