(Topic ID: 232681)

PIN2DMD not getting past logo


By OverSoft

1 year ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by lucky1
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

20181229_154955 (resized).jpg

#1 1 year ago

I've built a PIN2DMD v3.1 shield and connected it to a STM32F4 Discovery board.
I've activated it and it works without flaws on Visual Pinball and VPinMame.
The input test runs without problems (pin 1,3,5,7 and 11 show when they're shorted to ground).
There is a SD card in there which works properly (updated the firmware from it), but i have no custom colorizations on it yet.

Now i'm trying to put it in my STTNG machine, but it doesn't seem to get any input.
It's set to Bally/Williams input, the latest firmware is installed and i've tried both with enhancer and without, but it doesn't show anything other than the logo (see photo).

I've tried a different ribbon cable between the machine and the PIN2DMD and i've tried turning it on before and after the machine, but it doesn't show anything other than this. (When i connect to original DMD, the display works fine)

I have a couple of different machines (a Stern Whitestar and a couple of WPC and WPC95's), but haven't tried the others yet.

Does anybody have any ideas on how to get the display up and running?

20181229_154955 (resized).jpg

#2 1 year ago

Small addition: also doesn't work in my Stern High Roller Casino
Stuck on the logo

#3 1 year ago

Update: turns out i was missing the "enhancer" jumper. That fixed it.

2 months later
#4 1 year ago

I'm having the same issue with my Pin2DMD and my STTNG. Can I ask, what is "the enhancer jumper"? Can you maybe give me a screenshot or something? The Pin2DMD seems to work on my other machines, but not on the STTNG.
Thanks

3 weeks later
#5 1 year ago

Having same issue in my sttng. Have pin2dmd’s on a JP, JD, ST, and Metallica. No issues as all we’re really just plug and play. Can’t get the logo on the sttng. Tried a couple of units, and swapped ribbon cables as well. Nothing. If anyone can help or has ideas, it would be appreciated.

#6 1 year ago

I had the same problem in my STTNG and after I changed the WPC DMD Controller board it is working just fine.
Looking at the signals with logic analyzer it showed it has a defective rowdata signal which is is not recognizable on the Plasma
because the eye is to slow but pin2dmd will not get a proper sync with that board. So far did not have the time to identify
what is causing this problem but definitely not a problem of pin2dmd. Maybe you also have a defective dmd controller board.
Maybe you can swap boards to verify like I did. In your case it is not the enhancer jumper or setting because the pin2dmd is working
in other machines.

Promoted items from the Pinside Marketplace
4,700
$ 279.95

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside