(Topic ID: 173884)

Paging error on WPC DMD


By arolden

2 years ago



Topic Stats

  • 6 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by arolden
  • Topic is favorited by 2 Pinsiders

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    One image has been uploaded to this topic. (View topic image gallery).

    image (resized).jpg

    #1 2 years ago

    Hi all.

    My DW is displaying this error during the display test and has vertical lines across the right side if the screen.

    What components should I be targeting for replacement?

    Thanks for any advice.

    image (resized).jpg

    #2 2 years ago

    try a new ribbon cable if it still does it, the ram on the display board is likely bad. If it still does it with a new RAM.... it gets a bit more complex. There are a TON of ttl chips on that display board to check out.

    #3 2 years ago

    Most likely bad RAM at U24.

    #4 2 years ago

    Reseat the ribbon cables, and order a new set if yours are original. If you can't replace the RAM yourself, I can give you a couple recommendations for technicians in your country who can help.

    #5 2 years ago

    I swapped the ribbon cable for a known working one - same issue. So I will order a new RAM chip. I swapped a working display driver board in and this eliminated the issue, so definitely a problem with the board.

    Out of interest, I also pulled a different display driver board out of one of my project machines. This one displays a couple of lines on the right side of the screen and fails the display test with a RAM address error. I assume this one also needs U24 to be replaced?

    Also out of interest, I put both boards into my FT, which has a colour DMD. The issues were exactly the same on FT, and the display was greyscale instead of colour. This is expected I suppose, since the colour DMD still uses the original ROMs for display data.

    John, I would appreciate those recommendations also

    2 weeks later
    #6 2 years ago

    Just an update on this. I replaced both U24s and both displays are working properly now. Thanks for the advice!

    Promoted items from the Pinside Marketplace
    From: $ 50.00
    Gameroom - Decorations
    Pinball Art Prints
    $ 64.95
    From: $ 9.99
    Eproms
    Matt's Basement Arcade
    $ 48.00
    Cabinet - Other
    ModFather Pinball Mods
    $ 200.00
    Lighting - Interactive
    Professor Pinball
    From: $ 220.00
    Playfield - Toys/Add-ons
    CzTV Mods
    $ 159.99
    Lighting - Other
    Lighted Pinball Mods
    $ 49.00
    $ 44.95
    Playfield - Toys/Add-ons
    PinBoss Mods
    $ 5,799.00
    Pinball Machine
    Little Shop Of Games
    $ 27.99
    $ 29.99
    Cabinet - Sound/Speakers
    Lighted Pinball Mods
    $ 48.00
    Cabinet - Other
    ModFather Pinball Mods
    $ 87.00
    Playfield - Toys/Add-ons
    Lermods
    From: $ 5,599.00
    Pinball Machine
    Music City Pinball
    From: $ 42.00
    Cabinet - Shooter Rods
    ModFather Pinball Mods
    $ 40.00
    Playfield - Decals
    Great American Pinball
    $ 5,599.00
    Pinball Machine
    Great American Pinball
    $ 15.00
    Cabinet - Decals
    ModFather Pinball Mods
    € 9.10
    $ 6,499.00
    Pinball Machine
    Classic Game Rooms
    $ 11.95
    Playfield - Toys/Add-ons
    ULEKstore
    $ 76.95
    Cabinet - Shooter Rods
    Super Skill Shot Shop
    $ 69.99
    Playfield - Toys/Add-ons
    Lighted Pinball Mods

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside