(Topic ID: 135413)

Official Stern KISS LE / Premium Demon Lock Troubleshooting thread

By ScottinSGFNY

6 years ago


Topic Heartbeat

Topic Stats

  • 96 posts
  • 32 Pinsiders participating
  • Latest reply 2 years ago by snaroff
  • Topic is favorited by 11 Pinsiders

You

Linked Games

Topic poll

“How is your Demon working?”

  • almost always takes 1 try to get from VUK to Trough 7 votes
    6%
  • more often takes 2 or more trys to get ball from VUK to Trough 36 votes
    31%
  • When Ball shoots from Demon Mouth it almost never goes SDTM 17 votes
    15%
  • When Ball shoots from Demon Mouth it goes SDTM a lot 31 votes
    27%
  • When ball shoot from Demon Mouth it never goes SDTM 5 votes
    4%
  • I had problems and tried to make adjustments but it still isn't 100% 16 votes
    14%
  • I had problems and tried made adjustments and now it's almost 100% 4 votes
    3%

(Multiple choice - 116 votes by 78 Pinsiders)

Topic Gallery

View topic image gallery

IMG_2264 (resized).jpeg
IMG_2263 (resized).jpeg
IMG_0839.jpg
IMG_0838.jpg
PA190101.jpg
Kiss_Demon_005.jpg
Kiss_Demon_009.jpg
Kiss_Demon_006.jpg
Kiss_Demon_001.jpg

There are 96 posts in this topic. You are on page 2 of 2.
#51 6 years ago
Quoted from wizard1:

Be sure, that many people have done this, but it doesn't help !
I own some pins and I think, I know what to do.
In this case, I checked everything and set the power to many different settings.
There is a hardware problem, nothing else !!!
Really hard to find the right adjustments.
In the meantime, I have every time "operator notice" and my machine learn nothing ....
Bad job Stern ! How about a real quality and end control ?

I am not saying this is the final solution or a quick fix... but YES it does help my machine considerably, so if others haven't tried it, see if it helps yours until Stern can figure out our problems.

Would encourage people having similar issues to contact Stern Tech support if you haven't already done so. I know myself and a few others have.

#52 6 years ago

So did anyone who contacted Stern get any more help or info on this?

#53 6 years ago

OK, so now we have about 20+ games on it, I can confirm this is also happening on ours. It doesnt go SDTM EVERY time, but it does a times. The VUK sits there trying to lock the ball over and over and over and then it finally pittles out.

Pretty lame, hope they release a service bulletin and a fix.

#54 6 years ago
Quoted from Chitownpinball:

OK, so now we have about 20+ games on it, I can confirm this is also happening on ours. It doesnt go SDTM EVERY time, but it does a times. The VUK sits there trying to lock the ball over and over and over and then it finally pittles out.
Pretty lame, hope they release a service bulletin and a fix.

Please call Stern support (and/or your distributor) and tell them about the VUK problem. Don't assume they are going to fix anything without speaking up. The more people speak up, the more likely it will be fixed.

#55 6 years ago
Quoted from ScottinSGFNY:

So did anyone who contacted Stern get any more help or info on this?

I've been in contact with Pat about the VUK failures. He suggested I make sure it was aligned. I doubt it's alignment, since it works fine for 15-30 minutes and starts failing later. Nevertheless, I'll look at the alignment later today...

#56 6 years ago
Quoted from snaroff:

Please call Stern support (and/or your distributor) and tell them about the VUK problem. Don't assume they are going to fix anything without speaking up. The more people speak up, the more likely it will be fixed.

I already emailed my dist and hes got an email out to them.

#57 6 years ago

According to the ticket I have placed with Stern and in talking with their tech support their response:

"I spoke with product development about this, The next software update will address this problem."

#58 6 years ago
Quoted from paratrooper:

According to the ticket I have placed with Stern and in talking with their tech support their response:
"I spoke with product development about this, The next software update will address this problem."

Thats what i heard too.

#59 6 years ago

It is definently a software problem on the kiss le/premium.. the power to the vuk coil gets ramped up after two tries, u can tell by the noise its making, which is different then the first two tries.. My suggestion to stern is, making the demon ball eject so that there is an ball saver after spitting, so whenever it drains it brings the ball back to the player.

#60 6 years ago

WELL WELL! Try this for a quick work around until Stern fixes the issue with a CODE update. Works for me!!!!

Other than me ramping up the VUK to 64 ???

Try this....

When the ball goes into the DEMON lock, at anytime push both flippers at the same time ! BAM! It launches the ball from the VUK almost immediately!

In my experiences, it can take more than one "quick" press of both flipper buttons for it to work, but it does. Press them both quickly at the same time multiple times for best results! Be careful when the "real" DEMON Mulit-Ball works because they will come down FAST ! LOL

In fact, you can use this technique for anytime the VUK is trying to lock the ball which it will try to do at times even when it is not in the LOCK mode.

Something else I have been playing with is to simply hold both flippers until the VUK does whatever it needs to do!! Guys what? It works also..

Play with it and see what works for you.

Whew! !!!!!!

MUCH better game play now.

#61 6 years ago

I apologize for this comment. Had no idea it came off as harsh. Sorry community.

#62 6 years ago

Dude they are releasing a software update...its sit and wait now.

#63 6 years ago
Quoted from Chitownpinball:

Dude they are releasing a software update...its sit and wait now.

... in January

#64 6 years ago

I noticed the same issues. Had my LE now for a while (got it the 2nd day available- thanks JJ!)

the whole demon lock thing is touchy, sensitive, quirky!

HERE IS MY REVIEW OF ISSUES/GAME PLAY QUIRKS/ and MISC SUCH:

1. SDTM (love the acronym!) YES - that pisses me off but when Gene is getting ready to kick one out the right flasher fires a few times so I am ready to time a NUDGE of the game as it kicks out! seems to work and infact.. well requires some skill which all us PRO PINBALL PLAYERS (I say that sarcastically about myself!) like to do. I just kind of fell into a pit of .. "okay that is what to do!!"

2. sometimes my VUK gets goofed up like its looking for balls or resynicing? now reading this thread - seems to be a mild chronic issue with the game. Will read on in future to see if anyone figures it out

3. Stern saying game will learn.... hummmm... if so .. that is cool! sounds more like a mechanic working on my car that says - don't worry the more you drive it that sound will go away?!

4.my dumb little issue from day one was the right sling - is so damn super sensitive that it fires even when something else is hit.. I know its just a slight bend of the switch but , ahhh man right outta the gate .. yeah first world problem

5. was waiting to do the tweeks and all my little mods and add ons, shaker add on, until I got my topper and side blades from JJ (from stern) but just called them and they said - sometime in SEPT they will start to ship out the "accessories" - when talking to them I called them MODS... the gal there said - "oh you mean accessories" got a kick out of that!

6. I love the game! I shoot for the Paul Stanley love gun multiball target spot all the time.. that is a bitch..

7. hitting the right demon lock target I have found is tough(I just hope it gets hit randomly during play as I hard shot there and a MISS and its a 50/50 ball drain!!! AHHHH

8. I am not a complainer about the codes and flaws - but yeah at this point the game is just missing a deeper level of play (like metallica was from day 1... so I patiently wait

9. IS THERE A INITIAL SKILL SHOT ON THE GAME YET? or will there ever be?

10. would have been great if the playfield spinner was not buried under Gene's head and we could see it spin as it shot the ball into the area... and be a neat action attraction... oh well

11. SOUND IS ONE OF THE BEST IF NOT THE BEST IN THE BIZ!!!!

12. its kind of weird if you are playing a ball and the song ends and then you are playing without sound ====its kinda like .. man this sux... a real empty feeling (like something is broke!! ) HA

#65 6 years ago

I totally havent been able to get love gun going yet. Ive had it set up, ready to go, and I always miss the shot and drain, lol.

I agree, wheres the skill shot? I dont think there is one yet. I thought maybe lightly plunging and hitting the spinner did it, but nope.

#66 6 years ago

I hope we see an update for Labor Day.

I haven't opened my LE yet. Come October, I will. I'm hoping for a decent update before then.

#67 6 years ago
Quoted from hlazzer:

... in January

Code update 1.04 is NOW available!!!!! It claims to fix our VUK problem. Anyone try it yet?

Looks like a bunch of very cool updates for the gameplay....

UPDATE: Guess everyone is sleeping or didn't think STERN would help us with a update soon> WRONG!!!

I am updating my 1 GIG file now and will play the crap out of it to see how it works.

Side note: It takes way way way longer than WOZ update for sure! But hey... SSD HDD compared to SPIKE with a SD memory card>? No brainer.

UPDATE:

WOW!!!!!!!!!

Thank you STERN TECH SUPPORT and the Engineers who listened to US!

Amazing new game play with special effects.

VUK ISSUE IS FIXED! PERIOD (Edit to read " VUK issue is coming back")

Love the new light effects.

Love the new display features.

Cant say enough.

Thank you for listening and being so prompt and professional about providing an update as it was obviously needed.

Keep it up and things might get better for you ! LOL

1 week later
#68 6 years ago

Seriously??.. fixed?...period? So has the update fixed the problem for everyone??

#69 6 years ago
Quoted from Ferrone:

Seriously??.. fixed?...period? So has the update fixed the problem for everyone??

Mine seems a lot better. It struggles the odd time, but instead of re firing the vuk multiple times unsuccessfully, it seems to re adjust the coil strength a little and pops it up into Gene. I'm quite happy with it now.

#70 6 years ago

still sucks stdm for me on the le. gonna have to adjust the gene head i guess.

#71 6 years ago

I just got my Premium the other day and I have to say I am BEYOND frustrated with the whole Demon lock VUK mech. Machine is level. EVERY single shot outta Genes mouth goes SDTM. EVERY single one! And can someone please tell me what the HELL do I have to do to get Demon lock lit??? Its lit at the start of the game. Locks one ball and NEVER lights again. I've spelled DEMON 5 times in one ball and the lock still won't light. What am I doing wrong? I even have the lock set to Easy in the menu. It's to the point where I've stopped playing it. This big ugly head on my playfield is the biggest useless waste of space. And don't get me started on the impossible to shoot right ramp. Is something wrong with the game? If anyone can help I'd really appreciate it. Thanks.

#72 6 years ago
Quoted from thundergod76:

EVERY single shot outta Genes mouth goes SDTM

You can adjust the shot somewhat by moving the exit to the left. I believe some instructions are in this very thread (removing four screws, etc).

Also, the latest software adds a ball save when Gene spits it out. This was a god send for my machine on route. Don't like angry players on my machines!

Quoted from thundergod76:

what the HELL do I have to do to get Demon lock lit?

The two stand up's to either side of Gene's head. Hit them once each, lock should be lit. If not, you may want to check those switches to make sure they are registering. Mine is not lit at beginning of game.

Quoted from thundergod76:

And don't get me started on the impossible to shoot right ramp.

Toughest shot in the game, especially under pressure. Needs to be hard and clean up the ramp. Makes collecting the instruments tough.

Love the game! Super fast and tough.

#73 6 years ago

The right stand up isn't working. The arrow just flashes even when you hit it. I spent hours under the playfield yesterday hopefully it's just a loose wire Should I be checking switches in the diagnostic menu?

#74 6 years ago
Quoted from thundergod76:

Should I be checking switches in the diagnostic menu?

That's a good start! Probably just a loose wire. Check the gap on the switch as well, it may be shut closed.

#75 6 years ago
Quoted from smokedog:

That's a good start! Probably just a loose wire. Check the gap on the switch as well, it may be shut closed.

Already checked gap. When you manually hit it nothing happens.

#76 6 years ago

Removed switch and cleaned contacts...switch works well now. Updated to 1.04 and that did NOTHING to solve the Demon SDTM!! It's a shame. The head is the obvious focal point of the machine and it does nothing but waste your turn, misfire and dimple the Hell outta your playfield. It's pretty bad when Stern has to add a ball save to keep you playing. Is that's Stern's answer to the problem? Pretty lame

#77 6 years ago
Quoted from thundergod76:

Removed switch and cleaned contacts...switch works well now. Updated to 1.04 and that did NOTHING to solve the Demon SDTM!! It's a shame. The head is the obvious focal point of the machine and it does nothing but waste your turn, misfire and dimple the Hell outta your playfield. It's pretty bad when Stern has to add a ball save to keep you playing. Is that's Stern's answer to the problem? Pretty lame

I have to imagine the ball save is a temporary "solution". They need to find the root cause and come up with a service bulletin to fix it. My Premium doesn't have the problem, but it seems like a significant number of folks are complaining and there must be a better fix. They should have a diagnostic setting that counts how many times this happens so owners can give them an idea of how bad the problem is...

#78 6 years ago
Quoted from thundergod76:

Removed switch and cleaned contacts...switch works well now. Updated to 1.04 and that did NOTHING to solve the Demon SDTM!! It's a shame. The head is the obvious focal point of the machine and it does nothing but waste your turn, misfire and dimple the Hell outta your playfield. It's pretty bad when Stern has to add a ball save to keep you playing. Is that's Stern's answer to the problem? Pretty lame

this sdtm sucks all my balls smash into the playfield before going sdtm. just ruins the demon mulit-ball imho!

#79 6 years ago

I just can't understand why Stern didn't see this as a potential problem. Gene's mouth is perfectly aligned with the outhole. Where did they think the ball was gonna go when it was released? Only part of the Demon multiball that works is the light show.

#80 6 years ago
Quoted from thundergod76:

I just can't understand why Stern didn't see this as a potential problem. Gene's mouth is perfectly aligned with the outhole. Where did they think the ball was gonna go when it was released? Only part of the Demon multiball that works is the light show.

You can say that about so many pinball VUK's/mechs. Not all examples are having this problem, so it's most likely an adjustment/manufacturing issue. Demon MB works great for me...the lock issues seem to have been fixed with 1.04.

1 week later
#81 6 years ago

i lowered the power on the demon head to 22 and the balls shoot on the mylar, and to the left. i hated the fact it was shooting balls past the mylar. btw i adjusted the head to the left also. now i have hardly any stdm. don't lower the coil power on the lower part of gene head or the balls with get jammed.

#82 6 years ago

I left my Demon Eject power at 32. And lowered the Demon Lockup power to 22. Made a HUGE difference!!! Actually enjoying the Demon head for the first time. The settings seem backwards but that's what helped me solve this at least on my machine.

#83 6 years ago
Quoted from thundergod76:

I left my Demon Eject power at 32. And lowered the Demon Lockup power to 22. Made a HUGE difference!!! Ball no longer rifles down at the flippers thru the outhole. Actually enjoying the Demon head for the first time. The settings seem backwards but that's what helped me solve this at least on my machine.

1 week later
#84 6 years ago

I am starting to have problems again with locks not working, VUK not ejecting properly, constant locating balls is not working... etc.. etc...

Anyone else?

2 weeks later
#85 6 years ago

PA190101.JPG

1 month later
#86 5 years ago

When I contacted Stern about my Demon Lock malfunction. The balls would lock in the head but could not eject properly at certain times. They said it was a mechanical issue and sent me this part. I will install this today and report. It appears this new piece has a different angle to launch the ball. If I look under the head as the ball search is in progress the ball is ejected straight up and falls back into the hole instead of launching forward. I am hoping this helps as I am not looking forward to removing the head.

IMG_0838.JPGIMG_0838.JPGIMG_0839.JPG

5 months later
#87 5 years ago

How is everyone making out with this?

I didn't have any problems with the demon lock until the new code came along.

#88 5 years ago

Removed...previous fix did nothing.

#89 5 years ago

Mine is an issue every once in a while but mine seems like it's an issue with the ball actually being locked and not it being fired out. Maybe ill reduce the power and see if that helps.

#90 5 years ago

Im tired of pulling the glass to adjust the optos. Ours wont lock properly 1/5 games and then repeatedly does it after a few times. Game is unplayable.

#91 5 years ago

I received my game back in July 15' and had many of the same problems discussed in this thread. Talked with Chas at Stern, he didn't really have an answer back then, the game was pretty new still. He thought code would fix it eventually.

The software settings for power in the VUK didn't seem to do anything either way in my game. I decided to replace the VUK coil with a stronger value coil. After checking alignment MANY times and actually drilling small holes in the top of the metal lock guide, so I could see what the balls were doing in the lock, I concluded this new coil caused a very different problem than I originally thought. The first two balls locked easily, the third ball was hitting the second ball with enough force to send it back down to the VUK. TOO MUCH POWER! This is not what it appears to the eye from below when the game is playing.... I originally thought it was too weak.

I put the original coil back in and still had some problems but it works correctly most of the time, reducing the VUK power in software and the new game code seemed to have helped. Sometimes "less is more". I feel this is a design problem, the ball lock trough is too short, maybe Stern should have installed some type of ball gate to keep the third ball from coming back down - like the one used in the ball trough on some older games by the kick-out hole... just an idea.

***Also if you're a Pin-Browser user changing music, etc. and experience VUK troubles OR ball eject problems, do yourself a favour and re-install the latest code version before you physically go and work on stuff. I don't know why this happened, my Gene ball eject was firing randomly and at some point and didn't eject balls at all during game play ( but it worked fine in test!!! ). This caused me to take apart the lock more times than Stern did in the factory I suspect..... the reload of original code of v1.05 fixed it ( this was before v1.28 was available ). Just a note. I later went back and changed some songs again.... game works fine again****

#92 5 years ago

Before the latest update I had my Demon eject set to 32 and Demon lockup set to 23. After 1.28 I did notice more SDTM balls. So I left the Demon eject set at 32 and lowered the Demon lockup to 22. Now its back to where it was before the update. Maybe only 1 out of 3 balls for multiball goes SDTM. Stern has the settings flipped in the service menu. Maybe next update will correct this. After the initial adjustments I made my Demon VUK/lock has been almost trouble free. Every once in a blue moon does it have to fire more than once to eject a ball. Hope those still having issues get their problems solved ASAP.

#93 5 years ago

Alright so I am still having issues with my demon lock. I had thought it was an alignment issue because if I pushed a little on the first set of optos it would fix it....for like 1-2 games max. Now its back to not recognizing the first ball every game. So I opened her up AGAIN today. Pulled the "cape" plastic shroud, and pushed on the optos a bit again. Left the cape off, played a game, all good. Put the shroud back on, back to square 1. So.....needless to say the shroud is staying off. I didnt do a damn thing other than remove that plastic shroud and now it works perfect every time. So W T F. Grrrr.

1 month later
#94 5 years ago

Trying to help a friend out with the Demon VUK his KISS LE. Took the head apart to get a better look at what's going on. Frustrating that it's a big metal assembly and you can't even see inside to tell how many balls are locked!

In our case, I'm pretty sure the VUK was firing too hard. First lock almost always worked, lock 2 somewhat reliable and lock 3 was the worst. Leading me to believe the ball is crashing into the first two balls in the lock and bouncing back out. Having some sort of a gate in there would be nice, but good luck given it's a single enclosed assembly. Some sort of horizontal flap could work well, helping to deflect the ball and keep it from falling back down.

Quoted from thundergod76:

Stern has the settings flipped in the service menu. Maybe next update will correct this.

Running 1.28 game code, I think this is still the case. I was adjusting the "Demon lockup" coil power (second Demon coil adjustment) and not seeing much of a change. Set it all the way down to 10, and then the coil to release locked balls stopped working. So know that you might need to adjust the "ball release" setting (first Demon coil adjustment, sorry for not knowing the names, don't have access to the game now) to change the VUK power.

What's troubling is that on his game, the "lockup" coil had auto-adjusted from a default of 32 up to 40. I think they need to update the adjustment code to take into consideration how many balls are locked. If a VUK power of X% is highly successful for lock #1, but not locks #2 and #3, then it needs to lower the power.

And if it's adjusting the "lockup" coil value, but then swapping the values in actual use, things will get messed up fast.

1 month later
#95 5 years ago

I was able to finally fix the VUK to work 100% of the time.

Under the table, I took the VUK mechanism off. There's 5 screws total. The bottom one, I put 2 washers on. The 2 in the middle, 1 washer each. The top 2, I left alone. What I'm doing there, is aiming the ball to travel up the rear of the scope. I set the power to 28 for the VUK.

After about 3 months or so, I can say that that my VUK has worked with 100% accuracy.

As for the ball shooting out of Gene's mouth straight down the middle...I haven't come up with a solution yet. I'm getting close to having my welder to just fill and re-drill the holes at the bottom in order to have the piece aim at the flippers.

2 years later
#96 2 years ago
Quoted from Trekkie1978:

I was able to finally fix the VUK to work 100% of the time.
Under the table, I took the VUK mechanism off. There's 5 screws total. The bottom one, I put 2 washers on. The 2 in the middle, 1 washer each. The top 2, I left alone. What I'm doing there, is aiming the ball to travel up the rear of the scope. I set the power to 28 for the VUK.
After about 3 months or so, I can say that that my VUK has worked with 100% accuracy.
As for the ball shooting out of Gene's mouth straight down the middle...I haven't come up with a solution yet. I'm getting close to having my welder to just fill and re-drill the holes at the bottom in order to have the piece aim at the flippers.

My VUK started acting up recently (game probably has 500 or so plays...purchased it NIB).

Noticed black gunk (probably from the rubber pad on the spinning disk) that needed to be cleaned. Once I installed a new coil sleeve and polished the plunger, the VUK started coming back to life (without raising the power, which didn't sound "right" to me).

Now, the only time it fails is on the 3rd ball. I lowered the power to 28, but it still kicks back. I believe it's bouncing off the 2nd lock ball (and don't want to lower the VUK power any more).

I'm going to implement your washer solution and see if it solves this remaining problem. FWIW, my demon disk doesn't have the SDTM issue (which is unrelated to the VUK issue).

Thanks for the post!

IMG_2263 (resized).jpegIMG_2264 (resized).jpeg
There are 96 posts in this topic. You are on page 2 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside