(Topic ID: 277423)

Official Avengers Infinity Quest owners thread. "Pinsiders Assemble!"

By Scribbles

1 year ago


Topic Heartbeat

Topic Stats

  • 9,113 posts
  • 698 Pinsiders participating
  • Latest reply 6 hours ago by TenaciousT
  • Topic is favorited by 303 Pinsiders

You

Topic poll

“Of the Avengers featured on the inserts, who is your favorite?”

  • Hulk 105 votes
    20%
  • Iron Man 97 votes
    18%
  • Captain America 64 votes
    12%
  • Black Widow 39 votes
    7%
  • Thor 61 votes
    12%
  • Black Panther 26 votes
    5%
  • None of those weakling, THANOS! 137 votes
    26%

(529 votes)

Topic Gallery

View topic image gallery

277DA297-0498-43F9-B09A-16192A91C3E4 (resized).jpeg
8FA1C9C7-D650-4039-AC3F-D91E0C8E054B (resized).jpeg
IMG_9820 (resized).JPG
IMG_2003 (resized).JPG
A7CF59A6-1F0B-411A-B918-A45328216F7A (resized).jpeg
2C79F86A-92FE-4BB5-B2B3-5367EC9FB9B0 (resized).jpeg
77387C2C-F7EF-40BB-AEDE-B3FEA34C9B97 (resized).jpeg
1C416472-8416-4603-84AD-86D298F88344 (resized).jpeg
IMG_7457 (resized).JPG
IMG_7470 (resized).JPG
IMG_7462 (resized).JPG
20220103_154431 (resized).jpg
disc installed 2 (resized).jpg
Production Disc 1 (resized).jpg
Thanos Santa (resized).jpg
image (resized).jpg

Topic index (key posts)

19 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 9,113 posts in this topic. You are on page 55 of 183.
#2701 1 year ago
Quoted from CashMoney:

Any way you could send us some pics of the updated Subway mech? I asked my distributor for one a while back and haven’t heard anything yet... would help to have some pictures. I still have the issue of the ball getting stuck after the last finger of the subway.

Here is a pic of the subway exit going to the VUK. You can see where they now have slotted out the whole ball channel, where before there was only slots for each metal finger to move.

09A26663-EFE7-4E9A-90EA-1E08A18D0388.jpeg
#2702 1 year ago

FINALLY got my new AIQ Premium, turn it on...”Check Power Distribution Board.”

Language settings come up, I could flip, but not select w/ power button or action button (and neither were lit, though I don’t know if they should be on initial setup).

Tried power cycling, no change.

Tried swapping to a different SD with the latest code update (v0.93), node boards updated fine, then same “Check Power Distribution Board” error. Then it briefly went to the language select, but I couldn’t even flip this time. Then back to the error.

#2703 1 year ago
Quoted from zeldarioid:

FINALLY got my new AIQ Premium, turn it on...”Check Power Distribution Board.”
Language settings come up, I could flip, but not select w/ power button or action button (and neither were lit, though I don’t know if they should be on initial setup).
Tried power cycling, no change.
Tried swapping to a different SD with the latest code update (v0.93), node boards updated fine, then same “Check Power Distribution Board” error. Then it briefly went to the language select, but I couldn’t even flip this time. Then back to the error.

Did you check all the connectors on the power distribution board (with the power off) to make sure they're all snugly and completely connected?

#2704 1 year ago
Quoted from PinMonk:

Did you check all the connectors on the power distribution board (with the power off) to make sure they're all snugly and completely connected?

Yes, they all appear to be as firmly seated as they can be

#2705 1 year ago
Quoted from zeldarioid:

Yes, they all appear to be as firmly seated as they can be

I opened the coin door and was able to start selecting settings during initial setup from the buttons in the door, I can even rush through them and get to the Free Play attract screen, but still, after about 10 seconds, the “Check Power Distribution Board” error comes up.

I could’ve dealt with any of the other problems I’ve been reading about, but this??? I’m lost!

EDIT: I took the plate off the outlet to get to the V+ and V- in the power supply, and noticed that the CN2 connector wasn’t plugged in. After a little bit, decided to check a couple of my other Stern games...found they each had it plugged in. I plugged it in on the AIQ, and now, it appears to be working! I’m talking the connector was full-off, nowhere near the plug, looked like it was intentionally stowed away kind of “not connected,” which was why I initially thought maybe that was by design as a service thing. Glad I had other machines to check!

Well, it hasn’t kicked me out of the menus yet...will see if it gives me any other trouble!

#2706 1 year ago

Subway mech went this weekend, now tonight the post falls off. At least the post is a quick fix with some blue loctite to avoid any future problems - 192 plays

Found the nut down under left sling
Found the post up in the pops
Found the topside washer in the bottom of the cabinet
Found the screw when I lifted the PF and it dropped out of the subway

03B530A8-D934-419E-B4AD-2887CB8D7A27 (resized).jpeg749F1159-EAA5-49FC-B6EE-2D91A9F6FC99 (resized).jpeg85CD319B-49A3-40EE-9C59-38AD4099BDDA (resized).jpegFDD2D7BE-02A9-4938-ACDE-56F83FB05118 (resized).jpeg
#2707 1 year ago
Quoted from Yesh23:

Cliffy makes a Cliffy for this area on the game. This is the only guiderail that touches the playfield. Every other guiderail is cut a bit off the playfield so nothing touches.

The Thor captive ball rails touch down too, at least on the Pro model it does.

#2708 1 year ago

Duplicate poat

#2709 1 year ago

stern should look at how CGC (or maybe Williams?) do rails, they are high off the playfield...

IMG_1156 (resized).JPG
#2710 1 year ago

Okay I’m getting somewhere with this now, just need to workout which way to mount it, which way it looks best.

F7B56195-4E9E-4AB0-8B43-D57E4DB489D1 (resized).jpeg50BEABC0-38A1-43ED-9BA8-E29563397821 (resized).jpegC22A4A19-8072-4E9A-94FA-E7FA48E4A37D (resized).jpegEC8FA28F-FD37-4E6B-9851-385C04805D4C (resized).jpeg3E45AB8E-79B0-424B-90F9-9E3399CA7BCE (resized).jpeg

#2711 1 year ago
Quoted from Indusguys:

After having owned the game for a couple weeks I decided to give her a wipe down and found this.

Dammit you made me look at mine. Seeing the same thing. Should've checked it sooner and put a washer under there.

#2712 1 year ago

Has anyone figured out the purpose of the subway? When I shoot a ball into the Strange disc to start a mode, the ball goes into the subway and slow walks through the teeth to the VUK and then is kicked out. You can't even see the ball from the playing position. What is the point of this? I've also changed the setting from the default to "pass-through" but it works exactly the same when starting modes.

#2713 1 year ago
Quoted from mrgregb123:

Has anyone figured out the purpose of the subway? When I shoot a ball into the Strange disc to start a mode, the ball goes into the subway and slow walks through the teeth to the VUK and then is kicked out. You can't even see the ball from the playing position. What is the point of this? I've also changed the setting from the default to "pass-through" but it works exactly the same when starting modes.

The subway holds “portal” locks, which you can build from 1 to 2 balls (maybe 3? I don’t know because I haven’t done it) before opening the portal for a gem guest, essentially turning your quest into a 2 or 3 multiball.

If you have your subway set to pass through it will simply allow all balls to pass straight through into the VUK.

#2714 1 year ago
Quoted from mrgregb123:

Has anyone figured out the purpose of the subway? When I shoot a ball into the Strange disc to start a mode, the ball goes into the subway and slow walks through the teeth to the VUK and then is kicked out. You can't even see the ball from the playing position. What is the point of this? I've also changed the setting from the default to "pass-through" but it works exactly the same when starting modes.

Here's how it works when it's not on "pass-through": Hit enough combos before spinning the disc to spell STRANGE and you'll get a portal lock (green arrow flashing at the disc). That will hold the ball in the subway as a physical lock. You can get up to two portal locks for a gem quest. Then spin the disc to spell STRANGE to open the portal for a gem quest (purple arrow flashing at the disc), hit it in, and now you'll have a 2 or 3 ball multiball to start the gem quest.

#2715 1 year ago
Quoted from AUKraut:

Here is a pic of the subway exit going to the VUK. You can see where they now have slotted out the whole ball channel, where before there was only slots for each metal finger to move.[quoted image]

Thank you! I have forwarded this picture to my distributor to get a replacement Subway mech for my AIQ Prem.

Its been 2 weeks since my original request email and I have heard nothing. I will keep the group updated on my progress.

#2716 1 year ago
Quoted from paul_8788:

Dammit you made me look at mine. Seeing the same thing. Should've checked it sooner and put a washer under there.

It was probably this way when we received the game. I sent a picture to player one I doubt they’ll do anything, but we’ll see.

#2717 1 year ago
Quoted from zeldarioid:

I opened the coin door and was able to start selecting settings during initial setup from the buttons in the door, I can even rush through them and get to the Free Play attract screen, but still, after about 10 seconds, the “Check Power Distribution Board” error comes up.
I could’ve dealt with any of the other problems I’ve been reading about, but this??? I’m lost!
EDIT: I took the plate off the outlet to get to the V+ and V- in the power supply, and noticed that the CN2 connector wasn’t plugged in. After a little bit, decided to check a couple of my other Stern games...found they each had it plugged in. I plugged it in on the AIQ, and now, it appears to be working! I’m talking the connector was full-off, nowhere near the plug, looked like it was intentionally stowed away kind of “not connected,” which was why I initially thought maybe that was by design as a service thing. Glad I had other machines to check!
Well, it hasn’t kicked me out of the menus yet...will see if it gives me any other trouble!

That Stern quality control...

Glad you got this resolved!

#2718 1 year ago
Quoted from EaglePin:

Here's how it works when it's not on "pass-through": Hit enough combos before spinning the disc to spell STRANGE and you'll get a portal lock (green arrow flashing at the disc). That will hold the ball in the subway as a physical lock. You can get up to two portal locks for a gem quest. Then spin the disc to spell STRANGE to open the portal for a gem quest (purple arrow flashing at the disc), hit it in, and now you'll have a 2 or 3 ball multiball to start the gem quest.

Perfect. Thanks for this.

10
#2719 1 year ago

Built a few extra of these if anyone is interested in replacing the lame plastic on their pro. Plug and play. These are currently for pros only.

1ACEA5D4-225C-47EA-A196-D401EBDB1BA8 (resized).jpeg4C8FCC34-1410-46E5-B7F7-AABB52DA0EA9 (resized).jpeg598EAA5B-7C5E-495F-88C1-0517FD5530CA (resized).jpeg
#2720 1 year ago

Small bit of constructive criticism, might look better to print or paint the base black so it disappears back there. White kinda stands out.

#2721 1 year ago
Quoted from yancy:

Small bit of constructive criticism, might look better to print or paint the base black so it disappears back there. White kinda stands out.

thanks i have some gold paint ill touch up those bottom rings so the blend in with the glove

#2722 1 year ago
Quoted from CashMoney:

Thank you! I have forwarded this picture to my distributor to get a replacement Subway mech for my AIQ Prem.
Its been 2 weeks since my original request email and I have heard nothing. I will keep the group updated on my progress.

I got my new wall lock assembly and haven’t had any issues with the ball getting stuck. The finger at the end goes down more, think it might have been catching the ball with the original mech. Mine showed up in a few days, great service from cointaker. I emailed stern and they said to work through the distro.

#2723 1 year ago
Quoted from Lermods:

I got my new wall lock assembly and haven’t had any issues with the ball getting stuck. The finger at the end goes down more, think it might have been catching the ball with the original mech. Mine showed up in a few days, great service from cointaker. I emailed stern and they said to work through the distro.

This is great! Thanks for sharing. Not sure why it’s been hard to get my new subway mech.. my distributor has been great and very responsive and they’ve been emailing a guy named Pablo at Stern so sounds like the holdup has been with Stern...

#2725 1 year ago
Quoted from PinMonk:

For the Pro/Prem/LE lighting is done for the I-R-O-N inserts and matching arc reactor insert by the tower to make them more suggestive of electric blue light.

I went with orange on my IRON inserts to try to match the Iron Man Avenger insert color.

4B81FC76-C512-4D1E-A46A-6C999D0BA62F (resized).jpeg
#2726 1 year ago

My premium areived at my distributor today. I have to wait until next week for delivery but im all prepped. Printed off a rulebook and picked up this cool stool today

20201110_185353 (resized).jpg20201110_185743 (resized).jpg
#2727 1 year ago
Quoted from awesome1:

I went with orange on my IRON inserts to try to match the Iron Man Avenger insert color.
[quoted image]

Since those inserts are matched to the Arc reactor on the screen animations and the Arc Reactor insert at the base of the tower, I was trying to suggest blueish electrical light continuity. I can see the argument for orange, too...

#2728 1 year ago
Quoted from PinMonk:

Since those inserts are matched to the Arc reactor on the screen animations and the Arc Reactor insert at the base of the tower, I was trying to suggest blueish electrical light continuity. I can see the argument for orange, too...

Yours look great and good point about the arc reactor insert and animations.
I haven’t done anything with the arc reactor insert yet.

#2729 1 year ago

Totally digging the VCS Adventure foot tatt

26
#2730 1 year ago

Just bought a pro, first machine ever! Should be delivered end of week-- super stoked!

#2731 1 year ago
Quoted from SpectreJ:

Just bought a pro, first machine ever! Should be delivered end of week-- super stoked!

Awesome first machine! I started with a Gilligan’s Island. AIQ is an unbelievable first pin to own!

#2732 1 year ago
Quoted from KnockerPTSD:

My premium areived at my distributor today. I have to wait until next week for delivery but im all prepped. Printed off a rulebook and picked up this cool stool today
[quoted image][quoted image]

Where did you get your stool from?

#2733 1 year ago

Having an issue with the ball getting hung up under the gauntlet. I know some others are having this issue and wanted to see what the best fix is or is Stern going to have a fix for it. Really frustrating when this happens and you have to keep taking the glass off.

8EFDB804-DBC1-40C4-BA0D-D8B661638B5C (resized).jpeg
#2734 1 year ago
Quoted from wizman71:

Where did you get your stool from?

Its an Arcade 1up stool. $99cdn
I bought mine at Best buy. Also available at the brick, walmart and amazon. Perfect height. Im not one to play pinball while seated but it went so well with the game i had to snag it

#2735 1 year ago
Quoted from fastchef:

Having an issue with the ball getting hung up under the gauntlet. I know some others are having this issue and wanted to see what the best fix is or is Stern going to have a fix for it. Really frustrating when this happens and you have to keep taking the glass off.
[quoted image]

Had the same issue. Turned down the power on the ball auto launch. No more problems.

#2736 1 year ago
Quoted from arcadem:

Had the same issue. Turned down the power on the ball auto launch. No more problems.

#2737 1 year ago
Quoted from pinballaddicted:

You guys normally get your games before us. Please let us know when you get yours, ours will not be far behind!

Nooo! Worst news ever...er ok, worst 1st world problem news ever, heard today that Port delays in NZ mean my LE is now expected to get to port 20th Nov. Not sure if that means ship will go to Oz first then come back, or not, have you guys heard anything?

#2738 1 year ago
Quoted from fastchef:

Having an issue with the ball getting hung up under the gauntlet. I know some others are having this issue and wanted to see what the best fix is or is Stern going to have a fix for it.

Two bucks at Home Depot:
bumpers (resized).jpg

#2739 1 year ago

I’m new to Titan flipper rubbers, but I thought one of the selling points for them was durability. This is on the exposed upper flipper in my new AIQ, have only played it for one day, and this is already the state of the rubber.

Has anyone else seen this, or have any recommendations? Would standard rubber be better to take the beating that this flipper tip gets? Should this just be expected on this game? Is this an anomaly?

These are low bounce competition rubbers, for reference.

06FDD0A3-4D5C-4D28-A1CE-7F465DF5C678 (resized).jpeg
#2740 1 year ago
Quoted from zeldarioid:

I’m new to Titan flipper rubbers, but I thought one of the selling points for them was durability. This is on the exposed upper flipper in my new AIQ, have only played it for one day, and this is already the state of the rubber.
Has anyone else seen this, or have any recommendations? Would standard rubber be better to take the beating that this flipper tip gets? Should this just be expected on this game? Is this an anomaly?
These are low bounce competition rubbers, for reference.
[quoted image]

I always use the perfectplay ones from pinball life on the flippers:

https://www.pinballlife.com/perfectplay-silicone-flipper-rubber-standard-size.html

#2741 1 year ago
Quoted from zeldarioid:

I’m new to Titan flipper rubbers, but I thought one of the selling points for them was durability. This is on the exposed upper flipper in my new AIQ, have only played it for one day, and this is already the state of the rubber.
Has anyone else seen this, or have any recommendations? Would standard rubber be better to take the beating that this flipper tip gets? Should this just be expected on this game? Is this an anomaly?
These are low bounce competition rubbers, for reference.
[quoted image]

Maybe keep low bounce Titan’s on the bottom only and regular Titan on the top? I’ve never used the low bounce and find the regular fine for ball control. Thin titan on the upper with balls hitting upper flipper tip directly is going to beat up the thin silicon too easily.

#2742 1 year ago

Since that flipper takes such a beating I would try something else as well. Keep stock rubber, red rubber or superbands on it. The regular Titans May last longer too as the low bounce are thinner I believe.

#2743 1 year ago

After one day? Bizarre. My standard Titans hold up great (and are on my AIQ). Must be a problem with the low bounce (or you got a bad batch). You should show the Titan folks...I'm sure they will take care of you.

#2744 1 year ago
Quoted from zeldarioid:

I’m new to Titan flipper rubbers, but I thought one of the selling points for them was durability. This is on the exposed upper flipper in my new AIQ, have only played it for one day, and this is already the state of the rubber.
Has anyone else seen this, or have any recommendations? Would standard rubber be better to take the beating that this flipper tip gets? Should this just be expected on this game? Is this an anomaly?
These are low bounce competition rubbers, for reference.
[quoted image]

Ive never purchased low bounce but i put Titans on almost all my games. The slings are less resilient than rubber imo but ive never had an issue with flippers (standard flipper or mini flipper).
I dislike Titan post sleeves but i really like the look and feel of the rest of their rings.
Id say its either a defect or maybe these low bounce ones aren't as good their standard flipper rings.
I actually just ordered somenlast night. A full set for Avengers and some new slings and flippers for Maiden and Shadow (2yrs old on both. Over 3000 games on played on my Maiden with them)
My Maiden and Shadow still have no breaks. I have 3 rings that should be replaced soon so i i ordered the parts with my Avengers kit.
Fwiw I went dark blue with a purple upper flipper for Avengers.

#2745 1 year ago

Thanks for all the replies! I’ve been wondering whether perhaps it was due to either the rubber being low bounce (though they are only something like 1mm thinner than the regulars) or perhaps the chance of a bad batch. I’ll reach out to Titan to see what they think, and will see about some standard thickness rubbers there to see if that extra mm (or whatever it is) makes an appreciable difference.

#2746 1 year ago
Quoted from zeldarioid:

Thanks for all the replies! I’ve been wondering whether perhaps it was due to either the rubber being low bounce (though they are only something like 1mm thinner than the regulars) or perhaps the chance of a bad batch. I’ll reach out to Titan to see what they think, and will see about some standard thickness rubbers there to see if that extra mm (or whatever it is) makes an appreciable difference.

Titans customer service is great, I'm sure they'll be happy to replace it. If it turns out that the flipper just takes a beating and other rubbers dont survive, maybe consider a Superband rubber on that one flipper. I definitely prefer the play and feel of Titans, but Superbands are made with a different material (polyurethane?) and are tough as nails.

#2747 1 year ago
Quoted from Scribbles:

Titans customer service is great, I'm sure they'll be happy to replace it. If it turns out that the flipper just takes a beating and other rubbers dont survive, maybe consider a Superband rubber on that one flipper. I definitely prefer the play and feel of Titans, but Superbands are made with a different material (polyurethane?) and are tough as nails.

I have Superbands on my game with no show of wear.

#2748 1 year ago

I have a premium, is there supposed to be a handle on the back of the play field to assist lifting it out the the nuts are there but no handle.

#2749 1 year ago
Quoted from Sluggo39:

I have a premium, is there supposed to be a handle on the back of the play field to assist lifting it out the the nuts are there but no handle.

My LE does not have it. The captive nuts are present, though. I have thought about ordering one to put on.

#2750 1 year ago

Seems odd to install the nuts and not the handle, that’s beyond cheap

There are 9,113 posts in this topic. You are on page 55 of 183.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside