(Topic ID: 293510)

Night Rider SS no boot need help

By waymon

8 months ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 4 months ago by waymon
  • Topic is favorited by 1 Pinsider

You

Linked Games

You're currently viewing posts by Pinsider waymon.
Click here to go back to viewing the entire thread.

#1 8 months ago

Thanks for looking.

I just picked up a Night Rider SS version and the MPU was fried with acid. I got a new rectifier board (New transformer/rectifier unit), a rebuilt solenoid board, and an Alltek MPU.

The issue is that i get absolutely no flash or any kind of light out of the MPU board.

Here are some test results

Rectifier
T1 - 6.2
T2 - 247
T3 - 15.2
T4 - 7
T-5 - 44.9

Solenoid board
TP1 - 5.1
TP5 - 14.9

I then checked the molex connectors from both the back (where the wire goes in) and from where you would disconnect the wire from connector. Hopefully that last part makes sense.

A3 J3
PIN 11 - 15.2
PIN 14 - 5.1
PIN 15 - 5.1

A2 J3
PIN 12 - 44.8

A4 J4
PIN 12 - 15.2
PIN 15 - 44.7
PIN 16 - 5.1
PIN 17 - 5.1

Alltek board test points have no voltage.

I checked the ground to each board test point with the following procedure.
I put the meter in connectivity mode and placed the negative lead onto the ground portion of the wall plug in. (Yes it is actually still attached HA)
I got good readings from every test point at the boards ground location check point.

Further information
I have everything unplugged. the only connectors being used to try and get this to boot are the J3 plug on solenoid board and the J4 plug on MPU board.

Well i am at a loss as to why this MPU will not even have a flicker of LED or show anything for voltage.

3 months later
#4 4 months ago
Quoted from GottPinball:

What was the resolve? Was it the connectors?

Life turned into a whirlwind of sorts. I sold my house and moved to
Another one. My wife got sick and a slew of other things. I have not been able to dive back into this project yet. I am hoping to get to this in the next month or so.

You're currently viewing posts by Pinsider waymon.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside