(Topic ID: 130303)

New pinside server!


By robin

4 years ago



Topic Stats

  • 86 posts
  • 45 Pinsiders participating
  • Latest reply 4 years ago by swinks
  • Topic is favorited by 1 Pinsider

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    There have been 12 images uploaded to this topic. (View topic image gallery).

    image.jpg
    screen-capture-5.png
    mootools.png
    mootools.png
    image.jpg
    image.jpg
    image.jpg
    image.jpg
    Screen Shot 2015-06-12 at 6.01.52 AM.png
    image.jpg
    screen-capture-6.png
    pinsideerror.png

    There are 86 posts in this topic. You are on page 1 of 2.
    29
    #1 4 years ago

    Pinside has moved to a new server! The old server just didn't cut it anymore. we ran out of storage last year and I had to resort to 3rd party storage solutions which are fairly expensive.

    This was a pretty large undertaking, which was done parallel to coding the mobile update that was launched two weeks ago. I had to move over 150+GB of data, our 2GB database and configure a completely new server. I have done some pretty extensive testing but not everything is easy to test when you're not under actual user load and the actual Pinside domain.

    I'm closely monitoring how the new server is holding up. Note that you might experience weird problems, connectivity issues or not receive PM notifications or whatnot. Please post any issues that might be related to the server move here in this thread. Thanks!

    I always try to do this stuff when traffic is at it's lowest (dark Pinside of the moon time) to minimize your inconvenience. But please note that if everything blows up beyond my control that I will revert back to the old server, which could mean some more inconveniently timed website outtage.

    #2 4 years ago

    Im in

    Only issue so far is https://beta.pinside.com login box is popping up when I go from page to page or open a new thread etc.

    #3 4 years ago

    Cool! I was wondering since the "Logged in" counters are showing 0. Working on that

    #5 4 years ago

    I kept getting that log in box as well.

    #6 4 years ago

    I'm repeatedly getting asked for Beta Login (which I don't have)... I click cancel to that request a bunch of times and eventually get to where I can read (and submit if this goes) posts, but graphics and other things are missing. Maybe the move isn't complete yet?

    -Rob
    -visit http://www.kahr.us to get my daughterboard that helps fix WPC pinball resets or for Williams system 3-7 sound board solutions

    #7 4 years ago

    I was getting the same things but now seems fine.

    #8 4 years ago

    Tried to Upvote the login issue posts above, but it does not work, just scrolls up to the top of the screen once I click on the icon.

    #9 4 years ago

    Same here.

    #10 4 years ago

    "A username and password are being requested by https://beta.pinside.com. The site says: "The Pinside Beta is restricted - message me if you want to be a beta tester!"

    Won't stop popping up. Every page I try to open or even when using the back button and it takes multiple clicks to make go away. Won't even go away if I enter my name and password.

    #11 4 years ago
    Quoted from rkahr:

    I'm repeatedly getting asked for Beta Login (which I don't have)... I click cancel to that request a bunch of times and eventually get to where I can read (and submit if this goes) posts, but graphics and other things are missing. Maybe the move isn't complete yet?

    I reloaded the webserver, please try again?

    #12 4 years ago

    Seems to be better now.

    #13 4 years ago
    Quoted from lancestorm:

    Tried to Upvote the login issue posts above, but it does not work, just scrolls up to the top of the screen once I click on the icon.

    Is this also fixed now?

    #14 4 years ago

    On my side, I got an SMTP error after sending a PM. pinsideerror.png

    After clicking ok, the PM page stays there...

    #15 4 years ago

    I tried to open this site about 1.5 hours ago. It took several tries. I noticed several pictures missing on the market place ads. Everything is working well at this moment. Thank you for your hard work and effort. JLC

    #16 4 years ago

    I'm getting the above PM message also

    #17 4 years ago

    I'm working on the pm issue, seems like a misconfiguration somewhere...

    #18 4 years ago

    Yes the login screen appearing on every page opened (and needing to press cancel 5 times to get through) issue is resolved, good work. No requests for beta password are showing now. Thanks Robin.

    #19 4 years ago

    Robin if you are using an external mail server in phpmail make sure the ip of the new server is in the allowed relay or if you are using postfix or sendmail that the DS smart relay is set.

    #20 4 years ago

    Thanks for the hard work to provide a great product. I offer a fresh donation this morning to salute you!

    #21 4 years ago

    An OZ perspective
    I couldn't even connect to the site initially, then when i could i received the "beta log in" message a LOT. I was already signed in (errmmm forgot to log off last night ) so i managed to log off, left it for 20 minutes whilst i scoffed some food and have just logged back in. I was able to upvote a post and all seems good now Robin

    #22 4 years ago

    I got a 404 page not found for a few tries, with 'nginx' in the middle. Couple of minutes later (I guess some cache or other cleared) all was good.

    #23 4 years ago

    Yeah I have no idea what that was. I restarted my fpm service and then things got going again. It's weird, this server has been running for two months without any issue. Must be the user load that is on it now, looking into a solution.

    #24 4 years ago
    Quoted from Snux:

    I got a 404 page not found for a few tries, with 'nginx' in the middle. Couple of minutes later (I guess some cache or other cleared) all was good.

    Same here, but a few minutes later (now), I got in no problem.

    Appreciate the upgrade Robin and all your hard work towards providing us with this fantastic website.

    #25 4 years ago
    Quoted from marcd:

    On my side, I got an SMTP error after sending a PM. pinsideerror.png
    After clicking ok, the PM page stays there...

    The PM e-mail forwarding issue should be resolved now!

    #26 4 years ago

    just got this a minute ago when trying to send a pmscreen-capture-6.png

    #27 4 years ago

    All good on iphone 5 so far. Only thing I can see is the number od users active counter isn't working.image.jpg

    #28 4 years ago

    I also see that the user count is 0 -- using Chrome on a Mac.

    Screen Shot 2015-06-12 at 6.01.52 AM.png
    #29 4 years ago

    $_SESSION array (7)
    'token' => string (32) "08782bac2bae761afe444714c79bd044"
    'user_info' => array (74)
    'user_key' => string (5) "28403"
    'user_name' => string (11) "DevilsTuner"
    'user_accountstatus' => string (6) "active"
    'user_level' => string (2) "20"
    'user_karma' => string (6) "853150"
    'user_email' => string (25) "email deleted"
    'user_description' => string (0) ""
    'user_password' => string (40) "c4b2a71d5c42cc94adb724ab853058f219f8ce0d"
    'user_password_lost' => string (0) ""
    'user_loginfails' => string (1) "0"
    'user_reset_code' => string (0) ""
    'user_blocked' => string (1) "0"
    'user_frozen' => string (1) "0"
    'user_ipadress' => string (15) "removed"
    'user_activation' => string (0) ""
    'user_firstname' => string (0) ""
    'user_lastname' => string (0) ""
    'user_birthday' => NULL
    'user_gender' => string (6) "unsure"
    'user_company' => string (0) ""
    'user_sales_email' => string (0) ""
    'user_country' => string (0) ""
    'user_countrycode' => string (0) ""
    'user_state' => string (0) ""
    'user_city' => string (0) ""
    'user_street' => string (0) ""
    'user_phone' => string (0) ""
    'user_latitude' => string (1) "0"
    'user_longitude' => string (1) "0"
    'user_website' => string (0) ""
    'user_type' => string (7) "regular"
    'user_pro_status' => string (1) "0"
    'user_subscription_exp' => NULL
    'user_group' => string (1) "0"
    'user_koog' => string (1) "0"
    'user_register_date' => string (19) "2015-01-29 17:36:54"
    'user_activation_date' => string (19) "2015-01-29 17:37:12"
    'user_lastlogon_date' => string (19) "2015-06-12 15:26:44"
    'user_override_external_calls_check' => string (1) "0"
    'user_profilefilled' => string (1) "1"
    'user_privacy' => array (1)
    string (0) ""
    'user_notifications' => array (1)
    string (0) ""
    'user_features' => array (1)
    string (0) ""
    'user_pinsidemail' => array (2)
    string (7) "enabled"
    string (15) "realmailforward"
    'user_market' => array (1)
    string (0) ""
    'user_pinsidemail_lastchecked' => string (19) "2015-06-10 03:46:56"
    'user_features_other' => string (0) ""
    'user_linked_collections' => string (0) ""
    'user_donated_amount' => string (1) "0"
    'user_donated_lastdate' => string (10) "0000-00-00"
    'user_marketwatch_compiled' => string (1) "1"
    'user_marketwatch_asap' => string (1) "0"
    'user_marketwatch_frequency' => string (1) "7"
    'user_initials' => string (0) ""
    'user_ratingweights' => string (0) ""
    'user_favgames' => string (19) "mod,lss,ess,lem,eem"
    'user_tilt_disabled' => string (10) "0000-00-00"
    'user_tilt_disabled_count' => string (1) "0"
    'user_timezone' => string (3) "UTC"
    'user_ban_votes' => string (1) "0"
    'user_ban_count' => string (1) "0"
    'user_ban_date' => string (19) "0000-00-00 00:00:00"
    'user_ban_karmaloss' => string (1) "0"
    'user_website_settings' => array (10)
    'sfbox' => string (1) "1"
    'ts' => string (1) "2"
    'mb' => string (1) "2"
    'ii' => string (1) "1"
    'gif' => string (1) "1"
    'tc' => string (1) "1"
    'tcd' => string (1) "1"
    'as' => string (1) "1"
    'tilt' => string (1) "0"
    'iu' => string (1) "1"
    'user_starred' => string (1) "0"
    'user_email_disable_code' => string (40) "6b30856b4ac448512663644f93804c896eaef3e6"
    'image_key' => string (5) "94034"
    'image_sha1' => string (40) "18fbaedc803524d411c9f88ba453ecb23a1845c8"
    'image_linktype' => string (6) "avatar"
    'image_extension' => string (3) "jpg"
    'session_random' => string (9) "607924269"
    timestamp
    1989-04-07 05:51:09
    'user_fullname' => string (11) "DevilsTuner"
    'avatar_thumb_path' => string (86) "https://img-s.pinside.com/avatar/18/thumb/18fbaedc803524d411 …"
    https://img-s.pinside.com/avatar/18/thumb/18fbaedc803524d411c9f88ba453ecb23a1845c8.jpg
    'avatar_tinythumb_path' => string (90) "https://img-s.pinside.com/avatar/18/tinythumb/18fbaedc803524 …"
    https://img-s.pinside.com/avatar/18/tinythumb/18fbaedc803524d411c9f88ba453ecb23a1845c8.jpg
    'cuserkey' => string (5) "28403"
    'logged_in' => bool TRUE
    'disable_auto_mobile' => bool FALSE
    'mobiledevice' => bool FALSE
    'imgbar' => array (31)
    '0' => string (10) "bg-afm.jpg"
    '1' => string (10) "bg-bsd.jpg"
    '2' => string (12) "bg-bw100.jpg"
    '3' => string (19) "bg-circus-ramps.jpg"
    '4' => string (13) "bg-circus.jpg"
    '5' => string (11) "bg-crvt.jpg"
    '7' => string (10) "bg-dmd.jpg"
    '8' => string (9) "bg-dw.jpg"
    '10' => string (10) "bg-es2.jpg"
    '11' => string (16) "bg-fishtales.jpg"
    '12' => string (10) "bg-gnr.jpg"
    '13' => string (14) "bg-jackpot.jpg"
    '14' => string (9) "bg-jm.jpg"
    '15' => string (11) "bg-lane.jpg"
    '16' => string (12) "bg-lotr2.jpg"
    '17' => string (9) "bg-mm.jpg"
    '18' => string (11) "bg-mode.jpg"
    '19' => string (10) "bg-mon.jpg"
    '20' => string (11) "bg-otto.jpg"
    '21' => string (13) "bg-pinbot.jpg"
    '22' => string (9) "bg-rs.jpg"
    '23' => string (9) "bg-ss.jpg"
    '24' => string (13) "bg-sttng2.jpg"
    '25' => string (10) "bg-tom.jpg"
    '26' => string (11) "bg-tz-2.jpg"
    '27' => string (12) "bg-tz-2b.jpg"
    '28' => string (9) "bg-tz.jpg"
    '29' => string (14) "bg-voltage.jpg"
    '30' => string (10) "bg-wcs.jpg"
    '31' => string (11) "bg-wire.jpg"
    '32' => string (9) "bg-xf.jpg"

    #30 4 years ago

    I've noticed that PM in pinside works without error, but that reply by email doesn't seem to work. Probably best if someone else can confirm.

    #31 4 years ago
    Quoted from lyonsden:

    I've noticed that PM in pinside works without error, but that reply by email doesn't seem to work. Probably best if someone else can confirm.

    There was indeed an issue with replies not being accepted by our mail server. If all is well I should've fixed that about 10 minutes ago. So if you sent your mail between new server launch (2 hours ago?) and 10 minutes ago changes are your reply message went down the outlane. Please confirm your pm box to see wether your reply message made it. Sorry for the trouble!

    #32 4 years ago
    Quoted from robin:

    There was indeed an issue with replies not being accepted by our mail server. If all is well I should've fixed that about 10 minutes ago. So if you sent your mail between new server launch (2 hours ago?) and 10 minutes ago changes are your reply message went down the outlane. Please confirm your pm box to see wether your reply message made it. Sorry for the trouble!

    Thanks for the update. I sent it in that window of time and ended up replying in pinside's PM manager. No worries about it being lost -- I just copied the text out of my sent box. Also, thanks for the continued to work making Pinside's tech better and better. (Server swaps are no fun.)

    #33 4 years ago

    Sorry for the intermittent server issues, I'm working hard on finding the cause of the problem. All I know right now is that is related to my php5-fpm configuration and I'm "playing" with the settings to get it to stop crashing.

    #34 4 years ago
    Quoted from robin:

    Sorry for the intermittent server issues, I'm working hard on finding the cause of the problem. All I know right now is that is related to my php5-fpm configuration and I'm "playing" with the settings to get it to stop crashing.

    Just this once, we'll forgive you

    #35 4 years ago

    Member counter is working again! And the beta message is no longer appearing on the marketplace pages.

    #36 4 years ago

    So is the Server no longer in Canada?

    Back up and running, Great! (11:16 AM MST)

    #37 4 years ago
    Quoted from Darcy:

    So is the Server no longer in Canada?

    Yeah, Pinside has been down for most of the day for me.

    #38 4 years ago
    Quoted from robin:

    Sorry for the intermittent server issues, I'm working hard on finding the cause of the problem. All I know right now is that is related to my php5-fpm configuration and I'm "playing" with the settings to get it to stop crashing.

    Not fun.

    #39 4 years ago

    For anyone who understands nginx server:
    WARNING: [pool www] server reached pm.max_children setting (128), consider raising it

    I keep raising max_children setting and it keeps crashing with this error.

    #40 4 years ago

    Pinside has been in and out for me today, just a few minutes a couple times it said page not found try again later.
    Not very big interruptions but got kicked off then back in a few minutes and no problems still logged in afterwords too

    #41 4 years ago

    Robin.. Call me i'll PM you my cell. I know the issue.

    #42 4 years ago

    I'm getting the following error pretty often:

    image.jpg
    #43 4 years ago

    Robin, please either listen on the IPv6 address, or remove the AAAA DNS records. Currently your IPv6 address is giving connection refused. This causes browsers to do an extra hop to fail one protocol before falling back to the legacy IPv4 protocol.

    #44 4 years ago
    Quoted from robin:

    For anyone who understands nginx server:
    WARNING: [pool www] server reached pm.max_children setting (128), consider raising it
    I keep raising max_children setting and it keeps crashing with this error.

    i'm just parroting what comes up when i google that problem ... but have you tried this:

    I found that by setting the pm.max_requests value (which is commented out by default) helped in fixing these errors. This setting forces child requests to respawn after executing a certain number of requests and can be helpful if there are memory leaks somewhere in your code or 3rd party libs.
    In /etc/php-fpm.d/www.conf:
    pm.max_requests = 500

    seems like that in conjunction with a higher max_children could help.

    #45 4 years ago
    Quoted from pezpunk:

    i'm just parroting what comes up when i google that problem ... but have you tried this:

    seems like that in conjunction with a higher max_children could help.

    In this case that is actually going to cause the server to crash quicker.

    #46 4 years ago

    Thanks Robin, Pinside is the best forum period. I plan to donate this weekend.

    #47 4 years ago

    Thanks for the hard work, just made a donation to support your efforts.

    #48 4 years ago

    FYI, I just tried to attach some photos to a post, but it seems to be broken. It keeps saying Upload ID failed whether I drag and drop or browse to select them.

    #49 4 years ago

    Testin'.

    image.jpg
    #50 4 years ago

    Can't send pm dohhhhh

    Promoted items from the Pinside Marketplace
    $ 29.95
    Playfield - Toys/Add-ons
    ULEKstore
    $ 129.95
    Playfield - Toys/Add-ons
    Hookedonpinball.com
    $ 35.99
    Lighting - Interactive
    Lee's Parts
    $ 24.95
    Cabinet - Armor And Blades
    Hookedonpinball.com
    From: $ 9.99
    Eproms
    Matt's Basement Arcade
    From: $ 175.00
    Gameroom - Decorations
    Pinball Photos
    $ 28.00
    Playfield - Other
    Pin Monk
    $ 87.00
    $ 6,999.00
    $ 35.00
    Playfield - Toys/Add-ons
    3D MODS
    From: $ 20.00
    Playfield - Toys/Add-ons
    ModFather Pinball Mods
    $ 45.99
    $ 89.99
    Lighting - Led
    Lighted Pinball Mods
    $ 35.00
    Playfield - Decals
    Pinfarmer Mods
    $ 25.00
    Cabinet - Other
    Filament Printing
    $ 7,999.00
    Pinball Machine
    Classic Game Rooms
    From: $ 218.00
    $ 29.95
    Gameroom - Decorations
    Pinball Photos
    $ 174.99
    $ 45.00
    Playfield - Toys/Add-ons
    Just 3D Mods
    $ 999.00
    Flipper Parts
    Mircoplayfields
    $ 39.95
    Playfield - Other
    PinBoss Mods
    $ 19.95
    Playfield - Toys/Add-ons
    ULEKstore
    $ 15.00
    Playfield - Toys/Add-ons
    Pinball Haus
    There are 86 posts in this topic. You are on page 1 of 2.

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside