(Topic ID: 272899)

New! Pincoder Adapter

By pincoder

1 year ago

Topic Heartbeat

Topic Stats

  • 131 posts
  • 21 Pinsiders participating
  • Latest reply 6 months ago by jjoravec
  • Topic is favorited by 23 Pinsiders


Linked Games

Topic Gallery

View topic image gallery

3EF76420-34D7-4790-B108-D2AE0C1EF8BE (resized).jpeg
51DC0EAE-18D9-44B8-8B02-CF0371C71C0F (resized).jpeg
AED1241F-9433-4D95-8A6C-74719F6CFE7B (resized).jpeg
7B770EC1-FB75-4A18-988D-3BB29782B9BF (resized).jpeg
pasted_image (resized).png
B5549349-9494-4C52-9D95-ACFB005A18F8 (resized).png
23FAC8AC-9236-4DAA-8591-56694DD3B7B2 (resized).jpeg
Capture (resized).PNG
4x4 (resized).PNG
IMG_20210130_110211287 (resized).jpg
IMG_20210130_110150556 (resized).jpg
IMG_20210117_220828690 (resized).jpg
IMG_20210125_175553906 (resized).jpg
IMG_20210125_175434523 (resized).jpg
IMG_20210117_235547510 (resized).jpg
IMG_20210117_220919985 (resized).jpg

You're currently viewing posts by Pinsider talon.
Click here to go back to viewing the entire thread.

#30 9 months ago

While waiting for a response from my previous post, (and not sure if this is the right place to ask), is this a labeling error on the flipper roms? Flipper rom 1 says IC17 and flipper rom 2 says IC20. According to the schematic, flipper rom 1 should be IC20 and flipper rom 2 should be IC17. The game used to work before and I know these 2 roms were never switched. I do notice that one of the roms looks repaired with a leg that is soldered. I did plug in the Pincoder adapter in IC17, (according to the schematic and not the sticker), and have not had any issues running the tests.

IMG_20210117_220828690 (resized).jpgIMG_20210117_220840084 (resized).jpgIMG_20210117_220919985 (resized).jpgIMG_20210117_235547510 (resized).jpg
1 week later
#48 9 months ago
Quoted from pincoder:

That sounds like a bug in the test ROM, I'll verify that.
The flippers are only fired by pressing the flipper buttons. In the earlier tests they are not "enabled" and so will not fire. The solenoids test does "enable" them. The flipper relay on the MPU board will be energized in this case and you should be able to fire them.
If you get through all of the tests and the game still doesnt boot you likely have corrupt/dead ROMs, or bad rom sockets. Check the soldering job on the remaining ROM sockets and if you're in doubt replace the sockets with new ones. If they are "scanbe" sockets definately replace them as they are known to be bad.

Ok. Thanks for the reply and your help. I did order a burner(GQ-4x4) and eraser. It is supposed to arrive sometime tomorrow. I'll at least be able to check the roms with it. The rom in IC17 that I mentioned earlier looks suspect because it was repaired. I don't believe the sockets are scanbe, but I'll check again to be sure. I did make it through all of the other tests. It felt great to see the displays come to life.

IMG_20210117_220828690 (resized).jpgIMG_20210125_175434523 (resized).jpgIMG_20210125_175553906 (resized).jpg
#54 8 months ago
Quoted from slochar:

It's likely a masked rom and that # is the williams part #. Just burn a new eprom and replace, making sure your board is jumpered for the correct eprom.

Thanks. I'm not sure about jumper settings, but I'll look into it. Does anyone know if this is a reputable place for eproms: https://www.twistywristarcade.com/eproms/118-2532-eprom.html ?

#58 8 months ago

Thanks for the replies.

1 week later
#71 8 months ago
Quoted from barakandl:

If the GQ-4X seems to burn a chip really slow and/or all the bits not stay flipped typically means the Vpp is too low. Usually this means you are trying to burn a 25vpp chip at 21vpp but also could be you need an external power supply and not just USB power.
All the M2732 (M2716 too) out of china are marked with A suffix. A good portion of them are 25v chips and some even 12.5v. When you burn the 25v type at 21v expect GQ-4x to take way longer than usual and you may have to repeatedly burn it over and over to get all the bits to stay right. When I pick the right Vpp it burns quick and right the first time.
If you burn a 12.5vpp chip at 21, or 25vpp it gets killed.
If you are not sure Vpp of dodgy china remark start at 12.5 (2732B) and go up until it seems to work.

The chip I'm trying to burn is a TMS2532A-45JL. The other one(same exact chip), burned and verified with no issues. Same thing with the 2716 I burned, no issues. Both burned pretty fast too. So I tried to burn the same file that worked with the other 2532 and it still wouldn't burn. These were all done with a powered USB hub. I may have a power supply laying around here somewhere and have to look for it, but so far it's looking like the chip is bad

On one happy note: after I put in the 2 new flipper roms I burnt, my game now boots!

You're currently viewing posts by Pinsider talon.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside