New guy here, Need help with Johnny Mnemonic

(Topic ID: 154025)

New guy here, Need help with Johnny Mnemonic


By Mirage

2 years ago



Topic Stats

  • 35 posts
  • 10 Pinsiders participating
  • Latest reply 2 years ago by timtim
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 2 years ago

New to this forum. I am in north Georgia. I got a Johnny Mnemonic game that I am trying to fix everything. Had a bad power board and replaced it whit a rottondog board. Sent the factory power board and I call it the program board out to be fixed. Got the program board back and installed it. The problem I have with the game is when it goes into video mode the display goes blank. Have checked the fuses on the dot matrix driver board and all the conections still no luck. The dot matrix board is not the factory board it is a XO PIN board.Can anyone help me out PLEASE . Thank you for any help. Mirage

#2 2 years ago

9 min bump. curious about this one. So the DMD "only" goes out via video mode?

#3 2 years ago

Yes that is correct

#4 2 years ago

Ok, now that is a problem that makes no sense! Try new roms?

#5 2 years ago
Quoted from Euchrid:

Ok, now that is a problem that makes no sense! Try new roms?

I agree, sounds like the video mode is corrupt. what version roms are you using?

#6 2 years ago

On the dot matrix driver board?

#7 2 years ago
Quoted from Mirage:

On the dot matrix driver board?

Correct, should say the version, but the version is irrelevant you should not have this problem with any version. Buy a new set of roms should only cost you a few bucks from "JOHNWARTJR". If it doesn't solve your problems at least you can say you got new roms

#8 2 years ago

This is not the factory board it is a XO pin board. How do I find Johnwartjr? is this a company?

#10 2 years ago

Thanks I e-maid him to see if he could help me out . Thanks again

#11 2 years ago

Can you tell me which board these roms are located?

#12 2 years ago

Crazy thought... Is it possible that you are using the 5v from GI for one of your boards?
IIRC, video mode has GI off. If so, that explains why the DMD turns off during video mode.

-2
#13 2 years ago

The game might be doing you a favor cause the video mode is so bad. J/k

I'm gonna guess bad roms too. They're located on the board on the left side of the back box (when you're looking at the machine)

#14 2 years ago

I was watching a utube of the game on line and mine does not display a lot of stuff the one on line does. How many Roms need to be replaced . Sure hope John wart answers my E-mail. Would like to put a DONE stamp on this BAD BOY. Thanks again guys for all yalls help.

#15 2 years ago

There's a small chance you have a prototype game and/or ROMs. Do your mode inserts say access code 1 and 2 or super hero and riot?

#16 2 years ago

I vote roms too. Why would it work all the way up until the video mode? Gotta be rom related that's why

#17 2 years ago

My DESW had an issue where the DMD would go blank. It was a ground issue. But this would only happen random not just a particular moment like a video mode. However, something could be shorting out when the video mode starts. As mentioned above when you are in video mode other things get switched off/on.

Quoted from phillymadison:

The game might be doing you a favor cause the video mode is so bad. J/k
I'm gonna guess bad roms too. They're located on the board on the left side of the back box (when you're looking at the machine)

I think the video mode is really fun. Pretty bland looking, but very fun and challenging.

#18 2 years ago
Quoted from Jean-Luc-Picard:

I think the video mode is really fun. Pretty bland looking, but very fun and challenging.

I said I was kidding

#19 2 years ago

I don't know. Hope it is fun.Found the ROM on john Warts web sight and ordered it. Will let y'all know when I get it.

#20 2 years ago

The video mode has a couple caviets:
Its controls are crazy stupid.
Its ugly as hell.
There is a "slow-motion" bug that activates if you capture last node on 0 seconds.

What it does have is an Extra Ball light on second stage. That alone, is worth it all. Very satisfying to earn EB.

#21 2 years ago
Quoted from boogies:

The video mode has a couple caviets:
Its controls are crazy stupid.
B.

I swear one of these days I will deal with this on mine. Thinking a joystick and wire it into all flipper buttons. I will drill a small hole in the cabinet bottom for the wires to come through. Then the joystick can hang on an adhesive hook at the front, maybe on the coin door. When video snarf mode triggers, wammo grab the joystick for a more normal and achieving experience!!!! I have and extra joystick somewhere from an old game. Just gotta do it and post pics here

#22 2 years ago
Quoted from FrostyMug:

Thinking a joystick

I seen a vid with one. I'm sure it helps, but I believe that up n down become reversed once your "node" hits the top or bottom wall. Maybe its just me and my brain during this mode, but if I'm right, the joystick would still act funky.

#23 2 years ago
Quoted from FrostyMug:

I swear one of these days I will deal with this on mine. Thinking a joystick and wire it into all flipper buttons. I will drill a small hole in the cabinet bottom for the wires to come through. Then the joystick can hang on an adhesive hook at the front, maybe on the coin door. When video snarf mode triggers, wammo grab the joystick for a more normal and achieving experience!!!! I have and extra joystick somewhere from an old game. Just gotta do it and post pics here

This changes the game play if it's that difficult just turn off the vidio mode. I find this mode challenging and fun lots of hand eye/brain coordination . Just play better LOL!

#24 2 years ago
Quoted from freddy:

This changes the game play if it's that difficult just turn off the vidio mode. I find this mode challenging and fun lots of hand eye/brain coordination . Just play better LOL!

Yeah...the part I did not mention is I have RA, Osteo and Fybro. Left wrist and fingers are real bad. While I can manage to play pinball ok by mashing 1 button (each side of pin), I simply cannot do two buttons on the same side of the machine. for me I need to get the joystick solution or like you said, just turn it off.

#25 2 years ago

I got my new ROM and installed it and started play the game and the same thing happens. When it goes into video mode the DOT matrix goes blank the machine beeps for about 10 seconds then the game goes back to regular play. Again the game has a after market DOT matrix driver board in it.

#26 2 years ago

I'm still wild guessing that someone might've grabbed the GI 5v to power that newer DMD. Did you check on that?
An easy way to check is to go into settings and check your GI power levels. If the DMD turns off when GI is off, then I'm probably correct.

#27 2 years ago

I have not checked that but I have install a new power board and sent out the logic board to be checked out and up dated.I have ordered a new DOT matrix power driver board from rotten dog. Could have bad ribbon cables I guess. I will check out what you suggested tomorrow. Thank you for the help.

#28 2 years ago

I went to settings To look for GI power but could not find that. Ran the Dot matrix test and it was ok. Went through all test categories but could not find
GI power levels

#29 2 years ago

Tests -> T.6 Gen'l Illum

After you enter it, the power level starts on 1 - that's off with LEDs, not sure if it's off with incandescents?
If your DMD is still on, then you can just quickly cycle through (volume buttons) the different GI levels, and you're done, my hypothesis if wrong. If your DMD turns off at any point, then you can actually determine which GI string it's connected to.

#30 2 years ago

Ok i did that and it worked fine when i manually cycled through the test.

#31 2 years ago

Ok... Does all 4 flipper button work during switch test? I figure that your glove is working properly, forward and backwards, but the only software reason that I can think of to "disable" the video mode would be 1 of the 4 flipper switches not working.

#32 2 years ago

Yes all four buttons work. Two for the flippers and then all four work to move the glove.

#33 2 years ago

I will check them in the switch test.

#34 2 years ago

OK here is the up date. I installed a Rottondog DOT matrix driver board in machine and I NOW see things I have never seen BEFORE. This thing is a WHOLE new machine.Video mode works plus ALL kinds of other stuff. This did not have factory board in it it had a X pin in it. This game is FUN as hell to play now. Thank to everyone who help. PLAY ON

#35 2 years ago

Good to hear

That was a weird issue

Promoted items from the Pinside Marketplace
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 11.95
Playfield - Toys/Add-ons
ULEKstore
From: $ 369.95
Boards
PinSound
From: $ 22.00
$ 15.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside