(Topic ID: 151956)

Back To Factory ROM's From Demo Time; Claw Won't Work


By weaverj

3 years ago



Topic Stats

  • 247 posts
  • 15 Pinsiders participating
  • Latest reply 3 years ago by AKWhitey
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 16 images uploaded to this topic. (View topic image gallery).

IMAG0108[1]_(resized).jpg
DSC02203_(resized).JPG
IMAG0106[1]_(resized).jpg
IMAG0105[1]_(resized).jpg
IMAG0104[1]_(resized).jpg
images-6_(resized).jpg
DSC02200_(resized).JPG
IMAG0099[1]_(resized).jpg
IMAG0097[1]_(resized).jpg
IMAG0096[1]_(resized).jpg
IMAG0095[1]_(resized).jpg
IMAG0094[1]_(resized).jpg
IMAG0067[1]_(resized).jpg
IMAG0061[1]_(resized).jpg
IMAG0058[1]_(resized).jpg
IMAG0057[1]_(resized).jpg

You're currently viewing posts by Pinsider weaverj.
Click here to go back to viewing the entire thread.

#1 3 years ago

picked up a DM wednesday night. demo time is installed and i was told that i have all the originals, too. is there a quick layout of which roms go where? i wouldn't think it'd be that hard, right?

update: factory lx-4 is installed now, but the claw won't work: magnet error.

final update (i hope): turns out there are scratches on the cpu board under the game rom socket. this is probably from the previous owner rough-housin' when swapping roms. hindsight is 20/20, but it actually makes a lot of sense now.

every once in awhile i think i could have done this. i really don't think so, however. i got good fairly quickly at using a flathead screw driver to delicately pry the game rom off the board. my cpu board is really scratched up. someone messed this up many times. here's how to do it right:

you wedge the head in on one side. you don't need to stick it in far; maybe 1/8 inch. then you rotate the head back and forth a little bit. just enough to get the pins popping on that side a little. now you have a little more space to stick the screwdriver in further. you can go about 1/4-1/2 inch in. repeat the head rotation step and you'll be good to go about an inch or maybe the whole way. the most important thing is make sure you're as parallel with the board as possible, or you could develop scratches on the board like mine had. once you have the screw driver behind the entire game rom, rotate back and forth until the rom is completely loose. it doesn't take much effort at that point. good luck.

final update 2.0: it wasn't the cpu board, scratches and all. the claw wasn't getting far enough back over the elevator to pick the ball up. it would work with the demo time rom, since there's less light show on that rom. this is what i'm thinking anyway. less lights means more juice for the claw magnet. it could pick the ball up with the extra juice even though it wasn't directly over it.

figured this out when a buddy was over playing and it stopped working. yeah, it worked with lx4 for a few days after the cpu board swap. so weird. he was standing at the side and said it looked like the claw wasn't back far enough. i never noticed because i was always testing the game from the front of the machine, and again, it worked with the f'n demo time rom every single time.

well, i think this is it, guys. thanks for all the help the past 2 months. i owe some food and drink at allentown, that's for sure. now i can actual play this thing without any worries about if the damn claw is going to work. gotta work on those scorezzz!

#2 3 years ago

looks like there's 8 sound roms (u2-9) i only have the factory U2-7. dumb question: i need 8 originals, right? unless factory only had 6 with 2 expansion sockets on the system board.

also, i have a rom with a label on it that says "dm lx4". any ideas on that one?

#4 3 years ago

interesting. i received that one loose. looks like the main game rom just says "DTIME 1.01".

#5 3 years ago

think you're right about the LX4:

ebay.com link » Demolition Man Demo Man Pinball Chip Lx 4 Upgrade

also, this says there was 2 more sound roms added:

ebay.com link » Demolition Man Demo Man Pinball Cpu Sound Set Profanity Home Roms

i could just pop these in and see what happens, right? are these just like pulling batteries? i don't need any gel, glue or anything?

#7 3 years ago

so i tested that lx4 rom and it looks like an older demo time release, r01? that stinks. looks like i have no williams game rom...

another dumb q: do i need to put the demo time sound roms in or can i use the factory u2-7? will the dt sound roms, u2-9, work with a factory game rom?

#8 3 years ago

i didn't see your post in time, so i free-balled it. yeah, that first chip pull was ugly; pulled it by hand :l. got lucky it wasn't worse. i quickly learned the flathead method myself.

#10 3 years ago

i think i just emailed you through ebay .

okay, so maybe i have the curse roms. they're home-made labeled dm 2-9. they don't say dt, dtime or anything.

the lx4 game rom comes up saying freewpc demolition time r01. is it just mislabeled?

#11 3 years ago

came installed: DTIME 1.01
came installed: 9 sound roms labeled DM 2-9
came loose: DM LX4 (tested this one; looks like an earlier Demo Time, r01)
came loose: L1 U2-7 sound roms

#14 3 years ago

i need the pg rom .

so i can just pull the dm8 and 9 sound roms to take the cursing out? i actually don't think i've heard any yet.

#16 3 years ago

well, i got nothing now. i put it back to dtime 1.01 game and the u2-9, and it powers on with no bulbs and no dmd. kill myself.

#17 3 years ago

ok, it's back up. i pulled all the sound roms, u2-9, and the dtime 1.01 is booting up now. why would that happen?

#18 3 years ago

checking a picture archive from the previous owner, i had them in upside down...

#19 3 years ago

newbie alert!

#20 3 years ago

so i tried the lx4 rom and the claw doesn't pick the balls up. put the dt 1.01 in and it worked.

will the demo time game rom work with the factory sound u2-7?

#22 3 years ago

yep, i discovered that, along with the knocker disable, which i like.

thanks for your help, guys. i just ordered a real lx4 from pinball place.

1 week later
#23 3 years ago

got the lx-4 installed. i like it except the claw doesn't work...

why would my claw work with demo time, but not a williams rom?

#26 3 years ago

sorry, i could have specified. i get a magnet error. all motors appear to be working.

#28 3 years ago

you got it.

like i said, with the demo time rom, it works fine. is there a "fix" or something in the demo time?

#31 3 years ago

elevator is bringing it up. i can see the claw getting pushed up with the ball at the top of the elevator.

i tried the magnet test while holding a ball right under the claw, and it doesn't pick it up. ball is definitely in contact with the magnet, too.

#32 3 years ago

not sure it'll help, but the older demo time i have, r01, the magnet doesn't pick up on that either. it only works with the 1.01.

i feel like there is more lenient claw code on the demo time 1.01 rom or something. like it will work without everything begin perfect. the williams lx-4 is more anal. am i crazy?

#36 3 years ago

yeah, maybe the lx-4 is checking something the demo time isn't. didn't think about it going the other way around.

i should be able to get to those things tomorrow. thanks a lot.

#37 3 years ago

tested the fuses; i think they're okay.

are you talking about the dip switches close to the game rom? i see 2 and 3 are off.

#38 3 years ago

booted up with 2 and 3 on. it reset everything. still got no magnet. i flipped 2 and 3 back off.

#40 3 years ago

i'll switch them to on. yes, i have an audible multimeter. they were all squealing.

i'll check the claw wiring. i will add that although i said the claw worked with the demo time rom, it would fail to pickup maybe 1 out of 10 times. it would cycle the elevator again and pickup on the 2nd attempt. maybe that's normal when everything is working?

#41 3 years ago

and fyi, i can swap roms back and forth and it'll always work with demo time. so i have gone backwards, undoing the changes, and it works. in other words, checking fuses and wiring just seems like a waste of time.

i appreciate the help, however, and i will definitely look at anything you want me to.

#44 3 years ago

beam under the claw? if not, where exactly?

#48 3 years ago

in test mode, are those the 4 square indicators on the display for each thing, the optos?

#49 3 years ago
Quoted from balboarules:

I thought when you changed the rom, it did a reset, mine always has.

correct, it resets. it reset when i was playing with dip switches, too.

#52 3 years ago
Quoted from bigd1979:

When you put the factory rom back in don a factory reset also . I had a dm that did the exact same thing and it never made any sense lol.

just did a manual reset: no dice. claw goes far right, elevator cycles to the top a few times and quits. like i said, the ball is pushing the claw up a bit at the top, so it's definitely making contact. that's during game play.

#54 3 years ago

no, thanks for the reply. we'll get it figured out that way.

#56 3 years ago

my claw test is t.14. the index is x'd out at the bottom and the hold is x-d as it goes up and down. i don't have to push the buttons on the coin door.

#57 3 years ago

when i run park elevator, it starts with nothing x-d for a fraction of a second then hold lights up as it goes up and down. almost at the end of coming down hold goes off, then index flashes real quick on and off, then the test stops with nothing x-d.

#58 3 years ago

i'm going to try pulling the power/batteries.

#59 3 years ago

left it go over 30 minutes: no dice.

#61 3 years ago

the index x? i only get the index at the bottom. is that the problem?

#63 3 years ago

so anytime the elevator is moving, both should be x-d out at the same time and the entire time it's moving? definitely not happening on mine.

if that's correct, i guess the demo time doesn't check optos like the lx-4.

so any quick fixes or do i need new opto boards?

#67 3 years ago

ill need some detailed instructions/pics for that one.

#71 3 years ago

when i use the park elevator test, i see a quick "index" flash, then "hold" is solid up and down. when it completes, nothing is x-d out. it's not one up, one down, like you were describing.

#72 3 years ago

what i'm working with:

IMAG0057[1]_(resized).jpg

#73 3 years ago

would the fidelity speakers cause a conflict somewhere?

#77 3 years ago

this is what the top ones look like:

IMAG0058[1]_(resized).jpg

#78 3 years ago

i can see a lens on the white one, which is in the back. i can't see a lens on the black one. i cleaned both: same issue.

#79 3 years ago

when i was cleaning the optos, the hold indicator would register on the display.

#81 3 years ago

i think i got the black one.

hold was never on the entire time. let's say the elevator floor is 0% and the top is 100%. the test starts at 0%, and the hold comes on somewhere in the 25-50% range. it stays on solid from there to the top, 100%, and continues as it comes back down, then goes off in the 25-50% range.

if i was misleading you, sorry. this is tough to describe via the internet.

#84 3 years ago

i see the q2 cap now. i tried reseating everything, but that didn't help.

yeah, bob, maybe i'll take you up on that.

#86 3 years ago

nah, i haven't done a lot of networking yet. just got in the pin scene nov/dec. i guess bob will have to find another DM .

#88 3 years ago

is there a way to test the board on my end, maybe with multimeter?

#91 3 years ago

maybe i'll try a new board; doesn't seem unreasonable.

i will say, i notice ghosting from the led's on the williams lx-4 and not on the demo time. so another pro for the demo time, oddly enough...

#94 3 years ago

you mean a set of the latest sound roms or another game rom (home), u6 or whatever it is?

#96 3 years ago

shits and giggles, i threw the demo time back in: claw works, no ghosting.

i don't know, guys, i may take a break from working on this. it's wearing me out, know what i mean? i almost forgot i'm supposed to be playing this thing and having fun.

i don't think i'm giving up. some of the text is screwed up on the demo time and that will drive me nuts. i think i'll eventually order a new driver board. if you guys had to bet on a horse, would that be it you think? bob, you think they'll have those at pinfest?

i definitely appreciate the help and ideas, guys. hope i'm not letting you down.

#98 3 years ago

i can probably hand deliver to bob at pinfest.

#100 3 years ago

that's what i was thinking.

#103 3 years ago

okay, i'll let you guys know. thanks, again.

i'll update the thread after i try anything else, but it could be a week or two.

#104 3 years ago

an idea; i found this:

U6: Version L-3
Changes from revision L-2:
Made the claw smarter about the coin door interlock
switch disabling the magnet. When the coin door is
closed, the game checks to see if it thinks the magnet
is broken, and if so, tries to check it again.

so a theory i have is try an L-2 U6. maybe i just need the "dumber" claw code.

i e-mailed john about possibly getting one.

#106 3 years ago

bottom switch registers. top does not. i assume that's it, right?

i now know how alexander fleming must have felt.

#107 3 years ago

actually, the top button is the interlock. should that show something while in switch test? the bottom one says "coin door closed". like i said, top one doesn't show anything on the display.

#108 3 years ago

man, i hope this is it.

#110 3 years ago

remember, i had what appeared to be an older demo time rom and it didn't work on that one either. so of the 3 game roms i have, i'm 1 for 3.

#111 3 years ago

IMAG0061[1]_(resized).jpg

#112 3 years ago

looks like the interlock has 6 contacts and i'm on 1,3,4,6.

#114 3 years ago

he didn't have any ideas except try another lx4.

#116 3 years ago

i'll order one and see how it goes. i don't mind.

thanks for the help, guys.

#118 3 years ago

new card in: no dice. works with demo time and not the lx-4 :l. i'm depressed.

#119 3 years ago

i was talking to a local guy i just met and he's thinking voltage maybe. not sure i mentioned this before, but i noticed the demo time kicks balls out of the retina scan fairly hard. it will sometimes even hit the slingshot rubber, then bounce directly in the outlane drain. pretty annoying. the lx-4 rom kicks it out way more subtle, and it gracefully drops right into the inlane.

where i'm going with this is maybe the lx-4 is pulsing the magnet with lower voltage, which would work if everything was brand new. not everything is, obviously. most of this thing is still from '94. maybe something somewhere is wore out and when the demo time is in there, giving more volts to everything, it mysteriously works.

meh?

#122 3 years ago

sorry, the driver board.

#123 3 years ago
Quoted from pincredible:

Did u try removing or replacing the batteries?

i pulled them and the power cord for 30 minutes or so once to reset it. didn't try new ones or powering on without batteries.

#125 3 years ago

i get a magnet error when testing.

have not done anything with voltage. have not checked any readings on the claw.

#130 3 years ago
Quoted from johnwartjr:

I'm still willing to send you another one to try... no charge

want to send me one with ghosting patch? if it works, i'll buy it.

#131 3 years ago

elevator slow or noisy... well, i don't have anything to compare to really. it seems okay. it's a consistent pace and the noise is also consistent during the up/down process.

when there's a ball in the elevator, the hold box in test on the display is solid during the entire autorun.

#132 3 years ago

okay, so i almost just passed out.

had her in test mode, ball in elevator, claw max left. i held door close switch and interlock in. ran autorun. f'n magnet fired, picked ball up, moved it to far left and dropped it on the habitrail!

i closed the door. as i did that, i made sure the plate that pushes the door switches in looked like it was lined up. it did. started a game, got one up to the claw and it didn't work.

so it's not working, but i almost feel like it is. excited. what's next, guys?

#133 3 years ago

i'm busting, jerry; i'm busting!

#136 3 years ago

so something is pulling too much juice during game play, cock-blocking (if you will) the magnet? or could it be a weak power supply?

#138 3 years ago

yes. after i started a game and it got stuck, i just went into test mode and got the ball out with that so i didn't have to take the glass off. pretty smart, right?

no, the hold is off at the bottom. i can see that during the run elevator and park elevator test.

#140 3 years ago

correct about 2nd time working, and i think i was just holding in the interlock.

when the elevator is parked, entirely at the bottom, hold x is off.

#142 3 years ago

good idea. i'll try tonight.

#146 3 years ago

holding in the door switches manually during game play does not make a difference.

#147 3 years ago

claw left/right is fine. i just ran the auto run again. claw right highlights as it's picking up the ball, then goes off as soon as it starts moving. claw left pops on when it's far left as it drops the ball off.

#148 3 years ago

i've swapped between roms several times. demo time works every time.

#151 3 years ago

will do. have no clips.

#152 3 years ago

j907-6 and j902-6 both feel solid. didn't see any corrosion on any pins anywhere on the board. fuses checked good; brackets weren't loose. the big capacitors looked good too. there may be some "cold" solders on those. not sure that's the right term. some solders were thin or shallow. i'll take a pic.

almost had a heart attack though. i tried claw during game play: didn't work. went into test mode and it didn't work either. i moved the claw a little to the left, so the claw would move during auto run, then it worked. i'm thinking i probably didn't hit the right combo of maneuvers before we replaced that driver board for it to work in test. highly doubt i needed it. no big deal.

#153 3 years ago

IMAG0067[1]_(resized).jpg

#155 3 years ago

updating the thread, i picked up a HS2 on thursday and just tried the fliptronics board out of that in my DM: no dice. exact same behavior: magnet doesn't fire in-game but everything works fine in test auto run.

#158 3 years ago

swapped ribbon: same thing.

#160 3 years ago

i'm going to try a home rom.

#162 3 years ago

home rom installed today: same behavior...

#164 3 years ago

just the magnet during game play. i can run claw test auto run flawlessly.

#167 3 years ago

i can try the cpu board swap.

2 weeks later
#170 3 years ago

no, i've been dragging my feet, playing around with my HS2, chasing down other pins for the collection. i've just been running the demo time, since i've had some friends over playing.

i'll see if i can do this tonight. nothing on tv anymore anyway.

#172 3 years ago

yep.

#174 3 years ago

ok, i'm going in.

guess i just needed a kick in the butt, huh?

#175 3 years ago

cpu board # is a little different.

HS2: A-12742-50004
DM: A-12742-50028

i know we swapped flipper boards with a little different #. i can swap the cpu boards?

#177 3 years ago

okay. tomorrow, i promise.

#180 3 years ago

i noticed my ribbon cables are a little off from what the cpu board says. the dmd board is patched in where it says i/o (extend), j201, and the aux board runs to the display connector (j204). the manual agrees with how the cables were physically ran, and the length of cables seems to agree, too. i just thought that was weird.

pulling the getaway board out...

#181 3 years ago

DM board:

IMAG0094[1]_(resized).jpg
IMAG0095[1]_(resized).jpg

#182 3 years ago

ew, sorry the foot/sock.

#183 3 years ago

HS2 board:

IMAG0096[1]_(resized).jpg

IMAG0097[1]_(resized).jpg

#184 3 years ago

i still have the getaway flipper board in the DM. does that matter?

#185 3 years ago

uh, yeah. so...it worked. wtf?!!!

#186 3 years ago

can i just keep the boards (flipper/cpu) swapped and forget about it? i'm guessing you guys will say no.

#189 3 years ago

i think it's more relief than excitement. sorry, man .

it was really nice having another pin i could swap boards with. made troubleshooting a breeze. that's probably the biggest lesson here: have multiple, similar system pins in your collection. that and talk to the pinball gurus on pinside. thanks, again, guys.

i'll need some practice before i try adding solder to that board. i was having issues soldering speaker wires to a speaker on the getaway tonight: my first solder attempt ever. i can take a good look at the socket though.

of course, the million dollar question is why was the demo time working?

#192 3 years ago

balboa, you coming to allentown? lunch on me.

#195 3 years ago

i think i'll definitely be there on friday. not sure about saturday. probably just friday.

yeah, i may be able get that board in there tonight and test it.

#198 3 years ago

very nice!

so when i pulled the demo time rom out of the DM cpu board, i noticed a decent amount of scratching on the board under the cpu socket. sorry, should have took a pic, but i was embarrassed since i figured i did that when i originally swapped roms. actually, i don't remember being that aggressive with it. i know i bent some pins not knowing what i was doing, but i really doubt i did that. maybe it was from the previous owner. obviously he played around with roms, too. yeah, we'll blame him/her.

that would do it, right? luckily, it's in my HS2 working; no problems that i can tell. can't really fix that, so i guess if something comes up i'll have to look at new boards.

#200 3 years ago

yeah, i was just playing the lx4 with claw: good times. i can't get the ball to go in the second from the right drop though. i forget which one that is. guess i can put a little pad there to help the ball into that chute.

#204 3 years ago

it's when i try to drop the ball in the "super jets" chute up at the claw. it won't go in there, it just comes over to "prison break". the plastic looks good. the ball needs more coaxing.

it works sometimes, maybe 5-10%. i think if i material to the buttress, if you will, between the chutes, it'll fix it. not sure what to use though, that won't look like hell.

#207 3 years ago

everything with the claw is working. i guess there's something that is a little off as far as fitment maybe.

yeah, i drop the ball on "super jets" and it rolls over to "prison break". rails are under and that switch seems fine to me. i could try flattening it out a bit.

#208 3 years ago

IMAG0099[1]_(resized).jpg

#210 3 years ago

you ready for this?

claw stopped working tonight. same behavior. claw test auto run works flawlessly. in game, magnet won't pick ball up. i thought this was behind us...

#214 3 years ago

btw, i was entertaining guests, so i put demo time back in: worked no problems.

original flipper/cpu boards are in the getaway working no problems.

i'm going to take a pic. my buddy thought the claw was going far enough to the right. it's definitely not directly over the ball. the claw right does light up in test mode, however.

#217 3 years ago

i should be able to get back to it tonight.

#219 3 years ago

i lifted claw up as far as it went, ~20-25 degrees. i'm not seeing any screws. i'll just start tearing it down until i find something.

yeah, i fired it back up with lx4. claw missed first time, then got the ball second attempt, same shot. second time i hit the claw shot, it failed all 3 times. i pulled it out and the claw is getting back to cover about half the ball. the ball is hitting the back edge of the claw.

#220 3 years ago

IMAG0104[1]_(resized).jpg

IMAG0105[1]_(resized).jpg

IMAG0106[1]_(resized).jpg

#221 3 years ago

i don't see any allen screw, boss. there's two holes, but no screws.

#225 3 years ago

no screws on mine. it's not coming off the shaft either. i tried lifting it up a little. i'm lifting the entire playfield.

#227 3 years ago

lol, i got it now. i wasn't thinking the screws were actually down in those holes!

ok, i think i'm good. i loosened those up and moved the claw back over the ball. when i put the longer claw cover screw in, it's lifting the claw up though. how is the wiring supposed to be wrapped around this armature? actually, i took pics! looks like it should be on top. let me try that.

#230 3 years ago

i'm so close!

when i use the far left chute, the front claw arm stops the ball from going down the habitrail. the two screws that hold the cover on: there's a long and a short one, right? when i put the long one in the back hole, closer to the pivot, it lifts the whole arm up. it's so high, the magnet won't grab the ball. i put the short one in the back, but now i get that claw arm stopping the ball on the far left.

ahhhh! we figured out the problem, but i just can't get this f'n plastic on right.

#231 3 years ago

ok, i got it. i put the long one in the back and just used that to lift it up enough to fix my problem. it's not flush with the plastic cover, but i really could care less at this point.

DEMOLITION MAN IN THE F'N HOOOUUUSE!!!!!

#232 3 years ago

IMAG0108[1]_(resized).jpg
ADIOS, BITCH!

i really feel like doing some unspeakable things to that thing. if i didn't have that, we would have figured this out a month ago, at least?

#233 3 years ago

see, this is why i didn't get too excited after we swapped the cpu board and it worked for a few days. i didn't really understand why i wasn't happier, too. it was my sixth sense, i suppose.

#236 3 years ago

the williams light show is so much more exciting. when i put the demo time in, i fall asleep. the ball is rolling around, hitting things, and the lights aren't doing anything.

#239 3 years ago

i still have one incandescent flasher that i can't get to. flasher 21, side ramp i think. looks like i have to pull half the playfield apart to get to it. you can see the warm white light when it fires, too. pretty annoying.

also, the cars in my car crash ramp are backwards. i have to crack that open and switch them. oh yeah, and i want to replace the black eyeball in mine. i bought a normal white one.

so i'm not done, but getting closer.

#241 3 years ago

that flasher is actually under stuff on the underside, too. i got every bulb in the thing except that one.

#243 3 years ago

yes, sir. thanks, again.

Promoted items from the Pinside Marketplace
$ 135.00
Lighting - Led
LED OCD
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 18.95
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer

You're currently viewing posts by Pinsider weaverj.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside