(Topic ID: 151956)

Back To Factory ROM's From Demo Time; Claw Won't Work


By weaverj

3 years ago



Topic Stats

  • 247 posts
  • 15 Pinsiders participating
  • Latest reply 3 years ago by AKWhitey
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 16 images uploaded to this topic. (View topic image gallery).

IMAG0108[1]_(resized).jpg
DSC02203_(resized).JPG
IMAG0106[1]_(resized).jpg
IMAG0105[1]_(resized).jpg
IMAG0104[1]_(resized).jpg
images-6_(resized).jpg
DSC02200_(resized).JPG
IMAG0099[1]_(resized).jpg
IMAG0097[1]_(resized).jpg
IMAG0096[1]_(resized).jpg
IMAG0095[1]_(resized).jpg
IMAG0094[1]_(resized).jpg
IMAG0067[1]_(resized).jpg
IMAG0061[1]_(resized).jpg
IMAG0058[1]_(resized).jpg
IMAG0057[1]_(resized).jpg

You're currently viewing posts by Pinsider balboarules.
Click here to go back to viewing the entire thread.

#12 3 years ago

Your sound roms should be fine, John can make you the correct CPU rom, I have been using him for about 14 years, and he is fantastic. I would just order the cpu rom from John, and see how that goes. Demo time was a custom made rom for the game, I bought it, personally I did not care for it much and quickly went back to the original rom, not sure what others thought of it, I give them credit for being able to make it, must have been a ton of work.

#13 3 years ago

And make sure he sends you the CPU rom for the adult language, funny stuff in there!

#21 3 years ago

If you get the adult rom from John, you have the option in the settings to turn off the adult language.

1 week later
#25 3 years ago

The claw should move to the right, the elevator comes up and down and the claw then goes back to the far left, it should be doing that each time you turn the game on.

If you know how to go into the test menu, I believe option 16 is the claw test, and you can move the claw, run the elevator...etc..

When you say the claw does not work, what exactly is not working about it?

#27 3 years ago

Ok, so when you place a ball in the elevator the claw does not pick it up?

#29 3 years ago

Not that I am aware of, Is the elevator bringing the ball all the way to the top of the crane arm? I would take off the cover off the crane, check the wires to the magnet, make sure they are ok, then do a fuse check. In the claw test, option 16, one of the options is magnet test, I might take 2 people, but run the magnet test with a ball right under it, and see if it works in test mode. Remember to push in the 2 side buttons inside the cabinet so the game thinks the door is closed.

#30 3 years ago

Also make sure the claw cover in not too far down so it is blocking the path to the magnet. When you take the claw cover off, you can test it with the cover off.

#33 3 years ago

No, that should not be the case at all, if anything the factory roms should make the functions work better..

Go through every fuse in the head, make sure you are not just looking at them, but testing them with a meter, I am wondering if you did something when you had all the roms in upside down and turned the game on. Check out fuse F104 and F105 first. The connector for the magnet is J907-6. I would open the backbox and check those fuses, and also pull off that connector and put it back on then test it again..

#34 3 years ago

Also, make sure your dip switches are all set to on.

#35 3 years ago

The fuses you want to check are f103, f104, f105 and F112, F113

#39 3 years ago

They should all be flipped to on for US, Did you test the fuses with a meter? Did you take the cover off the claw and see if any wires were loose?

#43 3 years ago

Opto's would affect the claw movement, not the magnet. I am going to dig into my game and see what else I can find that would possibly cause this error. Just curious, did you test the opto's in the elevator? Easy to check, just put the game is test mode, and put your finger in to break the beam, I do not remember if there was another set of them in the elevator shaft, I know there is an opto board at the bottom of the elevator, but that would not play into this.. Try testing the optos, maybe they are failing and they have something to do with activating the magnet in the claw.

#46 3 years ago

When the claw goes to the far right to get the ball, the elevator sends the ball up to the claw, inside that elevator area towards the top there are 2 opto's one on each side, that tell the game the ball is in the elevator, if the opto's in that elevator lift area are not working, the machine could be assuming there is no ball in the elevator, and not turning on the magnet in the claw.

#47 3 years ago

I thought when you changed the rom, it did a reset, mine always has.

#55 3 years ago

Go to tests in your game menu, then go to T.16 test claw, the 3rd option is run elevator, on the right hand side of the display there are 2 options elev. index, and elev. hold. Make sure you push the 2 white buttons on the inside of the cabinet in before you run the test, or it will due nothing. I want to see if both sets of opto's are registering, they will put an X in the box each time the elevator goes up and down.

If these are working, the next thing I would try would be to put the new rom in (which I figure it is in), pull the battery's unplug the game for 15 min or so to wipe everything out, then put the batteries back in, plug it in and see if that helps. The coding in that rom could have bypassed the opto's on the elevator and just made the magnet go everytime it go to the ball... Just a theory as I know nothing about code.

#60 3 years ago

Ok, but can you run the test and have the elevator keep going up and down, just hold the run test button.. You may have some dirty opto's here

The elevator should keep going up and down, and the x will appear when the elevator is at the top and when it is at the bottom.

#62 3 years ago

Yes, when you run the elevator you see on the right hand side of the screen and elev index and a elev hold. As that elevator is going up and down they should be going x and x in the boxes as the elevator goes up and down. If you hold the button down the start the test, the elevator will keep going up and down

#64 3 years ago

No, sorry if you read it that way... only 1 should be x-ed out.. As the elevator goes up and down, you should see them both blank for certain periods, and up should x out 1 and down should x out the other....... As I had mentioned before, hold down the run elevator button and let the elevator go up and down several times, and as it goes up and down you should see an x on the top and then an x on the bottom, but it should never have both on.. There are 2 sets of opto's on this game, one at the top of the elevator and one under the elevator.

If you are seeing both working when you run the elevator, then you know the optos are good. If that is the case, I have only one idea left for you to try...

#66 3 years ago

Butch, my last thought is a bad driver transistor... now the reason I am thinking this might be possible, when the demotime code was written, it is possible that it was set up to use a different drive transistor.. I was also thinking that code might have been written to bypass the opto's on the elevator, which is why I wanted him to check those out.

What I was going to do was look up the drive transistor specifically for that magnet coil, and have him put an alligator wire clip to the transistor and touch the other end to a ground, while having a ball right near the magnet, to see if that triggers the magnet... it is the only thing I can possibly think of at this point.

#68 3 years ago

How did you make out running the elevator?

#69 3 years ago

The drive transistor is Q2

#70 3 years ago

Q2 is located on the Aux driver board, it is a 2n4403, however this style cannot be tested the way I was thinking. Butch, if your reading this, how would he go about testing Q2? At this point, I would personally just change it.

The board is a small board to the far right it is an aux driver board, a-16100-2

#74 3 years ago

Ok, there is something flaky with those opto's. First thing to do, take off the glass, look inside the elevator, you will see the 2 opto's at the top, get a q-tip and clean both of them.

The other opto's are only accessible from the bottom of the playfield. you will see a connector going to a board on the elevator, see if you can unplug it, and plug it back in, if the elevator is UP and you look at it from the correct angle, you can see the 2 opto's that the connector is connected to, these are different opto's they are black and look like a u only not curved at the bottom, if you take another q tip, you can get inside of them and clean those as well, windex or rubbing alcohol will work for the cleaning, just wet the tip of the q tip.

If you want to pre test the top opto's put the game in switch test, make sure the elevator is down, and just by putting your finger in the elevator shaft should break the beam and show up on the dmd.

Hold should NOT be solid the entire time, just when the elevator is at the top.

#75 3 years ago

The speakers would not. Try the opto thing I just posted, there is an issue there, that hold should NOT be locked on like that.

#76 3 years ago

I think your bottom opto's are fine, when you turn the game on and the claw does it thing, then go into test mode, neither is x'ed out. The index is the bottom opto board, the hold are the 2 optos on the top, I think your problem is there.

#80 3 years ago

Ok, so how about when you run the elevator test. Does it still say x on the hold indicator the whole time? Were you able to get to the black one?

#82 3 years ago

Ok, I understand.. Well, if the elevator opto's are working, the only think left I can think of is the Aux driver board I mentioned earlier. It is possible the Demotime software used a different driver to run the magnet, I honestly cannot think of anything else. The top upper right corner there is a small board, I mentioned the number in a previous post. I can only guess something is wrong with that board or just the Q2 that drives it... It is a tiny black cap with 3 legs on it and on the circuit board it is labeled Q2. You could email the guy who wrote that code and ask him if he is aware of any driver differences with the code he wrote. Last thing you could try, unplug each connector to that board, and plug them right back in.. sometimes over time connectors need that, I would also reseat all the ribbon cables, or if they are originals replace them.. I just cannot think of anything else other than that Q2.

Hope you figure it out, I thought we had a shot with the elevator opto's, but guess that is not the case.

#85 3 years ago

I think that is the best way, is to have that board checked, Like I had said, this is just a theory, I know NOTHING about coding, so I have no idea whether or not changes were made in that code for the operation of the magnet, but at this point I cannot think of anything else, the part that throws me is that it works with demo time code.. Which is why I am thinking something in that code may have used a different driver. Do you happen to know anyone in the area with a demo man who would let you bring that one board over and try it in their game?

#90 3 years ago

Same here, not the right guy.. BUT I do have a Demo man here, so if you wanted to send it to me to test it, I can do that for you. If it is the driver transistor I can swap that out.

#93 3 years ago

I have the home rom in my game and I have no issues with ghosting at all. You had mentioned 9 roms for sound, I would try ordering the home rom from John W. Cost is low enough, and you can disable the adult language in the settings. And who knows, maybe it will fix the claw at the same time.. cheap enough that it is worth a shot.

#95 3 years ago

Just another CPU rom, not all the sound roms.. Just email John and mention you want the HOME rom for Demo man. In the adjustments you can turn off adult language, also I have NO ghosting with that rom. Try that first, if it does not fix the claw, as I mentioned you can send me the board to test it, before you lay out the money for a new board.

#97 3 years ago

Try the home rom from John first. Send the driver board to Bob or myself.. Personally I would rather know the board is bad than to spend the money on another board to find out the board is not bad...

#101 3 years ago

Nope, it never hurts to have extra's, I am trying to keep any extra boards I end up with for whatever reason, too many times I needed a board I had, sold it for less than it costs, and had to spend more to replace it. Hell, if you replace it, I will buy it myself.

#102 3 years ago

https://ksarcade.net/rottendog-8-driver-for-wpc-a-16100-01-wdb008.html

At least if you do want to try this route, the board is cheap enough.. if you wanted to split it, I would give you 20 for yours and you could by this one for 40

#105 3 years ago

Worth a shot, have you switch tested your coin door switch by chance? In switch test you just press in the button, just curious if that is working.

#109 3 years ago

Are there wires connected to the top one? I just checked mine, the top one does nothing in switch test, only the bottom. Did you order the rom yet? I still think your best bet is that replacement board from K's arcade, I honestly still think the software is the only thing left that makes any sense as to why it works with demotime but not the current rom.

#115 3 years ago

I just do not think it is the rom... if it was only not working with LX4, then sure, but you say you have 3 roms now, and only 1 works. I still think the problem is in that aux driver board. My offer to split the cost of the new one with you stands, I can shoot you 20 paypal as a gift, you order the new one from K's and send me the old one.

#117 3 years ago

Let us know how it goes

#121 3 years ago

What do you mean by new card?

#124 3 years ago

So, with any other rom, except that Demo Time that does make the claw work, if you go into claw test, does the magnet work at all? If you were to hold the ball there would it be held at all or is it just nothing at all?

Have you done any voltage checks yet, there are several test points on the driver board where you can measure.

#126 3 years ago

Ok, so it say's magnet error when you go into the claw test menu. And you put a new aux driver board into the game already.. Ok, time for some research, let me dig around.

#127 3 years ago

Found an old post that mentioned the same problem, turned out this board was bad http://www.marcospecialties.com/pinball-parts/04-12330.. there was also mention of the elevator not moving up and down properly, do you find your elevator is slow or hear any scraping or grinding noise?

#128 3 years ago

Going through the manual, magnet error

This message is displayed when the game is unable to pick up the ball from the elevator platform with the claw magnet, this can be caused my a defective magnet in the claw arm, or the elevator hold switch being broken.

We may have covered this, but when you run the claw test, does the elevator hold box have an x in it when the claw is trying to pick up the ball?

#137 3 years ago

Ok, so in a test run it worked, when you started the game it did not. Did you try the test again with you holding in the button? Also, when you say the hold is always on when the ball is in the elevator, you don't mean even when it is at the bottom as well do you?

#139 3 years ago

Ok, so you went into test mode and got the ball out, so it worked 2 times in test mode? When your running test mode, are you holding in the button on the left side of the coin door, the white door button, or not holding it in?

And when the elevator is down, the hold x is not still on right?

#141 3 years ago

Ok, now this is a longshot but I am curious, take the glass off, keep the coin door open, hold in the white cabinet switch and start a game, just roll the ball down the cryo claw inlane to start it, then roll the ball up to the elevator, If it works in test this way, I want to see if it works during gameplay this way.

#143 3 years ago

Great, post the results.

#145 3 years ago

The opto board controls the left and right movement of the claw itself, I agree that replacement is a better option than the original, I bought one myself, and they will soon have the one for the bottom of the elevator shaft, I had sent them my old one which was not working, and just received the new version.

He has never mentioned any issues with the left and right movement, and we have gone though the test options and both left and right do register.. I really thought there was an issue with the Aux board that controls the magnet, but a new one was installed.. This claw working in test mode is new, now it may have to do with the new board he installed, not sure... still going though it.

When he checks in later, will have him double check the left and right movement in test mode again, to make sure they are both registering. Usually you get a claw out of range error message though, and he has not gotten that.

#149 3 years ago

Yet it works in test mode... Ok, the mystery continues...I will dig around some more, going to see exactly where the voltage for the magnet comes from.

#150 3 years ago

Ok, new thing to check, on the fliptronic board, J-907-6 is a red violet colored wire, this is voltage to the claw magnet, J-902-6 is a yellow violet wire again on the fliptronic board.. Check both of these connectors and make sure the wires are in tight, check the pins on the board for any corrosion, and recheck all 4 fuses on that board..

Do you have an Alligator wire clip, a wire with alligator clips on both sides?

On that fliptronic board Q2 is the big tip 36C, there are 4 of them in a row..

This board is in the top left hand corner. Also, pull the ribbon cable coming from the CPU to the fliptronics board off and double check the pins, make sure not a single one is bent

#154 3 years ago

Ok going to send you a PM

#156 3 years ago

Try using the ribbon cable out of the Getaway, it is the one with the 4 connection points.

#159 3 years ago

Yeah, take John up on the new rom at this point.. Other than that you could have a bad CPU chip socket.. I cannot think of anything else.

#161 3 years ago

Cannot hurt to try.

#165 3 years ago

Well, you have tried new boards, different ribbon cables, different roms, and we know the magnet is good... I am now officially stumped. The only possible thing I can think of is the socket the rom goes into... could be a scratched trace under it, I would take out the CPU, remove the rom and take a good look at the socket.. I think your Getaway uses the same MPU board... just for the sake of ruling it out, try the CPU from Getaway in Demo with the new rom you got.. If that does not do it, I am out of ideas...

#166 3 years ago

Also check all the solder on the back of the CPU, see if anything looks suspicious, any solder joints that look questionable.. Switching the CPU board should be the next step, could be a bad pin going to the driver board, could be a bad rom socket, last thing I can suggest.

#168 3 years ago

It is all I have left in my bag of tricks.. I cannot imagine what else it could be... the real stumper in this is the fact the magnet works with that one rom, but not an original rom... so weird. At least the CPU is easy to swap.

2 weeks later
#171 3 years ago

Going to try the CPU swap?

#173 3 years ago

Please post how it goes, I have been with you alongside for a while on this one...

#176 3 years ago

You should be fine.

#179 3 years ago

Sonny

In a previous post, I had mentioned the same thing about the code, and that the OP contact the guy who made the code and check with him in reference to whether or not that was the case. He has no failed opto's we went down that road, he swapped the aux driver board and the fliptronic board, new ribbon cables, check all fuses, and we know the wires are good to the magnet as it works with the demo time code.. my last thought was a problem on the CPU board, specifically the socket he has pulled the rom from several times and tried other roms, my last suggestion was to try the CPU from Getaway. We pretty much have gone though everything, including several roms...

#187 3 years ago

HA!!!!!!!!!!! Finally!!!!!!!!!!!!!!!!!!! You can put the board in your getaway and see if you encounter any issues with the Getaway, if everything works then you are fine. Really go though the Getaway, test solenoids, switches, etc.. everything..

I thought you would be more excited to see it work?

#188 3 years ago

Your demo man board has 3 holes where the chip is installed that look like then need more solder, if you look at the bottom side of the chip socket, you can see on the far left there is 1 that looks like it needs some, the next looks good and the last 2 look like they need some.. also check each pin the chip goes into, sometimes one of those gets corroded, or bent. As far as the ribbon cables they are fine that way

#191 3 years ago

Thank you cosmo, I appreciate that!

Demo man was working because the code was set up different on that Demo time code, as I stated before, I am sure the code was set up differently than the original code to make the claw work it may have used a different pin to control the claw or something, in your case, something is wrong with the CPU board, I still think that socket, but I could be wrong... do not attempt to solder yourself after what you mentioned, send the CPU board to John Wart, or Chris Hibbler, or K's arcade or Boryguard, or coin op cauldron or anyone else who does board repair, you need that CPU checked out. If you don't want to go that route, check out K's arcade for a replacement rottendog board for 179, the repair would be cheaper and the better way to go..

Again, NOT THE BOARD FOR YOU TO SOLDER if that was your first time soldering, send it out, get it done right!!

#193 3 years ago

I am seriously considering going to Allentown, trying to find someone to go with me, I hate making that drive alone. What days are you going?

#194 3 years ago

I know pinfest the show near me had a great board repair guy there doing repairs at the show, does Allentown have someone doing board repairs there? If so, you could bring your CPU there. But like I had mentioned you could try it in Getaway and see if everything works.

#196 3 years ago

If I go, I would go Fri as well, want to get there when there is more stuff available.

#197 3 years ago

Looks like I will be there Fri... as long as my buddy does not bail out on me!

#199 3 years ago

Hey, if it works, it works. Just go and do a solenoid test on Getaway, and see if all work, if they do, you should still be good. Yes, that would do it, it does not take much to ruin a trace like that. But perhaps you will get lucky and that pin will not be a factor on Getaway...

I am pretty sure it can be fixed if it comes to it, you will not end up buying a new board. But let's hope is just works perfect in Getaway, and you can relax and play them!

At least the Demo mystery is SOLVED... that is HUGE!

#201 3 years ago

Can you take a picture of what your talking about

#203 3 years ago

My buddy Dave said he will go with me, so I will be there on Fri.

#205 3 years ago

Are you saying the claw will not drop it in that spot, and drops it in prison break, or are you saying it drops on prison break but ends up rolling over to the next chute?

#206 3 years ago

If your saying the the second part of my question, make sure the rails are inserted UNDER the plastic, and check the switch to make sure it does down easy with no resistance, switch could be too high, or the rails could be on TOP of the plastic instead of under where they belong.

#209 3 years ago

It looks to me like the right side of it has a small crack, it also looks like the ball rail is sticking on a upward angle on the right, that should be lower, ball may be dropping and hitting that and sending it over the the left.

DSC02200_(resized).JPG

#213 3 years ago
Quoted from weaverj:

you ready for this?
claw stopped working tonight. same behavior. claw test auto run works flawlessly. in game, magnet won't pick ball up. i thought this was behind us...

You have got to be kidding me... I just spend yesterday tearing down my Demo man to put the new playfield protector, I am doing all my games with them, I had a few tiny kinks that I worked out.. On to your issue, so you are using the CPU out of Getaway now right? Last you had mentioned you were going to put the other board in Getaway and see if it worked ok like that, is this still the case?

Check all your fuses, ribbon cables, etc.. Then try a full game reset, take out the batteries and unplug it for a half hour or so, Now this is in creepy vill, how the hell could the same problem come back.. Did you happen to do anything to the game at all?

#215 3 years ago

Should be over the ball, no question there

#216 3 years ago

Your arm could need an adjustment, if you lift the arm with the cover on it, you will see a metal "box" that attaches to the post, it has an allen screw on it, you can loosen this screw and adjust it so the claw goes further right before it hits the opto sensor on the bottom, perhaps if it is not going all the way right, that is your issue.. Try my above steps first, if that does nothing, try what I suggested in this message.

#218 3 years ago

Keep me posted, I believe the allen screw is on the back, when you lift the arm, you should see it, a small metal block coming from the shaft under the playfield.

#222 3 years ago

Ok, you see that metal block? on the back side is there 2 holes there? Should have an allen head in one of them to lock the claw in place

#223 3 years ago

Should be here

DSC02203_(resized).JPG

#224 3 years ago

There should actually be 2 screws, parts number 4010-01169-04 Mach. Screw, 10-32 x 1/4 SH-CP-N

These screws are what holds the metal base to the shaft.

What you would do in this case is loosen the 2 screws on the back, then move the block a few inches to the right to line up the claw head so it goes right over the ball, the optos on the bottom would not be effected this way.. The allen heads could be tiny and inside to the point where you cannot see them, they are not always sticking out, the picture I posted is my spare block I have, and I can see the threading inside the hole, otherwise you block would not be attached to the motor shaft coming up to the arm.. Try looking with a flashlight, or take an allenhead wrench and put it in the hole, if both are missing, I do not know what would be holding the block to the shaft.

#226 3 years ago

If you hold the shaft with pliers, can you turn the block? Something has to be holding that block on the shaft, should be 2 screws.

#228 3 years ago

I put 2 washers to raise the fron of the claw cover, they put the screws in, the two washers went over the hole closest to the magnet

#229 3 years ago

Test the claw with the cover off, see if that did it.

#234 3 years ago

Thank you pinball gods, I feel like I just gave birth! I think on mine you can see the magnet too, but don't care as it picks it up every time.. Please let this now and forever be solved!

#235 3 years ago

You do whatever you like to that rom, I appreciate the hard work that went into it, but did not enjoy the changes that were made.. I still have it, but it will not be going back in!

#238 3 years ago

Thank you nerbflong, I have received a lot of help over the years, I know this game well, so I am just glad I was able to help, and now it sounds like we are home! I have the adult home roms in my game, love those, has a few different sayings, and some adult language, especially when you tilt it! It is my favorite game of them all..

#240 3 years ago

Getting to those cars is not that easy.. The bulb you can get from the bottom of the playfield, all the bulbs are held in place with one screw in the socket, so that is easy... to get to the cars, you pretty much have to take off the left wireform ramp, Now this is tricky because one of the nuts holding it on, is right in the middle of a long plastic, you want to be careful, loosen up the screws, then gently lift it to get to that nut.. You cannot access the other screws on that plastic till you take away the ramp, just be careful not to lift it too much or it will snap! If you have a skinny 1/4 inch extender with a magnetic head, this would be the time to use it, if you don't have a 1/4 nut driver and this extension, get them first.. trust me on this.. I have shopped/restored about 14 Demo man's..

#242 3 years ago

Well, your done with the problem that was driving us both insane... That was the big one!

#244 3 years ago

You are welcome, enjoy your game FINALLY!

#246 3 years ago

The claw runs on an opto board, there is one under the crane, and another under the playfield, check the connection under the playfield, you could have a loose wire on the connector, if you lift the playfield, you will see the board mounted towards the back end of the playfiled, there is a small connector going to the board, I had a loose wire in the housing, and it caused problems. The other thing to do, it to remove the cover to the claw and get to the opto board and clean the opto's, over the years it gets dirty in there.. q tip and rubbing alcohol or windex will do.

If the issue is in the trough, take out the balls and do a though test under switch test, a small flat head screwdriver will fit into the opening, and you can see if all the opto's are registering on switch test, if the boards are original it is not uncommon for those to fail after all these years, and you can also try cleaning both boards as well, same thing with q tip and windex. Worst case order new opto boards for the trough

Seems odd that happened after you changed that chip, did any of the traces get damaged when you did it? Are all the chip pins secure in the socket?

Promoted items from the Pinside Marketplace
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer
$ 99.00
Gameroom - Decorations
Pinball Sales
$ 10.00
Playfield - Decals
Metal-Mods
From: $ 233.10

You're currently viewing posts by Pinsider balboarules.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside