(Topic ID: 151956)

Back To Factory ROM's From Demo Time; Claw Won't Work


By weaverj

3 years ago



Topic Stats

  • 247 posts
  • 15 Pinsiders participating
  • Latest reply 3 years ago by AKWhitey
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 16 images uploaded to this topic. (View topic image gallery).

IMAG0108[1]_(resized).jpg
DSC02203_(resized).JPG
IMAG0106[1]_(resized).jpg
IMAG0105[1]_(resized).jpg
IMAG0104[1]_(resized).jpg
images-6_(resized).jpg
DSC02200_(resized).JPG
IMAG0099[1]_(resized).jpg
IMAG0097[1]_(resized).jpg
IMAG0096[1]_(resized).jpg
IMAG0095[1]_(resized).jpg
IMAG0094[1]_(resized).jpg
IMAG0067[1]_(resized).jpg
IMAG0061[1]_(resized).jpg
IMAG0058[1]_(resized).jpg
IMAG0057[1]_(resized).jpg

There are 247 posts in this topic. You are on page 1 of 5.
#1 3 years ago

picked up a DM wednesday night. demo time is installed and i was told that i have all the originals, too. is there a quick layout of which roms go where? i wouldn't think it'd be that hard, right?

update: factory lx-4 is installed now, but the claw won't work: magnet error.

final update (i hope): turns out there are scratches on the cpu board under the game rom socket. this is probably from the previous owner rough-housin' when swapping roms. hindsight is 20/20, but it actually makes a lot of sense now.

every once in awhile i think i could have done this. i really don't think so, however. i got good fairly quickly at using a flathead screw driver to delicately pry the game rom off the board. my cpu board is really scratched up. someone messed this up many times. here's how to do it right:

you wedge the head in on one side. you don't need to stick it in far; maybe 1/8 inch. then you rotate the head back and forth a little bit. just enough to get the pins popping on that side a little. now you have a little more space to stick the screwdriver in further. you can go about 1/4-1/2 inch in. repeat the head rotation step and you'll be good to go about an inch or maybe the whole way. the most important thing is make sure you're as parallel with the board as possible, or you could develop scratches on the board like mine had. once you have the screw driver behind the entire game rom, rotate back and forth until the rom is completely loose. it doesn't take much effort at that point. good luck.

final update 2.0: it wasn't the cpu board, scratches and all. the claw wasn't getting far enough back over the elevator to pick the ball up. it would work with the demo time rom, since there's less light show on that rom. this is what i'm thinking anyway. less lights means more juice for the claw magnet. it could pick the ball up with the extra juice even though it wasn't directly over it.

figured this out when a buddy was over playing and it stopped working. yeah, it worked with lx4 for a few days after the cpu board swap. so weird. he was standing at the side and said it looked like the claw wasn't back far enough. i never noticed because i was always testing the game from the front of the machine, and again, it worked with the f'n demo time rom every single time.

well, i think this is it, guys. thanks for all the help the past 2 months. i owe some food and drink at allentown, that's for sure. now i can actual play this thing without any worries about if the damn claw is going to work. gotta work on those scorezzz!

#2 3 years ago

looks like there's 8 sound roms (u2-9) i only have the factory U2-7. dumb question: i need 8 originals, right? unless factory only had 6 with 2 expansion sockets on the system board.

also, i have a rom with a label on it that says "dm lx4". any ideas on that one?

#3 3 years ago
Quoted from weaverj:

looks like there's 8 sound roms (u2-9) i only have the factory U2-7. dumb question: i need 8 originals, right? unless factory only had 6 with 2 expansion sockets on the system board.
also, i have a rom with a label on it that says "dm lx4". any ideas on that one?

The DM LX4 might be Version L4 with the LED anti-ghosting patch performed to it. I think that's how they suggested renaming them when you run the patch and make your own rom image. It would be the main Game Rom on the WPC board.

#4 3 years ago

interesting. i received that one loose. looks like the main game rom just says "DTIME 1.01".

#5 3 years ago

think you're right about the LX4:

ebay.com link » Demolition Man Demo Man Pinball Chip Lx 4 Upgrade

also, this says there was 2 more sound roms added:

ebay.com link » Demolition Man Demo Man Pinball Cpu Sound Set Profanity Home Roms

i could just pop these in and see what happens, right? are these just like pulling batteries? i don't need any gel, glue or anything?

#6 3 years ago

Well, a bit more delicate than swapping out batteries.

You need to pay close attention to where Pin #1 is or at least recognize the notch in both the top edge of the chip, as well as the socket. Do NOT use direction of printing on the labels to determine which end goes where!!!!

You need to observe proper anti-static handling procedures so you don't either zap the EPROMs or any parts on the main MPU board.

And, you need to pay close attention to not bending any legs under as you only get so many "Bend backs" until they break off.

But most importantly, you need to make sure you don't go digging in with a flat head screw driver and have the tip hit traces under the socket. This is the most common mistake beginners make when trying to remove EPROMs from their sockets. If you are not using some kind of a chip puller, then with a flat head screw driver, make sure you gently pry between the chip and the socket (NOT the socket and the board) and as you push in, keep the screw driver parallel to the PCB so as not to be pointing down to slip and dig into the board below the socket. When you manage to get the screw driver between the chip and the socket, twist the screw driver to bring that end of the chip up a bit. Move to the other end of the EPROM and repeat. Go back and forth so you keep the end pins straight and not have to bend them back because you pried the chip up about 45 degrees before you lifted it out.

#7 3 years ago

so i tested that lx4 rom and it looks like an older demo time release, r01? that stinks. looks like i have no williams game rom...

another dumb q: do i need to put the demo time sound roms in or can i use the factory u2-7? will the dt sound roms, u2-9, work with a factory game rom?

#8 3 years ago

i didn't see your post in time, so i free-balled it. yeah, that first chip pull was ugly; pulled it by hand :l. got lucky it wasn't worse. i quickly learned the flathead method myself.

#9 3 years ago

LX4 is the latest, original factory ROM revision

The 'X' refers to Export.

Originally, WMS released games with ROMs for multiple markets. LA4 would be American, LG4 would be German, etc.

When the internet became popular, and people started to want to download the ROMs, WMS made the eXport ROMS available for download, as opposed to each and every language. The X ROMs have all coinages, etc in them.

Originally, DM had sound ROMs in U2-U7. U8 and U9 were EMPTY. When the DM 'home' ROMs were leaked (the ones with swearing), the used U8 and U9 as well, and supposedly the audio quality is better as it uses less compression than the original factory ROMs.

I thought the custom ROMs used the factory sound ROMs, but I could be wrong. I didn't think there were special 'demolition time' sound ROMs.

#10 3 years ago

i think i just emailed you through ebay .

okay, so maybe i have the curse roms. they're home-made labeled dm 2-9. they don't say dt, dtime or anything.

the lx4 game rom comes up saying freewpc demolition time r01. is it just mislabeled?

#11 3 years ago

came installed: DTIME 1.01
came installed: 9 sound roms labeled DM 2-9
came loose: DM LX4 (tested this one; looks like an earlier Demo Time, r01)
came loose: L1 U2-7 sound roms

#12 3 years ago

Your sound roms should be fine, John can make you the correct CPU rom, I have been using him for about 14 years, and he is fantastic. I would just order the cpu rom from John, and see how that goes. Demo time was a custom made rom for the game, I bought it, personally I did not care for it much and quickly went back to the original rom, not sure what others thought of it, I give them credit for being able to make it, must have been a ton of work.

#13 3 years ago

And make sure he sends you the CPU rom for the adult language, funny stuff in there!

#14 3 years ago

i need the pg rom .

so i can just pull the dm8 and 9 sound roms to take the cursing out? i actually don't think i've heard any yet.

#15 3 years ago

Negatory, the U2-U9 for the 'adult' speech are completely different than the regular ROMs - you don't just pull the last 2.

Odds are, the L-1 U2-U7 sound ROMs are all you need for the sound
And the LX4 CPU ROM is what you need in the CPU board

Odds are, you have what you need.

If the one labeled LX4 isn't really LX4, then all you'd need is the LX4 CPU ROM.

#16 3 years ago

well, i got nothing now. i put it back to dtime 1.01 game and the u2-9, and it powers on with no bulbs and no dmd. kill myself.

#17 3 years ago

ok, it's back up. i pulled all the sound roms, u2-9, and the dtime 1.01 is booting up now. why would that happen?

#18 3 years ago

checking a picture archive from the previous owner, i had them in upside down...

#19 3 years ago

newbie alert!

#20 3 years ago

so i tried the lx4 rom and the claw doesn't pick the balls up. put the dt 1.01 in and it worked.

will the demo time game rom work with the factory sound u2-7?

#21 3 years ago

If you get the adult rom from John, you have the option in the settings to turn off the adult language.

#22 3 years ago

yep, i discovered that, along with the knocker disable, which i like.

thanks for your help, guys. i just ordered a real lx4 from pinball place.

1 week later
#23 3 years ago

got the lx-4 installed. i like it except the claw doesn't work...

why would my claw work with demo time, but not a williams rom?

#24 3 years ago

You don't want the claw to work anyway, so don't worry about it. (I'm not kidding, the game is way more fun with the claw disabled.)

More seriously, have you checked the operation in the test mode?

#25 3 years ago

The claw should move to the right, the elevator comes up and down and the claw then goes back to the far left, it should be doing that each time you turn the game on.

If you know how to go into the test menu, I believe option 16 is the claw test, and you can move the claw, run the elevator...etc..

When you say the claw does not work, what exactly is not working about it?

#26 3 years ago

sorry, i could have specified. i get a magnet error. all motors appear to be working.

#27 3 years ago

Ok, so when you place a ball in the elevator the claw does not pick it up?

#28 3 years ago

you got it.

like i said, with the demo time rom, it works fine. is there a "fix" or something in the demo time?

#29 3 years ago

Not that I am aware of, Is the elevator bringing the ball all the way to the top of the crane arm? I would take off the cover off the crane, check the wires to the magnet, make sure they are ok, then do a fuse check. In the claw test, option 16, one of the options is magnet test, I might take 2 people, but run the magnet test with a ball right under it, and see if it works in test mode. Remember to push in the 2 side buttons inside the cabinet so the game thinks the door is closed.

#30 3 years ago

Also make sure the claw cover in not too far down so it is blocking the path to the magnet. When you take the claw cover off, you can test it with the cover off.

#31 3 years ago

elevator is bringing it up. i can see the claw getting pushed up with the ball at the top of the elevator.

i tried the magnet test while holding a ball right under the claw, and it doesn't pick it up. ball is definitely in contact with the magnet, too.

#32 3 years ago

not sure it'll help, but the older demo time i have, r01, the magnet doesn't pick up on that either. it only works with the 1.01.

i feel like there is more lenient claw code on the demo time 1.01 rom or something. like it will work without everything begin perfect. the williams lx-4 is more anal. am i crazy?

#33 3 years ago

No, that should not be the case at all, if anything the factory roms should make the functions work better..

Go through every fuse in the head, make sure you are not just looking at them, but testing them with a meter, I am wondering if you did something when you had all the roms in upside down and turned the game on. Check out fuse F104 and F105 first. The connector for the magnet is J907-6. I would open the backbox and check those fuses, and also pull off that connector and put it back on then test it again..

#34 3 years ago

Also, make sure your dip switches are all set to on.

#35 3 years ago

The fuses you want to check are f103, f104, f105 and F112, F113

#36 3 years ago

yeah, maybe the lx-4 is checking something the demo time isn't. didn't think about it going the other way around.

i should be able to get to those things tomorrow. thanks a lot.

#37 3 years ago

tested the fuses; i think they're okay.

are you talking about the dip switches close to the game rom? i see 2 and 3 are off.

#38 3 years ago

booted up with 2 and 3 on. it reset everything. still got no magnet. i flipped 2 and 3 back off.

#39 3 years ago

They should all be flipped to on for US, Did you test the fuses with a meter? Did you take the cover off the claw and see if any wires were loose?

#40 3 years ago

i'll switch them to on. yes, i have an audible multimeter. they were all squealing.

i'll check the claw wiring. i will add that although i said the claw worked with the demo time rom, it would fail to pickup maybe 1 out of 10 times. it would cycle the elevator again and pickup on the 2nd attempt. maybe that's normal when everything is working?

#41 3 years ago

and fyi, i can swap roms back and forth and it'll always work with demo time. so i have gone backwards, undoing the changes, and it works. in other words, checking fuses and wiring just seems like a waste of time.

i appreciate the help, however, and i will definitely look at anything you want me to.

#42 3 years ago

Maybe clean the optos. Not easy to get to.

#43 3 years ago

Opto's would affect the claw movement, not the magnet. I am going to dig into my game and see what else I can find that would possibly cause this error. Just curious, did you test the opto's in the elevator? Easy to check, just put the game is test mode, and put your finger in to break the beam, I do not remember if there was another set of them in the elevator shaft, I know there is an opto board at the bottom of the elevator, but that would not play into this.. Try testing the optos, maybe they are failing and they have something to do with activating the magnet in the claw.

#44 3 years ago

beam under the claw? if not, where exactly?

#45 3 years ago

When you put the factory rom back in do a factory reset also . I had a dm that did the exact same thing and it never made any sense lol.

#46 3 years ago

When the claw goes to the far right to get the ball, the elevator sends the ball up to the claw, inside that elevator area towards the top there are 2 opto's one on each side, that tell the game the ball is in the elevator, if the opto's in that elevator lift area are not working, the machine could be assuming there is no ball in the elevator, and not turning on the magnet in the claw.

#47 3 years ago

I thought when you changed the rom, it did a reset, mine always has.

#48 3 years ago

in test mode, are those the 4 square indicators on the display for each thing, the optos?

#49 3 years ago
Quoted from balboarules:

I thought when you changed the rom, it did a reset, mine always has.

correct, it resets. it reset when i was playing with dip switches, too.

#50 3 years ago
Quoted from balboarules:

I thought when you changed the rom, it did a reset, mine always has.

Well I thought so also but ive had a few games that I upgraded the rom on and it kept all the old settings and did weird things . My dm was one of the weird ones that had the same issue that op is having .

Promoted items from the Pinside Marketplace
$ 9.99
Eproms
Matt's Basement Arcade
$ 10.00
Playfield - Decals
Metal-Mods
$ 159.99
Lighting - Other
Lighted Pinball Mods
There are 247 posts in this topic. You are on page 1 of 5.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside