New Acquisition Problems with Williams Fire!

(Topic ID: 211783)

New Acquisition Problems with Williams Fire!


By RetiredPinman

9 months ago



Topic Stats

  • 10 posts
  • 3 Pinsiders participating
  • Latest reply 3 months ago by RetiredPinman
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

Upper Playfield Decal Problem (resized).jpg
Reworked Control Bd Solder Side_04_21_2018 (resized).jpg
Reworked Control Bd Component Side_04_21_2018 (resized).jpg
Fire Photo 1 (resized).jpg
Fire Photo 2 (resized).jpg

#1 9 months ago

I was just given a Williams Fire! pinball. Its a Champagne Edition! Lots of issues but overall the game wants to work. First off batteries were toast. Game has been in a barn man cave for who knows how long. People said it worked when they first got it but one of flippers did not work (left flipper has a broken fiber link). With only one flipper they probably were not excited to play it. Took out batteries, had eaten some of the contact links holding it to PCB. There is sign of out gassing, blue residue on some component pins. Cleaned them as best I could with white vinegar. I am sure some of my problems are due to battery damage.

But game does come to life. Makes some sounds and GI lights come on when powered up after being off for some time. Can't read what it is trying to say because only four characters working in top two displays, two each at player 1 and 2 positions. No signs of life in positions 3 and 4. Fooled with diagnostic switches and display changes but can't read it.

Can get it into attract mode by pressing the processor test switch, the lower one, on the left side of the processor card. Once in attract mode can turn it off and on and it comes back up in attract mode. And have been able to get it into diagnostic mode and it steps through the tests. After a while all of the characters come to life in the player 1 and 2 positions. But never any sign of life in 3 and 4 positions. Sound system sounds great in attract mode and the diagnostic tests.

Put credits on it but could not get it to start playing a game. When start button pressed with credits on, it make a sound then activates a bunch of solenoids like its looking for a ball. Balls are there but none served up nor is the number of credits decremented. Machine just goes back to attract mode. All of the switches I tested are detected in the switch edge diagnostic test. In the solenoid test it serves up a ball. In the switches set test it says the center lane switch is set, none others unless I press a switch.

Another puzzling thing is that none of the three LEDS on the processor board light up. But the main processor and the sound processor are clearly up and running.

Any thoughts or things I should try? I hope there are some Williams System 11A experts out there that might be willing to lend a hand.

Fire Photo 2 (resized).jpg

Fire Photo 1 (resized).jpg

#2 9 months ago

"Given" a Fire! Champagne? I really shouldn't help you at all, I'm so jealous!

Please get us some high quality closeups of the board areas affected by the corrosion. While a wash can slow things down, alkaline corrosion is like a cancer. Read this scholarly thread:
https://pinside.com/pinball/forum/topic/terrybs-guide-to-repairing-battery-damage

Since you can get into diagnostics, that is a sign that most of the "central nervous system" of the MPU are working - certainly a good sign that this is worthy to invest some repairs. The LEDs are likely failed themselves, or traces that supply them. You can't have a functioning MPU without the +5V, so the absence of the +5V LED is invalid. Think of it like having a broken gas gauge on a car that you are still able to drive around. Pretty easy to replace the LEDs and see where it goes from there.

Part of your games start up confusion is from absence of battery backup, and I'll bet your getting an "Adjust Failure" message because of the lack of backup. I would add an off board battery pack at this time, because it is the easiest to implement - then check the keep alive voltage at the RAM.

It's a bit uncommon to get no start when you have correctly working switches, correct number of balls, and credits or freeplay turned on. Make certain you do both switch test (checks more for stuck switches) and switch edge tests - perform the tests only using a ball, not your finger. Make sure outhole, trough and shooter lane switches activate with a ball.

One step at time.

#3 9 months ago

I agree with the above except I would install NVRAM instead of worrying about batteries. Also eventually, I would recap the power supply as well, once everything else is working

#4 9 months ago
Quoted from PinballManiac40:

I agree with the above except I would install NVRAM instead of worrying about batteries. Also eventually, I would recap the power supply as well, once everything else is working

NVRAM requires socket install for System 11, so in the interest of first getting the game up and running without introducing more complexity at this time is why I suggested an offboard battery pack - NVRAM could be added later after the bugs are ironed out.

#5 9 months ago

Yes, I meant to say that as well as recapping the power supply after everything else is working. Shouldn't be too difficult.

#6 9 months ago

Wayout440 and Pinballmaniac40 thanks for getting back to me. You were spot on about the start up problem. It was due to the lack of battery power to keep the U25 Eprom alive. I rigged up battery power using the battery assembly out of a small LED flash light. AAA vs AA batteries but should be ok because low power draw. Connected it via jumpers to the anode of D2 and confirmed 4.5V on the U25 power pins. When I first turned the game on last night the Eprom memory was scrambled so the game made some sounds and tried to tell me something because only 4 characters in the upper two displays were working. This time I waited it out for more characters to appear so I could read the message. It took about 10 minutes for enough to read "ADJUST FAILURE" as you suggested it might. Found in the manual that if there is a problem with memory retention you will get that message or FACTORY SETTINGS. I got it into attract mode and put some credits on it, game still would not start; more about that later. Powered the game down and waited 5 or so minutes for all of the caps to discharge and then powered it back up. Game went into attract mode and retained the credits I put on it. So the memory retention feature is working. Powered it up again this morning after it sat all night and it still went into attract mode. I assume the credits are there, could not easily tell because only 2 characters were working. So one problem checked off; thanks.

I think the processor board is by and large working as it should. May be some solenoid driver or switch transistor problems but the system and sound processors seem to be alive and well. Given the battery acid contamination who knows how long that will last. Plan to get a new battery assembly, pull the processor board, install it and do some board cleaning. I am reluctant to get too aggressive and cause something that is working to die. I'll keep researching. I read the Pinside thread about battery acid and cleaning that you provided. Needless to say battery acid contamination is insidious.

I agree with you that the game start up problem is associated with it thinking that it is lacking three balls, even though they are there and pressing the ball trough assembly micro-switch arms. I have also noted that when I place a ball on the out hole switch the coil does not fire to push the ball over to the trough assembly. So I have been pushing the ball over there manually. Last night when I attempted to start a game the display flashed awaiting pinball after activating several coil assemblies apparently trying to free up a stuck/lost ball. I'll fool around with the trough assembly switches and see if I can make some progress. I am puzzled that if its lacking a pinball that it does not continue to display that message waiting for the operator to correct the problem. Instead it flashes the message and immediately goes back into attract mode like nothing is wrong. I was lucky to happen to be looking at the display when it flashed it. Now I'll be looking for it.

Another thing I have to look at in more detail is the Auto/Step switch, the middle one in the bank of three switches mounted on the back of the coin door. It does not stay down in the detente/step position like it should. I have been having problems getting the diagnostics to step/run as they should and I think that switch may have something to do with my problems.

So in summary I have three issues to address: the processor card including replacing the battery assembly, the displays, and the start up problem. Yes I was given the game but I may well have to buy new Pinscore displays and a Rottendog processor board to have a good game.

On the display, the top two display units after time say 10-15 minutes usually "warm up" and function. But the two lower displays that I think are just numeric have yet to show any sign of life. I am going to check and rework the display interconnections and check the voltages, especially the +/- 100V maybe with my O scope. Possibly battery contamination affected the connections and old caps may be affecting the 100v supplies. Any other ideas before I shell out $200 for Pinscore displays? Having the displays working would sure help with the troubleshooting and when I get the game started enjoyment playing it.

#7 9 months ago
Quoted from wayout440:

Please get us some high quality closeups of the board areas affected by the corrosion. While a wash can slow things down, alkaline corrosion is like a cancer. Read this scholarly thread:

Start with posting the picture around the battery pack area and measuring the voltages with a DMM. Oscope is not needed here.

1 month later
#8 7 months ago

Found two problems. Game could not read the three trough switches due to apparently a contact issue of the harness connector(s) to the control board. Pulled connectors to test switch circuits. Found no problems, put connectors back on, and then game could see the switches and I was able to start a game.

Display, controlled lamp, and coil voltage problems were due to the blanking circuit not operating properly. Blanking signal was cycling when it should not. Problem appeared to be that the timing constant 1 micro farad capacitor for the 555 timer changed value over time. Started low when game turned on cold and increased as game warmed up. Using jumpers I put another 1 micro farad cap across the board cap and the problem went away. The not blanking signal stayed high constantly as it should after game initialized. I cut the lead of the board cap so that my cap was the only one in the circuit and the controlled elements; display, controlled lamps and coils all worked as they should. Verified this over a period of several weeks.

Took control board out. Replaced all of the blanking circuit components and replaced the 6116 ram with the NVRam. Also cleaned the board as much as I could using vinegar. Pictures of the board are posted. I re-installed the board. Works fine, meaning like it did before I removed it, but with new blanking circuit parts and the NVRam. I did not replace the battery holder that I removed. Looking at the photos you probably will see four jumpers that I had to add to recover from damaging two circuit card pads. Battery damage may have been a contributing factor.

I need help determining whether I have display glass problems with the two lower player 3 and 4 displays. They still do not work. I am thinking about replacing the display system with the Pinscore replacement assembly using LED display elements. I think my player 3 and 4 display glasses have out gassed. Replacing them is not cost effective. I can do some soldering work but replacing those two glass elements is not in my wheel house. Plus they are expensive, like $75 - $100 per glass element. In addition to buying the replacement glasses I would have to package and send the control board to someone to do the replacement. What tests should I perform to confirm that my player 3 and 4 display glasses are bad and it's not a problem in the control card, connectors, cables, or display card? What display replacement should I consider and why? Thanks

Reworked Control Bd Component Side_04_21_2018 (resized).jpg

Reworked Control Bd Solder Side_04_21_2018 (resized).jpg

#9 7 months ago

Good job troubleshooting, and good post. As for displays, you are spot on with you're thoughts - go digital and don't look back. If I had one display outgassed and could find a replacement cheap enough or parts cheap enough, I've fixed them in the past, but any more than one display it goes right to a digital replacement. I've used both XPIN and Pinscore and they are both nice products.

3 months later
#10 3 months ago

Well finally I can report that the game is doing well and everything is working, at least it was last night. The last thing that I did was to rebuild both of the flippers. It came to me with the left flipper broken, the link attached to the plunger was broken. Of course I damaged one of the coils when trying to replace the coil sleeve. Flippers work nice now.

Overall lots of problems, but all except for the blanking circuit problem described above were "normal" issues especially for a machine that sat for years unplayed in an unheated man cave room in a barn.

Now it's shop the playfield and get it looking good with new rubbers and adjusted switches. Also plan to varnish the veneered box sides. Would like to get some box decals if any happen to come up on ebay. I have 2 plastic pieces that are broken. Was able to come up with replacements on ebay, so all of the plastics are good. There are two long plastic ramps on either side of the playfield that are cracked, the ones the ball travels along before dropping into the lock chambers under houses. One on right is the worst and it was repaired with a piece of wide clear adhesive tape. Would be a big job to make new ramps, but does not look impossible. But probably a job for down the road.

One last thing I could use advice on is how to replace the decals attached to the top of lighted plastic pieces inserted in the playfield. Most of the playfield is covered with a mylar sheet, I assume still the one installed by Williams when the game was manufactured. All of the decals under the mylar are in decent to good shape. But the ones not covered by the mylar, especially the ones at the top center of the playfield under the large house, see the photo I added. (The two circular ones and the four fire decals)

I was able to purchase a sheet with all of the playfield decals on it on ebay. The decals appear to be attached to the top of the plastic and those not covered by the mylar are subject to ball wear. Do you remove the plastic piece and then remove the remnants of the decal, clean the plastic piece, and attach a new decal? Or remove decal, clean plastic, and attach new decal without removing plastic piece?

Upper Playfield Decal Problem (resized).jpg
Promoted items from the Pinside Marketplace
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 22.00
Trade
Machine - For Trade
Independence, KY
Wanted
Machine - Wanted
Colts Neck , NJ
$ 27.99
Eproms
Matt's Basement Arcade
$ 18.99
Eproms
Matt's Basement Arcade
$ 14.00
Electronics
Yorktown Parts and Equip
From: $ 15.95
$ 32.00
Electronics
Yorktown Parts and Equip
€ 68.00
Playfield - Toys/Add-ons
YOYOKOPTER MODS
From: $ 6.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 46.00
Playfield - Toys/Add-ons
The MOD Couple
$ 29.95
$ 79.00
Cabinet - Shooter Rods
Arts Arcade
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside