(Topic ID: 146097)

nba fb ejecting 2 balls


By RandomKG

3 years ago



Topic Stats

  • 14 posts
  • 7 Pinsiders participating
  • Latest reply 3 years ago by pinnyheadhead
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 3 years ago

problem:

NBA FB is ejecting 2 balls but only on ball 2!

ball 1 is fine.

any thoughts? already replaced the trough sender opto and didn't fix.

having a similar problem on no good gofers

#2 3 years ago

Trough LEDs?

#3 3 years ago

Pull balls out. Put into switch edge test. Roll balls one at a time into the out hole and watch the switch count down.

#4 3 years ago

thanks taxman, did that one at a time switch count test and it acted as it should have. each of the four switches went from closed to open one at a time as expected.

tomgwi- what do you mean by trough LEDs? as in "are trough LEDs interfering with the opto transmission signal?"

#5 3 years ago

One of the optos in the trough is failing or the solder is cracked on a connector pin or emitter/receiver.

Take all the balls out. turn the game on. Put the game in switch edge test and wait about 15 minutes to see if one of the switches triggers by itself. If so, note which one. You need to reflow the solder on it. Also, nudge the machine and see if that will do it.

#6 3 years ago
Quoted from SealClubber:

One of the optos in the trough is failing or the solder is cracked on a connector pin or emitter/receiver.
Take all the balls out. turn the game on. Put the game in switch edge test and wait about 15 minutes to see if one of the switches triggers by itself. If so, note which one. You need to reflow the solder on it. Also, nudge the machine and see if that will do it.

Thanks- Will do in a cpl days next time I go to friend house to continue troubleshooting. Love your confidence! : )

#7 3 years ago

Ha, confidence is probably due to this behavior always being caused by trough opto problems - it's a pretty common one! Of course, it could be something else this time, but it seems unlikely.

#8 3 years ago

switch edge test has been on for over half hour-

still just says coin door closed
last switch 22

#9 3 years ago

ok left it on for over an hour and finally switch 36 went off. I don't have the book, thoughts?

#10 3 years ago

Sorry can't help, but what pin are you working on? Yours?

#11 3 years ago

Check the ball trough switch wires. Had a similar problem in my Avengers.

#12 3 years ago
Quoted from ATLpb:

ok left it on for over an hour and finally switch 36 went off. I don't have the book, thoughts?

Well, 36 is column 3 row 6. The switch itself is Center Ramp Opto. But guess what else is on Colum 3?

31 - Trough Eject
32 - Trough Ball 1
33 - Trough Ball 2
34 - Trough Ball 3
35 - Trough Ball 4

So, I'm going to stick with connector / cold solder joint. But I'm going to include the possibility of a failing diode.

#13 3 years ago

thanks guys, pinny- I'm helping dbaum.

had to leave before following up on this. will try again in a few days!

#14 3 years ago
Quoted from ATLpb:

thanks guys, pinny- I'm helping dbaum.
had to leave before following up on this. will try again in a few days!

For your help is he paying you back in pinball lessons?

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Cincinnati, OH
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 22.00
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside