(Topic ID: 230364)

Mystic Gate issue

By bushjc

3 years ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 3 years ago by bingopodcast
  • No one calls this topic a favorite

You

Linked Games

#1 3 years ago

Hello Everyone!

I am a newbie currently attempting to repair a Mystic Gate.

When I first started checking the machine, I did not get anything response on power up. No lights or activity, other than a slight hum. I replaced all of the fuses (6) and restarted. After that, the machine lit up when I flipped the power switch.

I dropped a coin in and the first game started, then the machine went dead. Blew the number 1 fuse, I think it was the 50v. I replaced the fuse and restarted. When I dropped in a coin this time, I was able to click off 2 games before the same fuse blew.

After looking around inside the coin door, I found another coin switch. On the chance that might be the issue, I disconnected the 3 wires from the switch that was mounted on the door and restarted the game. I found that I had to use a combination of touching two wires together and then one of those wires and the third wire would simulate a coin drop. I guess the best way to explain this is I have wire A B & C. I touch wire A and B together and I hear a click, then touch wire A and C together and credits roll up.

I can then press the Red button and the games peel off. The features/odds start to move and the ball motor place a ball in the chute. I can run up credits and raise the odds until the "40 coin limit" appears.

However, when I shoot a ball, the shudder does not close to hold the balls on the table. They fall straight through. Now if I tilt the machine, the shudder will close, ending the game. But when starting the next game, it opens back up and stays up.

Now a little history on this game. I know at one time it worked completely. It has been in my family over twelve years, but it has been in storage for the past eight years or so. This game along with a Nashville and a Miss America Deluxe belonged to my brother. He worked on them several years ago, but was unable to continue. He recently passed and I have made it my mission to get these machines working.

I have reviewed the Gerliz (sp) videos and I'm learning as I go along.

Any help would be greatly appreciated.

Thanks!

#2 3 years ago

Welcome! Check to see if your timer unit is stepping once the first ball is lifted/shot. My guess is that it is not.

The fault would either be at lifter cam #2 (a common problem for a game that's been sitting for a while), or in the limit switch for the timer unit itself (a switch that is normally closed, but opens when the timer is at it's maximum position).

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside