We're back!

After a disaster in our datacenter took down our server, we are now running Pinside on a brand new server. However, things may not work as expected as we are still polishing the playfield and adjusting some switches! We might be switching to maintenance mode a few times. Please see this forum topic for more info.

(Topic ID: 243388)

My Sure Shot Is Sick!!!


By icanswim70

1 year ago

Topic Heartbeat


Topic Stats

  • 44 posts
  • 6 Pinsiders participating
  • Latest reply 4 months ago by HowardR
  • Topic is favorited by 4 Pinsiders

You

Linked Games

#1 1 year ago

Hey everyone,

life went crazy so i'm just returning to the pinball repair hobby.

I went to play some pinball this afternoon, and found my sure shot is getting stuck in the End of Ball Bonus Stage; It just keeps stepping.

Not sure where to start, here are the schematics, any help would be great, i can also take a video for reference if needed

#2 1 year ago
Quoted from icanswim70:

my sure shot is getting stuck in the End of Ball Bonus Stage; It just keeps stepping.

There's a Make/Break switch on the Bonus Unit 15th position that should eventually switch power from the Q/Bonus Score relay to the O/Ball Return relay.
Sure Shot Bonus Count (resized).jpg
Is that working?

/Mark

#3 1 year ago

Here’s the issue in a nutshell

#4 1 year ago

You need to inspect the switch pair that Mark mentions. Remove glass and the ball. Lift playfield against backbox.

Find the make-break switch pair on the bonus unit. Is the bonus unit advancing to it's end position? (i.e. 15th position) You will notice that a post on the gear wheel should come around and hit the switches when at 15th position. The switch I marked as "2" needs to close in order to end the bonus unit procedure otherwise it will never stop as you experience. Switch 1 should open when 2 closes.

You can also see the operation with the game off by manually actuating the coil plunger I marked as A to advance the unit. Plunger B resets the unit to position 0.

46440904-C142-4C7D-B9CA-7A7314152BDA (resized).jpeg514E1F34-3F6C-4369-A9FB-4897692CB8C5 (resized).jpegFEF4D058-A670-4962-97A3-317110A7E30D (resized).jpeg
#5 1 year ago

Thank you guys so much for the great info. The reset coil works, but the stepper coil is sticky as hell. The make break switch you mentioned looks to be in good shape (A closed B open to reference your diagram) I’m just wondering if the stepper coil needs a touch of lubrication cause maybe it got stuck?

image (resized).jpgimage (resized).jpg
#6 1 year ago

Lubrication may have actually caused your problem but certainly will not fix it. The mechanism needs to be disassembled, cleaned and reassembled. Until you can easily advance all 15 steps with one coil plunger by hand and reset it with the other coil plunger by hand, it will not work.

#7 1 year ago

It is more likely that the stepper mechanism parts are gummed up rather than the plunger simply being stuck in its coil/sleeve. I can hear your add bonus coil plunger pulling in repeatedly during your video which means the plunger is moving somewhat in the coil/sleeve. It is not advancing the stepper however upon the plunger's spring-biased return out of the coil sleeve due to stepper gumminess most likely.

#8 1 year ago

jeffc It seems like the stepperis getting stuck during its count, as it sometimes “sticks”. Reset plunger works no problem now testing it. What do you do with the counter part that’s sticking?

#9 1 year ago

I feel like I should clarify a few things.

1) I’m young, I used to mess around with this machine as a kid and as I got older it became a fascination and now a hobby. I’m 24.

2) can’t read schematics, I’ve been trying desperately to learn for about 3 years, it just ain’t clicking.

I’m trying to learn from you guys at pinside, through text books, and messing with this thing, so I hope I’m not frustrating you with my lack of understanding.

#10 1 year ago

And the gear in front of the A/B switch is mucked up real nice

image (resized).jpg
#11 1 year ago

As mentioned. There is no fix short of removing the entire assmebly from the game and cleaning it. You need to sit down with your cell phone camera and a phillips head screw driver and a sheet. Place the playfield in a service position- pull it out and stand it up. Use a towel to protect top of the head if your worried- and tip playfield back so as you look at the game stabding at the flippers all you see is the bottom of the playfied. Now drape a sheet over the side rails so that any screws are caught before falling into the mechanics below.

Then- the simple part. Take a picture from every side of the part. Remove a screw (you can take the assembly off the playfield first) and take a pic of the screw next to its hole. Once you have the mechanical stepper free from the playfied (4 wood screws) you can then take pics of it fully assembled. Caputure every angle and especially how springs are attached. Then turn to removing the coil stops (2 machine screws with lock washers per). Take photos of the coils once you free them- notice how the plastic coil sleeves are oriented. Once those coils are free you want to carefully photograph the switch stacks. Take not is one uses machine screws and the other has a metal type thread as you take them apart. Take pictures of every dang thing before you mess with it ajd as you take it apart. Once you have switch stacks free the stepper until will be in your hands and out of the game.

Take another 20 pics- then get a can of carb cleaner- a bottle of Brasso- and a bunch of rags. Take it apart all the way- spray old junky grease away with car cleaner (outside! Also HiGHlY flammable). Put it back together they way you found it.

It can look like this when your done. Note this is not the same unit. But close enough to give you an idea of whats under all that grime

A575F7A5-C4CC-40B3-A647-677B8C89246B (resized).jpeg
#12 1 year ago

Thanks rufessor

Well the good news is this is how you learn. Schematics didn't make much sense to me either until I spent hours comparing them to mechanisms in a working game. The whole orchestration of the bonus sequence is semi complex so probably not the easiest example to learn from. I'd suggest staring at the schematics and trying to see why the numbered ball lights illuminate when you hit their targets.

#13 1 year ago

Just to confirm, when I detach the stepper from the play field (4 screws in the play field) What do you do with the stepper unit before getting to the gear on the underside as there are sautered wires going to other spots on the machine?

CCB55927-A5E8-478F-9AD0-FC514FBA1895 (resized).jpeg
#14 1 year ago

Are these the screws you are referring to for the coils? They are also attached to the switch stacks.

image (resized).jpgimage (resized).jpg
#15 1 year ago

Those are the screws! As for how to handle the unit while unscrewed but not out. You need to be the judge here- but most of those have a lot of wires soldered on and can hang if your careful about it. Better yet is to have playfield tipped over dar enough that its not just hanging on the wires but also kinda laying down. Basically tip playfield further back past vertical. Careful stuff is supported and your checking things for rubbing etc. Ideally a rotisserie but to be honest- short of a swap you dont need one.

#16 1 year ago

Just dont break stuff. Go slow. Watch both sides when you move it and dont hang it from one wire. A big bundle will hold plenty. One wire will not. Especiay dont catch other switch stacks or snag parts. Best to remove and mostly stay there with all tools required- basically strip it before it ever hangs. Thats what I do. It only takes a few minutes to free it up. Thats 8-12 screws and lots of ways to remove things ajd loose track. Take photos as you go. But try to do it all in a row. I may hang it long enough to snap a pic but usualy always have a hand on it.

#17 1 year ago

The bonus unit is very awkward to service, even if upright against the backglass. I removed the whole playfield and laid it across the cabinet. To do so you will first have to remove the 2 wire harness jones plugs from the bottom board and the 1 wire harness jones plug from the backbox.

Like so:

IMG_0356 (resized).JPG
#18 1 year ago

Run into a problem here, screws are old and literally disintegrating as I’m unscrewing them, screw on left tried ONE turn and that chunk came out, and that nut isn’t budging and also started disintegrating after 2-3 turns with the pressure of a toddler. I’ll replace them upon reassembly but how would you suggest taking it apart without ruining the damn thing

6089F63C-3AB4-42F7-8066-14DC785C7A5D (resized).jpeg
1 week later
#19 1 year ago

Here’s where I’m at: coils have been taken apart and cleaned (plastic sleeves still attached by wires, removed a metric ton of grease and goop from the coil holders, and am now trying to get the whole thing free) what’s the next step in freeing it?

I left it attached as I’m tight for space and will unscrew it once I can lift it straight out.

image (resized).jpg
#20 1 year ago

the screw broke because you did not have the proper sized screwdriver to take it off. the screwdriver should be as big as the slot and fit in snugly to transfer maximum torque to the screw head. this is one of the reasons why torx screws are used, that and machines handle them better. since you have the switch stacks out make sure they are svrewed together tight. as the game ages the spacer dry out and the stacks get looser

#21 1 year ago

The nut underneath was also a pain, but it’s been dealt with and removed.

As for moving forward, what’s the next part to remove? (It’s lookibg like the stepper itself will need to be removed to free the plate, I saw 3 screws on top of the stepper, are those to be removed?)

Also, the stepper isn't manually stepping with the coils, indicating an issue, how should I approach that as coils have already been cleaned?

#22 1 year ago

Ok- you are making progress. Congratulations.

First bit of advice. Resist the temptation to clean anything yet. Its more work now cause stuff is in the way.

You want to remove the switch stacks next. Looks like one may be missing a screw from pix or maybe you started. So pull all switches off. Pretty self explanatory- two screws each stack. Just count spacers and take pics frol a good few angles and close up and wel back.

Then- on turn to the electrical side with the brass wipers. That you remove by taking your fingers and holding the sprocket on the mechanical side while using a pliers to loosen nut and lock washer on center spindle on the electrical contact side. This is all easier if you unscrew the unit from the playfield. Typically this is four wide head wood screws- two per leg.

Then the whole thing comes out into your hands and you start by taking photos. Then remove springs- careful with larger center spring. This sometimes gets tightened over the years as an effort to “fix” it and can realy make a mess if you release it and it uncoils. Keep your hands on it and unwind it a bit. If that makes sense.

Then more pics and you can take off the levers and swing arms the coils accuate. Then remove the sprocket and if ambitious strip remaining assembly down. Clean everything and hit rewind to assemble.

Did I mention take more photos from more angles than you think you need- as each layer of the onion is removed.

#23 1 year ago

HOLD ON!!!

Here’s where I’m at, I’m going at a snails pace so I don’t break anything.

Switchstacks are free, photographed from every angle I could get.

The spring the stepper is attached to was appalling so I had to clean that, my hand looked like it was about to fall off.

So next is removing the stepper from the plate? There’s a lot of wires still attached making it hard to move certain parts

The 3rd picture is the grease that came off the big spring

160CA7B5-3AC0-4C49-9479-3629CE3F2FCB (resized).jpeg35A8DE17-BDD6-40FE-9B49-AE6A00281EAF (resized).jpeg5D698457-B600-41DD-A371-BEB6A5477D9C (resized).jpeg62C1570C-C9DD-41B2-9E5C-003597570F21 (resized).jpeg
#24 1 year ago

I dont own nor have ever worked on this game so I cannot give exact directions. However, in the second photo I can see the plate sitting on the playfield- metal attached to the stepper. There are what looks to be two nuts holding that down. I would guess there are four tota. If you can unscrew those the whole piece will come out a bit and you will need to basically figure out how to take it apart. Trace wires to find where they attach and inspect to remove them. If you want to try to clean in place thats fine too. I am not going to be able to do much more than offer experience working with other similar stepper units. Its really up to you as to if you ate comfortable diving further in. I honestly hesitate to push someone over the edge to a point beyond which they cannot put in back together on their own.

If your willing to keep peeling the onion I think the best thing for you is to remove the screws I talked about and hold the mech in your hand a bit (with some wires on but you should be able to inspect it). Then decide if you want to keep taking off parts.

There is not much more to it than a screw driver. So of you take photos and your comfortable- anything you unscrew is a step to disassembly.

#25 1 year ago

I have it photographed to bits and its not much use if i dont continue repairing it so i will keep going, i just dont wanna break anything. The stepper doesnt count up, so i know it needs to be cleaned, but how is the question im asking here.

#26 1 year ago

I've been following your direction regiliously rufessor, so thank you for breaking it down. Switch stacks are hanging as you can see, whats the next point of attack as im only working once this thread is updated again so i dont bend or heaven forbid break a wire,solder point, etc.

#27 1 year ago

Which screw needs to be removed to free the plate from the stepper?
2B603F01-EF02-4A7A-9AC5-F7CE4AA93970 (resized).jpeg

#28 1 year ago

go on you tube and enter "cleaning a gottlieb stepper unit" this should give you ideas on how this stuff comes apart and should be cleaned

#29 1 year ago
Quoted from wugly:

go on you tube and enter "cleaning a gottlieb stepper unit" this should give you ideas on how this stuff comes apart and should be cleaned

Appreciate the direction but there zero videos out there with this kind of stepper, hence this post. I'm trying to get direction due to a lack of resoutrces, any help with the next step is much appreciated!

#30 1 year ago

So after the clean and reassembly it is now clear it’s the reset coil as documented in my play field up test.

#31 1 year ago

There is a relay with a stack of switches. One of those switches controls the reset coil. My guess is that switch is bent open. Gottieb schematics are still available from PBResource.com. Likey copies but still good. You need to find the label for that stack- ID it in your game and check the switch. There are other possibilities as well but this one is the first to look for.

Looks nice and SHINY!

Also-
You did check to be sure both wires on there and the EOS switch on the stepper is closed - right? If that stepper has an EOS. Its the switch that is triggered each time the coil fires. Not the switch that is triggered by fingers on the stepper gear. It may not have one but if it does and its open- thats also a high possibility.

Did the coil function or buzz at all prior?

#32 1 year ago

On a a side note, anyone ever had a play field not sit right? The right side is raised a bit, it’s always been an issue but I was always able to jimmy it into place. There is nothing on apparently out of place preventing it sitting properly, you can see the plunger isn’t at the right height (I’ll get back to the previous issue after)

image (resized).jpgimage (resized).jpgimage (resized).jpg
#33 1 year ago

Here’s the schematic, can someone point me in the direction of the relay to check, I can only find the switch on the stepper (adjusted correctly might I add ) I was also made aware by you fine pinheads that Gottlieb schematics are copyright so don’t mind my scribble lol

03D3DF48-9A94-4115-BD90-85B3B8B92ADC (resized).jpeg0E1EE15F-A281-488D-9080-083A1062DD62 (resized).jpeg
#34 1 year ago

I checked the switch on the bonus relay and confirmed it should be open when powered off, so I adjusted it.

I took a video of the unit and noticed the relay is energizing funny, almost twitching if you will.

Here’s the video

1 week later
#35 1 year ago

So I’ve been digging and isolated the problem to the step up switch. It was soldered poorly causing a bad connection (after filing it down a bit and removing the oxidized bits) it started counting again, but only momentarily. To fix it I want to replace the switch completely, but I can’t fins it’s replacement anywhere as there’s no part number.

Can anyone tell me what “kind” of leaf switch it would be?

598C61D2-5714-4C1E-92D3-B8D8E3429AEB (resized).jpeg
1 month later
#36 1 year ago

I've almost finished the repair on this thing. There is a very frustrating issue when you're the most colorblind a human can be, wire colors on old faded wire. I need to replace the fuses shown (2 play field, 1 15 amp fuse on bottom panel) The fuses on the play field have no indicator of what they are, and the schematic colors look different to me. Can anyone confirm what ampage fuses go on the play field? (schematic picture is my suspicion)

FullSizeRender (resized).jpegc2FntVKtRBSMfaDXRcNGZA (resized).jpgreOosvYsTY6lli3cs3ykpw (resized).jpg
#37 1 year ago
WGGBmChBRwCAJoJdN4DbqQ (resized).jpg
#38 1 year ago

The wire colors in your picture are the same as those on the schematic for two 5 amp fuses.

1 month later
#39 1 year ago

Alright, gunna post an update, cause of entire problem is known now: bonus Unit isn’t stepping up because arm on underside isn’t turning the toothed wheel. Does anyone have a video of the bonus unit advancing properly so I can compare?

#40 1 year ago
FBFF8862-2B3F-47AD-96DB-608F449F6199 (resized).jpeg
#41 1 year ago

#42 1 year ago

Who’d a thunk one piece could bring down an entire machine, bonus unit step up joint solidified

37E8A4A0-0C57-49EA-8A6C-C8160445F402 (resized).jpeg
1 year later
#43 4 months ago

*UPDATE* I have fully shopped my Sure Shot by myself. Got it shining nicely, minus 3 light bulbs on the pool rack...

Anyways, I decided to get the dreaded half moon credit unit working, which i did (full disassembly, cleaning, inspection and reassembly). The problem is, it intermittenly works, about 50% of the time, the machine doesn't register that there are credits still on the unit (example being 5 credits showing, but cannot start a game. If you insert another coin, it will add a credit as it should, and then you can start a game)

I have double and triple checked all soldering, functionality, and coin relays, all seems to be in order. Can a half moon credit unit owner tell me what I'm missing?

#44 4 months ago

If pressing the Replay Button doesn't activate the Start relay (S), Inspect and diagnose this circuit with Alligator clip jumper wires
http://www.planetimming.com/Pinball/troubleshooting/EM%20Troubleshooting.pdf
http://www.pinrepair.com/em/index3.htm#features
Example of a pinsider actually doing this https://pinside.com/pinball/forum/topic/red-baron-tech-question#post-5858156

pasted_image (resized).png

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside