(Topic ID: 209234)

[Tech] Multiple Metallica issues

By huo

3 years ago


Topic Heartbeat

Topic Stats

  • 14 posts
  • 10 Pinsiders participating
  • Latest reply 1 year ago by Lermods
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 3 years ago

I've checked all switches to make sure they were working and not stuck. This game had several mods. Backglass led kit, lit flipper buttons, topper lighting, shaker motor, speaker lights. Game appears to have low plays.

* Ball over
I'm not sure what causes this exactly. But the flippers die and the ball is over while it is in play. The only thing I've noticed (possibly) is there's 1 ball locked in the coffin. At some random time and it's not repeatable, the ball ends. This recently started happening.

* Snake biting the ball
I'm not certain how to adjust the jaw. I called support and have the manual but can't figure out how to adjust the height of the jaw, if this is the solution to this issue. I've had a pro in the past and this was pretty easy on that. Premium is more complicated. I have it currently disabled. But the ball would go up the tongue, not going all the way in and slowly fall back down to the right in the mouth, the snake bites the ball. Without it disabled I tried testing the jaw with the coin door open, that got old. Then disabled.

* Not all balls register when hitting Sparky
With the glass off I can't replicate it. It must be fast balls not setting off the opto. I've reseated the connectors on the opto board and blew air at the sensors in case there was any dust. Did a switch test but all tests I did were successful. About 1/5 balls don't register.

Has anyone run into these issues?

#2 3 years ago

Ball in play ending is probably a trough switch issue, use test and adjust or replace to fix.
Sparky is probly the ball catching some air when crossing he magnet in front of sparky, grind flat or replace the core, and adjust to get level with the pf.
The snake I'm not sure about, but the Pro snake always seems to accept shots easier, I see a lot of rejects and balls dribbling out on the prem.
Possibly shim the entire mech from underneath?

#3 3 years ago
Quoted from huo:

* Ball over
I'm not sure what causes this exactly. But the flippers die and the ball is over while it is in play.

Reseat the connectors to the ball trough opto boards. If problem returns, remove them and reflow the solder to the optos and pins the connector plugs onto.

LTG : )

#4 3 years ago
Quoted from DNO:

Sparky is probly the ball catching some air when crossing he magnet in front of sparky, grind flat or replace the core, and adjust to get level with the pf.

I didn't think about this. Good point. Thanks.

Quoted from DNO:

The snake I'm not sure about, but the Pro snake always seems to accept shots easier, I see a lot of rejects and balls dribbling out on the prem. Possibly shim the entire mech from underneath?

I had a pro. It was a lot less complicated to adjust the jaw. The premium has a lot of things going on and I wasn't able to figure out how to adjust the jaw height.

Quoted from LTG:

Reseat the connectors to the ball trough opto boards. If problem returns, remove them and reflow the solder to the optos and pins the connector plugs onto.
LTG : )

Thanks LTG!

2 weeks later
#5 3 years ago

I finally got a larger adjustable wrench and replaced the magnet core. It doesnt feel like the new core lines up flat with the playfield, its a little off. Would you rather have the ball hit the metal core a bit more than have the back part of the wood hole be a tiny bump? Its currently set to the latter and appears to register all Sparky shots now.

#6 3 years ago

You can level the core. You’ll need to do that or you’ll wear the playfield prematurely.

#7 3 years ago
Quoted from huo:

I finally got a larger adjustable wrench and replaced the magnet core. It doesnt feel like the new core lines up flat with the playfield, its a little off. Would you rather have the ball hit the metal core a bit more than have the back part of the wood hole be a tiny bump? Its currently set to the latter and appears to register all Sparky shots now.

Put a straight edge across it and line it flush to the field; the core should not be angled, the only way this can be off is if your magnet mount is bent or the core is not cut flush (not likely); you can always put a washer under the bracket on the high side to bring it in position if need be.

If it has to be off...do not let it be off on the low side.

1 month later
#8 3 years ago

Hi,

What about the "ball over" problem? Did you solve it?
I have exactly the same issue with a Stern Star Trek, and it is driving me nuts...

Thanks for your help

#9 3 years ago

Trough issue, follow what ltg said above, or replace the opto boards, they are cheap. It’s either loose plug connection on opto board, bad solder joint or the opto transmitter is just flaky or bad.

1 year later
#10 2 years ago
Quoted from huo:

I've checked all switches to make sure they were working and not stuck. This game had several mods. Backglass led kit, lit flipper buttons, topper lighting, shaker motor, speaker lights. Game appears to have low plays.
* Ball over
I'm not sure what causes this exactly. But the flippers die and the ball is over while it is in play. The only thing I've noticed (possibly) is there's 1 ball locked in the coffin. At some random time and it's not repeatable, the ball ends. This recently started happening.
* Snake biting the ball
I'm not certain how to adjust the jaw. I called support and have the manual but can't figure out how to adjust the height of the jaw, if this is the solution to this issue. I've had a pro in the past and this was pretty easy on that. Premium is more complicated. I have it currently disabled. But the ball would go up the tongue, not going all the way in and slowly fall back down to the right in the mouth, the snake bites the ball. Without it disabled I tried testing the jaw with the coin door open, that got old. Then disabled.
* Not all balls register when hitting Sparky
With the glass off I can't replicate it. It must be fast balls not setting off the opto. I've reseated the connectors on the opto board and blew air at the sensors in case there was any dust. Did a switch test but all tests I did were successful. About 1/5 balls don't register.
Has anyone run into these issues?

Wow man. I bought a Metallica LE and have all these problems. I'm such a newb too.... glad I found this thread. Did you ever solve everything? (Oddly enough previous owner says he never had any of these....)

7 months later
#11 1 year ago
Quoted from Lobo2k:

Wow man. I bought a Metallica LE and have all these problems. I'm such a newb too.... glad I found this thread. Did you ever solve everything? (Oddly enough previous owner says he never had any of these....)

Same here. I’m having the “ball over” problem. Also mine keeps giving me two balls when I start a new game.

#12 1 year ago
Quoted from Lermods:

Trough issue, follow what ltg said above, or replace the opto boards, they are cheap. It’s either loose plug connection on opto board, bad solder joint or the opto transmitter is just flaky or bad.

Is there a cheat sheet to know what and where the OPTO board is? I’m a noob

#13 1 year ago

Is there a way to change the coil strength on the trough kicker? Mine is way to strong!

#14 1 year ago
Quoted from bobzilla:

Is there a cheat sheet to know what and where the OPTO board is? I’m a noob

There are two opto boards on either side of the trough where the balls eject.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside