(Topic ID: 259660)

Mr&mrs pacman pin.


By arcadebeast

1 year ago



Topic Stats

  • 37 posts
  • 8 Pinsiders participating
  • Latest reply 10 months ago by arcadebeast
  • No one calls this topic a favorite

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    There have been 7 images uploaded to this topic. (View topic image gallery).

    1 (resized).jpg
    8AECF932-5048-4EAE-9841-FA945DF14459 (resized).jpeg
    51ADDBA1-0B4D-4F9F-879A-AF5439996799 (resized).jpeg
    1 006 (resized).jpg
    1 005 (resized).jpg
    1 001 (resized).jpg
    IMG_2880 (resized).JPG

    #1 1 year ago

    Anyone know where the braided ground coming from the body hooks up in the back box? Thanks

    #2 1 year ago

    Their should be a braided strap along the top back box that has a hole for the truss head screw.
    The braid is stapled to the bottom surface of the top backbox.
    If the braid is not present, it could have been removed by someone.

    1 week later
    #3 12 months ago

    Thank for the response vec-tor. Do u happen to have a pic of it? Thanks again.

    #4 12 months ago

    On mine, it was attached here. I do not know if it's from origin or not.

    IMG_2880 (resized).JPG
    #5 12 months ago

    As long as its attached to the metal shielding you are good.

    #6 12 months ago

    thanks guys, always there when i need help. thanks again

    4 weeks later
    #7 11 months ago

    hey, guys once again I'm looking for help. replaced CPU and driver board with alltek boards. all was fine and while playing a game last night all lamps under plastics and bumpers not lighting up. all other lamps on the playfield are working fine. switched out lamp driver board with 2 others and still the same. Did anyone ever have this issue? thanks

    1 001 (resized).jpg1 005 (resized).jpg1 006 (resized).jpg
    #8 11 months ago

    No G.I. lighting? Check the rectifier board fuses.

    #9 11 months ago

    this may be a dumb question. I'm green when it comes to fixing these things but where would that be located?

    #10 11 months ago

    Turn the power off to the game. They are in the lower body of the game. You can pull each one and check if they are good.

    #11 11 months ago
    51ADDBA1-0B4D-4F9F-879A-AF5439996799 (resized).jpeg8AECF932-5048-4EAE-9841-FA945DF14459 (resized).jpeg
    #12 11 months ago

    all fuses good

    #13 11 months ago

    Do you have general lighting in the head/ back box?

    #14 11 months ago

    yes everything else work fine

    #16 11 months ago

    Q19 led on the driver board stays lit if that means anything. ok, thanks for the link will check it out now. thanks for the help.

    1 (resized).jpg
    #17 11 months ago

    I was hoping it was something on the easy side. Haha. Do a little reading and if you can’t get it, one of the big guys can walk you through it. Good luck.

    #18 10 months ago

    GI lights come right off the power supply and (typically) have no connection to the computer of the game. If all the playfield GI is out but you are positive the fuse is good you have a loose connector or broken wire. Start with the playfield power connector plugged into the power supply. There is a triac in all of this so see my further notes....

    It's been pointed out there is a lamp flasher and triac to power the GI. That's probably where the fault is. See my post below...

    #19 10 months ago

    This is incorrect, there's a Traic that turns the GI light on and off, during different game modes.
    Its mounted next to the power supply.
    I had same problem with mine, I just bypassed it.

    #20 10 months ago

    Hey guys thanks for the reply. I do have some lights lit on Playfield. Only ones not lit are all under Playfield plastics and pumpers. Also wdenni do you have a pic of triac that you bypassed. Meanwhile I will check wires thanks again.

    #21 10 months ago

    Thanks Wdennie, I completely forgot about the triac. That is most likely the problem. There is a lamp flasher board on the playfield that needs a load lamp to activate. Sometimes this lamp is bad or missing or replaced with an LED. If any of this is true the triac will not activate and there will be no playfield GI.

    #22 10 months ago

    Q19 is the coin lockout coil, nothing to do with your issue.

    #23 10 months ago

    Where is this triac board? On the Playfield?

    #24 10 months ago
    Quoted from arcadebeast:

    Where is this triac board? On the Playfield?

    Reread post #19

    #25 10 months ago

    Should be mounted in the metal plate next to the power (fuse) board near the transformer

    #26 10 months ago

    thanks, guys
    had the time to mess with it today. after hrs of going nuts, I figured out. Aux driver board under the playfield. I resolder the pins. now lamps work but I must have messed something up with soundboard. green lite flash 5 times at boot up all good. but no sound. when I press on sound rom U4 I got sound pulled it out to reseat it and now nothing. could it be the rom. and where can I get new ROMs already set up for the game? thanks

    #27 10 months ago

    I also have another soundboard but the green light stays on after boot up.

    #28 10 months ago

    Ahhh, you have the domino effect.
    You know, you try and fix one thing, then another shows up and then another and so on.

    #29 10 months ago

    lol, this machine was working fine. this all happened last Saturday. do you know of anyone that repairs bally soundboards?

    #30 10 months ago

    I am having to repair a Bally Centaur S&Q board that is flaky...
    Also, a Harlem Globetrotter SND board.
    But I am on the west coast.

    #31 10 months ago

    Do u repair boards??

    #32 10 months ago
    Quoted from arcadebeast:

    Do u repair boards??

    Yes, I have repaired different pinball boards...
    Most of the boards I have repaired are from the 1970's to 1990's

    #33 10 months ago

    I see ignored user post. How did that happen??

    #34 10 months ago

    Sorry vect-tor I don’t know how I did that. Anyway is there any where I can send my soundboard for repair?

    #35 10 months ago

    Soundboard all set. Sound rom at U5. i re soldered chip socket all is good. Thanks to all taking the time to help.

    #36 10 months ago
    Quoted from arcadebeast:

    Soundboard all set. Sound rom at U5. i re soldered chip socket all is good. Thanks to all taking the time to help.

    Fantastic...

    #37 10 months ago

    Thanks vec-tor

    Promoted items from the Pinside Marketplace
    $ 25.00
    Cabinet Parts
    Flashinstinct
    $ 159.00
    $ 5.00
    Cabinet - Other
    UpKick Pinball
    $ 24.99
    Lighting - Led
    Lee's Parts
    $ 7,699.00
    Pinball Machine
    Gulf Coast Pinball, LLC
    $ 27.99
    $ 79.00
    Playfield - Toys/Add-ons
    Pixels Arcade Games
    $ 26.00
    Playfield - Other
    Pin Monk
    $ 24.75
    Playfield - Toys/Add-ons
    The MOD Couple
    From: $ 255.00
    Playfield - Toys/Add-ons
    Pinball Mod Co.
    From: $ 35.00
    Playfield - Plastics
    Gameroom Mods
    $ 259.99
    Cabinet - Toppers
    Lighted Pinball Mods
    $ 11.95
    $ 125.00
    From: $ 33.00
    Gameroom - Decorations
    Rocket City Pinball
    From: $ 33.00
    Gameroom - Decorations
    Rocket City Pinball
    $ 29.95
    Playfield - Toys/Add-ons
    PinBoss Mods
    $ 139.00
    From: $ 91.00
    $ 259.99
    Cabinet - Toppers
    Lighted Pinball Mods
    $ 1,248.00
    $ 7,699.00
    Pinball Machine
    Little Shop Of Games
    $ 48.00
    Cabinet - Other
    ModFather Pinball Mods
    $ 999.00
    Flipper Parts
    Mircoplayfields
    $ 48.00
    Cabinet - Other
    ModFather Pinball Mods
    $ 7.50
    Playfield - Decals
    Pinball Haus
    $ 17.50
    Hardware
    Pinball Haus
    $ 29.25
    Playfield - Toys/Add-ons
    The MOD Couple
    $ 54.99
    Cabinet - Shooter Rods
    Lighted Pinball Mods

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside