(Topic ID: 242828)

Mr Mrs PacMan F5 Fuse (GI) Showing Continuity?????


By kentmurphy

67 days ago



Topic Stats

  • 6 posts
  • 4 Pinsiders participating
  • Latest reply 62 days ago by kentmurphy
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

ps_schematic (resized).png

#1 67 days ago

So I'm confident this is a stupid question, but I'm going to ask anyway.

All sounds (music and speech) on my Mr & Mrs PacMan pinball went dead.

I suspected the the Squawk and Talk board so I checked each supply and noticed the -5vdc supply was 0vdc.

The -5vdc supply is feed by the 6.5vac GI supply so I checked the GI fuse at F5 on the power supply in the bottom of the cabinet.

The continuity check with the fuse in the block was good, but when I tested the fuse out of the block, the fuse was bad.

Even with the fuse out of the block I was able to get a positive continuity test when I hit just the F5 fuse clips with my meter.

I'm a bit perplexed. Is this normal?

Thanks!

ps_schematic (resized).png
#2 67 days ago

You should probably take a look at the board and see what's causing the continuity with no fuse. You shouldn't get a positive reading without a good fuse. Remember to unplug your machine before digging around.

#3 67 days ago

Disconnect the GI OUT connectors and recheck across fuse clips. You can get false continuity feedback through the lamps.

#4 67 days ago

I did this. I unplugged any connector which had a GI output and then rechecked for continuity. It did not have continuity when those connectors were disconnected. I suspect you should be getting a continuity reading here, but it just seems strange to me.

Quoted from cody_chunn:

Disconnect the GI OUT connectors and recheck across fuse clips. You can get false continuity feedback through the lamps.

#5 63 days ago

Relax, you are over thinking this. That fuse goes across the transformer windings and all the GI lamps so unless you pull every connector off the board you will see continuity except at very low resistance setting on your meter. A much simpler test is is does the GI light up? If the fuse is blown you will have no GI and no 6.3vac at TP4. If that is measuring 0 then yes you have no GI and the S&T will not boot up.

#6 62 days ago

bigal56 Thanks Al! Originally I was perplexed, but after reading ur response it makes complete sense. Thanks.

Promoted items from the Pinside Marketplace
$ 16.00
Electronics
Yorktown Parts and Equip
From: $ 140.00
$ 20.00
Electronics
Yorktown Parts and Equip
€ 3.95
Flipper Parts
Multigame
From: $ 169.95
$ 279.95
From: $ 45.00
Displays
PinballSolutions.eu
$ 90.00
Lighting - Led
Geeteoh Electronics
From: $ 13.00
Electronics
Third Coast Pinball
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 175.00
Lighting - Interactive
Professor Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside