(Topic ID: 237782)

moved my Lethal Weapon 3 and it's smoking


By cdsinfla

3 months ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 3 months ago by Mank
  • No one calls this topic a favorite

You

Linked Games

#1 3 months ago

I moved my Lethal Weapon 3 machine upstairs and it started up ok but I immediately smelled smoke. I also noticed a hum or buzz that sounded like it was coming from below the playfield. I found the smoke coming from the coil for the left kickback. Turned it off & checked the wiring to the coil. Looked fine. Checked the connectors in the backbox. They look ok as well.
Not sure where/what to look for...

Appreciate any help

#2 3 months ago

Pinched wires. Anything close to metal and shorting along underside of playfield edges. LTG : )

#3 3 months ago

I clipped the wire to the coil on the "banded side of the diode" (above my pay grade). Machine is working now without smoke or the coil. Guessing I somehow grounded it out. Definitely melted the coil as it won't move.

#4 3 months ago

Check the transistor to that coil

Promoted items from the Pinside Marketplace
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 279.95
$ 279.95
$ 279.95
950 (OBO)
Sale Pending!
Bakersfield, CA
$ 279.95
$ 279.95
$ 279.95
$ 279.95
$ 279.95
$ 279.95
$ 279.95
$ 279.95
$ 279.95
$ 279.95
3,999
Machine - For Sale
West Chicago, IL
$ 279.95
$ 279.95
$ 279.95
$ 279.95
1,800
Machine - For Sale
Weedville, PA
2,000 (OBO)
Machine - For Sale
Pacheco, CA

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside