(Topic ID: 120815)

Monster Bash Phantom Flip NW issue

By skywalker

7 years ago


Topic Heartbeat

Topic Stats

  • 21 posts
  • 9 Pinsiders participating
  • Latest reply 5 years ago by colonel_caverne
  • Topic is favorited by 4 Pinsiders

You

Linked Games

#1 7 years ago

Hey all,
I have a MB I'm working on it has a Phantom Flip issue,
Just got the machine don’t know if it was working previously or a ongoing issue,
the 3 blue target lamps & switch's all work ok
the 2 FP lamps above the inlanes both light up during attract mode,
the left & right optos work during switch test running the ball down,
flipper eddy sensors register during test also,

the issue I have is the ball hits the targets ok,
word PHANTOM gradually gets spelt, once fully spelt on the DMD, one of the lower blue inlane lamps should light up??

Nothing happens, no lamps lite up either side of the inlanes,

2 PF inlane Lamps are 23, 41

#2 7 years ago

Yes, one side should light and alternate each time either flipper is pressed.

#3 7 years ago

if i can sort this out the PF should work ok

#4 7 years ago

Turn off the tournament mode in the settings.

#5 7 years ago

Ok didnt think of this will check that 2night,
i only checked disable PF settings

pretty sure all the boards have removed prior so it should have re set to factory setting??

#6 7 years ago

Go into switch test and see if the 3 switches on each side detect the ball. Inlane, opto, then eddy.

If that is the case, IIRC then the blue light should light after it detects them enough on each side sorta like Thing flips. I remember this because I could get it on one side and not the other due to a bad eddy on one side

#7 7 years ago
Quoted from KJL:

Go into switch test and see if the 3 switches on each side detect the ball. Inlane, opto, then eddy.
If that is the case, IIRC then the blue light should light after it detects them enough on each side sorta like Thing flips. I remember this because I could get it on one side and not the other due to a bad eddy on one side

all 3 switches register during test on both sides,

#8 7 years ago

After getting the Eddy sensor to work I had to play a bunch of games before it worked. Did you try it with the glass off running the ball down the inlane, etc?

This is the post I think that clued me in. If not search Phantom Flip.

https://groups.google.com/forum/#!searchin/rec.games.pinball/phantom$20flip/rec.games.pinball/fo1ZZcgm5fw/w3ET0u3OkssJ

#9 7 years ago

my issue is a bit different,
the blue lamp does not light up in the inlane, needs to be lit for PF to work ?

#10 7 years ago
Quoted from furnissrohio:

Turn off the tournament mode in the settings.

Checked not on tournament mode, did a factory reset, still the same

#11 7 years ago

After your factory reset, if all the switches work properly, it will take a few games before the game "learns" the shots and starts attempting them. Until then, spelling PHANTOM will not light either of the inlane lights. And interestingly, both left and right aren't necessarily "learned" at the same time. One side will turn on and start attempting shots before the other.

If you haven't played it much, then there's a good chance you don't have any problem.

But again, to confirm, in switch test, when you roll the ball down either inlane, there should be three switches in a row that trigger. Is that right?

#12 7 years ago

+1 on what Mot said. Once you clear the settings. The machine takes a while to learn the ramp shots. It takes quite a few games....

The 3 switches Mot is refering to: Inlane/Inside switch, Opto, and then the proximity sensor under the playfiled.

In edge test mode, you need to confirm all 3 are registering correcly.

#13 7 years ago

Thanks guys, yes all 3 switch's register both sides, will take the glass off 2night & fast track the learning

#14 7 years ago

Nonono. That's the point. You can't fast track the learning. It doesn't learn by flipping, it learns by watching you flip.

Go for the ramps!

#15 7 years ago

Ok got it,

#16 7 years ago
Quoted from mot:

Nonono. That's the point. You can't fast track the learning. It doesn't learn by flipping, it learns by watching you flip.
Go for the ramps!

This is right. I needed to be more clear. Ball has to go down inlane and you have to hit the shot. Catching the ball and shooting doesn't work. Must go past all 3 switches and then have a successful ramp shot. On mine, one side lit way before the other but that may be I nail the left ramp and seem to brick the right a lot.

#17 7 years ago

The game is better without that "feature". Leave it broken.

#18 7 years ago
Quoted from Pimp77:

The game is better without that "feature". Leave it broken.

Strongly agree. If tournament mode disables it I'm excited to try tournament mode.

#19 7 years ago
Quoted from Pimp77:

The game is better without that "feature". Leave it broken.

Eh, I've got one, and I think this might be my favorite feature of the game. When the game can make two or more back to back ramp shots as I take a step back.... perfection!

1 week later
#20 7 years ago

Thanks all, PF is working perfect now, Looks like it had a rom issue, had the boards tested.

2 years later
#21 5 years ago

hi,
i have the same issue on mine. had only right side working.
now it solved thanks to you. never i would thought you needed to succeed the shot and so record it.

does it only work with ramp or you can also hit a loop?

thanks

Promoted items from the Pinside Marketplace
$ 35.00
Cabinet - Other
Arcade Upkeep

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!