(Topic ID: 128232)

MMR Owners Club, all things MMR discussed


By SuperPinball

4 years ago



Topic Stats

  • 4,869 posts
  • 457 Pinsiders participating
  • Latest reply 1 day ago by PtownPin
  • Topic is favorited by 265 Pinsiders

You

Linked Games

Topic Gallery

There have been 592 images uploaded to this topic. (View topic image gallery).

238385DE-4D61-45E6-A1FC-6E69B4EE2406 (resized).jpeg
IMG_4298 (resized).JPG
0EBB2CDF-C0CC-4115-BEAB-5A60471E54D0 (resized).jpeg
52F32CC1-5E75-40B1-8E89-D1E086DC6339 (resized).jpeg
5A3FDCCD-7068-4E71-9208-6E60B939A13A (resized).jpeg
20191218_213207.jpg
20191218_173406 (resized).jpg
20191218_165621 (resized).jpg
DC27E4EE-BB7E-457B-A80F-33F3B5565091 (resized).jpeg
pic1 (resized).jpg
triceratops02.jpg
face off poster simple layers.jpg
sidon dash river layout one.jpg
sandman one.jpg
plane_green_b_w sketch.jpg
oldman_bodies.jpg

Topic index (key posts)

2 key posts have been marked in this topic

Post #1 first pic Posted by SuperPinball (4 years ago)

Post #3445 anti scratch tape Posted by Jarbyjibbo (1 year ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider dluth.
Click here to go back to viewing the entire thread.

#831 3 years ago
Quoted from stangbat:

Regarding the catapult eject being weak, below is what I've found after having my MMR on location for over a year.
Occasionally the moat eject and usually the castle destruct would get weak or quit working. Lately it is the castle destruct coil that gets flaky after 1-2 weeks. I checked connections, repinned connectors, tried various different things and the problem would always come back. I finally figured out the issue, and the same issue could be affecting your catapult strength.
The small driver board that contains the transistors sits on standoffs above the large playfield PCB that has the insert LEDs. Data is passed to the driver board through 0.1" header pins. The pins are on the driver board and push down through a 0.1" socket on the large playfield PCB. The pins are located under the chip that is on the driver board PCB. The solution is to push down and wiggle this connection to make sure you are getting good contact. After doing this my moat problems went away and my castle destruct works fine for a couple weeks but eventually it starts getting flaky again.
I don't have a good picture of what I'm describing, but I did find a pic and I've highlighted the chip that has the connector underneath it. See below.
At some point I'll fix it for good by changing the pins and socket. But right now since the game is on location I raise the playfield every couple of weeks and push/wiggle the connector and the problem goes away. This may not be your problem, but give it a try and see if it helps.

Would turning off the shaker motor help (if you haven't already done this)?

2 months later
#975 3 years ago
Quoted from Lermods:

Joined by the club today...its an LE. Playfield protector, color chip, titan rubber everywhere, lighted star posts. Its a distributor game and I'm told it has some special animations that arent in the stock LE game.

Haven't heard that one before...

7 months later
#1983 2 years ago

I got one in my goody bag!

Quoted from Oldgoat:

This was actually my initial guess, but all looked fine. Now that having been said, after disassembly and reassembly I may have unwittingly adjusted back to the necessary gap. I was not aware there was a tool to set the gap. What's it called and who carries it?
Thanks

1 year later
#3959 8 months ago
Quoted from Mvfvette1:

Video mode is available after completing all 4 inlane/outlanes, 10 times (factory setting). I enjoy playing the video mode, so I currently have the setting at 5 completions to make it available. You need to kill 30 birds to light the extra ball and I have never even come close.

Remember you have a smart bomb.

2 months later
#4050 5 months ago

My right flipper is intermittently dying. When it does, i have done the following tests.
Flipper opto switch: working fine
Flipper coil test: power test fails, hold test works
There is 75V at each lug. The orange and brown wire ones drop to 68V when I press the flipper button. The blue wire one drops to 0V. Same behaviour as the left (working flipper)
When I ground the middle (brown) lug with my DMM to test the voltage and hit the flipper button, the flipper works.
Not sure of the next step???

***edit***
Think I have found the issue...I think the middle lug needs some reflowed solder...when I tested the middle lug again with the DMM the black lead came off the ground, but the flipper still worked. If I took the red lead off the middle lug, it stops working. So I assume the lead on the lug is completing the connection which must be flaky due to the intermittent nature of the problem. So some new solder should fix it I expect.

#4052 5 months ago

Thanks, it was the middle lug...reflowed solder and its good to go. Pic is from before doing this and you can see connection looks a bit sketchy.

Quoted from KozMckPinball:

Check that a holding screw did not come loose, the screw that holds the solenoid bracket. This happened to me, I think the shaker shook it loose. So the solenoid does not move properly up and limits the flipper travel. Just a guess. Although it would not be intermittent in that case.

A3DC49A9-8789-409D-95FC-CFE071CF56C3 (resized).jpeg
Promoted items from the Pinside Marketplace
$ 395.00
Playfield - Toys/Add-ons
M&M Mods
8,400
Machine - For Sale
Houston, TX

You're currently viewing posts by Pinsider dluth.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside