New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 128232)

MMR Owners Club, all things MMR discussed


By SuperPinball

5 years ago



Topic Stats

  • 7,922 posts
  • 605 Pinsiders participating
  • Latest reply 23 hours ago by neverahighscore
  • Topic is favorited by 314 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,340 images uploaded to this topic. (View topic image gallery).

20201202_191702 (resized).jpg
0965E78D-F116-4955-ACDA-4BF8249A92A8 (resized).jpeg
20201129_120606 (resized).jpg
D4A0EA80-C992-46B2-A898-0925C3A9999B (resized).jpeg
CB17862F-F117-414C-8C6B-8BCB55FB94B1 (resized).jpeg
Trollface (resized).JPG
20201125_215552 (resized).jpg
20201125_215605 (resized).jpg
20201124_184422 (resized).jpg
Trollface (resized).JPG
a2c33644c3e880ab6e8e8947c191554916c72508 (resized).jpg
f1facaf75bd6f4895f96af676ae3581433d3c80f (resized).jpg
20201119_094724 (resized).jpg
pasted_image (resized).png
3102E694-C427-4A6E-BB9B-13E4A68B2415 (resized).jpeg
Custom Logo Instructions.pdf (PDF preview)

Topic index (key posts)

5 key posts have been marked in this topic (Show topic index)

There are 7922 posts in this topic. You are on page 133 of 159.
#6601 4 months ago
Quoted from sataneatscheese:

My issue is not resolved. I would strongly encourage you to open a ticket with CGC. https://chicagogamingcompany.freshdesk.com/support/login
I have an earlier model LE from the original run. Number 260. My machine had the 1.0 code on it and I updated directly to 3.0 but couldn't complete the install. It would get to 8x%, say it failed installation, and then upon reboot said it was updated to 3.0 code. Everything works, but I am unsure if I can upgrade it or not. I have done every bit of troubleshooting I can. Factory reset on machine. Battery out power recycle. Downgrading to the 2.2 code that came with my color chip and then re upgrading to 3.0. Trying the memory card write process on multiple memory cards on multiple computers with different disk imager and SD cards with no difference in outcome.
CGC has been responsive, but their latest step is to mail them the controller board and SD card to use. I have not done so as my machine currently works but was debating sending it to them.
However, if I am not the only person with this issue, it is likely a more systemic problem, at least with some older versions of the machine. If multiple people are having the same issue (we are) that would indicate it is now a "problem" and not an "incident". CGC can't approach the problem as a larger issue unless they know multiple folks are having the same problem so I would point you back to opening a ticket. The more people that open the same type of ticket the more likely it is to be resolved in a timely manner.
Here is what CGC replied to my ticket updates, hopefully these may be your issue and it may fix itself:
1. Is the micro-SD card you're using 8 GB (at least) and class 10 (has 10 inside a C symbol)? The link on our Website is to Amazon.com, and what they put there might not be what you need.
2. Older versions of the software have problems. ​Are you getting your software from the link below? https://www.chicago-gaming.com/coinop/medieval-madness/update/latest
3. Please go to our Website and download the software again. I believe it's been updated since you last downloaded it. Be careful to download it to a location where it can't be confused with your previous downloads, as the file name will be the same.
4. I take it your game has been made unplayable by the attempted software update. If you like, you can send your controller board and SD card to us, and we will do whatever it takes to get it working. You would only pay for shipping, unless we have to replace the Beaglebone. ​Please let me know if you'd like to do this, and I will have an RMA number sent to you.
I would like to emphasize that CGC is helping with this and has been reponsive to my tickets, but it is still not resolved. I hold no ill will towards CGC, am simply trying to pass along what I know and have been told, and have no idea if the upgrades will work with the installation in this state.
Once again as is my machine works 100% and the game as a whole is awesome.

Bummer. I'm heading out of town for a week and a half but I'll open a ticket when I return. For reference, my machine (#126) was on 2.xx code when I initially tried the 3.0.0 update, I've been running color for several years and I don't have any of the 'new' upgrades installed. I don't know how far the first update got because I left the room and returned to the error on the screen. Subsequent updates have failed in the mid-90%.

#6602 4 months ago

My MMrRe plays great, but there is a "buzz" when the sound is playing. I only have the sound set to 5 or 6. Is this normal? Is there an easy fix?

#6603 4 months ago
Quoted from CaptainRedEye:

My MMrRe plays great, but there is a "buzz" when the sound is playing. I only have the sound set to 5 or 6. Is this normal? Is there an easy fix?

Please check this. If it is audio related. I would check the wires going to the lower right side of the beagle board in the back box for the speakers. On my MMR they were cable tied to other wires. I separated them and put one of these on the audio wires -
clip on ferrite ring core RFI EMI noise suppressor cable clip. You can find them on Amazon, Ebay, etc. etc.

LTG : )

#6604 4 months ago

Here is the Mantis *Edit* (castle protector). I didnt feel like I needed both kits but the Mantis protector for this spot protects a wood chipping machine. I have one of the Mantis pieces and here it is. Really don't like the second screw hole on the left. I don't want to drill the top side of my playfield so will leave as is. May glue the head of a screw there so it looks right.

#6605 4 months ago
Quoted from sataneatscheese:

Here is the Mantis moat jump install. I didnt feel like I needed both kits but the Mantis protector for this spot protects a wood chipping machine. I have one of the Mantis pieces and here it is. Really don't like the second screw hole on the left. I don't want to drill the top side of my playfield so will leave as is. May glue the head of a screw there so it looks right.

That's not the Mantis Moat Jump, it's the Mantis castle protector. The Mantis Moat Jump protects the hole like the Cliffy Moat Jump that complements it.

#6606 4 months ago
Quoted from KozMckPinball:

That's not the Mantis Moat Jump, it's the Mantis castle protector. The Mantis Moat Jump protects the hole like the Cliffy Moat Jump that complements it.

Fixed. I call it the moat jump in the video but it's the Mantis Castle protector. The naming convention on these are confusing.

#6607 4 months ago
Quoted from sataneatscheese:

Fixed. I call it the moat jump in the video but it's the Mantis Castle protector. The naming convention on these are confusing.

So if you drill a hole to attach the castle protecter i assume you use a flat headed screw? Do they provide you with that screw or know what size?. By not having a screw in there, does the ball get hung up or divert because of the bevel hole is empty as its missing the screw?

#6608 4 months ago
Quoted from bent98:

So if you drill a hole to attach the castle protecter i assume you use a flat headed screw? Do they provide you with that screw or know what size?. By not having a screw in there, does the ball get hung up or divert because of the bevel hole is empty as its missing the screw?

It came with no instructions and no screw, but I did special order just this one part. I don't see a way for the ball to get hung up on the hole.

#6609 4 months ago

Just pick a flat headed screw that sits flush in the hole. Drill a pilot hole using a drill bit that's much smaller than the screw. I also put a piece of 3m clear mylar over the protector . Btw, I've used this protector on 2 previous original MM's and never had the screw turn out or come loose. Do the job right and you'll have no issues.

#6610 4 months ago

I did not drill a hole for teh left screw, but uses a clear tape all around the left side of the protector and the left castle plate below the flap, which fixes the protector sufficiently together with the right screw. No need to use a second screw at the left side. Works for years now.

#6611 4 months ago

Humm
I order the whole mantis kit . IS there overlaps for castle protector with what I got on my Cliffy?

#6612 4 months ago

So I just got my Mantis full protector set. Through the instructions, Ive identified all parts except for these two. What are they for? Do I need them If I have the cliffys installed?

https://mantispinball.com/wp-content/uploads/installation-mm-protectors.pdf

IMG_3547 (resized).jpg
#6613 4 months ago

MMR XL Display Speaker coat of arms
mirror acryl

IMG_2472 (resized).jpegIMG_2473 (resized).jpegIMG_2474 (resized).jpegIMG_2475 (resized).jpegIMG_2476 (resized).jpeg
#6614 4 months ago

Are you going to add for MMR SE/RE?

#6615 4 months ago
Quoted from bent98:

Are you going to add for MMR SE/RE?

what do you mean?
this is the panel with XL display like MMR royal edition

#6616 4 months ago
Quoted from CaptainRedEye:

My MMrRe plays great, but there is a "buzz" when the sound is playing. I only have the sound set to 5 or 6. Is this normal? Is there an easy fix?

I have that same kind of buzz or extra base at the end of ball - it is kind of annoying - not sure if same thing though

#6617 4 months ago

Anyone know what size the rubbers are above the slingshots on the left and right side. Is it 1.5 and 1in rubber on the right?

Thanks

#6618 4 months ago
Quoted from Gumby510:

Anyone know what size the rubbers are above the slingshots on the left and right side. Is it 1.5 and 1in rubber on the right?
Thanks

https://www.titanpinball.com/kits/index.php/browse/bygame/3056

#6619 4 months ago

I didn’t go by that because it was written 2in and 1in in front of the catapult. These are behind it. Just wanted to confirm before I order.

#6620 4 months ago
Quoted from bent98:

So I just got my Mantis full protector set. Through the instructions, Ive identified all parts except for these two. What are they for? Do I need them If I have the cliffys installed?
https://mantispinball.com/wp-content/uploads/installation-mm-protectors.pdf
[quoted image]

Anyone know?

#6621 4 months ago

Pretty sure it's the catapult hole and the castle hole behind the castle.

#6622 4 months ago

Its the Mantis Moat Jump and the Mantis Moat Eject protectors. This information is already here in the thread. There's a video showing the Mantis Moat Jump install and my picture of the installed Mantis Moat Eject. Just read the posts that are already here.

#6623 4 months ago

Cliffy Drain Hole Protector Installation

*Note, this did not come with the original set I ordered. Cliffy mailed me this gratis (thanks!) after I sent him a link to the other install videos. You can request these in your kit but newer MMRs come with a protector from the factory.

#6624 4 months ago

Got a question that I could not answer for someone asking me about MM- is there an "Adult Mode" in the new MMr? Has there ever been an adult chip for MM? I have never heard of one.

"I'm Howard Hurtz who the **** are you?" Comes to mind.

#6625 4 months ago
Quoted from Cobray:

Got a question that I could not answer for someone asking me about MM- is there an "Adult Mode" in the new MMr? Has there ever been an adult chip for MM? I have never heard of one.

"I'm Howard Hurtz who the **** are you?" Comes to mind.

Yes there is. Adult on you get Howard Hurtz bleeped. Off you don't get the Howard Hurtz line.

For the original MM there is a hacked ROM that unbleeps the **** and has the swear word. MMR doesn't have ROMs.

LTG : )

#6626 4 months ago

You can alter the firmware to enable profanity mode. It's just the one call-out though.

#6627 4 months ago

Learn something new every day. Thanks!!

#6628 4 months ago

Cliffy Ejector Shooter Lane Installation

*Note, this did not come with the original set I ordered. Cliffy mailed me this gratis (thanks!) after I sent him a link to the other install videos.

#6629 4 months ago
Quoted from CaptainRedEye:

My MMrRe plays great, but there is a "buzz" when the sound is playing. I only have the sound set to 5 or 6. Is this normal? Is there an easy fix?

The buzz I occasionally hear in my SE is actually the glass sitting in the track and vibrating.

#6630 4 months ago
Quoted from KozMckPinball:

Its the Mantis Moat Jump and the Mantis Moat Eject protectors. This information is already here in the thread. There's a video showing the Mantis Moat Jump install and my picture of the installed Mantis Moat Eject. Just read the posts that are already here.

I assume i dont need them if I have the cliff protector set. correct?

#6631 4 months ago
Quoted from bent98:

I assume i dont need them if I have the cliff protector set. correct?

Having just installed cliffys the one piece that is still unprotected by it is the moat jump piece. You want something protecting the wood on top of the playfield in front of the castle door. It is one of the first areas to show wear. I put a mantis on that spot. I did not get the full set.

#6632 4 months ago
Quoted from KozMckPinball:

I installed the Mantis protector in the castle moat jump hole last night. I have about 750 games on my MMR and could already see some clear cracking and a tiny bit of edge wear on the playfield wood straight back from where the ball enters that castle ball lock entrance. I agree that this is an essential protector for MM/MMR. Lots of disassembly required though, on the underside where the mantis goes, VUK mech has to come off ( 3 wood screws), to get that off, loosen a small circuit board to get the 3rd VUK screw out, have to unscrew 4 wiring harness ties, disconnect 3 wire connectors to FL72, SW37 and SW41 and then remove the moat by taking out 7 screws and disconnecting the moat wire connector. Have to loosen one of the L brackets where one of the wiring harness ties goes in as it interferes with one of the Mantis screws, which there are 3 of in total. Took me all of the late Monday Night football game Broncos/Chargers, I figure 3.5 hours. The Cliffy moat jump protects the same area of wood that Mantis does and also protects the moat plastic itself, which the Mantis does not. I agree that that Cliffy moat jump might not be essential, top dis-assembly seems difficult to get it in anyway. The moat assembly if it gets cracked would cost about $85, but could be replaced.

I found the post you made., Looks like you the mantis castle moat jump and and the Mantis Moat Eject protectors needed and can work with the cliffy moat jump. You mentioned a video of that install. I couldn't find it.

also, do i need the eject protector or does the cliffy one take its place?

I wish I had a picture of video as it gets confusing as how those mantis work with the cliffy. I want to install but want to make sure i do everything and not have to do extra work.

#6633 4 months ago

Can someone tell me what voltage the spotlight LED's are that are on each side of the castle. Does it matter that I have a royal edition which has the RGB GI. Those bulbs look to be 1 color, just white, so I assume they are 6.3V wedge style?

#6634 4 months ago
Quoted from Quint_of_Dust:

The buzz I occasionally hear in my SE is actually the glass sitting in the track and vibrating.

I get a glass vibrating buzz and a tranalite speaker panel buzz. Usually can get it to go away by moving them slightly. But doesn't last long.

#6635 4 months ago
Quoted from bent98:

Can someone tell me what voltage the spotlight LED's are that are on each side of the castle. Does it matter that I have a royal edition which has the RGB GI. Those bulbs look to be 1 color, just white, so I assume they are 6.3V wedge style?

It would probably be quicker for you to just use a voltmeter and find out...

#6636 4 months ago

About how long is Cliffy behind on shipping for those who recently ordered a set?

In all fairness to Cliff he told me he's backed up, just curious how long others have waited recently since he wouldn't commit to a time frame? Tks.

#6637 4 months ago
Quoted from Westsiderkg:

About how long is Cliffy behind on shipping for those who recently ordered a set?
In all fairness to Cliff he told me he's backed up, just curious how long others have waited recently? Tks.

Ordered May 31st. Mailed to me June 19th.

#6638 4 months ago

I just received my Medieval madness MMrREThe speakers on the back box are not playing any sound. It was at first and then just went out. I checked out all the connections and all were fine and none were loose. Music is still playing but only coming from the sub woofer. Please Help!

#6639 4 months ago
Quoted from Westsiderkg:

About how long is Cliffy behind on shipping for those who recently ordered a set?
In all fairness to Cliff he told me he's backed up, just curious how long others have waited recently since he wouldn't commit to a time frame? Tks.

i just ordered some items and he told me 3-4 weeks. Not a biggie just need to be patient and we will all get them.

#6640 4 months ago

Update to my previous post about the back box speakers. When you turn the game on the initial bing that you get does come through those speakers but the game music does not.

#6641 4 months ago
Quoted from izboy:

I just received my Medieval madness MMrREThe speakers on the back box are not playing any sound. It was at first and then just went out. I checked out all the connections and all were fine and none were loose. Music is still playing but only coming from the sub woofer. Please Help!

I kicked your ticket up to the engineer.

LTG : )

#6642 4 months ago
Quoted from zpinman370:

i just ordered some items and he told me 3-4 weeks. Not a biggie just need to be patient and we will all get them.

Cool, tks. Still learning patience everyday!

#6643 4 months ago
Quoted from zpinman370:

I have that same kind of buzz or extra base at the end of ball - it is kind of annoying - not sure if same thing though

Just a quick follow up to this post.

Upon further investigation it appears it was more the back glass rattling from the speaker base at the end of ball. I took some black electrical tape and ran two strips along the top and bottom and this made a nice difference on the hum

#6644 4 months ago
Quoted from zpinman370:

Just a quick follow up to this post.
Upon further investigation it appears it was more the back glass rattling from the speaker base at the end of ball. I took some black electrical tape and ran two strips along the top and bottom and this made a nice difference on the hum

I have the same buzz. I am kind of a newbie so please forgive my ignorance. When you said back glass do you mean the image in the back box and if not and you meant the play field glass and you say top and bottom you are referring to the short sides correct?

#6645 4 months ago
Quoted from izboy:

I have the same buzz. I am kind of a newbie so please forgive my ignorance. When you said back glass do you mean the image in the back box and if not and you meant the play field glass and you say top and bottom you are referring to the short sides correct?

Yes, the backglass is the vertical glass with the artwork on the face of the backbox. In this case, he means the long edges of that piece.
If the playfield glass were rattling in the track, anti-rattle tape would go in the tracks on the long sides.

#6646 4 months ago

I installed the cliffy Merlin protector but the mantis one didn't work out. WTF

I was able to install mantis protector by drilling pilot holes and installed the screws from underneath but the protector mount prevented me from installing the Merlin eject assembly .In the picture (red arrow), the the Merlin assembly mounting holes don't to line up because the mantis plate (yellow arrow) prevents the Merlin asserbmly from going to the far left. If you look at the play field top view (last pic) you see the Merlin black arched metal piece is not centered with the hole but instead, all the way to the left. Is that supposed to be that way?

install (resized).JPGmmr (resized).jpgtop view (resized).JPG

#6647 4 months ago
Quoted from bent98:

I found the post you made., Looks like you the mantis castle moat jump and and the Mantis Moat Eject protectors needed and can work with the cliffy moat jump. You mentioned a video of that install. I couldn't find it.
also, do i need the eject protector or does the cliffy one take its place?
I wish I had a picture of video as it gets confusing as how those mantis work with the cliffy. I want to install but want to make sure i do everything and not have to do extra work.

I seem to be describing the Cliffy Moat Jump and Mantis Moat Jump not the Mantis Moat Ejector. The Mantis Moat Ejector needs a screw and I have a picture of it in one of my recent posts here. The Cliffy on the Moat Edge is just press on contact and in a different location than the Mantis Moat Ejector.

As far as the Moat Jump install, the recent videos are what you need to look at, if he did it in 45 minutes he did far less disassembly than I did. The Cliffy would require the least disassembly, in relation to the Mantis. However, the Cliffy Moat Jump protects the moat plastic from a ball dropping through the hole and for that is important to have in there. Cracking the moat plastic it seems is an $85 part plus shipping cost.

For

#6648 4 months ago
Quoted from bent98:

I installed the cliffy Merlin protector but the mantis one didn't work out. WTF
I was able to install mantis protector by drilling pilot holes and installed the screws from underneath but the protector mount prevented me from installing the Merlin eject assembly .In the picture (red arrow), the the Merlin assembly mounting holes don't to line up because the mantis plate (yellow arrow) prevents the Merlin asserbmly from going to the far left. If you look at the play field top view (last pic) you see the Merlin black arched metal piece is not centered with the hole but instead, all the way to the left. Is that supposed to be that way?
[quoted image][quoted image][quoted image]

I mentioned this in my previous posts. The Merlin actuator bracket sits in a recessed spot that has to be considered when installing the Mantis Merlin.

#6649 4 months ago
Quoted from KozMckPinball:

The other thing about the Mantis Merlin protector. The scoop hole is round, unlike the castle moat jump hole that is rectangular. Being a round hole, the protector can be rotated 360 degrees, and the position has to be figured out and hole location marked, then drilled. It is not a discrete position like the other protectors and this is important. Find the spot in the Merlin hole by rotating the protector around until it does not interfere with playfield mechs/parts. The Merlin solenoid bracket has to be removed to get the protector in, and you have to be aware that the solenoid bracket sits in a recessed spot in the playfeld, offset to the Merlin hole, when finding the right position for the Mantis Merlin protector. A video would be better for sure, but in my case, I've already done the work long ago. One other important note, the Mantis Merlin if positioned height-wise to the playfield is too high, there will be a lip that causes ball rejects. This can happen if the protector is bent before install.

My previous comments, post #6587, about the Merlin actuator bracket...

#6650 4 months ago
Quoted from KozMckPinball:

My previous comments, post #6587, about the Merlin actuator bracket...

I dont see how thats possible since the bracket is half moon. ITs not a 360 degree round hole protector. The position that i installed it was the only option. If you try to rotate the protector, the lip of the protector on the Merlin hole on the playfield side would change and there fore not be protected. can you share with me in the position of the bracket. Talk in terms of o'clock position. If you can provide a picture of yours atleast from the playfield side, it might clear things up for me.

looking at the Mantis instructions, https://mantispinball.com/wp-content/uploads/installation-mm-protectors.pdf
It doesnt look like the machine in the picture has that Black metal Arch that is attached to my merlin eject assembly. That is what is preventing me from installing the assemble back because it interferes with the bracket. Do you have that on yours?

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 279.95
Lighting - Led
Pin Stadium Pinball Mods
There are 7922 posts in this topic. You are on page 133 of 159.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside