(Topic ID: 128232)

MMR Owners Club, all things MMR discussed


By SuperPinball

5 years ago



Topic Stats

  • 6,671 posts
  • 563 Pinsiders participating
  • Latest reply 2 hours ago by PtownPin
  • Topic is favorited by 298 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,016 images uploaded to this topic. (View topic image gallery).

IMG_2578 (resized).JPG
IMG_2497 (resized).JPG
MM-PreProPF (2) (resized).jpg
s-l400 (resized).jpg
unixporn (resized).png
desktop (resized).jpg
IMG_3569 (resized).jpg
merlin (resized).JPG
install (resized).JPG
top view (resized).JPG
mmr (resized).jpg
IMG_2472 (resized).jpeg
IMG_2473 (resized).jpeg
IMG_2475 (resized).jpeg
IMG_2474 (resized).jpeg
IMG_2476 (resized).jpeg

Topic index (key posts)

5 key posts have been marked in this topic (Show topic index)

There are 6671 posts in this topic. You are on page 115 of 134.
#5701 75 days ago

great video, I can hardly wait

#5702 75 days ago

Whoa! It looks amazing!! Cannot wait!!!

Congrats. Be great to get some feedback on the gameplay experience of the Royal Edition?

#5703 74 days ago

Yay today is the day! Royal to arriave

#5704 74 days ago

My Royal arrived this morning and was finished getting setup about an hour ago! This will help to deal with the isolation. Played multiple games already and couldn't be more glad to have it.

#5705 74 days ago

Congrats to you new RE owners!
If you want to be included on the tracking thread I started please post your info and serial here:

https://pinside.com/pinball/forum/topic/mmrre-tracking-thread#post-5610369

Thanks

#5706 74 days ago
Quoted from IonRay:

My MMR Royal showed up yesterday! Made a quick video on the unboxing and setup.

Fantastic! I wish I could give you more than one thumbs up for this

#5707 74 days ago

Did CGC go to original white style castle inserts on the RE models? this screen grab from the video makes them look white not clear like early MMr.. also most of us have owned MM in the past, for those that have received their MM Royal does it feel like the extra $$ was worth it?

A5A194CF-A022-41C4-94DE-F6F17DCAB767 (resized).png
#5708 74 days ago
Quoted from Concretehardt:

Did CGC go to original white style castle inserts on the RE models?

MM had clear, ( I just checked mine ) MMR has clear, MMR Royal has clear.

LTG : )

#5709 74 days ago

Yes.
Remember that back when MM was being made, there was a milky clear put over the field - for some reason. I'm not clear why. But this layer that went down before any ink made clear inserts LOOK 'white'.

#5710 74 days ago
Quoted from Coyote:

Yes.
Remember that back when MM was being made, there was a milky clear put over the field - for some reason. I'm not clear why. But this layer that went down before any ink made clear inserts LOOK 'white'.

Interesting! Any thoughts on why this was done on Williams games LTG?

#5711 74 days ago
Quoted from Concretehardt:

Any thoughts on why this was done on Williams games LTG?

No. Mine didn't have it. I had an early one.

LTG : )

#5712 74 days ago

Can someone with a Royal Edition attempt to load a custom logo? I've tried several times with no success, even re-imaged by machine and using the same SD card tried again. The error I get is 'unable to mount SD card'.

I've been working with CGC but because of stay at home policies they are unable to test so I thought I would ask here if someone could give it a go. Thanks!

#5713 74 days ago
Quoted from Multiballmaniac1:

I’d buy a MMr SE but it’s not worth 9300. The upcoming major recession might help pricing.

Well in a total reversal I just bought a MMr Royal Edition 15 minutes ago. Probably comes next week. No sleep tonight.

#5714 74 days ago
Quoted from jcoble:

Just got called by Fedex Freight that mine is on the way! Thanks to Zach at Flip-N-Out!

Mine too. Luckily caught today’s FedEx call. My phone sends their local distribution center straight to voicemail for some reason and apparently this was my last call before they were going to ship it back!

Arrives Monday.

#5715 74 days ago
Quoted from Multiballmaniac1:

Well in a total reversal I just bought a MMr Royal Edition 15 minutes ago. Probably comes next week. No sleep tonight.

Wow that was fast!

#5716 74 days ago
Quoted from Multiballmaniac1:

Well in a total reversal I just bought a MMr Royal Edition 15 minutes ago. Probably comes next week. No sleep tonight.

Good choice!

#5717 74 days ago

Thanks.

#5718 74 days ago
Quoted from jarozi:

Can someone with a Royal Edition attempt to load a custom logo? I've tried several times with no success, even re-imaged by machine and using the same SD card tried again. The error I get is 'unable to mount SD card'.

I don't have the Royal, but the new SE has the same screen and I was able to easily load a custom logo once I figured out the proper way to export a BMP image on a Mac.

"Unable to mount" seems like a formatting issue on the SD card. Perhaps try a different method format the SD card?

#5719 74 days ago
Quoted from Concretehardt:

Wow that was fast!

I just said f$ck it. Only here once.

#5720 74 days ago

Mine came! It has a ding. I’m sad. They offered decals, but who realistically ever installs those? I’ll touch up with orange paint and probably never notice it again. The upgrades are super sweet and game plays great right out of the box! This weekend will install Cliffies, custom painted castle & dragon and install titans. Probably purple titans but with the color changing GI might decide on clear.
C6E912F1-8451-4BAA-81A3-E4F4E9AFCAED (resized).jpeg

#5721 74 days ago
Quoted from WackyBrakke:

Mine came! It has a ding. I’m sad. They offered decals, but who realistically ever installs those? I’ll touch up with orange paint and probably never notice it again. The upgrades are super sweet and game plays great right out of the box! This weekend will install Cliffies, custom painted castle & dragon and install titans. Probably purple titans but with the color changing GI might decide on clear.
[quoted image]

I went with clear it looks Awesome with the color changes. Looks like a laser band.

#5722 74 days ago

Checking in to see if people have issues with their Royal. It seems my right troll only registers hits about a quarter of the time.

Hitting Merlins Magic seems to go through and veer off the kick plate to the right with out every registering.

Anyone had anything similar?

Rob

#5723 74 days ago

My screen has a goofy flickering line through it. Ugh my royal is a lemon

#5724 74 days ago
Quoted from WackyBrakke:

My screen has a goofy flickering line through it. Ugh my royal is a lemon

Reseat the video cable and see if it helps.

#5725 74 days ago

Got the call a couple hours ago that I've been waiting on for months. My Royal will be delivered Sunday morning - thanks to Phil at Arcades at Home!

#5726 74 days ago
Quoted from pintechev:

Reseat the video cable and see if it helps.

Ok! Will do! Thx

#5727 74 days ago
Quoted from robnotto:

Hitting Merlins Magic seems to go through and veer off the kick plate to the right with out every registering.

Lower flipper strength.

Quoted from robnotto:

It seems my right troll only registers hits about a quarter of the time.

There is a leaf blade switch involved. Long front blade hooked to troll face. Shorter rear blade needs to be bent a tiny bit closer so the slightest ball hit triggers it but vibration going up doesn't.

LTG : )

#5728 74 days ago
Quoted from pintechev:

Reseat the video cable and see if it helps.

No luck :-/ I’ll wait and see what CGC says. Might be a bad board or screen.

#5729 74 days ago
Quoted from WackyBrakke:

No luck :-/ I’ll wait and see what CGC says. Might be a bad board or screen.

If you have another CGC game, swap the HDMI and see if the issue moves with the cable.

#5730 74 days ago
Quoted from Concretehardt:

Did CGC go to original white style castle inserts on the RE models? this screen grab from the video makes them look white not clear like early MMr.. also most of us have owned MM in the past, for those that have received their MM Royal does it feel like the extra $$ was worth it?
[quoted image]

MMrSE are clear.

20200227_154919 (resized).jpg
#5731 74 days ago
Quoted from robnotto:

Checking in to see if people have issues with their Royal. It seems my right troll only registers hits about a quarter of the time.
Hitting Merlins Magic seems to go through and veer off the kick plate to the right with out every registering.
Anyone had anything similar?
Rob

My right troll on my MMrSE needed a direct impact to register. Made some small adjustments to the switch and it is better, but still not as good as the left troll. My slings switches also needed to be adjusted as they would at times fire even when the ball bounced off the rubber of the inlanes.

#5732 73 days ago
Quoted from TimBoch:

My right troll on my MMrSE needed a direct impact to register. Made some small adjustments to the switch and it is better, but still not as good as the left troll. My slings switches also needed to be adjusted as they would at times fire even when the ball bounced off the rubber of the inlanes.

What should should the approximate gap be? Or is it just adjust it put it back together, test, tear down and repeat?

Thanks this is a great site, hope to contribute back some day.

#5733 73 days ago
Quoted from robnotto:

Or is it just adjust it put it back together, test, tear down and repeat?

Why tear it apart.

I'd put a cloth down to protect the playfield. Pull the troll mech up and grab the side of the carriage in the jaws of a vice grip. So it can't fall back down into the playfield. Then adjust the rear blade with a point ( leaf blade ) bender or flat nosed pliers. Adjust as close to the fiberboard spacers of the leaf blades as you can.

The remove the vise grip and lower the troll mech back down.

Try a game or two. A tweak or two and you should be good to go.

LTG : )

#5734 73 days ago
Quoted from default_user:

I don't have the Royal, but the new SE has the same screen and I was able to easily load a custom logo once I figured out the proper way to export a BMP image on a Mac.
"Unable to mount" seems like a formatting issue on the SD card. Perhaps try a different method format the SD card?

I've tried 3 SD cards now, formatted FAT32 on Windows and Mac, confirmed my image meets the criteria. Every time I get "could not mount SD card".

Can you confirm your OS version? Mine is 3.0.0 BETA 3. Thanks again.

#5735 73 days ago
Quoted from LTG:

grab the side of the carriage in the jaws of a vice grip.

Like in these pictures.

LTG : )

DSC00231 (resized).JPGDSC00232 (resized).JPG
#5736 73 days ago
Quoted from LTG:

Why tear it apart.
I'd put a cloth down to protect the playfield. Pull the troll mech up and grab the side of the carriage in the jaws of a vice grip. So it can't fall back down into the playfield. Then adjust the rear blade with a point ( leaf blade ) bender or flat nosed pliers. Adjust as close to the fiberboard spacers of the leaf blades as you can.
The remove the vise grip and lower the troll mech back down.
Try a game or two. A tweak or two and you should be good to go.
LTG : )

Yes worked out. Thanks for your help again! Stay safe, healthy and sane!

#5737 73 days ago
Quoted from TimBoch:

My slings switches also needed to be adjusted as they would at times fire even when the ball bounced off the rubber of the inlanes.

My left sling was self triggering a bit. Minor adjustments to the switches fixed it.

#5738 73 days ago
Quoted from jarozi:

Can someone with a Royal Edition attempt to load a custom logo? I've tried several times with no success, even re-imaged by machine and using the same SD card tried again. The error I get is 'unable to mount SD card'.
I've been working with CGC but because of stay at home policies they are unable to test so I thought I would ask here if someone could give it a go. Thanks!

I have the same issue. To test my card, I successfully loaded the logo on my MBr. That test seems to indicate there's an issue in MMrRE software.

#5739 73 days ago
Quoted from jarozi:

Can you confirm your OS version? Mine is 3.0.0 BETA 3. Thanks again.

3.0.0 BETA 1 (Jan 15, 2020)

#5740 73 days ago
Quoted from Oscilated:

I have the same issue. To test my card, I successfully loaded the logo on my MBr. That test seems to indicate there's an issue in MMrRE software.

Quoted from default_user:

3.0.0 BETA 1 (Jan 15, 2020)

Thanks guys, based on this I'm going to assume it's a possible bug in BETA 3. I've reported all this info to CGC via my support ticket.

#5741 73 days ago

I had a few issues trying to get a custom logo loaded. Saw the same messages at different times. Not sure why it worked sometime and not at others. The only strange thing I’ve not been able to fix is that my date and time don’t update when the machine is off. I took the battery out and saw a lot of sticky residue on it and in the battery slot. Replaced the battery and the new one got sticky residue. Cleaned the slot with isopropyl and still no luck. Arturo asked that I reinstall 3.0 beta. I bought a new SD card yesterday. My only concern is I’ll lose my scores and achievements. Ironically, those stay even though the date and time don’t. Must use different memory?

5D40E6A4-488F-410E-9DE0-C6B0E8E55CAB (resized).jpeg09120941-9B04-4344-A430-EE6B484EB4DF (resized).jpeg98828BEB-F4E0-4CF8-BBC8-697A7C976BEE (resized).jpeg
#5742 73 days ago
Quoted from TimBoch:

I had a few issues trying to get a custom logo loaded. Saw the same messages at different times. Not sure why it worked sometime and not at others. The only strange thing I’ve not been able to fix is that my date and time don’t update when the machine is off. I took the battery out and saw a lot of sticky residue on it and in the battery slot. Replaced the battery and the new one got sticky residue. Cleaned the slot with isopropyl and still no luck. Arturo asked that I reinstall 3.0 beta. I bought a new SD card yesterday. My only concern is I’ll lose my scores and achievements. Ironically, those stay even though the date and time don’t. Must use different memory?
[quoted image][quoted image][quoted image]

Interesting. I have this on my MB....won't save date and time, however, saves the scores and what not....

#5743 73 days ago
Quoted from LTG:

Like in these pictures.
LTG : )
[quoted image][quoted image]

Thanks for the advice Lloyd, took care of my stubborn right troll this morning using your vice technique. Now the trolls are (slightly) less obnoxious to battle.

#5744 73 days ago

I've got a persistent issue with my right flipper sticking. I can't figure out the issue. Maybe the button is catching up on some wiring connector? Its an odd intermittent issue.

#5745 73 days ago
Quoted from pinfarmer:

Maybe the button is catching up on some wiring connector? Its an odd intermittent issue.

Start eliminating stuff. Remove the flipper button and clean it with Windex, 409, stuff like that. Rinse thoroughly and dry. Try that.

Next I'd suspect the opto interrupter isn't always closing the opto going back in and the flipper stays up. A small piece of black electricians tape on it would help sort that out.

LTG : )

#5746 72 days ago

I've been having a consistent problem from day one with my new RE. The ball continually gets hung up on the lip of the protector at the drain. Today I got fed up with it and decided to fix it. See the pictures I've attached. I used a round file to grind the protector's edge down so it no longer sticks up. Now it works fantastic. Just thought I would share if anyone else is having the same issue.

20200503_114039 (resized).jpg20200503_114659 (resized).jpg20200503_115605 (resized).jpg20200503_115849 (resized).jpg
#5747 72 days ago
Quoted from imagamejunky:

I've been having a consistent problem from day one with my new RE.

Nice!

Robert

#5748 71 days ago
Quoted from imagamejunky:

I've been having a consistent problem from day one with my new RE. The ball continually gets hung up on the lip of the protector at the drain. Today I got fed up with it and decided to fix it. See the pictures I've attached. I used a round file to grind the protector's edge down so it no longer sticks up. Now it works fantastic. Just thought I would share if anyone else is having the same issue.
[quoted image][quoted image][quoted image][quoted image]

Good idea.

#5749 71 days ago

My Royal was shipped last Friday, May 1st. I just got off phone with ABS freight this morning, May 4th.

The phone rep says the following, 'Unfortunately, we are too booked up to deliver your item tomorrow and the earliest we can deliver it to you is Monday, May 11th between 9am-6pm.'

Another week of waiting.

#5750 71 days ago
Quoted from evh347:

My Royal was shipped last Friday, May 1st. I just got off phone with ABS freight this morning, May 4th.
The phone rep says the following, 'Unfortunately, we are too booked up to deliver your item tomorrow and the earliest we can deliver it to you is Monday, May 11th between 9am-6pm.'
Another week of waiting.

I wouldn't wait a week. Find out where it is and go pick up your game. That's exactly what I did.

Promoted items from the Pinside Marketplace
$ 98.00
Playfield - Other
ModFather Pinball Mods
$ 89.99
8,495
Machine - For Sale
Milford, CT
From: $ 19.50
There are 6671 posts in this topic. You are on page 115 of 134.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside