(Topic ID: 65921)

Missing voltage on Bally 2518 power module


By brad808

6 years ago



Topic Stats

  • 12 posts
  • 4 Pinsiders participating
  • Latest reply 6 years ago by viperrwk
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

power.png
power assembly.png

#1 6 years ago

So I have a baby pacman game that I've never had boot up. When I first got the game it had the main fuse blown. I replaced that and tried to start the game, the mpu wouldn't go through the boot sequence (led stuck on). I tried a different mpu and still led stuck on.

I'm looking at the power now and tested the transformer, all tests good. On the rectifier board (as-2518-132) test pins 1 and 2 have no voltage, all others test fine. I could use a couple hints as to where I should be testing and what I should be looking for. I've tested with the connectors both connected and unplugged and still no voltage at those pins.

Thanks for any help that can be given.

power assembly.png

#2 6 years ago

I can't read the schematic. Too blurry to be sure where the Test Points are.

I'll venture a guess -
Looks like TP2 is on the output side of a bridge rectifier constructed of diodes CR1, CR2, CR3, and CR4 - check these diodes for continuity.
Looks like TP1 is on the output side of bridge rectifier BR1 - check this rectifier for continuity

#3 6 years ago

Fanatic is correct. Check the two bridges. One rectification is done by four 1n4004 diodes, the other is in a single package BR1.

If you are unsure how to test a bridge with your DMM, watch some youtube videos. It is a simple test to do.

#4 6 years ago

Those voltages are not used in Baby Pac. TP2 is HV for plasma displays. TP1 is for controlled lamps which are handled on the AC in Baby Pac. That's why they are not connected in the schematic (see image.) This board doesn't usually have issues in Baby Pac. Your problem is likely battery corrosion on the Vidiot board. You need to check the ROM sockets below the MPU on the Vidiot and the connectors between the boards as well. The -107 driver board can use the same upgrades as the regular Bally driver (save for the HV obviously.)

viperrwk

power.png

#5 6 years ago

Thanks for the helps guys, someone on another forum made me wise to the fact that both of those voltages go unused in this game so I may be searching for a problem in the wrong place... Back to the old drawing board I guess.

#6 6 years ago

Thanks Viper. I was hoping it wasn't the mpu because I had bought a second one that was supposed to be working. It's possible that I was sold a dud though. Guess I'll have to do some more troubleshooting on it.

#7 6 years ago

Baby Pac is a bear to get working correctly. The only board I didn't have to do anything to in mine is the rectifier board. I still need to change the pots on the Vidiot as I lose the blue adjust occasionally. Also be sure to adjust the drops to make sure they are flush with the playfield otherwise damage will happen.

viperrwk

#8 6 years ago

That's not what I want to hear haha, I always seem to get the games that are notoriously hard to fix .

So I've hooked it all back up and checked the test pins on the mpu.

TP1 - 1.65 Volts (Should be 5)
TP2 - 16.6 Volts (Should be 11.9)
TP3 - 4.95 Volts (Should be 21.5)
TP4 - Ground
TP5 - 1.65 Volts (Should be 5)

I then checked connector J4 which is the power going into the mpu, pins 16 and 17 should be +5 and they are at 1.41. So I'm guessing a problem between the rectifier board and the mpu maybe?

#9 6 years ago

I think I'm getting closer, it appears j4 on the mpu pulls power from j8 on board a3 (voltage regulator, solenoid driver board). All test pins in that board are also reading low (1.7 volts or so) but should be at 5v. Hmm I get deeper down the tunnel...

#10 6 years ago

You should see the same voltage at TP3 on the rectifier board (12-14VDC) as you do at TP1 on the lamp/solenoid board. That voltage then gets regulated to 5v on the driver board. You test that at TP2 on the lamp/solenoid board. You should be seeing 5VDC+/- .25v there. I wound up changing LOTS of connectors and plugs to get all the correct voltages where they needed to be. It chains to a lot of places in this machine. But you'll never get it working correctly if the power isn't working properly everywhere.

viperrwk

#11 6 years ago

Thanks again Viper. I'm getting 16 volts at TP1 on the Solenoid Driver board. 1.6v at TP2. It seems as though it should be changing from 16v to 5v at q41 (with the huge heatsink) as far as I can see on the schematics. Does my testing seem right? What should I be testing/replacing q41 with?

#12 6 years ago

I would change the big cap at C2 (and C4 while you're at it) and see if it makes a difference. C2 is probably shot. I don't know which device is installed in your board but chances are it can't handle the ripple. If after changing C2 you still don't have 5v, just change Q41 - LM323K.

I'll dig out my notes and parts list and PM you later so you can piece together an order for what you need.

viperrwk

Promoted items from the Pinside Marketplace
$ 14.50
Electronics
PinballElectronics.com
From: $ 18.00
Apparel - Men
Pinside Shop
$ 10.00
Electronics
Yorktown Parts and Equip
From: $ 19.95
Trade
Machine - For Trade
Ukiah, CA
From: $ 159.95
€ 3.95
Flipper Parts
Multigame
5,000 (OBO)
Machine - For Sale
Rancho Mirage, CA
$ 66.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 19.95
Playfield - Protection
Little Shop Of Games
$ 229.99
Lighting - Other
Lighted Pinball Mods
$ 40.99
Lighting - Interactive
Lee's Parts
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 32.25
Playfield - Toys/Add-ons
The MOD Couple

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside