(Topic ID: 154382)

Meteor sound problems with Alltek


By SealClubber

3 years ago



Topic Stats

  • 8 posts
  • 5 Pinsiders participating
  • Latest reply 3 years ago by dothedoo
  • No one calls this topic a favorite

You

Linked Games

  • Meteor Stern Electronics, 1979

You're currently viewing posts by Pinsider acebathound.
Click here to go back to viewing the entire thread.

#4 3 years ago

Is the SB-300 cable the original and if so, has it been re-pinned? There's always a chance that could have been working fine before and disturbing it just exposed some issues with fatigued or oxidized/corroded pins. Also verify it's not off by one pin.. if it's a ribbon cable variety, I don't think those have keying pins so easy to miss a pin when reconnecting. Even the cables that do have keying pins could have the non-keyed cable shifted. Just something to check, along with perhaps having someone trigger the switches where sounds are messing up while you slowly wiggle the cable slightly up and down at the MPU J5 and SB-300 J1 connectors.. if sounds return, then it's likely the cable.

Promoted items from the Pinside Marketplace
From: $ 155.00
From: $ 155.00

You're currently viewing posts by Pinsider acebathound.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside