(Topic ID: 228859)

Meteor - coils not working

By AWKnewstubb

1 year ago

Topic Stats

  • 10 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by AWKnewstubb
  • Topic is favorited by 1 Pinsider


Linked Games

  • Meteor Stern Electronics, 1979
#1 1 year ago

Hi all, I have recently got hold of a Stern Meteor. I had it running well, all coils firing, until during a game the coils all stopped firing. I ran a test and only the knocker and the coil on the solenoid board now fire.
I immediately though this would be the playfield fuse. I checked this and someone had put in a 10amp fuse in instead of the 1amp.
So my question is, what would this 10amp fuse do in this position? Would it mean some particular components get blown?
I have checked the solenoid board and all the resistors and diodes test fine. A couple of the solenoid transistors are getting funny readings. During attract mode Q18 does not get any volts and Q19 is only getting 3.5V. The rest get 5v or 43v. Would this affect all the coils?

Any help here would be appreciated.

#2 1 year ago

Over amperage can cause a lot of issues. The fuse might not blow but all corresponding components might get fried.

#3 1 year ago

Pull out the multi-meter and see if your getting 43 volts to the playfield. Then get rid of that fuse before something cooks.

#4 1 year ago

Thanks BigAl,

I have already replaced the fuse. I will test the playfield and report back.

#5 1 year ago

Check all voltages and fuses on the rectifier board.

Then check the molex connectors as well. Could well be toasted up and need replacing.

Can also be the connectors from the MPU to the solenoid board - the MPU tells the solenoid board what to do. Common for these little -100 connectors to crap out after 30 years ...


#6 1 year ago

I seem to only be getting 5.2V to all the coils and play field fuse (except knocker). As far as I am aware this should be 43V?
Traced this back to the solenoid board. All associated transistors are only showing the 5.2V too.
I have tested TP3 which shows 5.3V. There is definatly 43V getting to the board, as the knocker coil and corresponding transistor shows 43V.
Does this mean something wrong on the Solenoid board? Or potentially something else?
Will replace the molex plugs next time, to eliminate that potential problem.

#7 1 year ago

Oh and rectifier board TPs all test fine except TP4 which has no voltage. But the GI is fine so I assume this is probably a false reading?

#8 1 year ago

Cancel that, TP2 on rectifier only reads 143V.

#9 1 year ago
Quoted from AWKnewstubb:

Will replace the molex plugs next time, to eliminate that potential problem.

Just examine the 3x rectifier molexes for now - are any of them burnt up in places?

Re the rectifier testing - do you have the meter on DC and AC? Both are present.

TP1 = +5.4 (AS2518-18 version, feature lamps)
TP1 = +6.5 vdc (AS2518-49 version, feature lamps)
TP2 = +230 vdc (score displays)
TP3 = +11.9 vdc (+5 regulated)
TP4 = 7.3 vac (general illumination)
TP5 = +43 vdc (solenoid voltage)
GND = Ground

Once you’ve confirmed this, check the bible.



#10 1 year ago

So turned out that the molex plug for the 43V line was plugged into the wrong pin on the rectifier board. Strange that that everything worked up until a point.
Thanks for the guidance on this one.

Promoted items from the Pinside Marketplace
1,800 (OBO)
Machine - For Sale
Santa Cruz, CA
$ 5.00
Playfield - Decals
Doc's Pinball Shop
$ 19.95
Machine - Wanted
Nashville, TENNESSEE
From: $ 10.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside