(Topic ID: 199695)

Metallica - Two switches fire at once


By Guzz4851

1 year ago



Topic Stats

  • 7 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by Guzz4851
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider Guzz4851.
Click here to go back to viewing the entire thread.

#1 1 year ago

I recently installed a spinner mod on my Metallica pro. Not sure if that has anything to do with this....I connected the spinners to the pic target like I was supposed to. Alligator clipped underneath at pic target. Nothing touching.

Noticed today that when I hit the left spinner and the ball travels up to the left orbit entrance rollover switch, the right slingshot will go off. If I hit the spinner only, it registers, and everything is fine. When the ball rolls over the orbit, that is when the slingshot goes off. Right side orbit is completely fine and doesn't activate any other switches.
Went into switch test...when pressing a switch, only that one appears on the DMD...I do not get multiple switches going off in test mode like I do in the actual game play.
Switch #27 is the right slingshot with wires green-red / tan-orange
Switch #43 is the left orbit with wires green-orange / tan-orange

I noticed the last two wire combinations are the same color so I'm not sure if that means the same row or column or if that even matters.
Can someone help troubleshoot why this might be happening? I'm hoping I didn't screw something up....it only started happening after the spinner install.
Thanks.

#4 1 year ago

Thanks to all.
LTG Yes two clips, one red and one black.
I removed the one side that was causing the problem....it worked. I couldn't replicate when the mod was uninstalled on the left side spinner.
I hooked the spinner up to the pic target to the right of the right ramp....seems to be ok and work normally. I depressed the switches in order and the sling didn't go off. So it appears that the pic target I had it hooked to causes the problem.

#5 1 year ago

Would a diode be required on the spinner switch?
As it sits right now, there isn't one. Just the two wires (red and black) soldered to each tab.
All other switches in the game have diodes. Since this is clipped onto a switch already with a diode, would the spinner switch itself need one?

#7 1 year ago

I added a diode IN4004. Switch still works.

Promoted items from the Pinside Marketplace
$ 24.95
Playfield - Toys/Add-ons
ULEKstore
$ 70.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 64.00
From: $ 119.99
Lighting - Backbox
Rock Custom Pinball
4,950 (Firm)
Machine - For Sale
Portland, OR
4,600
Machine - For Sale
Bakersfield, CA
$ 5,599.00
Pinball Machine
Great American Pinball
$ 5,599.00
Pinball Machine
Operation Pinball
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 129.95
Lighting - Interactive
Hookedonpinball.com
From: $ 75.00
Magazines/books
The Flipper Room
$ 199.99
Lighting - Led
Lighted Pinball Mods
Trade
Machine - For Trade
Ronkonkoma, NY
$ 399.95
$ 279.95
$ 35.00
$ 299.00
Lighting - Interactive
...redshiftLED
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 45.00
Cabinet - Other
...redshiftLED
$ 16.00
5,000 (Firm)
Machine - For Sale
Warren, MI

You're currently viewing posts by Pinsider Guzz4851.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside