(Topic ID: 50762)

Metallica owner's thread


By swampfire

6 years ago



Topic Stats

  • 17,289 posts
  • 965 Pinsiders participating
  • Latest reply 1 day ago by MJW
  • Topic is favorited by 368 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,965 images uploaded to this topic. (View topic image gallery).

IMG_9571 (resized).JPG
IMG_9559 (resized).JPG
IMG_9562 (resized).JPG
20200205_182944 (resized).jpg
20200205_182932 (resized).jpg
IMG20200129202541 (resized).jpg
IMG20200129204549 (resized).jpg
IMG20200129204401 (resized).jpg
IMG20200129204337 (resized).jpg
Untitled (resized).jpg
043F87DF-794F-4F00-AE21-B51F6F34A971 (resized).jpeg
b8c0f2e2465930d6fe917697e219f84bae3d1b6e.jpeg (resized).jpg
20200126_165041 (resized).jpg
7E873FB7-3693-497C-8928-EA87AF9418C0 (resized).jpeg
1A93D9FE-6F28-4633-AB69-2AC241163DF1 (resized).jpeg
EE7496D8-1BB5-4B65-8EA8-D9795DF7EB0E (resized).jpeg

Topic index (key posts)

5 key posts have been marked in this topic


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider jb-7x.
Click here to go back to viewing the entire thread.

15
#11177 2 years ago

I've lurked around this site for a long time but never bothered making an account because I had nothing to talk about. Those days are over now, its time to join the club! Just got my first pin yesterday. Picked up a HUO Metallica Monsters Premium from Kurt at hemispheres amusements. I've played plenty of pros out on location but never a premium. For the price I couldn't pass it up. Ordered some leg protectors, a pin gulp, some super bands , and a full set of plastic protectors from pinbits. Really looking forward to diving into this game over the weekend without my job getting in the way!

#11183 2 years ago
Quoted from BillySastard:

Do not put leg protectors on your pin, they are not needed. You will wrinkle the cab decals.

Thanks for the info. There are plastic ones on there now, just figured the metal ones would be better. Guess they'll just get shelved.

#11206 2 years ago

Ive had my Monsters Premium for about a week now and have indeed been playing the hell out of it and loving every second.

Seeing a problem developing with the sheet metal guard below the snakes mouth. It's starting to buckle. Anyone know where I could find a new piece for this and / or a walk through of how to change it out?

I've been working my way through the hundreds of pages of this thread and haven't found any talk of this yet.

IMG_0763 (resized).JPG

#11216 2 years ago

I'll do that. Thanks! I ordered the newton ball assembly to replace that block so I'll have to take that stuff out anyway to change it. What a dumb design choice that block was. It's guaranteed to do nothing but get blown apart and disperse shrapnel into the game. I'm a machinist and could probably easily make a replacement block but I'm not interested in all those metal fragments in my new machine.

3 weeks later
#11356 2 years ago

I've owned my met premium for about a month now and pretty much everything has been smooth sailing but I am however a first time pin owner and I'm now having an issue with my GI lighting.

It was starting to flicker/ strobe a bit here and there at random times, usually right after a ball launch. After clocking around 500 plays so far I knew it wasn't normal. Yesterday when I fired up my game I had absolutely zero GI lights. All my insert lighting is functional but all of my white lights are out. Anyone able to point me in the direction of where to trouble shoot this issue?

#11358 2 years ago
Quoted from dnapac:

Check all connections to boards. Sounds like a loose connection that finally came undone. Also check the fuses. Look up the manual on Sterns site and it should give you insight as to which one(s). Sorry I don't know it off the top of my head.

Thanks! I did go through and double check all the connections but maybe I missed something. I'll start there and hopefully get it sorted. I was just trying to get a more focused area to check.

I'm a noob in this hobby but totally interested in learning all the things involved.

#11360 2 years ago
Quoted from Kawydud:

Is it only the white GI lights that are out? It should have white/red/blue GI lights if it is a premium.

You're right. Not only the whites. My intent was to say that all the under playfield insert lighting was functional.

IMG_0849 (resized).JPG

#11374 2 years ago
Quoted from WJxxxx:

I've had the same issue - usually after transporting it.
It's the grey 'data' cable which is loose, the one with a modem/phone type connection. Either on the board under the playfield or in the backbox.
With mine I found it wasn't actually loose to the board, more that the wires were loose to the end connector on the wire.
Look at that first. Replace the cable if necessary and you'll be good to go

Thanks. I did unplug and replug both ends of that data cable, even slacked it out some in the harness. I'll give it a better look today after work. Is it a regular phone cord or is it special? Just curious for if I do indeed replace it.

Quoted from j_m_:

I've had this exact same problem (along with many other MET owners)
if your machine starts to exhibit this issue, definitely do yourself a favor and get a new cable. based on the way that it was run underneath the playfield, it can get pinched in a few locations (including near the up/down post at the top of the playfield
if it's not a break in the cable, as WJxxxx has stated, it could possibly be a bad terminated end

Thank you for the info guys

#11377 2 years ago
Quoted from j_m_:

I've had this exact same problem (along with many other MET owners)
if your machine starts to exhibit this issue, definitely do yourself a favor and get a new cable. based on the way that it was run underneath the playfield, it can get pinched in a few locations (including near the up/down post at the top of the playfield
if it's not a break in the cable, as WJxxxx has stated, it could possibly be a bad terminated end

Quoted from WJxxxx:

I've had the same issue - usually after transporting it.
It's the grey 'data' cable which is loose, the one with a modem/phone type connection. Either on the board under the playfield or in the backbox.
With mine I found it wasn't actually loose to the board, more that the wires were loose to the end connector on the wire.
Look at that first. Replace the cable if necessary and you'll be good to go

After a trip to Home Depot and purchase of a pack of RJ11 contacts, a 100 ft length of cat5 cable , and a RJ11 crimper for $50 I made myself a new data cable and I still don't have my GI. Probably could have ordered one somewhere for cheaper but I want to get my game going asap and don't want to wait for shipping. This is a bummer. I'm going to call my distributor tomorrow hopefully and reach out for some of his tech support otherwise I'll have to give 1 800 kickers a go and try to make some headway.

All of my fuses are good as well. Im still totally open for other suggestions from some of you OG pinheads if you have any other recommendations of where else to start looking.

#11398 2 years ago
Quoted from Kawydud:

Do they wire the data cable the same as standard? Maybe the wiring is different.

When I hand made the new cable I made sure I had all the appropriate colors in the right spots on the terminal ends. A little time consuming but weekends are my pin time and I didn't want to track one down online and wait to get it shipped.

Update on my GI issue:

After reseating everything , my GI lights are back. I am still getting some flicker at random times that aren't part of the normal light show. I'm currently corresponding with pat at stern via email to get everything figured out and back to 100%

Quoted from sudsy7:

Check the power connector coming off the bridge rectifier in the backbox - it's a 3-position z-connecotor having a red and a black wire going through it (one posiiton is not used). Should be toward the left side of the backbox in plain view. Unmate it, then remate it and see if the lights work now.

I'll add this to my list of today's checks when I get off work and get some time to go tinker around in there.

Thanks.

2 weeks later
#11524 2 years ago

Hey guys, I've been having an occasional issue with the coffin lock magnet on my premium. Every once and a while the magnet will just let go of the ball while the drop and lock sequence is going. It's not the end of the world for me but it did cost me a personal best score yesterday when it dropped the ball sdtm on me.

I see in there are feature adjustments for the coffin #91-#93 but I don't really understand what they mean. My manual doesn't cover the feature adjustment definitions, only the standard ones. Anyone able to direct me to somewhere that I could maybe get a printable set of feature adjustment definitions to add to my owner manual?

Or if someone just happens to know what those 3 adjustments mean that would work too.

Thanks.

#11526 2 years ago
Quoted from WJxxxx:

Did you get this resolved 100%?
I've been having a few more issues with mine recently and wonder whether I need to buy a new data cable

I did get my lighting fixed. It wasn't the data cable at all. A 3 pin connector (on the top right corner of the board) on my GI driver board wasn't staying tight. Stern sent me a new Driver pcb and wire harness and now everything is perfect again.

#11528 2 years ago
Quoted from johnnyutah:

I'm thinking about changing out my Metpro for a new MetPre. Anyone know a good/decent price range to look out for as I shop around? Also, will these still be produced into 2018?

I just bought a low play (130) premium about 2 months ago for $6100 shipped. It's my first pin but I thought the price was fair and it was worth every penny to me. I was originally in the market for a NIB pro but was having trouble finding one so I went up a peg and got a nice pre. From what I've heard there will be no more premiums made from here on out, only pros.

#11530 2 years ago
Quoted from Raegor:

Not sure if they'll still be making pros either...

When I was talking on the phone with my distributor 2 weeks ago about troubleshooting a lighting issue I had he was saying he was just over at stern and the word he had gotten was that they would continue to make pros but had no timeframe of when the next production run was. Of course this was second hand info to me and third hand to you so take it for what it's worth I guess. My premium will never leave my gameroom so at least I got that covered

2 weeks later
#11604 2 years ago
Quoted from Meph:

I added my custom topper tonight. I pre-ordered the Metallica Pops! as soon as I saw they were coming out. My only disappointment is that they aren't bobble heads, instead they are fixed. I was hoping for the headbanging when the shaker fires I plan to add an led strip below them and facing them to give a spotlight effect. Will see how it comes out.

I had my eye on these when they announced them.l and was planning on doing the same. They look good! I should probably just order the set now.

2 weeks later
#11666 2 years ago
Quoted from snakesnsparklers:

After a few hundred games my Met Pro Mystery eject is shooting SDTM 90% of the time. I do not see anything adjustable on this assembly other than bending the metal scoop. Has anybody else had this issue and corrected it?

You could try lowering the scoop eject power in the game settings. That may get your ball to a more favorable spot on kick out.

2 months later
#12239 2 years ago
Quoted from embryon:

My met monster GI's are strobing like crazy making gameplay impossible. Stern's warning is a reality if I tried to play with this happening for an extended period. If I disconnect/reconnect the grey data cable it seems to fix it for a very short time. Any ideas

Try reseating all connections on the GI driver board. It’s the same board that data cable connects to dead center under the playfield. I had a 3pin connector go bad in mine that caused a crazy strobe.

#12241 2 years ago

Has anyone here with a Premium ever tried switching all the red & blue GI lights to two different colors? Kinda curious what some other color combos might look like.

#12259 2 years ago
Quoted from WJxxxx:

I had the same problem with my GI, strobing, completely off, weird colours.
I thought it was the data cable as well, because every time I reseated it the GI worked fine.
Turns out it was the 3pin connector right next to it(as stated above) which was the problem. It just so happened that as I was reseating the data cable I must have touched the 3pin and knocked it right.
The connector just needs reflowing to the board, as there is likely a dry joint.

When my 3pin went bad I bush fixed it while waiting on a new board and harness from stern. I took a small flathead optical style screwdriver and stuck it in the end of the connector to bend the metal tabs to a harder angle so they sat more secure on the posts when connected. It worked so well I never bothered to install the new board and harness yet. Figured I’d wait till my fix failed and 4 months later the issue has never popped back up for me.

3 weeks later
#12438 2 years ago

I’ve been having some issues with my trough kicker on my monsters Premium. For a while now it’s been kicking balls out kinda hard where sometimes it bounces right back into the trough which at times leads to getting 2 balls kicked out on the second attempt. Now as of this weekend it’s kicking so hard that I’ve had a couple land up on the rail and hang up by the bubble level.

Is there a setting where I can adjust the power of just that coil that I’m not seeing or anyone have some advice on how to get this dialed back in?

#12440 2 years ago
Quoted from Rickwh:

Wonder if the ball guide part of the top of the trough is loose or missaligned? Have you take a peek under the apron to see if anything looks funny?

Everything looked good as far as I could tell. I had everything apart last week for a full set cliffy install. I was however having this problem well before all of that.

When I get home from work today maybe I’ll pull it all apart again and take a second look just to make sure.

3 weeks later
#12580 2 years ago
Quoted from butterz:

Hey, i need to get to the end of the line. I can do two crank it ups a game, if im lucky. Been focusing on getting everything lit on the cross, and getting that multiball first. Also working on better ball control. Can anyone give any more tips?

I’ve only been able to get to end of the line once in the 8 months I’ve had my game. It happened for me after watching one of McSirTuna’s tutorials on YouTube where his strategy on each crank it up was to “get in and get out” by hitting the cemetery, chair, snake, and coffin once and then cashing out immediately at the scoop to reduce the ball time of playing the CIUs to completion.

I pretty much go into any new game now with the mindset of either playing for points or playing for the objective of hitting end of the line. At my house score seems to be king so after finally getting there once I don’t even sweat it anymore.

1 month later
#13094 1 year ago
Quoted from Koos:

Do you have pictures of how dit does look? And can you just sand down the core? Isn't it a plated material?

I bought a spare set of magnet cores. I work in a machine shop so I swapped the new ones in and just turned down the ends of the originals a bit in a lathe so next time they’re all pitted and whatnot I can just rotate the spares in and not have any downtime. There is more than enough thread on the ends of them where you could easily knock a quarter inch off of them over time and not have any assembly problems.

#13096 1 year ago
Quoted from j_m_:

that's a great idea. my father has a metal lathe, I should probably invest in a 2nd set and do the same

I replaced the originals at around 1300 plays when I finally got my act together and did a full cliffy set install. With the addition of the core cliffys 500 games later I’m hardly seeing any pitting in my new cores either. I only own one pin and having any downtime sucks so I figured that this was a cheap investment of $16 from Marco to keep me going if the situation ever arises again.

1 month later
#13503 1 year ago
Quoted from Rob_G:

Even played GoT and had Winter Is Coming hurry up? Or escape Boba Fett on SW? That's exactly what the GI is now doing on my MeT Premium. Now that I have some time I will check for taught wiring/connectors and what else?
» YouTube video
Rob

I had a bad strobing issue on my premium too. After some back and forth via email with stern support we tracked it to the 3 pin connector on the upper right corner of the GI driver board (dead center of under playfield), not the actual data cable that seems to get brought up a lot with this problem. Wiggle that connector while the game is powered up and see if it triggers your strobe effect. Stern sent me a new GI board and harness. I never installed the board but the new harness did the trick.

1 month later
16
#13863 1 year ago

This morning my wife totally surprised me for my birthday and gave me the color dmd for my MET premium that I’ve been wanting forever. The fact that she was able to find where to get it and get the right one without really knowing much about my hobby just blew me away. I guess she does listen when I ramble on about this stuff. I don’t get surprised very often but this was one of those times!

Can’t wait for the work day to be over so I can get it installed. This is the last add on I wanted before considering my game complete.

Any pro tips for the install as far as stuff I should watch out for??

#13866 1 year ago
Quoted from DaveH:

It really depends on which backbox you have in your game. But really, it is a pretty straighforward install.
Oh, and you chose your wife wisely.

I have the older style wooden box. I saw she ordered the extra kit for the metal box cause she was unsure about what I had. I’m sure sooner or later that kit will get used when I eventually get my next game which will more than likely be whatever newer stern game catches my eye by the time I get the money together

#13868 1 year ago
Quoted from Raegor:

I'd buy the kit from ya.

I’m just going to hang on to it. I’m an inventory type guy by nature anyway. I’ll just spec out the pieces when I’m bored and learn to make them at work (plus side of being a CNC machinist)

#13872 1 year ago
Quoted from 85vett:

Not for the install but a pro tip to be sure you are listening to her ramblings now if you weren't before. Pay her back buy an equally thoughtful gift for her next birthday. Happy wife = happy life I'm also lucky that mine loves the pinball collection aspect too (not so much playing though).
Congrats on the color dmd!

This. Always this!

She’s the only person I go out of my way to please. Everyone else can kick rocks.

3 weeks later
#13999 1 year ago
Quoted from Rob_G:

Who here has made it to EOTL, the final wizard mode?
Rob

I have made EOTL once in the year I’ve owned my game. Was also one scoop shot away from a second time but I broke stride, cradled, and called my wife in to see it and bricked the shot with the reject going right between the flippers. That “almost” game still left me at my personal best of 814,000,000.

#14014 1 year ago
Quoted from Rob_G:

I have done 2 CIU, but I usually rush into the shots too fast and thus drain too quickly. I'm going to try harder once I get my game set back up in my new place. Maybe lower CIU requirements would help a bit?
Rob

When I finally got the perfect game going to reach EOTL I had just watched a tutorial where the guy “got in and got out” of CIUs quickly by just hitting each of the 4 shots to allow a quick cash out. It’s not the greatest for score but you’re spending less time potentially draining and moving on the the next CIU progression.

4 months later
#15406 1 year ago

I hit a new personal best with the new code. Previous best was around 960,000,000. Factory everything except mb stacking was enabled and I set the sparky magnet to low. Game lasted about 45 minutes, made it through end of the line (only 2nd time I’ve got there) , then one more ciu after that.

B318BCBD-98A0-43A8-8878-5457991F444B (resized).jpeg
6 months later
#16505 7 months ago
Quoted from Roostking:

Thinking i need some playfield protectors under the ramp dropouts. Looking for sometning better than Mylar. Thanks in advance!! Love this game!!

Get a couple in lane protectors from cliffy. Install is as easy as it gets and they work great.

Promoted items from the Pinside Marketplace
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
5,000 (Firm)
Machine - For Sale
Toms River, NJ
$ 25.50
$ 139.00
Playfield - Toys/Add-ons
Sparky Pinball

You're currently viewing posts by Pinsider jb-7x.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside