New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 50762)

Metallica owner's thread


By swampfire

7 years ago



Topic Stats

  • 17,834 posts
  • 1,000 Pinsiders participating
  • Latest reply 1 day ago by pkrobin
  • Topic is favorited by 367 Pinsiders

You

Linked Games

Topic Gallery

There have been 3,081 images uploaded to this topic. (View topic image gallery).

C5F6C623-DC8D-4AAA-838D-49EAF46D8F43 (resized).jpeg
1BD0AB09-FA76-4906-B577-0453E5D77709 (resized).jpeg
BF0D9FC4-7057-4F05-AD95-F1BE0B7BEF0C (resized).jpeg
thumbnail-11 (resized).jpeg
MET Board (resized).jpg
MET Board 2 (resized).jpg
4AFE37E0-1598-42D2-8022-85F72BB2565E (resized).jpeg
20201017_192702 (resized).jpg
Stern LED 2 (resized).jpg
Stern LED 1 (resized).jpg
thumbnail_processed (2) (resized).jpg
thumbnail_processed (1) (resized).jpg
thumbnail_processed (resized).jpg
20201004_171337 (resized).jpg
20201004_171325 (resized).jpg
IMG_20201003_174405855 (resized).jpg

Topic index (key posts)

5 key posts have been marked in this topic (Show topic index)

There are 17834 posts in this topic. You are on page 356 of 357.
#17751 31 days ago
Quoted from Viggin900:

If everyone complains this game is chopping wood than why doesn't Stern do an update to the code? I think it deserves it since this was the game that broke the mold.

you're listening to your fanboys.

#17752 31 days ago
Quoted from Spaghetti73:

hello everyone I have a big problem with my Metallica I just turned it on and the monitor shows me these two lines, also the shaker motor is always running .... please can you help me?
[quoted image]

reseat ribbon cables first.

#17753 29 days ago
Quoted from ED-209:

Greetings Metallica Owners and Fans, have a question for the masses....
I finally took the plunge and am getting a Pinwoofer setup, I’ve read a few posts that say if you replace the stock songs with just about any normal quality, mainly stereo, that it will really improve the sound, is this true?
Has anyone tried this with either an upgraded speaker system, such as Pinball Pro or Flipper Fidelity and\or a Pinwoofer setup?
I’m familiar with PinBrowser so that isn’t a problem but before I go and replace all the songs and ensure the lengths match, etc. , I just figured I’d ask the experts as surely someone has tried this?
Thanks for any input and stay safe.

I haven't set up upgraded speakers, so I can't speak to that, but one of the five pinned topics in the Topic Index (Key Posts) has all the song links and locations for both pro and prem/LE

#17754 29 days ago

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.

Screen Shot 2020-09-27 at 8.19.23 AM (resized).png
#17755 29 days ago
Quoted from bicyclenut:

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.
[quoted image]

Holy hell.....

#17756 29 days ago
Quoted from bicyclenut:

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.
[quoted image]

So much wrong with this....

#17757 29 days ago
Quoted from bicyclenut:

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.
[quoted image]

Yes, that is the Master of Puppets pro version.

It's got to add... um, take away at least $250 off the value.

#17758 29 days ago

Put a color dmd (lcd) in my 2013 wood back box met pro. Love the colorized dmd. But without the red filter on there the spots and gi in the return lanes are putting a bunch of glare. Anyone else have a solution for this? I think i left a clear plastic panel on in front of the color lcd. Should i have taken that off? Suggestions?

3D7394BA-978A-4255-BC37-CE9C8E6E6524 (resized).jpeg9F39B786-FE93-4041-AC1D-18AA690D218D (resized).jpeg
#17759 29 days ago
Quoted from Rickwh:

Put a color dmd (lcd) in my 2013 wood back box met pro. Love the colorized dmd. But without the red filter on there the spots and gi in the return lanes are putting a bunch of glare. Anyone else have a solution for this? I think i left a clear plastic panel on in front of the color lcd. Should i have taken that off? Suggestions?
[quoted image][quoted image]

Read the instructions. Of course it is to be removed tho there is also glare guards made from bent plastics that really help the older sterns

#17760 29 days ago
30A9296B-9349-40EB-ACC6-718CF712EF08 (resized).jpeg
#17761 28 days ago
Quoted from Dee-Bow:

Read the instructions. Of course it is to be removed tho there is also glare guards made from bent plastics that really help the older sterns

I did read the instructions.
Step 4 says to remove the red fliter and store it away. I did. But also says a clear lens is required... so i left that part in...

5E188BA7-654A-4A76-B160-FA26AC951D3A (resized).jpeg
#17762 28 days ago

I read that different. Says- If the dmd lens is NOT clear.. what color is the lens after removing the red film? Don't think the plastic protector they ship with is what they meant..As it says the clear lens is sold separately

#17763 28 days ago

My machine had a red filter/paper and a clear hard plastic screen. I removed the red filter and left the clear plastic protector. That is the only thing between the lcd and the wood/player.

I read the directions that maybe sometimes stern used blue or red or green hard plastic screens. And obviously that would beed to be removed to see the lcd screen.

Ill try removing the clear plastic. See if that helps with the glare. I guess in the home env the extra protection isnt needed anyways.

#17764 28 days ago

It's mainly there to protect from dust, but I have the same pin and dont see the reflection like yours. I still have the clear protector over my colordmd.

#17765 28 days ago

I believe it's just the angle of the wooden backbox..that glare blocker plastic will do the trick i bet! The colordmd is sooo frikkin with it on this pin tho!

#17766 28 days ago
Quoted from bicyclenut:

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.
[quoted image]

Smokeshow though! But yea...unacceptable.

#17767 28 days ago
Quoted from bicyclenut:

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.
[quoted image]

Maybe he prefers tits to art

#17768 28 days ago

For glare, try this. It's only $15 and works great. I have not tried in on colordmd displays but works great on regular dmds. I would stick it on the clear protector so you don't mess with the colordmd display.

#17769 28 days ago
Quoted from bicyclenut:

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.
[quoted image]

Maybe that's the owner's wife who died in a terrible accident... they initially met at a Metallica concert, and also played in pinball tournaments together. This is a way to honor and remember her brief life...

... but probably not.

#17770 28 days ago
Quoted from jawjaw:

For glare, try this. It's only $15 and works great. I have not tried in on colordmd displays but works great on regular dmds. I would stick it on the clear protector so you don't mess with the colordmd display.

Did you forget a link?

#17771 28 days ago
Quoted from bicyclenut:

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.
[quoted image]

something to look at while he plays with his balls?

#17773 28 days ago
Quoted from bicyclenut:

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.
[quoted image]

I mean, she’s hot for sure.. but uh, wtf!

#17774 28 days ago
Quoted from bicyclenut:

I apologize in advance if this is someones game on here. I don't mean to offend you, but why would you change your translite artwork for this? One of the best parts of a MET machine in the artwork.
[quoted image]

what the heck?!? that's a pic of my gf and there's no way I gave anyone any permission to use her image on their machine!!! lol

#17775 28 days ago
Quoted from Rickwh:

Put a color dmd (lcd) in my 2013 wood back box met pro. Love the colorized dmd. But without the red filter on there the spots and gi in the return lanes are putting a bunch of glare. Anyone else have a solution for this? I think i left a clear plastic panel on in front of the color lcd. Should i have taken that off? Suggestions?
[quoted image][quoted image]

https://www.pinballlife.com/bent-plastic.html

#17776 28 days ago

I don't think that would work for what he needs.

#17777 27 days ago

Yeah im trying to prevent the playfield from glaring on the color dmd. Not the dmd from reflecting off the playfield glass. The light is coming from down near the flippers and slings.

I think the bent plastic isnt designed for that long of an angle.

Considering a glare screen i saw on comet pinball. Or buying glare screen protectors for a computer monitor and cutting them down to size

#17778 26 days ago
Quoted from Rickwh:

I think the bent plastic isnt designed for that long of an angle.

It will work. (have someone hold the lid of a shoebox at 45deg at the top of the glass if you want to test it)

#17779 25 days ago

Had a very good first ball yesterday. 460 million at start of ball two.
Then I totally f*up the last two balls and ended up with 526 million...
Oh well there is always next game...

C04EF522-5690-4B87-ABA2-391CFA53AB7A (resized).jpegD322BCE9-216B-441A-A4E8-1EE876AE6B75 (resized).jpeg
#17780 22 days ago

Alright, after a couple of hours (!) of research I'm stuck. I'm installing a Stern Shaker on my Pro. The kit from Marcos was..lacking...with extra bolts, not enough screws, a misaligned shaker cover, a bent pin on a board, and an "extra" piece: Part #520-6934. The instructions do not mention this piece. It appears this is a filter that, according to several online sources, goes inline with J3 on the backbox board. But it's a different size than J3. It -is- the same size as J2 however (see pics). Should this go inline with J2 instead? While I'm working pretty confidently on this, I also know I'm not plugging something in unless I'm 100% sure it goes there.

IMG_20201003_174144033 (resized).jpgIMG_20201003_174405855 (resized).jpgIMG_20201003_174416075 (resized).jpg
#17781 22 days ago
Quoted from arcyallen:

Alright, after a couple of hours (!) of research I'm stuck. I'm installing a Stern Shaker on my Pro. The kit from Marcos was..lacking...with extra bolts, not enough screws, a misaligned shaker cover, a bent pin on a board, and an "extra" piece: Part #520-6934. The instructions do not mention this piece. It appears this is a filter that, according to several online sources, goes inline with J3 on the backbox board. But it's a different size than J3. It -is- the same size as J2 however (see pics). Should this go inline with J2 instead? While I'm working pretty confidently on this, I also know I'm not plugging something in unless I'm 100% sure it goes there.
[quoted image][quoted image][quoted image]

It *looks* like one of the lighting filter boards that go in the bottom left corner of the left backbox board. They clean up the lighting signal for LEDs - all Metallica’s Pro LEDs came with 2 of them, so do all LED native SAM Pro games. Is yours an original incandescent version or LED? I’ve never seen one of these used for a shaker, but best to check with Marcos.

#17782 22 days ago
Quoted from monkeyboypaul:

It *looks* like one of the lighting filter boards that go in the bottom left corner of the left backbox board. They clean up the lighting signal for LEDs - all Metallica’s Pro LEDs came with 2 of them, so do all LED native SAM Pro games. Is yours an original incandescent version or LED? I’ve never seen one of these used for a shaker, but best to check with Marcos.

Mine's a later LED Pro. I emailed Marcos and we'll see what they say. I'll also check the backbox for similar looking plugs.

#17783 22 days ago

It has been a while, a long while. But I installed a stern shaker in my met pro (wooden backbox). There was nothing to do in the backbox. The game was pre wired for the shaker with a (brown I think) wire with a connector on it laying on the floor toward the back of the lower cabinet already. There was a small board to mount to the left side of cabinet near the shaker.

I think you are doing the right thing to question stuff. Doesn’t seem like they did a good job packing yours up? I faintly remember there being a version A and B of the shaker. Do you have the right one for your version of met?

Sorry not much more help. I will take some pics if you like?

12
#17784 21 days ago

Ok Mr. Lyman...I did it. Got through the End of the line and game started over. Can you send me a code update please.

Kidchrisso

20201004_171325 (resized).jpg20201004_171337 (resized).jpg
#17785 21 days ago
Quoted from kidchrisso:

Ok Mr. Lyman...I did it. Got through the End of the line and game started over. Can you send me a code update please.
Kidchrisso
[quoted image][quoted image]

Damn. Congrats!

#17786 20 days ago
Quoted from monkeyboypaul:

It *looks* like one of the lighting filter boards that go in the bottom left corner of the left backbox board. They clean up the lighting signal for LEDs - all Metallica’s Pro LEDs came with 2 of them, so do all LED native SAM Pro games. Is yours an original incandescent version or LED? I’ve never seen one of these used for a shaker, but best to check with Marcos.

Per Marcos it's a switch filter. It goes on the right board, not the left one as I was trying. To answer your question I have the LED version. Rickwh: The Stern kit I got definitely attaches to the backbox in addition to the cabling at the front of the cabinet.

#17787 17 days ago
Quoted from Bundy:

Had a very good first ball yesterday. 460 million at start of ball two.
Then I totally f*up the last two balls and ended up with 526 million...
Oh well there is always next game...
[quoted image][quoted image]

....this right here is my headache. Have come one away SOOOOOOOOO many times to EOTL, even with 3-5 extra balls and it's a disaster after!!! I feel your pain

#17788 16 days ago
Quoted from woody6092:

....this right here is my headache. Have come one away SOOOOOOOOO many times to EOTL, even with 3-5 extra balls and it's a disaster after!!! I feel your pain

Here is the key for me playing the game. I got through the game on ball two, granted I probably had 4 extra balls awarded. Your easiest multiball to get into is the grave yard targets. It is an easy and controllable backhand shot and then let the others present themselves as they come. Even though I finished it I will never get tired of it. Let me know how it works for you going at it that way.

Kidchrisso

#17789 16 days ago

Metallica pinball will never get old for me
Casket multiball will always remain one of the greatest.

#17790 10 days ago

Just got a MET Pro and wanted to put in LED flipper buttons. When I installed the buttons, something happened and I'm getting 46(!) device malfunction errors. However, when I go into diagnostics and check each switch/coil/etc. with a malfunction, it works. So I'm guessing that what I did somehow damaged a board but don't know if there is a fix or if I'm going to have to replace the entire Board (but first I'll have to figure out which board). Has this happened to anyone else? If so, I'd would be very grateful if you could let me know how you fixed it. I've reached out to Stern support already and waiting to hear back. I also disconnected the buttons (didn't work) and reinstalled the operating software (also didn't work). I looked over all of the connections and don't see a loose connector or broken wire. Below are some pictures of what the display shows:

thumbnail_processed (1) (resized).jpgthumbnail_processed (2) (resized).jpgthumbnail_processed (resized).jpg
#17791 9 days ago
Quoted from sugarhillabe:

Just got a MET Pro and wanted to put in LED flipper buttons. When I installed the buttons, something happened and I'm getting 46(!) device malfunction errors. However, when I go into diagnostics and check each switch/coil/etc. with a malfunction, it works. So I'm guessing that what I did somehow damaged a board but don't know if there is a fix or if I'm going to have to replace the entire Board (but first I'll have to figure out which board). Has this happened to anyone else? If so, I'd would be very grateful if you could let me know how you fixed it. I've reached out to Stern support already and waiting to hear back. I also disconnected the buttons (didn't work) and reinstalled the operating software (also didn't work). I looked over all of the connections and don't see a loose connector or broken wire. Below are some pictures of what the display shows:[quoted image][quoted image][quoted image]

Sorry, I don't have an answer about the error or how/why it happened, but I'm curious where you plugged in the flipper button lights. They would normally plug into the aux plug above the service box. This is a 3-pin plug yhat is ground/5v/12v.

#17792 9 days ago
Quoted from Sparky:

Sorry, I don't have an answer about the error or how/why it happened, but I'm curious where you plugged in the flipper button lights. They would normally plug into the aux plug above the service box. This is a 3-pin plug yhat is ground/5v/12v.

That is where I plugged it in, just below the plunger. Here's where I get to the potential "doh" moment in that I thought the lights were for Stern SAM, but were in fact for SPIKE. I did not realize this would be the result.
Hoping it's not ending up with a new Board.

#17793 9 days ago
Quoted from sugarhillabe:

Just got a MET Pro and wanted to put in LED flipper buttons. When I installed the buttons, something happened and I'm getting 46(!) device malfunction errors. However, when I go into diagnostics and check each switch/coil/etc. with a malfunction, it works. So I'm guessing that what I did somehow damaged a board but don't know if there is a fix or if I'm going to have to replace the entire Board (but first I'll have to figure out which board). Has this happened to anyone else? If so, I'd would be very grateful if you could let me know how you fixed it. I've reached out to Stern support already and waiting to hear back. I also disconnected the buttons (didn't work) and reinstalled the operating software (also didn't work). I looked over all of the connections and don't see a loose connector or broken wire. Below are some pictures of what the display shows:[quoted image][quoted image][quoted image]

Fairly sure this is corrupted RAM. If so, good news, it's an easy fix. You have to pull the power, the coin battery and use some small clips to short the power and ground legs on the SRAM chip. Leave that sit for an hour or two and it should be enough to drain off the stored capacitive charge enough to erase the part. If you need help figuring out where to clip, I can get some pictures in a day or so.

#17794 9 days ago
Quoted from sugarhillabe:

That is where I plugged it in, just below the plunger. Here's where I get to the potential "doh" moment in that I thought the lights were for Stern SAM, but were in fact for SPIKE. I did not realize this would be the result.
Hoping it's not ending up with a new Board.

Plugging in your spike flipper buttons to a Sam plug should not harm anything, both are 12v. the flipper buttons just wont light if the polarity is reversed. It’s when a short occurs you run into issues, but that would mainly be a blown fuse. Should have nothing to do with your switch matrix. Is it possible your flipper button lights touched the flipper switch and caused a short?

If you have a spike set up for the flipper buttons, how is it even possible to plug into Sam as the connections are a different size.

#17795 9 days ago
Quoted from Lermods:

Plugging in your spike flipper buttons to a Sam plug should not harm anything, both are 12v. the flipper buttons just wont light if the polarity is reversed. It’s when a short occurs you run into issues, but that would mainly be a blown fuse. Should have nothing to do with your switch matrix. Is it possible your flipper button lights touched the flipper switch and caused a short?
If you have a spike set up for the flipper buttons, how is it even possible to plug into Sam as the connections are a different size.

It is possible that the flipper button lights touched something. I had the power off while installing but could have shifted slightly when I lowered the playfield. I'm not sure about the Spike/SAM issue -- this is my first Stern so I don't have anything to compare to -- it's just after this happened I looked at the bag the buttons came in and it states "Stern Spike" on it, but the connector was the same so that may have absolutely nothing to do with it.

#17796 9 days ago
Quoted from RobF:

Fairly sure this is corrupted RAM. If so, good news, it's an easy fix. You have to pull the power, the coin battery and use some small clips to short the power and ground legs on the SRAM chip. Leave that sit for an hour or two and it should be enough to drain off the stored capacitive charge enough to erase the part. If you need help figuring out where to clip, I can get some pictures in a day or so.

That would be great if you could do so! Thanks for the advice!

#17797 8 days ago
Quoted from sugarhillabe:

It is possible that the flipper button lights touched something. I had the power off while installing but could have shifted slightly when I lowered the playfield. I'm not sure about the Spike/SAM issue -- this is my first Stern so I don't have anything to compare to -- it's just after this happened I looked at the bag the buttons came in and it states "Stern Spike" on it, but the connector was the same so that may have absolutely nothing to do with it.

Weird the connector would say spike and have the sam connector. That connector isn’t compatible with a spike game. Can you post a pic of the connector and the mod? Spike games often utilize 5v and the wiring is backwards relative to Sam, but not sure how it could cause switch issues. Even if it shorted, you’d blow a fuse.

It is possible something touched the flipper switches and caused the issue, that’s why a pic of the install might help.

#17798 8 days ago
Quoted from Lermods:

Weird the connector would say spike and have the sam connector. That connector isn’t compatible with a spike game. Can you post a pic of the connector and the mod? Spike games often utilize 5v and the wiring is backwards relative to Sam, but not sure how it could cause switch issues. Even if it shorted, you’d blow a fuse.
It is possible something touched the flipper switches and caused the issue, that’s why a pic of the install might help.

Thanks! I don't have a picture of the install, because I removed everything when everything went to hell (pardon my french), but here's some pictures of the items. I'm coming around to the idea of wires touching and shorting out the RAM, but this is to date well beyond my limited tech abilities.

Stern LED 1 (resized).jpgStern LED 2 (resized).jpg
#17799 8 days ago
Quoted from sugarhillabe:

That would be great if you could do so! Thanks for the advice!

Ok here you go. The SRAM is the Cyprus chip. Clip to the opposite corners as shown in the picture. If you do not have microclips, these probably will work; amazon.com link »

You didn't need to short anything to corrupt the memory. I ran into this with a bad total light show board. It took a long time to figure out what was going on. I have a theory how this could happen, but don't really want to type it out..haha. The important point is that the SRAM on SAM boards keep their memory without power and battery backup for an impressively long period of time (days? weeks? I gave up waiting).
20201017_192702 (resized).jpg

#17800 8 days ago
Quoted from sugarhillabe:

Thanks! I don't have a picture of the install, because I removed everything when everything went to hell (pardon my french), but here's some pictures of the items. I'm coming around to the idea of wires touching and shorting out the RAM, but this is to date well beyond my limited tech abilities.
[quoted image][quoted image]

That’s very odd someone would sell a spike mod with that connection since that connection doesn’t exist in a spike game. If you have an external 12v power source, you could test them.

Promoted items from the Pinside Marketplace
8,900
Machine - For Sale
Mequon, WI
$ 64.00
$ 24.00
Playfield - Other
Pin Monk
There are 17834 posts in this topic. You are on page 356 of 357.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside