(Topic ID: 50762)

Metallica owner's thread


By swampfire

6 years ago



Topic Stats

  • 16,854 posts
  • 947 Pinsiders participating
  • Latest reply 1 day ago by Graysonsdad
  • Topic is favorited by 358 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,855 images uploaded to this topic. (View topic image gallery).

Plunger Plate & Shooter Knob Mod - Marshall (resized).jpg
Plunger Plate & Shooter Knob Model - Marshall (resized).jpg
shiny (resized).jpg
pasted_image (resized).png
E6242E9A-2132-4071-AE15-1264B836090B (resized).jpeg
DF782AB3-DEA5-4AC1-90E4-0E6B15419BF9 (resized).jpeg
FB_IMG_1570754293555 (resized).jpg
Image from iOS (7) (resized).jpg
20191005_171001 (resized).jpg
IMG_2894 (resized).jpg
2 (resized).jpg
IMG_20190926_234519 (resized).jpg
00000PORTRAIT_00000_BURST20190916203030373 (resized).jpg
buzzkill (resized).jpg
MVIMG_20190920_182141 (resized).jpg
15684089715109170470619334034077 (resized).jpg

Topic index (key posts)

5 key posts have been marked in this topic (Show topic index)

There are 16854 posts in this topic. You are on page 336 of 338.
#16751 56 days ago
Quoted from embryon:

The flipper plunger rod is probably mushroomed on the edge. Do a flipper rebuild to fix. How many games played on your game? Also. If you have young kids who flip a thousand times per ball will wear this rod out quickly too

My game has about 1500 balls played. My Maiden has 3x that amount of play. My 6yr old son doesnt play our Metallica. "Its too hard." He likes to play Maiden though.

#16752 56 days ago

Need some diagnose help. Sparky sensor is triggering at random times, usually when I hit the right ramp. Just keep triggering and multiball starts. Did switch test and all switches come in clean. Thinking maybe the opto is bad, or not lined up properly, both lights on the opto board are lit and I checked the connections. Any tips to realign it, or should I just replace it? I reached out to my distributor and I am waiting to see about getting replacement parts (machine is just over a year old), but thought there might be an easy way to fix/diagnose.

#16753 56 days ago

I have an unused Metallica Monsters translite signed by Lyman, Borg and Dirty Donnie. I'm thinking of selling it to fund some repairs etc. PM me an offer if you are interested.

#16754 55 days ago
Quoted from Graysonsdad:

My game has about 1500 balls played. My Maiden has 3x that amount of play. My 6yr old son doesnt play our Metallica. "Its too hard." He likes to play Maiden though.

That's not many. Check for binding on the mech

#16755 55 days ago
Quoted from JDub03:

Need some diagnose help. Sparky sensor is triggering at random times, usually when I hit the right ramp. Just keep triggering and multiball starts. Did switch test and all switches come in clean. Thinking maybe the opto is bad, or not lined up properly, both lights on the opto board are lit and I checked the connections. Any tips to realign it, or should I just replace it? I reached out to my distributor and I am waiting to see about getting replacement parts (machine is just over a year old), but thought there might be an easy way to fix/diagnose.

Could be possible that the ramp flasher could be “blinding” the sensor? Try removing the ramp flasher and see if that changes the behavior at all. Years ago I replaced my flashers with LEDS and had to bend the brackets to get the flasher face closer to the play field. It was blinding the sensors on the cross drop targets. Something to try at least.

#16756 55 days ago
Quoted from JDub03:

Need some diagnose help. Sparky sensor is triggering at random times, usually when I hit the right ramp. Just keep triggering and multiball starts. Did switch test and all switches come in clean. Thinking maybe the opto is bad, or not lined up properly, both lights on the opto board are lit and I checked the connections. Any tips to realign it, or should I just replace it? I reached out to my distributor and I am waiting to see about getting replacement parts (machine is just over a year old), but thought there might be an easy way to fix/diagnose.

I had some flaky Sparky senors that would trigger at random times. I thought that it was the optos at first but it still happened even after I put new ones in. I think I eventually just swapped them around took the left side put it on the right side and moved the right opto to the left. Everything started working again perfectly. There is something going on with the metal bracket those optos sit in and the way the IR beam aligns. At least that was the issue on my MET.

#16757 55 days ago

If anyone is interested in a POPULATED pro playfield PM me.

#16758 55 days ago
Quoted from Spiderpin:

Or Wife/Girlfriend

Or self..... someone had to say it

#16759 55 days ago
Quoted from Graysonsdad:

If anyone is interested in a POPULATED pro playfield PM me.

I didnt realize I have a maximum of 20 messages per day. To those who messaged me about the translite or playfield and didnt hear back from me, I will contact you tomorrow.

#16760 54 days ago
Quoted from JDub03:

Need some diagnose help. Sparky sensor is triggering at random times, usually when I hit the right ramp. Just keep triggering and multiball starts. Did switch test and all switches come in clean. Thinking maybe the opto is bad, or not lined up properly, both lights on the opto board are lit and I checked the connections. Any tips to realign it, or should I just replace it? I reached out to my distributor and I am waiting to see about getting replacement parts (machine is just over a year old), but thought there might be an easy way to fix/diagnose.

On mine this was the opto...I had the exact same issue. I would try wiggling the cords on them while in switch test and if it starts beeping uncontrollable then that's the problem. Otherwise, it sounds like some others have sent some other areas to considered.

#16761 54 days ago

I've received a lot more messages about my stuff than expected. I will think it over and get back to people soon.

#16762 53 days ago

Hello fellow owners,
I finally got to join the club after years of dreaming about it. I bought a beautiful 2013 Pro. I've spent the last week replacing the Sparky magnet, changing out a couple songs, adding a ColorDMD, and adding a Pinnovators PINPAC. I'm also pretty sure I read every page of this thread. I'm pretty excited!
All was well until I was playing a game and the game started looking for balls after an Electric Chair multiball.
I've since done a switch test and all of Drive 2 does not register in test. (That's all trough switches, all lanes and the pop bumper switches) I tested continuity and I have continuity all the way back to the board. I'm assuming now that it is a board issue but I'm still hoping not.
Can anyone give me some advice on where to look next? If I had to guess I'll have to take off the board and check for any damage. Maybe (hopefully) I'm missing some simple explanation.
What do you all think?

Added 28 days ago:

Just a follow-up: It turned out my issue was a faulty wire/connector connection at the trough switch. It ended up taking out the trough opto as well as the sparky and cross optos which are on the same row/column on the switch matrix. Since fixing the connection I've had zero issues.

#16763 53 days ago
Quoted from ReallifePin:

Hello fellow owners,
I finally got to join the club after years of dreaming about it. I bought a beautiful 2013 Pro. I've spent the last week replacing the Sparky magnet, changing out a couple songs, adding a ColorDMD, and adding a Pinnovators PINPAC. I'm also pretty sure I read every page of this thread. I'm pretty excited!
All was well until I was playing a game and the game started looking for balls after an Electric Chair multiball.
I've since done a switch test and all of Drive 2 does not register in test. (That's all trough switches, all lanes and the pop bumper switches) I tested continuity and I have continuity all the way back to the board. I'm assuming now that it is a board issue but I'm still hoping not.
Can anyone give me some advice on where to look next? If I had to guess I'll have to take off the board and check for any damage. Maybe (hopefully) I'm missing some simple explanation.
What do you all think?

Check your fuses.

#16764 53 days ago
Quoted from dnapac:

Check your fuses.

The lights all show good. I manually checked the cab and playfield fuses for good measure and there doesn't appear to be any fuse issues.
Thanks for the suggestion though. Keep em coming.

MVIMG_20190920_182141 (resized).jpg
#16765 53 days ago
Quoted from ReallifePin:

I've since done a switch test and all of Drive 2 does not register in test. (That's all trough switches, all lanes and the pop bumper switches) I tested continuity and I have continuity all the way back to the board. I'm assuming now that it is a board issue but I'm still hoping not.

You could try inspecting all those switches for anything shorted to ground.

#16766 53 days ago
Quoted from Neal_W:

You could try inspecting all those switches for anything shorted to ground.

I will do that. Thanks!

#16767 53 days ago

I sold a decent amount of BUZZKILL noise reducing washers, so I ordered up another batch. This time they are thicker, made from 1/64" thick Neoprene. They do a great job stopping that coil buzz when you flip and trap up on some of the noisier Sterns.

If you want a set, send me $5 via PayPal along with your address. I'll send you a set (two washers) USPS Mail. Great for Metallica (Pro) AC/DC (Pro) Transformers (Pro) The Walking Dead (Pro) and other machines that buzz when you trap up.

You can make 10-15 sets yourself with a gasket from Auto Zone for $7 (plus tax) and be out time for the errand and work, with a misshapen gasket to show for it.

buzzkill (resized).jpg
#16768 53 days ago

I'm sure its been talked about but I had a chance to play guardians of the galaxy last week after owning Metallica. Its the exact same game except the ramps flow through the back box? I still prefer Metallica over guardians!

#16769 52 days ago
Quoted from Viggin900:

I'm sure its been talked about but I had a chance to play guardians of the galaxy last week after owning Metallica. Its the exact same game except the ramps flow through the back box? I still prefer Metallica over guardians!

Met will always rule over GOG, and most other pins, regardless of the layout.

#16770 52 days ago

Even though the layout is similar, GOTG and Met play nothing alike. I think they're both great games, but Met is just a masterpiece.

#16771 52 days ago
Quoted from ReallifePin:

Hello fellow owners,
I finally got to join the club after years of dreaming about it. I bought a beautiful 2013 Pro. I've spent the last week replacing the Sparky magnet, changing out a couple songs, adding a ColorDMD, and adding a Pinnovators PINPAC. I'm also pretty sure I read every page of this thread. I'm pretty excited!
All was well until I was playing a game and the game started looking for balls after an Electric Chair multiball.
I've since done a switch test and all of Drive 2 does not register in test. (That's all trough switches, all lanes and the pop bumper switches) I tested continuity and I have continuity all the way back to the board. I'm assuming now that it is a board issue but I'm still hoping not.
Can anyone give me some advice on where to look next? If I had to guess I'll have to take off the board and check for any damage. Maybe (hopefully) I'm missing some simple explanation.
What do you all think?Unfortunately, if a whole row of switches is out it probably is a board problem. A friend of mine had that issue on his Shrek a few years ago. IIRC he had to send the board out for repair.

#16772 52 days ago
Quoted from LOTR_breath:

Unfortunately, if a whole row of switches is out it probably is a board problem. A friend of mine had that issue on his Shrek a few years ago. IIRC he had to send the board out for repair.

I'm thinking you're right. I'm going to take a look at the board for anything physical but I may be able to swap it out with a working board just to confirm. Still have my fingers crossed.
Edit: looks like you were correct. The Q2 transistor is bad but already socketed. I should be back up and running soon!

00000PORTRAIT_00000_BURST20190916203030373 (resized).jpg
#16773 47 days ago

Anyone want 3 fangs from Mezel for the price of 2?

$40 + $5 shipping anywhere in US or Canada.

PM if interested.

IMG_20190926_234519 (resized).jpg
#16774 46 days ago
Quoted from WizardsCastle:

Anyone want 3 fangs from Mezel for the price of 2?
$40 + $5 shipping anywhere in US or Canada.
PM if interested.[quoted image]

2 fangs sold. Still have one available.

Also have an extra Magnet control board, and 5 SMD light boards.

Magnet goes for about $60-70 new, and SMD are $6.99 each on Pinball Life.

I can do the magnet board and SMDs for $70 USD with shipping anywhere in the US or Canada.

Add an extra $10 if you want the Mezel fangs.

#16775 44 days ago

Thanks! Draegermeister ... got my BUZZKILL washers yeasterday and they absolutely did the trick on quieting down my Metallica flipper coils.

#16776 43 days ago

My NIB Premium arrived on Friday from Trent at Tilt Amusements and I love it! I have added a cliffy on the scoop, a Sparky protector from pinbits, and new carbon steel balls from bctrade (Ball Baron is sold out). I have a topper and ColorDMD on the way.

I am having two issues and wanted to see if anyone could help:
1) Out of the box the plunger would not plunge the ball into the game. I swapped the orange spring out with a blue spring which would get the ball into the playfield but just barely, I tried a green spring and now the ball goes all the way up but my kids struggle to pull it back. Since the game came with an orange spring I feel that something is wrong and a higher powered spring is just a band aid. Any idea what to try?

2) I have had balls get stuck on the metal around the snake, it seems like there is some magnetism there. I have maybe 50 games on the machine so I did not expect the balls to magnetize already and they are not sticking to each other or any other part in the game. Any idea how to stop this?

Thanks for the help!

2 (resized).jpg
#16777 43 days ago
Quoted from LargemouthAss:

My NIB Premium arrived on Friday from Trent at Tilt Amusements and I love it! I have added a cliffy on the scoop, a Sparky protector from pinbits, and new carbon steel balls from bctrade (Ball Baron is sold out). I have a topper and ColorDMD on the way.
I am having two issues and wanted to see if anyone could help:
1) Out of the box the plunger would not plunge the ball into the game. I swapped the orange spring out with a blue spring which would get the ball into the playfield but just barely, I tried a green spring and now the ball goes all the way up but my kids struggle to pull it back. Since the game came with an orange spring I feel that something is wrong and a higher powered spring is just a band aid. Any idea what to try?
2) I have had balls get stuck on the metal around the snake, it seems like there is some magnetism there. I have maybe 50 games on the machine so I did not expect the balls to magnetize already and they are not sticking to each other or any other part in the game. Any idea how to stop this?
Thanks for the help![quoted image]

I'd check and make sure the plunger is hitting the ball at it's center. You can loosen and reposition the whole shooter assembly as needed. If it's way off, it may not launch properly.

#16778 43 days ago
Quoted from yzfguy:

I'd check and make sure the plunger is hitting the ball at it's center. You can loosen and reposition the whole shooter assembly as needed. If it's way off, it may not launch properly.

I removed the assembly but I do not see how to reposition it. Any hints on how?

#16779 43 days ago
Quoted from LargemouthAss:

I removed the assembly but I do not see how to reposition it. Any hints on how?

Not just the shooter rod. Loosen the four nuts that hold the whole rectangular assembly to the cabinet. Then you can move that whole thing slightly in the direction needed and re tighten. ( Up , down, sideways).

#16780 43 days ago
Quoted from yzfguy:

Not just the shooter rod. Loosen the four nuts that hold the whole rectangular assembly to the cabinet. Then you can move that whole thing slightly in the direction needed and re tighten. ( Up , down, sideways).

Awesome! I will give that a shot!

#16781 43 days ago
Quoted from yzfguy:

Not just the shooter rod. Loosen the four nuts that hold the whole rectangular assembly to the cabinet. Then you can move that whole thing slightly in the direction needed and re tighten. ( Up , down, sideways).

Worked perfectly!!! Thanks for the advice!!

10
#16782 43 days ago
Quoted from LargemouthAss:

Worked perfectly!!! Thanks for the advice!!

Awesome. Woah.... I helped someone!

#16783 43 days ago
Quoted from yzfguy:

Awesome. Woah.... I helped someone!

Nice, thats like a pass for your next bad deed right?

#16784 43 days ago
Quoted from LargemouthAss:

My NIB Premium arrived on Friday from Trent at Tilt Amusements and I love it! I have added a cliffy on the scoop, a Sparky protector from pinbits, and new carbon steel balls from bctrade (Ball Baron is sold out). I have a topper and ColorDMD on the way.
I am having two issues and wanted to see if anyone could help:
1) Out of the box the plunger would not plunge the ball into the game. I swapped the orange spring out with a blue spring which would get the ball into the playfield but just barely, I tried a green spring and now the ball goes all the way up but my kids struggle to pull it back. Since the game came with an orange spring I feel that something is wrong and a higher powered spring is just a band aid. Any idea what to try?
2) I have had balls get stuck on the metal around the snake, it seems like there is some magnetism there. I have maybe 50 games on the machine so I did not expect the balls to magnetize already and they are not sticking to each other or any other part in the game. Any idea how to stop this?
Thanks for the help![quoted image]

I dont think Ball Baron sells the right balls. Mine magnetized too and they advertized them as not going to magnetize. Also, where did you get the new balls from? I bought some off of Amazon from BC precision, which were super rusty.

Awesome game btw !!!!!!

#16785 42 days ago

you cannot purchase the ninja balls from ball baron. those are the ones that will magnetize within 50-70 games
he was supposed to stock a carbon core ball that isn't as subjective to becoming magnetized

#16786 42 days ago

Yeah I got them from Bctrade on ebay and they arrived in great shape. They are the carbon steel balls that are not supposed to magnetize quickly.

#16787 42 days ago

I get mine from pinball life and never had an issue

#16788 39 days ago

Had my met for years just joining the club today.

#16789 39 days ago

Got a MET a week ago. Loving the game, even though it could only stay at the house a day before going on location. Now even more people are enjoying it.

#16790 39 days ago

I just noticed tonight that when I shoot the snake, it doesn’t always count as a snake hit. It ejects the ball every time but doesn’t count towards the snake count most of the time. I have a premium. What switch needs to be adjusted on the snake to make it actually register a make?

-1
#16791 38 days ago

I have a bunch of Metallica picks that are cool to glue to various parts of the machine. They are $4.98 eac + $3.50 shipping. If you want to buy more than one, shipping is still $3.50. I only have qty 1 left so first come first serve. PM me with what you want.

IMG_2894 (resized).jpg
-2
#16793 38 days ago

Hot glue. I have a bunch of pics in various spots in my machine...they look awesome imo.

#16794 38 days ago

I have one on a Freeplay card, that's as far as I'll go

#16795 38 days ago

Don't do it!...just saying

#16796 38 days ago

I always think it’s funny how people get so upset with what you do with your machine.

#16797 38 days ago
Quoted from dnapac:

I always think it’s funny how people get so upset with what you do with your machine.

That's because they're always thinking resale value. I just enjoy playing my games and never get bogged down with what I'll get for them when I sell. It's like the guys who garage and put low mileage on their cars. All they're doing is keeping it nice for the next guy who'll pay way less than the original price and enjoy using it how it was intended.
I play, customise and enjoy my games to death, and worry about resale when and if the time comes

#16798 38 days ago

That's because they're always thinking resale value. I just enjoy playing my games and never get bogged down with what I'll get for them when I sell. It's like the guys who garage and put low mileage on their cars. All they're doing is keeping it nice for the next guy who'll pay way less than the original price and enjoy using it how it was intended.
I play, customise and enjoy my games to death, and worry about resale when and if the time comes

#16799 38 days ago
Quoted from embryon:

That's because they're always thinking resale value. I just enjoy playing my games and never get bogged down with what I'll get for them when I sell. It's like the guys who garage and put low mileage on their cars. All they're doing is keeping it nice for the next guy who'll pay way less than the original price and enjoy using it how it was intended.
I play, customise and enjoy my games to death, and worry about resale when and if the time comes

You can say that again!

#16800 38 days ago
Quoted from dnapac:

Hot glue. I have a bunch of pics in various spots in my machine...they look awesome imo.

Me too but sticky tack. Never glue

Promoted items from the Pinside Marketplace
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 259.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 5.00
Playfield - Other
Chrome Candy
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 24.95
Playfield - Toys/Add-ons
ULEKstore
There are 16854 posts in this topic. You are on page 336 of 338.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside