(Topic ID: 50762)

Metallica owner's thread


By swampfire

6 years ago



Topic Stats

  • 16,854 posts
  • 947 Pinsiders participating
  • Latest reply 1 day ago by Graysonsdad
  • Topic is favorited by 358 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,855 images uploaded to this topic. (View topic image gallery).

Plunger Plate & Shooter Knob Mod - Marshall (resized).jpg
Plunger Plate & Shooter Knob Model - Marshall (resized).jpg
shiny (resized).jpg
pasted_image (resized).png
E6242E9A-2132-4071-AE15-1264B836090B (resized).jpeg
DF782AB3-DEA5-4AC1-90E4-0E6B15419BF9 (resized).jpeg
FB_IMG_1570754293555 (resized).jpg
Image from iOS (7) (resized).jpg
20191005_171001 (resized).jpg
IMG_2894 (resized).jpg
2 (resized).jpg
IMG_20190926_234519 (resized).jpg
00000PORTRAIT_00000_BURST20190916203030373 (resized).jpg
buzzkill (resized).jpg
MVIMG_20190920_182141 (resized).jpg
15684089715109170470619334034077 (resized).jpg

Topic index (key posts)

5 key posts have been marked in this topic (Show topic index)

There are 16854 posts in this topic. You are on page 324 of 338.
#16151 6 months ago

Hey guys!! Question, what's are the go to subwoofers for these things nowadays? I'm finally looking to install one but don't know what to go with. I do have an old non powered 12" sub that works but I'd have no idea how to hook it up to a pin, along with an external amp and it sounds like a waste of time and effort honestly.

#16152 6 months ago
Quoted from bowtech:

sweet lord, I understand nothing about that.....

Same here lol. I had a computer wiz buddy do it for me instead

#16153 6 months ago

I'm quite certain, '74 Plays' and Total Free Plays' are totally different

#16154 6 months ago

Save yourself $1000 and buy a used one. Spend that extra $1k on mods

#16155 6 months ago
Quoted from sohchx:

Hey guys!! Question, what's are the go to subwoofers for these things nowadays? I'm finally looking to install one but don't know what to go with. I do have an old non powered 12" sub that works but I'd have no idea how to hook it up to a pin, along with an external amp and it sounds like a waste of time and effort honestly.

Pinnovators sub kit + Polk psw10
It's what I'm using and I've heard the same here from MANY other owners. Best bang for your buck.
Edit: also dead simple to install.

#16156 6 months ago
Quoted from sohchx:

Hey guys!! Question, what's are the go to subwoofers for these things nowadays? I'm finally looking to install one but don't know what to go with. I do have an old non powered 12" sub that works but I'd have no idea how to hook it up to a pin, along with an external amp and it sounds like a waste of time and effort honestly.

The go to sub most use is a 10” Polk powered subwoofer. Cost is around $100. The difference with adding a sub to the machine is well worth the price.

#16157 6 months ago
Quoted from sohchx:

Hey guys!! Question, what's are the go to subwoofers for these things nowadays? I'm finally looking to install one but don't know what to go with. I do have an old non powered 12" sub that works but I'd have no idea how to hook it up to a pin, along with an external amp and it sounds like a waste of time and effort honestly.

Go buy yourself a Polk PSW10. They are $130 on amazon right now, but they regularly dip to $100 or less (just depends on how long you are willing to wait, $130 is still a great price). Then, you will need to attach a speaker wire to your cabinet speaker. You can either solder the connections, or if you want something less permanent, just use a set of aligator clip jumpers and connect them between the wire and the speaker. After that, run the speaker wire out and to the PSW10. You will be able to hook up 2 different pins to the sub, one on the left channel, one on the right. Crank it up and enjoy the sweet sound. It takes all of like 5 minutes including unpacking the sub. So easy a caveman could do it.

#16158 6 months ago

+1 on Polk PSW10 powered sub and Pinnovators sub kit for easy plug and play. There are cheaper ways to get it done but not worth the hassles imo. Don't think every pin needs a subwoofer but definitely a great addition to MET.

#16159 6 months ago
Quoted from sohchx:

Same here lol. I had a computer wiz buddy do it for me instead

If you buddy is passing though Michigan any time soon have him stop by and help me out. Beers are on me.

21
#16160 6 months ago

Officially part of the club today!!!

Met prem monsters , just got her inside.

20190423_130720 (resized).jpg20190423_130730 (resized).jpg
#16161 6 months ago

Big thanks for the advice on the subwoofer guys!! Much apreciated!!!

#16162 6 months ago
Quoted from bowtech:

If you buddy is passing though Michigan any time soon have him stop by and help me out. Beers are on me.

He's in New Jersey. What I did was sent him a thumb drive and he put the songs I wanted on it. He then sent it back and I uploaded them to the machine.

#16163 6 months ago
Quoted from sohchx:

He's in New Jersey. What I did was sent him a thumb drive and he put the songs I wanted on it. He then sent it back and I uploaded them to the machine.

Do you still have your thumb drive? I could compensate you to borrow it and send it back to you.

#16164 6 months ago
Quoted from charles4400:

Officially part of the club today!!!
Met prem monsters , just got her inside.[quoted image][quoted image]

You sure do have a great collection going on there.

#16165 6 months ago
Quoted from bowtech:

Do you still have your thumb drive? I could compensate you to borrow it and send it back to you.

No my wife wiped it clean to use it and has it Lord knows where. Sorry

#16166 6 months ago
Quoted from bowtech:

Do you still have your thumb drive? I could compensate you to borrow it and send it back to you.

Are there specific songs you want/don't want? If you're not picky, I have song changes I can share with you on Dropbox.

Quoted from sohchx:

No my wife wiped it clean to use it and has it Lord knows where. Sorry

You should have copied it to your computer first.

#16167 6 months ago

So I just had a chance to setup the new pin but ran across a strange problem. I have read where the snake jaw is too high but I think mine is mounted too low!

This is the position at game start. I can still make balls into the mouth in this position and the jaw never blocks balls. It acts strange when balls go in I assume because it is not expecting a ball in the scoop yet.

If you lower the jaw with washers then how do you raise it higher?

20190423_191132 (resized).jpg
#16168 6 months ago
Quoted from Spiderpin:

You sure do have a great collection going on there.

Thanks, appreciate that! Its taken awhile to get the pins on my wantlist with plenty of breaks from the hobby throughout the years but I keep on coming back !

#16169 6 months ago
Quoted from Graysonsdad:

Pinnovators sub kit

I"ve been using the Pinovators sub kit but using a Monoprice 8" sub. Not quite getting what I want out of it so, I just ordered a Polk 10" like suggested above. I also am going to change the front speakers to a little bit better quality. Thanks for the tip

-1
#16170 6 months ago
Quoted from sohchx:

Hey guys!! Question, what's are the go to subwoofers for these things nowadays? I'm finally looking to install one but don't know what to go with. I do have an old non powered 12" sub that works but I'd have no idea how to hook it up to a pin, along with an external amp and it sounds like a waste of time and effort honestly.

https://pinside.com/pinball/forum/topic/new-amplified-subwoofer-kits-by-pinwoofer

#16171 6 months ago
Quoted from charles4400:

So I just had a chance to setup the new pin but ran across a strange problem. I have read where the snake jaw is too high but I think mine is mounted too low!
This is the position at game start. I can still make balls into the mouth in this position and the jaw never blocks balls. It acts strange when balls go in I assume because it is not expecting a ball in the scoop yet.
If you lower the jaw with washers then how do you raise it higher?
[quoted image]

Think I solved the problem. Found this screw had the locking nut way loose and the bolt itself was unscrewed pretty far out. With some trial and error i turned the screw until the jaw can now lock open and closed. Then tightened down the locking nut. So it wasn't mounted too low, it was just never able to close its jaw and it essentially always stayed open (trying to close but unable to because of bad screw adjustment)

Should have looked at that earlier.... don't mind me i'm the new guy whose just happy to be here

Here's a pic after I adjusted the screw and before I tightened down the lock nut in case it helps anyone else out.

20190423_224841 (resized).jpg

#16172 6 months ago
Quoted from charles4400:

So I just had a chance to setup the new pin but ran across a strange problem. I have read where the snake jaw is too high but I think mine is mounted too low!
This is the position at game start. I can still make balls into the mouth in this position and the jaw never blocks balls. It acts strange when balls go in I assume because it is not expecting a ball in the scoop yet.
If you lower the jaw with washers then how do you raise it higher?
[quoted image]

The position at game start on my game is mouth open. The jaw never locks balls unless a multiball is going and you hit all 4 pick targets. That opens the snake mouth for add-a-ball and 20 second double scoring while the ball stays in the mouth. After the 20 seconds, the ball is spit back out.

There is a snake mouth diagnostic in the menu for testing switches and mouth position. Here are pictures of mine open and closed. I added washers to shim the snake mechanism lower. Somewhere between 1/16 and 1/8.

Rob

20190424_000134 (resized).jpg20190424_000152 (resized).jpg
#16173 6 months ago
Quoted from Rob_G:

The position at game start on my game is mouth open. The jaw never locks balls unless a multiball is going and you hit all 4 pick targets. That opens the snake mouth for add-a-ball and 20 second double scoring while the ball stays in the mouth. After the 20 seconds, the ball is spit back out.
There is a snake mouth diagnostic in the menu for testing switches and mouth position. Here are pictures of mine open and closed. I added washers to shim the snake mechanism lower. Somewhere between 1/16 and 1/8.
Rob[quoted image][quoted image]

Thanks for the pics! It helps, I think mine is good now but cant play tonight as Ill wake up the house grrrr...

On 1.7 code (what my game shipped with) the mouth starts closed on game startup. Hit it once and then opens. Initially before the fix, in snake test mode, the mouth just kind of jittered when activating the coil, never locking closed. I didnt know how it was supposed to act earlier but now I think I do. In gameplay it did weird jittery stuff when balls went in the scoop.

I upgraded to 1.8 and after screw adjustments now the game starts with an open snake mouth. I need some time on the game to get more familiar with it for sure.

Initially the screw was extremely loose and the locking nut was far away from the bracket causing the probs. Should have taken a pic but after spotting it, it looked way off, factory forgot to tighten nut and adjust screw.

Now mine looks alot like yours (actually not as low) Ill test in gameplay if I need to do the washer trick or not and lower mine like yours., cant wait to actually play it tomorrow! Thanks for the pics they helped confirm what its supposed to look like closed and open.

#16174 6 months ago

Anybody change up the songs for the newer code that would be willing to share

#16175 6 months ago
Quoted from manadams:

Anybody change up the songs for the newer code that would be willing to share

Scroll 8 posts up.

#16176 6 months ago

Has anyone changed out the front speakers in their game? Stock speakers are 8 ohm and I bought 4 ohm speakers thinking I could change the ohm setting like on the spike games. Could I possibly over load the amp? Or does it auto adjust? Anyone have any knowledge about this?
Thanks for any help

#16177 6 months ago
Quoted from RA77:Thanks Neal,
Spot on
I sourced the Clarions locally, Pinball Life shipped the LED speaker kit which conveniently makes for a standoff
Yes SAM speakers are in series so the original load from factory is 2 x 8 ohms = 16 ohm load
Now installed Clarions reduced load 2 x 4 ohms = 8 ohms
I did not notice any improvement in audio level or quality.
So I do not see any gain to change back box speakers.
Even though cheap ass, the dynamic range and power handling of the factory units are fine.
I already have an upgraded cabinet speaker installed,
Next step was to install Pinbits sub kit , ( awesome product thank you Pinbits )
I used a cable tie to add some stain relief on those dirty big ferrite cores.
Hooked up and dialled in a bangin' sub I scored from a mate !
To bring the package together I also installed a Color LCD, (Hi Res mode set) Again another great product Thank you color DMD
This motivation was only made possible due to my IMDN LE arriving soon.
They will be the perfect pair and I want MET to stand up to that bad boy that is so near !
Ps,
Is it a problem to mount LCD hard up to panel ?
Seems to be okay.
Had a few drinks so ordinary play [quoted image][quoted image][quoted image]

I think I found my answer

#16178 6 months ago
Quoted from Sparky:

Scroll 8 posts up.

Thank you, awesome song changes!!

#16179 6 months ago
Quoted from bicyclenut:

I"ve been using the Pinovators sub kit but using a Monoprice 8" sub. Not quite getting what I want out of it so, I just ordered a Polk 10" like suggested above. I also am going to change the front speakers to a little bit better quality. Thanks for the tip

You will like the Polk 10.

#16180 6 months ago

Was there ever a permanent fix for a weak coffin/hammer magnet?
Seems like the only way it will hold onto balls is if a ball ricochets into it. A direct shot or fast ball rolling over the magnet will keep on going.

Running latest code , 1.8.
It's a late model prem. (monsters)
2018 model

#16181 6 months ago

So I just upgraded to V 1.8 and now my flippers, particularly the right one, are definitely weaker. Is that a thing? Any advice??

#16182 6 months ago

And why is no one talking about adding Last Caress/Green Hell???

#16183 6 months ago
Quoted from mthirkell:

So I just upgraded to V 1.8 and now my flippers, particularly the right one, are definitely weaker. Is that a thing? Any advice??

Ive been 1.8 for awhile. No issues with mine.

#16184 6 months ago
Quoted from mthirkell:

So I just upgraded to V 1.8 and now my flippers, particularly the right one, are definitely weaker. Is that a thing? Any advice??

No problems with 1.8 here. Either install 1.7 and see how the flippers are, or reinstall 1.8.

#16185 6 months ago
Quoted from mthirkell:

So I just upgraded to V 1.8 and now my flippers, particularly the right one, are definitely weaker. Is that a thing? Any advice??

Inspect the right flipper mech and confirm it is moving free, and none of the hardware is coming loose, etc.

#16186 6 months ago

Anyone have issues with rear post divertor? On my game sometimes it works and sometimes it doesn’t. Last time it was working I went into test mode and made it go up about three times then it stopped working. When it is not working during game play I tried test mode and doesn’t work. If it was a bad transitor wouldn’t it not work all the time?

#16187 6 months ago
Quoted from MJW:

Anyone have issues with rear post divertor? On my game sometimes it works and sometimes it doesn’t. Last time it was working I went into test mode and made it go up about three times then it stopped working. When it is not working during game play I tried test mode and doesn’t work. If it was a bad transitor wouldn’t it not work all the time?

The same thing happened to mine. It eventually stopped working completely. Turns out, the coil wire was disconnected. I had to solder it in place. If that’s the problem it will be easy to see.

#16188 6 months ago
Quoted from mthirkell:

The same thing happened to mine. It eventually stopped working completely. Turns out, the coil wire was disconnected. I had to solder it in place. If that’s the problem it will be easy to see.

yep, those fine coil wires can break due to all of the vibration. I had that happen on my RFM for an up-down post and could see it because it broke off in the eyelet that the wire passed through. what made it even harder to track down was that it worked some of the time (when it was making contact with the eyelet

#16189 6 months ago

After a harsh 8 months without my pro I'm back in the club with a premium which I'm grabbing this weekend!

It comes with a few uninstalled mods I won't be using... I went crazy modding my old one and think I'm more of a stock guy now (well, aside from color DMD of course). PM me if interested in any of this stuff and I'll cut some deals.

Spinny Vinny hammer w/ silver leaf paint upgrade (never used), pinbits fluorescent yellow plastic protectors (full set), Snake ramp mod w/ plastic and decal (Premium/LE only, won't fit pro), and the Pingraffix EL creeping death Powerbladez (again, never installed).

Here's what the hammer looks like installed in a random machine, and here's the actual mods.
7974a9c172f5c5fdf07ad73ef11173f950c210a3 (resized).jpgcb6c377d58ed6bfa3094a40225f21fcf44b447a4 (resized).jpg

Added 6 months ago:

Just gonna sell this stuff as a lot in an ad, thanks.

#16190 6 months ago
Quoted from GorillaBiscuits:

After a harsh 8 months without my pro I'm back in the club with a premium which I'm grabbing this weekend!
It comes with a few uninstalled mods I won't be using that I'll throw up here once I have pictures... Spinny Vinny hammer, pinbits fluorescent yellow plastic protectors (full set), Snake ramp mod, and the EL creeping death blades. I went crazy modding my old one and think I'm more of a stock guy now (well, aside from color DMD of course).
One thing I am looking for is a clear extended plastic Sparky airball protector, the usual sources seem to have run dry. If anybody has a spare you could part with please PM me, I would also give you a solid price on any of the above if you're interested. Thanks!

Interested in the 3d snake mod, pm sent.

#16191 6 months ago

Woops forgot about the 3D one, sorry mine is the sticker. Edited that bit in the post.

#16192 6 months ago
Quoted from MJW:

Anyone have issues with rear post divertor? On my game sometimes it works and sometimes it doesn’t. Last time it was working I went into test mode and made it go up about three times then it stopped working. When it is not working during game play I tried test mode and doesn’t work. If it was a bad transitor wouldn’t it not work all the time?

Sounds like a loose connection or cold solder. Try pulling on the coil wires and see if any are loose. I had similar problem on different game where wire was loose but still looked like it was soldered in place.

#16193 6 months ago

So I was playing my MET Pro last night and got a little too aggressive with nudging that the speaker panel fell down on to the glass along with the translite , Luckily the glass didn't break and no damage at all! I guess the pinball gods were looking down on me, could have been disastrous!

Have since been a lot more gentle with my baby

#16194 6 months ago

That shouldn't come out no matter how hard you bump it. Was it locked?

#16195 6 months ago

finnflash If you mean the Translite yes it was locked, that was the first thing I checked, when I put the speaker panel back in I was pulling it back and forward to see if I could replicate it but couldn't. There is some leeway from left to right on the speaker panel maybe 1/4" but it sure looks like it's locked in on the tabs pretty good. I'm at a total loss as to how/why it happened but thankful there was no damage.

#16196 6 months ago
Quoted from mthirkell:

The same thing happened to mine. It eventually stopped working completely. Turns out, the coil wire was disconnected. I had to solder it in place. If that’s the problem it will be easy to see.

Thanks guys. Ill check it out . Maybe a loose wire is causing intermittent problems. Can’t hurt to resolder I suppose. Last time I checked coil both wires were connected were connected and coil would not fire.

#16197 6 months ago
Quoted from Chappie101:

finnflash If you mean the Translite yes it was locked, that was the first thing I checked, when I put the speaker panel back in I was pulling it back and forward to see if I could replicate it but couldn't. There is some leeway from left to right on the speaker panel maybe 1/4" but it sure looks like it's locked in on the tabs pretty good. I'm at a total loss as to how/why it happened but thankful there was no damage.

Sounds like you did not have the speaker panel put in correctly and it was sticking out. It should never pop up with any movement of the pin since it has to be lifted up and out.

#16198 6 months ago

Well this happened..

2 soft shots to get the super in grave muktiball. They stayed there during ball search and game eventually ended ball and served up the 4th/last ball in the shooter lane.

20190502_212423 (resized).jpg
#16199 6 months ago
Quoted from Rickwh:

Well this happened..
2 soft shots to get the super in grave muktiball. They stayed there during ball search and game eventually ended ball and served up the 4th/last ball in the shooter lane.
[quoted image]

That one happened to me once!

#16200 6 months ago

Is this a simple bulb replacement? Odd that both ends of the bulb are still lighting up.
Forgive my ignorance, but I purchase a replacement at Home Depot, for example?
Thanks!

IMG_3742 (resized).jpg
Promoted items from the Pinside Marketplace
From: $ 248.85
Cabinet - Sound/Speakers
PinWoofer
$ 5,599.00
Pinball Machine
Classic Game Rooms
There are 16854 posts in this topic. You are on page 324 of 338.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside