(Topic ID: 151478)

Metallica Hammer magnet not detecting ball.


By volkdrive

4 years ago



Topic Stats

  • 18 posts
  • 11 Pinsiders participating
  • Latest reply 3 years ago by extendo
  • Topic is favorited by 3 Pinsiders

You

Linked Games

Topic Gallery

There have been 6 images uploaded to this topic. (View topic image gallery).

image_(resized).jpeg
image_(resized).jpeg
image_(resized).jpeg
image_(resized).jpeg
image_(resized).jpeg
image_(resized).jpeg

#1 4 years ago

Go to play Metallica, and this happens:
-hit captive ball to light lock
-magnet won't detect ball
-phantom hits by hammer and magnet dropping
What we found:
-broken wire to switch 64(coffin magnet down - repaired)
-still same issue, with original and updated magnet board
-switch 63 magnet test failed, will not detect or grab ball.
-all fuses check out and transistors with multi meter.

Now feeling frustrated and hoping to find some suggestions on where to go next.

Thanks

#2 4 years ago

I had the same issue,fried something on the board in the back box.
I had Jay Richardson fix it,plus my magnet locked on at the same time and blew the fuse.
Added the new magnet board at that time,fixed the board issue.

#3 4 years ago

similar problem -just occurred.
Hammer magnet wasn't holding the ball. After some testing, realized Sparky magnet, same thing.
I saw that it blew a fuse. Replaced it, but same symptoms you're having. No magnets (Hammer or Sparky) working at all.

#4 4 years ago

Try reseating connections on the magnet board. I had an issue a while back and that took care of it on my machine.

#5 4 years ago

Another fix mentioned to me was spread the wires out that connect to the magnet board, I think there was a zip tie to cut off.

I went through 2'mag boards, the original that shipped with the machine and then the first revised one, 3rd board was the charm.

#6 4 years ago

Had the same issues with my original magnet board, but that was in the very early days. Replacement also went, but the most recent one i've never had any issues.

#7 4 years ago

If the F7 fuse doesn't appear to be blown after replacement, but the light above it doesn't light up, what does that tell us?
Anything?

#8 4 years ago
Quoted from Chambahz:

If the F7 fuse doesn't appear to be blown after replacement, but the light above it doesn't light up, what does that tell us?
Anything?

Check it with your Meter to start with for sure. Otherwise that fuse isnt get current to it, which is why the LED isn't lighting up

#9 4 years ago
Quoted from Gexchange:

Check it with you Meter to start with for sure.

and make sure the coin door is closed.

#10 4 years ago

Update. Can anyone confirm there is a power LED on magnet board for the hammer that should always be on? I see one on the board and it is off on both I have tried. Thinking I'm not getting power to the board....also test mode for the magnet is zilch. No response at all....

#11 4 years ago

Mine flashes three times on power up and goes off.

#12 4 years ago

Ok I do have that. Thanks Dan. Also getting a buzz of different tones in the test modes, thinking maybe the magnet core?

#14 4 years ago

So, came home from work, put a fresh look on this and found the problem.....magnet wire had rubbed through from hitting "U' shaped stop at top of coffin under playfield, and the other wire was broken where it was zip tied to the magnet assembly. Installed another assy borrowed from fellow pin head to confirm. The game has not played this good even when new. Definitely not the expected issue.

#15 4 years ago

Any chance you could take pics of that? Sounds like I need to find a similar problem on my pin. Seeing what you found might be helpful.

#16 4 years ago

Sure, here you go. The U shaped bracket towards back of Pf rubbed through on one wire, and when I removed the magnet drop assy I found the other wire broken. On mine it was just before the magnet where it was zip ties to the bracket. Broken clear through.

image_(resized).jpeg

image_(resized).jpeg

image_(resized).jpeg

image_(resized).jpeg

image_(resized).jpeg

image_(resized).jpeg

3 months later
#17 3 years ago

I just received my Metallica machine and when the magnet brings the ball down to the coffin it seems to get stuck. I have provided a video. Everything is level so I am not sure what is the cause

#18 3 years ago
Quoted from SomeCaliGuy:he coffin it seems to get stuck.

Raise the pinball and make sure it's level.

Promoted items from the Pinside Marketplace
$ 48.00
Cabinet - Other
ModFather Pinball Mods
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Lighting - Interactive
Professor Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside