Medieval Madness playfield lamps randomness

(Topic ID: 189419)

Medieval Madness playfield lamps randomness


By c9er

1 year ago



Topic Stats

  • 6 posts
  • 2 Pinsiders participating
  • Latest reply 1 year ago by zacaj
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 1 year ago

Have been trying to troubleshoot a problem for a few months now where the lamps lit on the playfield bear no connection to what's happening during the game. Lamps are not burned out - they all physically work. All or most will often be on when I first start a game, but progressing through features like peasants, exploding castles, and extra balls doesn't change what is lit up or what shuts off. I tried removing and reseating all the ribbon cables, to no avail. Anyone ever encountered this issue before? Feels like a more serious circuit board issue...

#2 1 year ago

Go into the single lamp test and make sure each lamp is turning on and off correctly.

Probably a matrix issue (assuming not the remake?)

#3 1 year ago
Quoted from zacaj:

Go into the single lamp test and make sure each lamp is turning on and off correctly.
Probably a matrix issue (assuming not the remake?)

Went into the lamp test menu and am not able to switch on and off individual lamps or to turn the entire group of them on and off. Does that call for a circuit board repair or replacement?

#4 1 year ago

No matter what when you scroll through the different lamps in single lamp test you should be getting at least some that turn on. Can you elaborate on what you're getting?

3 weeks later
#5 1 year ago
Quoted from zacaj:

No matter what when you scroll through the different lamps in single lamp test you should be getting at least some that turn on. Can you elaborate on what you're getting?

Sorry for the slow reply here. I have a random assortment of playfield lamps on when I first switch on the game. Going into the single lamp test does not cause any of those to turn off or on. The full lamp test will turn them all on, but not off. It's a very strange problem. I've heard it could be an aging capacitor that needs to be replaced?

#6 1 year ago

What lamps are they? Are they all in one row or column?

Promoted items from the Pinside Marketplace
7,995
Machine - For Sale
West Chicago, IL
$ 128.00
Playfield - Toys/Add-ons
Lermods
7,500
Machine - For Sale
Dover, OH
$ 40.00
Lighting - Other
Rock Custom Pinball
From: $ 19.50
$ 229.99
$ 43.00
Playfield - Toys/Add-ons
Lermods
€ 9.10
$ 98.00
Playfield - Other
ModFather Pinball Mods
€ 40.00
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
From: $ 15.95
$ 36.99
Lighting - Interactive
Lee's Parts
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 9.95
From: $ 29.00
Boards
KAHR.US Circuits
€ 8.10
Flipper Parts
Buthamburg
$ 35.00
Electronics
Ewe22 Security PIC Chips
$ 53.00
Playfield - Toys/Add-ons
Lermods
$ 989.00
Pinball Machine
Mircoplayfields
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 15.00
Great pinball charity
Pinball Edu

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside