(Topic ID: 302948)

Medieval Madness Not Launching Multi Balls

By nerdygrrl

3 months ago



Topic Stats

  • 8 posts
  • 5 Pinsiders participating
  • Latest reply 3 months ago by LTG
  • No one calls this topic a favorite

You

Linked Games

#1 3 months ago

I finally got around to play testing my MM after a PF swap. When you collect whatever goal and then hit the Merlin Shot, it will announce, "XXX Multiball", but the trough will not fire the extra balls. It seems like that "fire" signal is getting dropped.

My first instinct is to swap out the trough boards with another game, but I wasn't sure if I was missing anything else.

#2 3 months ago

Balls magnetized and not rolling down the ball trough right. ( usual problem )

Plunger at end of ball trough sticking up a tiny bit too high and not letting balls roll into position right ? ( is adjustable, 4 screws in slotted holes on end of ball trough, don't go too high or too low )

LTG : )

#3 3 months ago
Quoted from LTG:

Balls magnetized and not rolling down the ball trough right. ( usual problem )
Plunger at end of ball trough sticking up a tiny bit too high and not letting balls roll into position right ? ( is adjustable, 4 screws in slotted holes on end of ball trough, don't go too high or too low )
LTG : )

In those cases should you still hear the sound of an attempted ball eject?

#4 3 months ago
Quoted from nerdygrrl:

My first instinct is to swap out the trough boards with another game, but I wasn't sure if I was missing anything else.

Trough opto board problems at common with the OEM "widebody" boards. These are the board set used in:

Medieval Madness does NOT use this board set.

You can swap with boards from a compatible machine but it may not fix the problem. Go to the switch edge test and drop balls into the trough and see what switches register.

#5 3 months ago

Thank you everyone. I had a similar issue with my Demo Man and it was the trough PCB so my mind went there. It also seemed signal related to me b/c the Castle multiball would work, just not the Merlin.

Anyhoo, LTG was correct. The balls are not being fed in the trough correctly. They are getting hung up and not advancing down.

#6 3 months ago

LTG is right 9 out of 10 times...IMHO

He's been here to help us all for over 20 years as I recall.

#7 3 months ago
Quoted from sepins:

LTG is right 9 out of 10 times...IMHO

Thank you.

But when I get one wrong. It's usually pretty big !

LTG : )

#8 3 months ago
Quoted from sepins:

He's been here to help us all for over 20 years as I recall.

Around 27 years.

Not always easy. Try and figure the person's skill level as to what they can fix or not. Try and understand the problem. People may not know the correct part names or how to describe, may not tell the whole story how it got that way, and or language barriers.

Just trying to make my little corner of pinball better.

LTG : )

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside