(Topic ID: 294994)

Medieval Madness loading ball drops it into cabinet

By Golgotha

7 months ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 7 months ago by Golgotha
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

IMG_1833 (resized).jpg
IMG_1828 (resized).jpg
IMG_1827 (resized).jpg
IMG_1826 (resized).jpg

#1 7 months ago

I just acquired an amazing MM. It bounced around during an eight hour drive from CA to AZ. The game fired right up and I played a few games and called it a night. The next day I started getting a missing ball error. I validated that all 4 were loaded. The missing ball would happen about every other game. Then all of a sudden it when to load a ball and a loud bang was heard. The ball instead of being loaded to the shooter it dropped into the cabinet. I opened the coin door and the long 1.75 inch bolt fell out onto the floor. I assume it was associated with the issue. In the coin box there was also this yellow bracket. I looked in the manual and I did not see strange bracket. Last night it went into ball missing fit and this time the ball was on top of the playfield under the apron.

So the questions are:
1. What the heck is the yellow bracket?
2. Any idea what is causing my wayward balls. It is shear MADNESS! LOL
3. Looks like something is missing not have anything at the end of ball channel. The manual does not show anything at the open end either. No barrier.

IMG_1826 (resized).jpg

IMG_1827 (resized).jpg

IMG_1828 (resized).jpg
#2 7 months ago

The yellow bracket is positioned in the coin door opening to press on the high voltage switch to simulate the coin door being closed. Used when servicing the game.

The ball trough looks ok to me. Could your ball eject mechanism be faulty and somehow push balls backwards (not very likely)?

Maybe you are missing a post right beside the shooter lane topside? No idea if MM has one but I know many other pins have one and if it's missing the ball gets into the shooterlane and then roll down the side under the apron/inside cabinet.

#3 7 months ago
Quoted from Lhyrgoif:

Maybe you are missing a post right beside the shooter lane topside? No idea if MM has one but I know many other pins have one and if it's missing the ball gets into the shooter lane and then roll down the side under the apron/inside cabinet.

EXACTLY! Problem solved. The red post was stuck in wiring underneath. All I had was the long bolt. Thank You so much! Now I can finish some subtle mods.

IMG_1833 (resized).jpg

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside