(Topic ID: 254305)

Maverick Switch Issues


By ViriiGuy

8 months ago



Topic Stats

  • 11 posts
  • 3 Pinsiders participating
  • Latest reply 8 months ago by ViriiGuy
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

782D7B45-8F51-44C1-9036-C94C92C09293 (resized).jpeg
C6761EF4-9AE1-4A3A-817C-54669B48283F (resized).jpeg
A24D3810-90A0-4227-90EE-D72A53E66125 (resized).jpeg

#1 8 months ago

Hello all,

I just brought home a beautiful Maverick, but it was DOA. So I did a little digging, and found it had a blown F1 7a fuse and a burnt pin 1 on CN8. I also noticed that the MPU looked like the resistors had been burned up. So I replaced the fuse, cleaned up the connector, while I wait for a replacement part... and tested all the resistors. They all check out at 26-27 ohms. So, after replacing the fuse and cleaning the connector it powers up and plays.

However.... it was acting like a ball had drained, while it was still in play. I have narrowed it down to the 5 bank drop targets. If target 1 is activated, it also triggers the other four. Also, it doesn’t allow the other four switches to register on their own, when it is active.

The other four, only activate themselves. However, hitting one of them while the game it in play, triggers a ball drain. Even though none of them trigger a trough switch.

*Correction* It seems as if targets 5 and 3 in that same bank are triggering two unused switches. 9 and 10.

The diode on each switch tests fine, so I’m not really sure what I’m looking at here. Any thoughts?
782D7B45-8F51-44C1-9036-C94C92C09293 (resized).jpegA24D3810-90A0-4227-90EE-D72A53E66125 (resized).jpegC6761EF4-9AE1-4A3A-817C-54669B48283F (resized).jpeg

#2 8 months ago

The more I dig, the weirder this issue gets.

The problem seems to move around the switch matrix, row to row.
A little while ago, the upper 4 bank Drop Targets, Top target was triggering several switches at once.. It wasn't previously.
I took the switches out, checked them and soldered everything back in. Issue has now moved to the boat optos. The front opto is triggering the switches for the pop bumpers, right return lane.. everything on the CN8-7 row this time. And it isn't the opto itself. I can move the connectors to the other opto and the problem follows. So before it was CN8-3 being triggered, next it was CN8-4, now CN8-7. Each time all I have done is remove, check and reinstall.

I have tested numerous components on the board and everything checks out... Even those 27 ohm 3 watt resistors. It is OBVIOUS they have burned, But I get 26-27 ohms on every single one. None of this makes any sense to me at the moment.

I'm guessing at this point it is the MPU itself. But I am not sure where to check, with the issue moving around so much!

#3 8 months ago

Do a jumper test on the switch matrix of the MPU. Dont have the manual handy, but it should identify the row and column connectors on the board. Pull the two connectors, and using a small jumper wire, jumper pin 1 of the row to each pin of the column, one at a time on the board connector pins. Do this in switch edge test mode. Follow along and see if every row/column combo corresponds correctly to the matrix. Then move to pin 2 and repeat and so on, until you test all 64 combos.

If they show up correctly, then it's a wiring or diode issue in the playfield. If they dont, then board issue.

#4 8 months ago

I did that last night and the issue is definitely a board issue. The puzzling part is, the issue jumps around. I went ahead and ordered a Rottendog MPU, as I have two pins that both need the same MPU. So I can have a working one to test with.

#5 8 months ago
Quoted from ViriiGuy:

I did that last night and the issue is definitely a board issue. The puzzling part is, the issue jumps around. I went ahead and ordered a Rottendog MPU, as I have two pins that both need the same MPU. So I can have a working one to test with.

For unusual behavior like that probably the data buffer IC took a hit. RD board is fine, but yours could be fixed relatively inexpensively, especially if you have the tools to do it yourself. If you want to sell the board as is, let me know, as I have a maverick also with an RD board, but wouldnt mind pitting an original back in.

#6 8 months ago

Will do. My plan is to fix mine though and eventually put the RD into the Batman Forever at my house, with major acid damage. And thank you! I will check out the buffer. I have been trying to make out the schematics, but the PDF on IPDB is less than great. Better than nothing though, for sure!

#7 8 months ago

Page 78 of the ipdb schematics....would be IC 8J or 8H.

#8 8 months ago

Thank you! I will check them out when I get home tonight!

#9 8 months ago

You can Pull the corresponding connector for the DT switches at the mpu and enter test to see if they’re still active. If they stop, you can rule out a short on the board, and focus on the playfield.

If it’s the lower left 5 DT bank, double check that none of the wires or switches on that bank are bent/shorting to something.. That area is tight and on the edge of the playfield. Tidy up the wiring as best as you can.

On the maverick project I’m finishing up; That bank was replaced by a previous owner. The original was most likely damaged from the playfield getting dropped inside the cabinet as both of my mdf strips on the inside of the cabinet were busted/gone. I pulled the old staples/nails so nothing was touching the underside of the playfield.

In my case, the drop target bank they replaced the original with was obviously from a different game. Double check the connector from your DT bank to the harness and make sure your wiring matches up to the rest of the main harness/schematic, reconfigure accordingly.

A couple of my switches were out of adjustment and closed as well as wired to whatever game the DT bank came out of. This caused all kinds of crazy switch problems for me.

#10 8 months ago

The RottenDog MPU was installed today. That solved MOST of the issues. But I am still having a random end of ball and a game reset. I have found the game reset, there seems to be a short on one of the riverboats Opto Sensors. If I smack it, the game reboots. So I will try to fix that tomorrow, by reflowing the solder joints.

The End of ball issue, I have not found yet. I thought it was in the upper right DTs, but none of them are firing off any other switches. I have tested every switch on the PF and they all only fire off themselves now.

#11 8 months ago

I stripped the playfield and cleaned it.. Looks new again! But, I have a lot more switch errors now. So I am suspecting I have some cracked wires somewhere. I hope to get some time this weekend to look further into the issue. I found one wire that was caught in a DT assembly and has gotten cut. I fixed it, but there seems to be more going on.

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Bristol, TN
From: $ 18.00
Apparel - Men
Pinside Shop
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 9.99
$ 21.00
Electronics
Yorktown Arcade Supply
From: $ 40.00
Lighting - Interactive
Professor Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside